Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
compiz-fusion and keyboard layout
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Wed Dec 17, 2008 2:23 am    Post subject: compiz-fusion and keyboard layout Reply with quote

When I boot into compiz fusion standalone, a few keys do not work properly. The up arrow for instance takes a screenshot which I have worked around by changing the screen shot command in ccsm, but more importantly, my Home key does not function at all.

I am using the evdev driver (2.0.2) and xorg-server 1.4.2

When I boot into openbox I do not have this problem.

Any workaround for the Home key someone might know of? It's very aggravating not being able to return the the top of a page with a single key press...

Thanks.


Edit: This is the output from xev when I press the Home key:
Code:
FocusOut event, serial 32, synthetic NO, window 0x2400001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 32, synthetic NO, window 0x2400001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 32, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

I would try to use xmodmap if I could determine the keycode from that and the corresponding 'command' to return normal Home key functioning...


Additional edit: This problem occurred once before and was fixed by disabling auto log-in with GDM, I now no longer use a log-in display manager
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Wed Dec 17, 2008 9:16 pm    Post subject: Reply with quote

I re-installed GDM and now the keyboard functions normally apart from that ctrl+alt+F# instead of switching to another tty, turns my screen off, and by pressing the Menu button, I can turn it back on.


what the hell?
Back to top
View user's profile Send private message
Etrnls
n00b
n00b


Joined: 20 Dec 2008
Posts: 8

PostPosted: Sat Dec 20, 2008 11:48 am    Post subject: Reply with quote

Same problem here : If I set the window manager to compiz in system setting in KDE, then the up key doesn't work, but if I start compiz after KDE started (and of course kwin started), everything is OK.
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Sun Dec 21, 2008 12:22 am    Post subject: Evdev prerequisities Reply with quote

For evdev to work you have to:
  1. Remove all inputdevice sections from xorg.conf.
  2. Edit /etc/hal/fdi/policy/10-x11-input.fdi and put something like
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <deviceinfo version="0.2">
        <match key="info.capabilities" contains="input.keys">
            <!-- Option "XkbModel" "pc104" -->
            <merge key="input.xkb.model" type="string">evdev</merge>
            <merge key="input.xkb.layout" type="string">us,cz</merge>
            <merge key="input.xkb.options" type="strlist">grp:alt_shift_toggle</merge>
            <merge key="input.xkb.rules" type="string">xorg</merge>
            <append key="input.xkb.options" type="strlist">grp_led:scroll</append>
        </match>
    </deviceinfo>
    inside.
  3. Select Evdev managed keyboard instead of Standard 104-keys keyboard or whatever used to be there.
Check that lines like
Code:
(II) XINPUT: Adding extended input device "ImPS/2 Generic Wheel Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
are present in /var/log/Xorg.0.log.
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Mon Dec 22, 2008 4:49 pm    Post subject: Reply with quote

but my keyboard works just fine in openbox

Code:
# Select Evdev managed keyboard instead of Standard 104-keys keyboard or whatever used to be there.

in where?
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Tue Dec 23, 2008 7:51 pm    Post subject: Reply with quote

I switched my framebuffer driver from vesa to intel in my kernel, and I can now switch between ttys if I login using GDM (somehow starting X as root vs using startx as user messes up the keyboard layouts?) but if I ctrl+alt+backspace, instead of restarting X, the screen goes black and I cannot get it back on without restarting...though this now happens in both openbox and compiz-fusion, so I guess this is no longer the appropriate forum, but I can get by with just switching tty's then stopping X from there I suppose...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum