Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to install entrance (enlightment overlay)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Wed Dec 17, 2008 2:48 pm    Post subject: unable to install entrance (enlightment overlay) Reply with quote

hi there,

as the titel says i want to install "entrance" (login-manager)

i have put several packages in /etc/package.keywords

but at some point i got this error :

Code:
# emerge -av entrance

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-libs/esmart-0.9.0.011" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/esmart-9999 (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-misc/entrance-0.9.0.013" [ebuild])
(dependency required by "entrance" [argument])


i looked into /usr/portage/profiles/package.mask but there is no esmart ...

any idea in which file of the overlay i can unmask esmart ?

thx a lot
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Wed Dec 17, 2008 4:13 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
unsupported stuff, so moved here
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Bumbl
n00b
n00b


Joined: 05 Sep 2007
Posts: 50

PostPosted: Wed Dec 17, 2008 4:52 pm    Post subject: Reply with quote

Code:

echo "x11-libs/esmart **" >> /etc/portage/package.keywords/x11-libs
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Wed Dec 17, 2008 11:47 pm    Post subject: Reply with quote

Bumbl wrote:
Code:

echo "x11-libs/esmart **" >> /etc/portage/package.keywords/x11-libs


Code:
# echo "x11-libs/esmart **" >> /etc/portage/package.keywords/x11-libs
bash: /etc/portage/package.keywords/x11-libs: Not a directory


to create a dir called package.keywords is impossible since there exists a file called so

so what dont i understand ?


thx so far
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Wed Dec 17, 2008 11:56 pm    Post subject: Reply with quote

Then instead do
Code:
echo "x11-libs/esmart **" >> /etc/portage/package.keywords
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1439
Location: indiana

PostPosted: Thu Dec 18, 2008 12:07 am    Post subject: Reply with quote

slycordinator wrote:
Then instead do
Code:
echo "x11-libs/esmart **" >> /etc/portage/package.keywords


but now i got this error :
Code:
 # emerge -av entrance

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-libs/evas-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/evas-9999 (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-libs/esmart-9999" [ebuild])
(dependency required by "x11-misc/entrance-0.9.0.013" [ebuild])
(dependency required by "entrance" [argument])


i tried to add :
Code:
echo "x11-libs/evas-9999 **" >> /etc/portage/package.keywords


but that did not help
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum