Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OVERLAY] java-binary
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Sun Mar 23, 2008 5:01 pm    Post subject: [OVERLAY] java-binary Reply with quote

Since everyone and his brother have an overlay nowadays, I decided I need one too, so I threw a few likely-looking ebuilds into a folder and created 'java-binary'. It brings ebuilds for mathematica 6.0.1, matlab 2007b, netbeans 6.0.1 (and 6.1 beta), openoffice 3 milestone builds, staroffice 8.0.9 (german and english) and some other packages besides.

From the overlay descriptor:
Quote:
java-binary is a portage overlay for, indeed, binary java software (and a few more or less java related binary packages). The included packages are those that I happen to need; they are hacked together in a rough fashion sometimes and for the most part aim to provide only basic features. Updates will happen infrequently and when I feel like it. No promises, no handholding, no fancy feature requests implemented (except feature requests by myself). If you want to see a particular package in this overlay, or a particular bug fixed, send me an ebuild, and it may or may not be included.


Packages (as of March 23, 2008):
Code:
dev-java/batik-bin
dev-java/grizzly-bin
dev-java/fop-bin
dev-java/ant-bin
dev-java/sanselan-bin
dev-java/saxonb-bin
dev-java/woodstox-bin
dev-java/itext-bin
www-servers/tomcat-bin
dev-db/apache-derby-bin
app-office/openoffice-dev
app-office/staroffice
sci-mathematics/mathematica
sci-mathematics/matlab
app-text/jabref-bin
app-text/pdfrenderer-bin
dev-util/netbeans-bin


To add java-binary to your overlays, execute:
Code:
layman -f --overlays=http://demandiseineseite.gmxhome.de/java-binary/overlays.xml -a java-binary


Last edited by Voltago on Tue May 27, 2008 9:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Thu May 01, 2008 3:23 pm    Post subject: Reply with quote

Hi all!
java-binary has been updated: No new packages, but version bumps for netbeans-bin to 6.1 and openoffice-bin (formerly openoffice-dev) to 3.0.0_beta2, staroffice to 8.0.10, along with minor bumps for some of the libraries.
Several libraries now support the USE flag 'netbeans-integration': Packages installed with that flag will register their JAR files with netbeans-bin for use as libraries. See 'Tools->Libraries', the entries marked with '(portage)' are portage-generated through java-netbeans.eclass.
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Wed May 07, 2008 8:39 pm    Post subject: Reply with quote

Small bump, 'updated' openoffice-3.0.0_beta2 to _beta1, since the previous version was kind of like the second release candidate of the beta. Or something. And I'm damned if I know where they hide the application icons in there, so I added some from gnome-look.org.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Thu May 08, 2008 10:05 am    Post subject: Reply with quote

Just tried your openoffice-bin, it works, I just have to change in ebuild

from this

if use gnome; then
ooodev_unpack ooobasis3.0-gnome_integration
fi

to

if use gnome; then
ooodev_unpack ooobasis3.0-gnome-integration
fi
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Thu May 08, 2008 2:28 pm    Post subject: Reply with quote

I literally had to stare at the monitor for thirty seconds or so to notice the difference between those two codeblocks. Thanks for the feedback, it's fixed now.
Back to top
View user's profile Send private message
Zougloub
n00b
n00b


Joined: 14 Dec 2007
Posts: 30

PostPosted: Tue May 27, 2008 7:27 pm    Post subject: Reply with quote

Voltago, I am adding your overlay to the http://gentoo.zapto.org/ search engine, I hope you don't mind :)
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Tue May 27, 2008 9:53 pm    Post subject: Reply with quote

Sure, go ahead.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 535
Location: Venice FL

PostPosted: Sat Jun 07, 2008 10:15 pm    Post subject: Reply with quote

Thought I'd try your netbeans-bin-6.1

Seems the file is no longer present:

Code:
# emerge -v netbeans-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-util/netbeans-bin-6.1  160,177 kB [1]

Total: 1 package (1 new), Size of downloads: 160,177 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/java-binary

>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) dev-util/netbeans-bin-6.1 to /
>>> Downloading 'http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/netbeans-6.1-200804211638.zip'
--2008-06-07 18:12:24--  http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/netbeans-6.1-200804211638.zip
Resolving distro.ibiblio.org... 152.46.7.109
Connecting to distro.ibiblio.org|152.46.7.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-06-07 18:12:25 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.mirrors.pair.com/distfiles/netbeans-6.1-200804211638.zip'
--2008-06-07 18:12:25--  http://gentoo.mirrors.pair.com/distfiles/netbeans-6.1-200804211638.zip
Resolving gentoo.mirrors.pair.com... 216.92.2.140
Connecting to gentoo.mirrors.pair.com|216.92.2.140|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-06-07 18:12:25 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.arcticnetwork.ca/source/distfiles/netbeans-6.1-200804211638.zip'
--2008-06-07 18:12:25--  http://gentoo.arcticnetwork.ca/source/distfiles/netbeans-6.1-200804211638.zip
Resolving gentoo.arcticnetwork.ca... 206.75.218.53
Connecting to gentoo.arcticnetwork.ca|206.75.218.53|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-06-07 18:12:25 ERROR 404: Not Found.

>>> Downloading 'http://download.netbeans.org/netbeans/6.1/final/zip/netbeans-6.1-200804211638.zip'
--2008-06-07 18:12:25--  http://download.netbeans.org/netbeans/6.1/final/zip/netbeans-6.1-200804211638.zip
Resolving download.netbeans.org... 72.5.124.114
Connecting to download.netbeans.org|72.5.124.114|:80... connected.
HTTP request sent, awaiting response... 404 Not found
2008-06-07 18:12:26 ERROR 404: Not found.

!!! Couldn't download 'netbeans-6.1-200804211638.zip'. Aborting.
 * Fetch failed for 'dev-util/netbeans-bin-6.1'
!!! can't process invalid log file: merge.ERROR


And the directory http://download.netbeans.org/netbeans/6.1/final/zip/ shows it's not there, but new with more cool stuff.

Suggestions?

Thanks;
George
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Fri Jun 27, 2008 10:19 pm    Post subject: Reply with quote

Ok, I know it's been a while, but now I finally found the time to push out a new tarball, which contains a fixed download URL for netbeans among other things.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 535
Location: Venice FL

PostPosted: Fri Jun 27, 2008 11:49 pm    Post subject: Reply with quote

Voltago wrote:
Ok, I know it's been a while, but now I finally found the time to push out a new tarball, which contains a fixed download URL for netbeans among other things.


Thanks much, I'll give it a try.

George
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Sun Jul 13, 2008 3:51 pm    Post subject: Reply with quote

A bunch of updates: openoffice-bin-3.0.0_beta2, staroffice-8.0.11, itext-bin-2.1.3, grizzly-bin-1.8.2, sanselan-bin-0.92, saxon-bin-9.1.0.1, a bugfix for the netbeans-bin installation.
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 9:57 pm    Post subject: Reply with quote

Thanks for your work.
Do you know how to get spell check working with this openoffice 3 (beta2) ?
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Thu Jul 31, 2008 11:31 am    Post subject: Reply with quote

coolsnowmen wrote:
Thanks for your work.
Do you know how to get spell check working with this openoffice 3 (beta2) ?

No, I haven't looked into this. Perhaps there's a missing dependency on aspell, hunspell or watchacallumspell...
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Wed Oct 29, 2008 11:25 pm    Post subject: Reply with quote

Hi. Long time no update. Enjoy tomcat-bin-6.0.18, mathematica-6.0.3 (from .iso), matlab-2008b (also from .iso), and libusbjava-bin-0.5.7 (which isn't really a binary ebuild), as well as some other updated libs. Check out the cool systemjava USE flag for matlab and mathematica which will use your system's JRE instead of the shipped one and almost certainly break all your stuff. Stay tuned for netbeans-bin-6.5_rc/final.
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Tue Dec 16, 2008 9:53 pm    Post subject: Reply with quote

Update! Several ebuilds have gained the amd64 keyword, most prominently mathematica and matlab. Netbeans-bin bumped to 6.5.
Back to top
View user's profile Send private message
alistair
Retired Dev
Retired Dev


Joined: 15 Jul 2005
Posts: 869

PostPosted: Wed Dec 17, 2008 7:15 pm    Post subject: Reply with quote

Why? Please Why? I could understand if you had an overlay with stuff we hadn't packaged, or couldn't package. But whats wrong with the tomcat, fop, etc, etc in the tree.
_________________
______________
Help the gentoo-java project. Visit Gentoo Java Project

what good are admin powers if you don't abuse them for personal gain - mark_alec
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2591
Location: userland

PostPosted: Wed Dec 17, 2008 9:31 pm    Post subject: Reply with quote

Some of the packages you provide have too many build time dependencies (like netbeans, for tomcat things seem to be better now), or try to drag in older jdk versions (tomcat does that for some reason). Other libraries used to be outdated in the tree, so I added them quick and dirty, and they kind of stayed on. As for the libs, I'm experimenting with netbeans integration (i. e. making libs available to netbeans projects via Tools->Libraries). Not all libs I'm using regularly are supported (yet), the implementation is somewhat horrible, netbeans is a devil for caching data about modules, so updating does not work at this stage, but it is at least a proof of concept, and I'm meaning to re-work it one of these days...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum