Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI]Problème installation driver officiel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 1:01 am    Post subject: [ATI]Problème installation driver officiel Reply with quote

Bonjour à tous,

Suite à une installation récente d'une gentoo, je cherche à installer les pilotes officiels ATI pour ma carte graphique. Mon problème est qu'avec emerge j'ai l'erreur suivante: "die ${P} requires support for pci_find_slot."

Enfin en essayant d'installer le pilote trouvé sur le site d'ATI j'ai l'erreur suivante: "failed to install compiled kernel module"

J'avoue ne pas avoir trouvé de réelle solution à ce souci.

En vous remerciant par avance pour vos réponse.

@+


Last edited by jibe on Sun Dec 28, 2008 5:22 pm; edited 2 times in total
Back to top
View user's profile Send private message
sephiroth2
n00b
n00b


Joined: 17 Apr 2008
Posts: 53

PostPosted: Sun Dec 28, 2008 2:32 am    Post subject: Reply with quote

Salut,
il faut que tu recompiles ton kernel avec l'option pci_find_* activée.
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Dec 28, 2008 11:04 am    Post subject: Reply with quote

Ou utiliser les drivers libres ;)

Sinon, peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 12:03 pm    Post subject: Reply with quote

merci sephiroth2 ca compile mais j'ai de nouveau une erreur lors de la compile des pilotes: "eval emake HOSTCC=\ $(tc)-get-BUILD_CC".

geekounet voila normalement c'est conforme :wink:. Pour les drivers libre je crois qu'il gèrent difficilement les dernières cartes ATI (j'ai une radeon 3850).

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Sun Dec 28, 2008 1:33 pm    Post subject: Reply with quote

Peux tu poster les logs de compilation complets, ou du moins de la fin à "suffisament haut pour qu'on puisse voir ce qu'il se passe"?
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 2:07 pm    Post subject: Reply with quote

Voila mon log de compilation:

Code:


* Preparing fglrx module
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.27-gentoo-r7'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_ProcessIsTerminated':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1368: error: implicit declaration of function 'find_task_by_pid'
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1368: warning: assignment makes pointer from integer without a cast
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_get_ke_pte':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2610: error: 'NOPAGE_SIGBUS' undeclared (first use in this function)
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2610: error: (Each undeclared identifier is reported only once
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2610: error: for each function it appears in.)
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_get_vm_phys_addr':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2638: error: 'NOPAGE_SIGBUS' undeclared (first use in this function)
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_get_vm_page_table':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2660: error: 'NOPAGE_SIGBUS' undeclared (first use in this function)
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_TestAndClearPageDirtyFlag':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2788: error: 'NOPAGE_SIGBUS' undeclared (first use in this function)
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_flush_cache':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2974: error: too many arguments to function 'smp_call_function'
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3833: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3833: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3851: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3851: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3858: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3858: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3865: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3865: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3872: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3872: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3879: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3879: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3886: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3886: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3895: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3895: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_CallFuncOnOtherCpus':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4615: error: too many arguments to function 'smp_call_function'
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_enable_pat':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4822: error: too many arguments to function 'smp_call_function'
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_disable_pat':
/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4840: error: too many arguments to function 'smp_call_function'
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-8.501/work/common/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.27-gentoo-r7'
make: *** [kmod_build] Error 2
 *
 * ERROR: x11-drivers/ati-drivers-8.501 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3184:  Called linux-mod_src_compile
 *             environment, line 2399:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=  GCC_VER_MAJ=4 KVER=2.6.27-gentoo-r7 KDIR=/usr/src/linux kmod_build
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.501/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.501/temp/environment'.
 *

 * Messages for package x11-drivers/ati-drivers-8.501:

 * You have DRM support enabled builtin, the direct rendering will not work.
 *
 * ERROR: x11-drivers/ati-drivers-8.501 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3184:  Called linux-mod_src_compile
 *             environment, line 2399:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS=\"$(get_abi_LDFLAGS)\"                   ${BUILD_FIXES}                   ${BUILD_PARAMS}                   ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS=  GCC_VER_MAJ=4 KVER=2.6.27-gentoo-r7 KDIR=/usr/src/linux kmod_build
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.501/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.501/temp/environment'.
 *


Merci.

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Sun Dec 28, 2008 2:35 pm    Post subject: Reply with quote

Ton kernel, 2.6.27 est trop récent pour utiliser les drivers pour utiliser les fglrx 8.6 (8.501).

Utilises la version ~arch des ati-drivers...

Ajoutes la ligne suivante à /etc/portage/package.keywords
Code:
x11-drivers/ati-drivers x86 ~x86
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3101
Location: Paris

PostPosted: Sun Dec 28, 2008 2:47 pm    Post subject: Reply with quote

Dis moi YetiBarBar, Kwenspc t'as remis ta carte du SAVAGE ou pas encore? :)
Merci de tenir la boutique pendant qu'on s'empiffre ;)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Sun Dec 28, 2008 2:56 pm    Post subject: Reply with quote

El_Goretto wrote:
Dis moi YetiBarBar, Kwenspc t'as remis ta carte du SAVAGE ou pas encore? :)
Merci de tenir la boutique pendant qu'on s'empiffre ;)


[HS]Pas encore, mais j'y songe![/HS]
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 3:03 pm    Post subject: Reply with quote

YetiBarBar wrote:
Ton kernel, 2.6.27 est trop récent pour utiliser les drivers pour utiliser les fglrx 8.6 (8.501).

Utilises la version ~arch des ati-drivers...

Ajoutes la ligne suivante à /etc/portage/package.keywords
Code:
x11-drivers/ati-drivers x86 ~x86


Merci mais quand je fais cette manip, emerge m'indique ">=x11-base/xorg-server-1.5" have been masked. et je ne peux pas compiler.

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Sun Dec 28, 2008 3:32 pm    Post subject: Reply with quote

Oups, un peu trop bourrin...

Retire la ligne que je t'ai faite ajouter vu que tu utilise un xorg-server différent du 1.5, il va falloir "taper juste". A priori, le bon driver serait le 8.10...

Ajoute la ligne:
Code:
=x11-drivers/ati-drivers-8.542
à
Code:
/etc/portage/package.unmask
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 3:44 pm    Post subject: Reply with quote

Toujours la même erreur :(, mais j'ai l'impression que unmask n'a pas fonctionné car il reste toujours sur la version 8.501.

@+
Back to top
View user's profile Send private message
marmotton
n00b
n00b


Joined: 29 Oct 2007
Posts: 57
Location: Toulouse, France

PostPosted: Sun Dec 28, 2008 5:00 pm    Post subject: Reply with quote

Salut,

Il me semble qu'il faut ajouter
Code:
=x11-drivers/ati-drivers-8.542

à /etc/portage/package.keywords.
(le package.unmask permet de démasquer ce qui est hardmasked, mais ne change pas le keyword)
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Sun Dec 28, 2008 9:04 pm    Post subject: Reply with quote

Merci c'est bon ca compile mais par contre autre soucis, dès que je met "fglrx" comme pilote dans mon xorg.conf je n'ai aucune accéleration 2D-3D. Dès que je bouge une fenêtre ca rame.

@+
Back to top
View user's profile Send private message
marmotton
n00b
n00b


Joined: 29 Oct 2007
Posts: 57
Location: Toulouse, France

PostPosted: Sun Dec 28, 2008 9:48 pm    Post subject: Reply with quote

que te disent :

1) glxinfo

2) les logs de xorg

Personnellement je pencherai pour un problème de xorg.conf, à voir....

PS : je ne l'ai pas trouvé en regardant le début du topic, tu as quelle carte graphique exactement?
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Mon Dec 29, 2008 12:28 pm    Post subject: Reply with quote

Voici ce que me donne glxinfo :
Code:

name of display: :0.0
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
    GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_program,
    GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
 GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_draw_buffers, GL_ATI_texture_env_combine3,
    GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square,
    GL_NV_fragment_program, GL_NV_light_max_exponent, GL_NV_point_sprite,
    GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_NV_vertex_program,
    GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SGIX_shadow, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None


Les logs de xorg sont vraiment enormes, je sais pas si c'est jouable de poster ca ici.

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Dec 29, 2008 1:52 pm    Post subject: Reply with quote

Bonjour,

Pour les logs de xorg, si ils sont trop gros:

Code:
emerge nopaste

Code:
nopaste /var/log/Xorg.0.log
puis copie du lien
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Mon Dec 29, 2008 2:04 pm    Post subject: Reply with quote

Volià:

http://rafb.net/p/H3SHVU77.html


merci

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Dec 29, 2008 2:20 pm    Post subject: Reply with quote

Peux tu:

- mettre ton xorg.conf (le pilote utilisé étant vesa...)
- lancer:
Code:
eselect opengl set ati
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Mon Dec 29, 2008 2:40 pm    Post subject: Reply with quote

Voila mon Xorg.conf.

http://rafb.net/p/0obzZL77.html

Pour vesa, effectivement petite erreur de ma part. Je suis repassé à ce pilote quand j'ai vu que ca ne fonctionnait pas avec les drivers ATI.

En lancant
Code:
eselect opengl set ati
je ne constate aucun changement ca rame autant :(.

Merci

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Dec 29, 2008 3:16 pm    Post subject: Reply with quote

Un petit coup de Xorg.0.log avec le driver fglrx cette fois?
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Mon Dec 29, 2008 3:49 pm    Post subject: Reply with quote

Voilà le fichier de log Xorg avec le driver ATI.

http://rafb.net/p/0CY6Ci84.html

@+
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Dec 29, 2008 5:40 pm    Post subject: Reply with quote

extrait de ton xorg.conf wrote:
Section "Module"

# This loads the DBE extension module.
# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
# This loads the font modules
# Load "type1"
# This loads the GLX module
Load "dbe" # Double buffer extension
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection
Load "freetype"
# Load "xtt"
Load "glx"
# This loads the DRI module
Load "dri"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "type1"
EndSection


Vire les doublons dans cette section, surtout extmod qui te ramène xfree86-dga dont tu n'as très certainement pas besoin et vire le Group 0 qui limite à root l'accés à DRI...!

Si tu y tiens, contente toi d'un
Code:
group "video"
(or be root :lol: )
Back to top
View user's profile Send private message
jibe
n00b
n00b


Joined: 03 Dec 2007
Posts: 18

PostPosted: Mon Dec 29, 2008 8:47 pm    Post subject: Reply with quote

J'ai fait toutes les manip et ca rame toujours autant, je suis repassé sur le pilote vesa.

Merci de ton aide.

@+
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum