Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Fri Jan 09, 2009 3:12 am    Post subject: Reply with quote

I upgraded to 4.1.87 seemingly fine after getting rid of crazy. But when I logged out and back in, I get a plasma-workspace crash. All the error says is:
Code:
Plasma Workspace crashed causing a signal 11
[current thread is 0 (LWP 1868]


I'll go search bugs but maybe someone knows a quick remedy. I can still log into 3.5.10.

cheers, Jd

[edit] I also deleted the ~/.kde4.2/share/config/plasmarc with no luck. Another error that pops up is "cannot use xine multimedia backup - no shared library found"
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 09, 2009 7:09 pm    Post subject: Reply with quote

I just did a fresh Gentoo pure ~amd64 54bit install on my new hardware on a spare partition, and wanted to try a fresh kde-crazy. I noticed that qt-split is up to 4.5_beta1.
Is it recommended to move to that at this time? I have run qt-9999 svn, so I'm not worried- I just wish to know what others on this thread are using, and any advice or comments. I was looking for 4.4.3, but find no ebuilds in portage or kde-crazy. Is Gentoo skipping 4.4.3, and just going straight to 4.5? Other Distros have been successfully using 4.4.3 for some time, so I wonder about this.

Also, what about the glib and opengl USE flags on core and gui- they use to be mandatory. Is this no longer true? Are they beneficial and are they needed for any 3D stuff you want to mess with?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Fri Jan 09, 2009 7:39 pm    Post subject: Reply with quote

Quote:
I noticed that qt-split is up to 4.5_beta1. Is it recommended to move to that at this time?


I wouldn't recommend it myself, it seemed to break a few things without offering any real benefit.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 09, 2009 7:46 pm    Post subject: Reply with quote

mikedee wrote:
Quote:
I wouldn't recommend it myself, it seemed to break a few things without offering any real benefit.
Well- guess it's too late now- almost done installing 4.5_beta1. :roll: Could you be a bit more specific- what does it have problems with? I'll post back what happens with kde-crazy.

Anyone else have some more comments? :)
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Fri Jan 09, 2009 7:49 pm    Post subject: Reply with quote

Some programs crash on exit, amarok won't compile...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Fri Jan 09, 2009 8:02 pm    Post subject: Reply with quote

the kde-testing overlay now has 4.1.96 ebuilds but none of the kde servers have a 4.1.96 directory. Is there some other place those files should come from?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 09, 2009 8:09 pm    Post subject: Reply with quote

Thanks for the replies. :)
Since this is basically just a new 64bit testing partition for yet another kde-crazy install, and i don't use Amarok, guess for now I'll give 4.5_beta1 a shot and see what happens. :)
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Fri Jan 09, 2009 8:09 pm    Post subject: Reply with quote

This is the RC which will come next Tuesday!
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Fri Jan 09, 2009 8:39 pm    Post subject: Reply with quote

Ah, putting in the ebuilds before the actual release... tricky but interesting. I guess I'll leave them masked, then.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Fri Jan 09, 2009 11:44 pm    Post subject: Reply with quote

Hmmm. libworkspace keeps failing after removing source files and a fresh checkout with this. Anyone know what causes the rsync error, and how to get around or fix it? This is on ~amd64.
Code:
A    workspace/kwin/clients/ozone/lib/helper.h
Checked out external at revision 908588.

Checked out revision 908587.
 *    working copy: /usr/portage/distfiles/svn-src/kdebase-workspace/workspace

 * Exporting parts of working copy to /var/tmp/portage/kde-base/libkworkspace-9999/work/libkworkspace-9999
rsync: change_dir "/libs" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.5]
 *
 * ERROR: kde-base/libkworkspace-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3769:  Called kde4-meta_src_unpack
 *             environment, line 3000:  Called kde4-meta_src_extract
 *             environment, line 2915:  Called die
 * The specific snippet of code:
sed: can't read /var/tmp/portage/kde-base/libkworkspace-9999/temp/environment: No such file or directory
 *  The die message:
 *   subversion: can't export subdirectory 'libs/kworkspace' to '/var/tmp/portage/kde-base/libkworkspace-9999/work/libkworkspace-9999/libs'.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/libkworkspace-9999/temp/build.log'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-meta.eclass
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-base.eclass
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-functions.eclass
 * This ebuild is from an overlay: '/usr/local/portage/layman/kde-crazy/'
 *

EDIT: remerge of subversion seems to have fixed libworkspace- it compiles fine, but on the very next package it fails with a similar rsync/subversion error. :?
Code:
A    apps/plasma/CMakeLists.txt
 U   apps
Checked out revision 908596.
 *    working copy: /usr/portage/distfiles/svn-src/kdebase-apps/apps

 * Exporting parts of working copy to /var/tmp/portage/kde-base/libkonq-9999/work/libkonq-9999
could not make way for new symlink: lib
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.5]
 *
 * ERROR: kde-base/libkonq-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3769:  Called kde4-meta_src_unpack
 *             environment, line 3000:  Called kde4-meta_src_extract
 *             environment, line 2904:  Called die
 * The specific snippet of code:
 *           rsync ${rsync_options} "${ESVN_WC_PATH}"/${kmnamedir}* "${S}" || die "${ESVN}: can't export toplevel files to '${S}'.";
 *  The die message:
 *   subversion: can't export toplevel files to '/var/tmp/portage/kde-base/libkonq-9999/work/libkonq-9999'.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/libkonq-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/libkonq-9999/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-meta.eclass
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-base.eclass
 *   /usr/local/portage/layman/kde-crazy/eclass/kde4-functions.eclass
 * This ebuild is from an overlay: '/usr/local/portage/layman/kde-crazy/'


EDIT2: OK- a remerge of rsync-3.0.5 seems to have fixed my problem- 6 packages have proceeded normally and compile is continuing on kdebase-live. :D
This is ridiculous- package 7 0f 72 just failed with the same type error! 8O
Code:
A    runtime/COPYING.LIB
Checked out revision 908600.
 *    working copy: /usr/portage/distfiles/svn-src/kdebase-runtime/runtime

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kdesu-9999/work/kdesu-9999
rsync: link_stat "/kdesu" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.5]
 *
 * ERROR: kde-base/kdesu-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3768:  Called kde4-meta_src_unpack
 *             environment, line 2998:  Called kde4-meta_src_extract
 *             environment, line 2913:  Called die
 * The specific snippet of code:
 *               rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 *  The die message:
 *   subversion: can't export subdirectory 'kdesu/' to '/var/tmp/portage/kde-base/kdesu-9999/work/kdesu-9999/'.

This is just weird! If I do an "emerge --resume" the failed package compiles fine, and keeps going! WTF is going on here? :?
Failed again after 15 packages- emerge --resume started it up again- now at 5 more packages- still going. :? :? :? OK- all 51 packages left in kdebase went OK. However, on kdeartwork, kdeadmin, and kdeutils, the first package of each set failed with the same error as above, and an emerge --resume compiled the failed package AND the rest of each set. :?

Any ideas?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental


Last edited by wrc1944 on Sat Jan 10, 2009 1:29 am; edited 1 time in total
Back to top
View user's profile Send private message
laughinggnome
n00b
n00b


Joined: 07 Mar 2006
Posts: 45

PostPosted: Sat Jan 10, 2009 1:29 am    Post subject: Reply with quote

genstorm wrote:
Some programs crash on exit, amarok won't compile...


Amarok now compiles: https://bugs.kde.org/show_bug.cgi?id=177863
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Sat Jan 10, 2009 3:04 am    Post subject: amarok 2.0.1 Reply with quote

I'm not sure if anyone cares but:
I noticed there was an amarok-2.0.1 (bug fix from 2.0-r1?) so I just renamed the 2.0 ebuild from kde-testing and the install went fine.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sat Jan 10, 2009 10:12 am    Post subject: Reply with quote

activating nepomuk in system settings makes my cpu always at 20-30% also if strigi is off or idle... it's only my problem?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 10, 2009 1:56 pm    Post subject: Reply with quote

wrc1944 wrote:

EDIT2: OK- a remerge of rsync-3.0.5 seems to have fixed my problem- 6 packages have proceeded normally and compile is continuing on kdebase-live. :D
This is ridiculous- package 7 0f 72 just failed with the same type error! 8O
Code:
A    runtime/COPYING.LIB
Checked out revision 908600.
 *    working copy: /usr/portage/distfiles/svn-src/kdebase-runtime/runtime

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kdesu-9999/work/kdesu-9999
rsync: link_stat "/kdesu" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.5]
 *
 * ERROR: kde-base/kdesu-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3768:  Called kde4-meta_src_unpack
 *             environment, line 2998:  Called kde4-meta_src_extract
 *             environment, line 2913:  Called die
 * The specific snippet of code:
 *               rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 *  The die message:
 *   subversion: can't export subdirectory 'kdesu/' to '/var/tmp/portage/kde-base/kdesu-9999/work/kdesu-9999/'.

This is just weird! If I do an "emerge --resume" the failed package compiles fine, and keeps going! WTF is going on here? :?
Failed again after 15 packages- emerge --resume started it up again- now at 5 more packages- still going. :? :? :? OK- all 51 packages left in kdebase went OK. However, on kdeartwork, kdeadmin, and kdeutils, the first package of each set failed with the same error as above, and an emerge --resume compiled the failed package AND the rest of each set. :?

Any ideas?


yeah, I second that :P

I'm getting this strange error already for some time (afaik I already encountered it on november or october),

it seems to occur spontaneously and if you resume emerge it strangely works again

for me it also was trying to sync files from / (and execute it ???)

anyone could do an audit to subversion's / rsync's code ? maybe there's some malicious routines in it ? (which one of them both is actually the cause or is it just portage going crazy ?)

I started learning programming 4 years ago but quickly stopped since I switched to another study - so if I saw something strange I wouldn't know :lol: ,

so any input (explaining this behavior) on this would be appreciated :idea:

thanks
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D


Last edited by kernelOfTruth on Sat Jan 10, 2009 2:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Sat Jan 10, 2009 2:21 pm    Post subject: Reply with quote

tampakrap said that the eclasses were going into the main tree this weekend, so I would probably expect some wierdness. Personally I am going to wait until tomorrow and then do a full layman -s kde-crazy && emerge --sync which should put everything right. If I am not mistaken, the portage tree and the layman overlay need to be in exact sync or you will have problems.
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Sat Jan 10, 2009 6:06 pm    Post subject: Reply with quote

I have a very strange problem with plasma, it simple don't start. I can't fire any program or see anything (exept a checkered pseudo-wallpaper)

The .xsession-errors said that plasma cannot find serviceType "Plasma/Applet" and stuff like that.

Code:
circe kde4 # cat .xsession-errors                                               
xset:  bad font path element (#98), possible causes are:                                                                     
    Directory does not exist or has wrong permissions                                                                         
    Directory missing fonts.dir                                                                                               
    Incorrect font server address or syntax                                                                                   
startkde: Starting up...                                                                                                     
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher                                                                 
kdeinit4: preparing to launch /usr/bin/kded4                                                                                 
kdeinit4: preparing to launch /usr/bin/kbuildsycoca4                                                                         
kbuildsycoca4 running...                                                                                                     
kdeinit4: preparing to launch /usr/lib/kde4/libexec/kconf_update                                                             
"KConfigIni: In file /tmp/kde-kde4/kconf_updateUA5920.tmp, line 1: " Invalid entry (missing '=')                             
kded(5916)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "KDEDModule"  not found       
kdeinit4: preparing to launch /usr/bin/kcminit_startup                                                                       
kcminit(5960)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "KCModuleInit"  not found 
kdeinit4: preparing to launch /usr/bin/ksmserver                                                                             
could not access kephald, falling back to QDesktopWidget                                                                     
adding an output 0 with geom:  QRect(1152,0 1152x864)                                                                         
adding an output 1 with geom:  QRect(0,0 1152x864)                                                                           
adding a disconnected output 2                                                                                               
adding a disconnected output 3                                                                                               
kwin(5964): Couldn't start knotify from knotify4.desktop:  "Could not find service 'knotify4.desktop'."                       

kdeinit4: preparing to launch /usr/bin/plasma
could not access kephald, falling back to QDesktopWidget
adding an output 0 with geom:  QRect(1152,0 1152x864)   
adding an output 1 with geom:  QRect(0,0 1152x864)       
adding a disconnected output 2                           
adding a disconnected output 3                           
QFSFileEngine::open: No file name specified             
QFSFileEngine::open: No file name specified             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                           
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Animator"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found 
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                           
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found 
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                           
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Wallpaper"  not found                                                                                                                             
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found 
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found                                                                                                                           
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/DataEngine"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Applet"  not found
plasma(5969)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Containment"  not found
kdeinit4: preparing to launch /usr/bin/krunner
kdeinit4: preparing to launch /usr/bin/kmixctrl
kded(5916)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "KDEDModule"  not found
kdeinit4: preparing to launch /usr/bin/kmix
kdeinit4: preparing to launch /usr/bin/klipper
QObject: Do not delete object, 'unnamed', during its event handler!
klipper(5976)/kdecore (KWin) KWindowInfo::geometry: Pass NET::WMDesktop to KWindowInfo

QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
krunner(5973)/kdecore (trader) KServiceTypeTrader::defaultOffers: KServiceTypeTrader: serviceType  "Plasma/Runner"  not found
QObject: Do not delete object, 'unnamed', during its event handler!
XIO:  fatal IO error 11 (Recurso no disponible temporalmente) on X server ":0.0"
      after 15 requests (8 known processed) with 0 events remaining.
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
Unexpected response from KInit (response= 0).
startkde: Could not start ksmserver. Check your installation.
Error: Can't open display: :0


I have this problem in .85 and .87, with a clean user or with my default user. I google about this error and only find stuff related to amarok (someting about a .desktop file missing. I check with another machine with equery -f kdelibs and seems that both machines have the same files )

Any idea? I almost sure it's a permission problem or a bad config file, but I cannot find the source of the problem.[/code]
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sun Jan 11, 2009 1:04 am    Post subject: Reply with quote

@wrc1944
@kernelOfTruth

Check whether svn extract issues are still present in kde-crazy with live ebuilds (that means sync overlay).
_________________
Maciek
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jan 11, 2009 11:34 am    Post subject: Reply with quote

I have recently sync the kde-testing and kde-crazy overlay and I get this:
Code:

emerge -uDNav world
Error during set creation: Redefinition of set 'plasmoids' (sections: 'kde sets', 'kde crazy sets')
Error during set creation: Redefinition of set 'qt-split' (sections: 'kde sets', 'kde crazy sets')
Error during set creation: Redefinition of set 'koffice-2' (sections: 'kde sets', 'kde crazy sets')



It's something I should worry about it?
Back to top
View user's profile Send private message
cracki
n00b
n00b


Joined: 12 Oct 2005
Posts: 34

PostPosted: Sun Jan 11, 2009 5:00 pm    Post subject: Reply with quote

Krog wrote:
activating nepomuk in system settings makes my cpu always at 20-30% also if strigi is off or idle... it's only my problem?


Same here. I have it disabled so that KDE becomes actually useable.
Also my Xserver consumes now up to 10% cpu with desktop effects enabled and newest nvidia-drivers .22
Dont know if this is normal. :?:
Back to top
View user's profile Send private message
cracki
n00b
n00b


Joined: 12 Oct 2005
Posts: 34

PostPosted: Sun Jan 11, 2009 5:06 pm    Post subject: Reply with quote

tampakrap wrote:
@cracki: i already stated this twice: remove the gstreamer flag.


Opps. Im sorry I didnt red your message.
Sound does now work thx to your tips, although the backend list is still empty. :?:
I think it would be worth adding a comment in the ebuild regarding the fact that gstreamer use flag causes malfunction.
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 154
Location: Czech Republic

PostPosted: Sun Jan 11, 2009 5:38 pm    Post subject: Reply with quote

marcus84 wrote:
I have recently sync the kde-testing and kde-crazy overlay and I get this:
Code:

emerge -uDNav world
Error during set creation: Redefinition of set 'plasmoids' (sections: 'kde sets', 'kde crazy sets')
Error during set creation: Redefinition of set 'qt-split' (sections: 'kde sets', 'kde crazy sets')
Error during set creation: Redefinition of set 'koffice-2' (sections: 'kde sets', 'kde crazy sets')



It's something I should worry about it?


The same situation there, followed by

Code:
 !!! All ebuilds that could satisfy ">=kde-base/kdepimlibs-4.1.96[-kdeprefix]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdepimlibs-9999 (masked by: missing keyword)
- kde-base/kdepimlibs-4.1.96 (masked by: package.mask)
/usr/local/portage/layman/kde-testing/profiles/package.mask:
# Alexey Shvetsov (09 Jan 2009)
# Masked untill release


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "kde-base/kdedglobalaccel-4.1.96" [ebuild])
(dependency required by "@world" [argument])


EDIT: It was my faul, the kde-base/kdedglobalaccel was in /etc/package.unmask for some reason...


Last edited by mkyral on Sun Jan 11, 2009 9:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Sun Jan 11, 2009 6:03 pm    Post subject: Reply with quote

Krog wrote:
activating nepomuk in system settings makes my cpu always at 20-30% also if strigi is off or idle... it's only my problem?
No, it's the same on my system
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Sun Jan 11, 2009 6:04 pm    Post subject: Reply with quote

cracki wrote:
Krog wrote:
activating nepomuk in system settings makes my cpu always at 20-30% also if strigi is off or idle... it's only my problem?


Same here. I have it disabled so that KDE becomes actually useable.
Also my Xserver consumes now up to 10% cpu with desktop effects enabled and newest nvidia-drivers .22
Dont know if this is normal. :?:
not really KDE related, bus it firefox 3 working for you with driver 180.22 and nvidia opengl implementation?
Back to top
View user's profile Send private message
cracki
n00b
n00b


Joined: 12 Oct 2005
Posts: 34

PostPosted: Sun Jan 11, 2009 6:56 pm    Post subject: Reply with quote

Dusdan wrote:
not really KDE related, bus it firefox 3 working for you with driver 180.22 and nvidia opengl implementation?


Yes, firefox 3.0.5 no problems here.
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Sun Jan 11, 2009 10:04 pm    Post subject: Reply with quote

cracki wrote:
Dusdan wrote:
not really KDE related, bus it firefox 3 working for you with driver 180.22 and nvidia opengl implementation?


Yes, firefox 3.0.5 no problems here.
Can you please give me some more info here:
https://forums.gentoo.org/viewtopic-p-5326292-highlight-firefox+nvidia.html#5326292
?

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 38, 39, 40  Next
Page 6 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum