Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Dont Panic
Guru
Guru


Joined: 20 Jun 2007
Posts: 322
Location: SouthEast U.S.A.

PostPosted: Wed Jan 14, 2009 1:36 am    Post subject: Reply with quote

Isn't printer configuration supposed to be available in the 4.2 betas?

I'm having trouble finding it and/or getting it working.

I've just updated to the 4.1.96 versions of the @kdebase-4.2, @kdeadmin-4.2, and @kdeutils-4.2 sets, but I don't see a Printer Configuration option in my System Settings panel.
Back to top
View user's profile Send private message
bleumas
n00b
n00b


Joined: 14 Jan 2009
Posts: 1

PostPosted: Wed Jan 14, 2009 4:51 am    Post subject: libkworkspace failed to emerge Reply with quote

Hello,

I just tried to emerge the kde live build and got the following error message.

Code:

CMake Error at CMakeLists.txt:220 (macro_write_basic_cmake_version_file):
  Unknown CMake command "macro_write_basic_cmake_version_file".


-- Configuring incomplete, errors occurred!
 *
 * ERROR: kde-base/libkworkspace-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_configure
 *             environment, line 3764:  Called kde4-meta_src_configure
 *             environment, line 2898:  Called kde4-base_src_configure
 *             environment, line 2611:  Called cmake-utils_src_configure
 *             environment, line  954:  Called cmake-utils_src_configureout
 *             environment, line  973:  Called die
 * The specific snippet of code:
 *       cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";
 *  The die message:
 *   Cmake failed


I have no idea what the problem is. Haven't found anything helpful on the Internet .

I run the latest cmake version in portage (2.6.2-r1).


EDIT:
I checked the installation of the other packages and noticed that kdelibs-9999 only installed 5 files, the same for kdepimlibs-9999. I tried to reinstall both packages, but the same thing happened. It didn't even try to configure the package, but it said it was successfully emerged. I checked out the source files again and still had the same problem.
After a reboot, kdelibs-9999 emerged like it was supposed to. I have no idea what the problem before was, but at least now I know why nobody else seems to have this problem.


Last edited by bleumas on Wed Jan 14, 2009 7:36 am; edited 2 times in total
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Wed Jan 14, 2009 6:48 am    Post subject: Reply with quote

well.... I'm note the one!!!
Back to top
View user's profile Send private message
Strayer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2003
Posts: 75
Location: Germany

PostPosted: Wed Jan 14, 2009 8:41 am    Post subject: Reply with quote

Just a quick question... should I really run "emerge --regen" after each overlay sync as described in the error/warning that portage gives me each time? (eclasses override)

Or, in other words, what will I lose/risk if I don't? According to the manpage the only thing that could happen is a slower dependency resolution.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Wed Jan 14, 2009 9:28 am    Post subject: Reply with quote

as explained here: http://vizzzion.org/?blogentry=904
i'm triyng to use sesame/soprano/nepomuk with sesame2 backend (which is java, as i understand).
They say it is more fast than the default clucene backend.
There is sesame2 support in soprano ebuild, but not in strigi one:
Code:
[ebuild   R   ] app-misc/strigi-0.6.2  USE="clucene* dbus exif fam qt4 -debug -hyperestraier -inotify -log -test" 0 kB [1]
[ebuild   R   ] dev-libs/soprano-2.1.64  USE="clucene* sesame2 -debug -doc -redland" 0 kB [1]

In fact it does'nt function with sesame2, at least for me.
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Wed Jan 14, 2009 10:40 am    Post subject: Reply with quote

Krog wrote:
as explained here: http://vizzzion.org/?blogentry=904
i'm triyng to use sesame/soprano/nepomuk with sesame2 backend (which is java, as i understand).
They say it is more fast than the default clucene backend.


I guess they ment sesame2 backend (java library accessed via JNI C++ wrapper) ifs faster than redland (using raptor or librdf).
Anyway, apparently you have some 'incompatible' java sdk. IBM Jdk is known to not be found by cmake FindJNI module. Try with sun-jdk instead if you want to make use of sesame2.
_________________
Maciek
Back to top
View user's profile Send private message
PaV
Apprentice
Apprentice


Joined: 28 Jan 2004
Posts: 176
Location: Poland

PostPosted: Wed Jan 14, 2009 6:51 pm    Post subject: Reply with quote

I did layman -S today and got kind of unusual output from emerge, some of those even say "report a bug"... What should I do?

Code:
# emerge -auv world                                                               

These are the packages that would be merged, in order:

Calculating dependencies / *
 * ERROR: x11-themes/gtk-engines-kde4-0.8-r1 failed.
 * Call stack:                                     
 *                        ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/x11-themes/gtk-engines-kde4/gtk-engines-kde4-0.8-r1.ebuild'                     
 *   gtk-engines-kde4-0.8-r1.ebuild, line    6:  Called inherit 'kde4-base'               
 *                        ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'                                                                             
 *                        ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'                                                                                 
 *                 kde4-base.eclass, line  166:  Called die                               
 * The specific snippet of code:                                                           
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 
 *  The die message:                                                                       
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild                   
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 | *
 * ERROR: media-gfx/digikam-0.10.0_beta8 failed.
 * Call stack:                                 
 *                     ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/media-gfx/digikam/digikam-0.10.0_beta8.ebuild'                                     
 *   digikam-0.10.0_beta8.ebuild, line   11:  Called inherit 'kde4-base'                   
 *                     ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'                                                                                 
 *                     ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'                                                                                   
 *              kde4-base.eclass, line  166:  Called die                                   
 * The specific snippet of code:                                                           
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 
 *  The die message:                                                                       
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild                   
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 - *
 * ERROR: x11-themes/plasma-themes-0.2-r1 failed.
 * Call stack:                                   
 *                     ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/x11-themes/plasma-themes/plasma-themes-0.2-r1.ebuild'                             
 *   plasma-themes-0.2-r1.ebuild, line    9:  Called inherit 'kde4-base'                   
 *                     ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'                                                                                 
 *                     ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'                                                                                   
 *              kde4-base.eclass, line  166:  Called die                                   
 * The specific snippet of code:                                                           
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 
 *  The die message:                                                                       
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild                   
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 | *
 * ERROR: kde-misc/kdiff3-0.9.93 failed.
 * Call stack:                         
 *               ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-misc/kdiff3/kdiff3-0.9.93.ebuild'                                                   
 *    kdiff3-0.9.93.ebuild, line    9:  Called inherit 'kde4-base'                         
 *               ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'                                                                                       
 *               ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'                                                                                         
 *        kde4-base.eclass, line  166:  Called die                                         
 * The specific snippet of code:                                                           
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 
 *  The die message:                                                                       
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild                   
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 | *
 * ERROR: kde-base/kdedglobalaccel-4.1.96 failed.
 * Call stack:                                   
 *                       ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kdedglobalaccel/kdedglobalaccel-4.1.96.ebuild'                         
 *   kdedglobalaccel-4.1.96.ebuild, line    8:  Called inherit 'kde4-meta'                 
 *                       ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                               
 *                       ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                 
 *                kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kdedglobalaccel'                                                                                 
 *           kde4-functions.eclass, line  358:  Called die                                 
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 - *
 * ERROR: net-p2p/ktorrent-3.2_beta1-r1 failed.
 * Call stack:                                 
 *                      ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/net-p2p/ktorrent/ktorrent-3.2_beta1-r1.ebuild'                                   
 *   ktorrent-3.2_beta1-r1.ebuild, line    9:  Called inherit 'kde4-base'                 
 *                      ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'                                                                               
 *                      ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'                                                                                   
 *               kde4-base.eclass, line  166:  Called die                                 
 * The specific snippet of code:                                                           
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild" 
 *  The die message:                                                                       
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild                   
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 \ *
 * ERROR: kde-base/libplasmaclock-4.1.96 failed.
 * Call stack:                                 
 *                      ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/libplasmaclock/libplasmaclock-4.1.96.ebuild'                             
 *   libplasmaclock-4.1.96.ebuild, line   10:  Called inherit 'kde4-meta'                 
 *                      ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                               
 *                      ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                   
 *               kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/libplasmaclock'                                                                                   
 *          kde4-functions.eclass, line  358:  Called die                                 
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 / *
 * ERROR: kde-base/powerdevil-4.1.96 failed.
 * Call stack:                             
 *                  ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/powerdevil/powerdevil-4.1.96.ebuild'                                         
 *   powerdevil-4.1.96.ebuild, line    8:  Called inherit 'kde4-meta'                     
 *                  ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                                   
 *                  ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                       
 *           kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/powerdevil'
 *      kde4-functions.eclass, line  358:  Called die                                     
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 / *
 * ERROR: kde-base/kdeartwork-desktopthemes-4.1.96 failed.
 * Call stack:                                           
 *                                ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kdeartwork-desktopthemes/kdeartwork-desktopthemes-4.1.96.ebuild'                                                                                         
 *   kdeartwork-desktopthemes-4.1.96.ebuild, line    9:  Called inherit 'kde4-meta'       
 *                                ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                     
 *                                ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                         
 *                         kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kdeartwork-desktopthemes'                                                               
 *                    kde4-functions.eclass, line  358:  Called die                       
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 / *
 * ERROR: kde-base/kwrited-4.1.96 failed.
 * Call stack:                           
 *               ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kwrited/kwrited-4.1.96.ebuild'                                                 
 *   kwrited-4.1.96.ebuild, line    7:  Called inherit 'kde4-meta'                         
 *               ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                                       
 *               ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                         
 *        kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kwrited'       
 *   kde4-functions.eclass, line  358:  Called die                                         
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 | *
 * ERROR: kde-base/phonon-kde-4.1.96 failed.
 * Call stack:                             
 *                  ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/phonon-kde/phonon-kde-4.1.96.ebuild'                                         
 *   phonon-kde-4.1.96.ebuild, line    9:  Called inherit 'kde4-meta'                     
 *                  ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                                   
 *                  ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                       
 *           kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/phonon-kde'
 *      kde4-functions.eclass, line  358:  Called die                                     
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *                                                                                         
 | *
 * ERROR: kde-base/kephal-4.1.96 failed.
 * Call stack:                         
 *               ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kephal/kephal-4.1.96.ebuild'                                                   
 *    kephal-4.1.96.ebuild, line    9:  Called inherit 'kde4-meta'                         
 *               ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'                                                                                       
 *               ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'                                                                                         
 *        kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kephal'       
 *   kde4-functions.eclass, line  358:  Called die                                         
 * The specific snippet of code:                                                           
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"           
 *  The die message:                                                                       
 *   Package  not found in KDE_DERIVATION_MAP, please report bug                           
 *                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.     
 *
 \ *
 * ERROR: kde-base/kdebase-desktoptheme-4.1.96 failed.
 * Call stack:
 *                            ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kdebase-desktoptheme/kdebase-desktoptheme-4.1.96.ebuild'
 *   kdebase-desktoptheme-4.1.96.ebuild, line    9:  Called inherit 'kde4-meta'
 *                            ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'
 *                            ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'
 *                     kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kdebase-desktoptheme'
 *                kde4-functions.eclass, line  358:  Called die
 * The specific snippet of code:
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"
 *  The die message:
 *   Package  not found in KDE_DERIVATION_MAP, please report bug
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
 \ *
 * ERROR: kde-base/kwalletd-4.1.96 failed.
 * Call stack:
 *                ebuild.sh, line 1867:  Called source '/usr/portage/local/layman/kde-testing/kde-base/kwalletd/kwalletd-4.1.96.ebuild'
 *   kwalletd-4.1.96.ebuild, line    8:  Called inherit 'kde4-meta'
 *                ebuild.sh, line 1224:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'
 *                ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'
 *         kde4-meta.eclass, line   45:  Called get-parent-package 'kde-base/kwalletd'
 *    kde4-functions.eclass, line  358:  Called die
 * The specific snippet of code:
 *      die "Package $target not found in KDE_DERIVATION_MAP, please report bug"
 *  The die message:
 *   Package  not found in KDE_DERIVATION_MAP, please report bug
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *
... done!

!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
kde-base/kdeartwork-desktopthemes:4.2 kde-base/kwrited:4.2 kde-base/kdebase-desktoptheme:4.2

!!! All ebuilds that could satisfy ">=media-libs/libkexiv2-0.1.6" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/libkexiv2-0.1.7-r1 (masked by: ~amd64 keyword)
- media-libs/libkexiv2-0.1.6 (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "media-gfx/digikam-0.9.4" [ebuild])
(dependency required by "@world" [argument])



Code:

# cat /etc/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j3"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="7zip X a52 aac alsa -arts bash-completion cairo canna cdr cgi chm
     cjk cpudetection cscope cups dbus djvu dvd dvdr -emacs dvdread ebook exif fbcon
     ffmpeg fftw
     flac foomaticdb ftp gcj gif gimp -gnome gphoto2 gstreamer gtk idn ieee1394
     imagemagick immqt-bc jack jpeg kde kdeenablefinal latex lm_sensors
     mime mmx mmxext mp3 mpeg mplayer musepack ncurses nls nptl nsplugin ogg
     openal opengl pdf perl png postgres python qt3 qt4 quicktime raw real rss ruby smp
     srt sse sse2 sse3 ssse3 ssl subversion svg threads tiff truetype unicode usb vidix
     vim-syntax win32codecs wxwindows x264 xulrunner xvid zlib"

INPUT_DEVICES="keyboard mouse"
ALSA_CARDS="virtuoso"
VIDEO_CARDS="fglrx radeon"
PORTDIR_OVERLAY="/usr/local/portage"
FEATURES="metadata-transfer"
CAMERA="ptp2"
source /usr/portage/local/layman/make.conf
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Thu Jan 15, 2009 2:33 am    Post subject: Reply with quote

Has anyone tried out to add a script to KDE4 autostart? It doesn't seem to work for me and loses settings next time I start systemsettings.

It's the same with the Task Scheduler...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Thu Jan 15, 2009 3:41 am    Post subject: Reply with quote

what do you do to get amarok2 to have sound? Everything else seems to work - smplayer, audacity, vlc. I have xine-lib installed and phonon and phonon-kde, I emerged amarok with these use flags:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="ipod kdeprefix mp4 mtp opengl semantic-desktop -daap -debug -ifp -mp3tunes -njb"

I don't have gstreamer installed.

When I open up systemsettings, I don't have a "Sound" choice but "Multimedia" is there and it shows backend as blank (it did, before I upgraded to kde-4.1.96, show xine in there as backend but sound did not work for amarok then either). Sound card is HDA Intel (AD198x Analog).

I'm using kde-testing overlay.

cheers, JD
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Thu Jan 15, 2009 6:38 am    Post subject: Reply with quote

I installed koffice @koffice-2 all goes well except for the language, it gives me this error
Code:
>>> Emerging (1 of 1) app-office/koffice-l10n-1.9.98.5 from kde-crazy
 * koffice-l10n-fr-1.9.98.5.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                      [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                     [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                    [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                   [ ok ]
>>> Unpacking source...
>>> Unpacking koffice-l10n-fr-1.9.98.5.tar.bz2 to /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/work
>>> Source unpacked in /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/work
>>> Configuring source in /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/work ...
>>> Source compiled.
>>> Test phase [not enabled]: app-office/koffice-l10n-1.9.98.5

>>> Install koffice-l10n-1.9.98.5 into /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/image/ category app-office
>>> Completed installing koffice-l10n-1.9.98.5 into /var/tmp/portage/app-office/koffice-l10n-1.9.98.5/image/


>>> Installing app-office/koffice-l10n-1.9.98.5
 * checking 0 files for package collisions
>>> Safely unmerging already-installed instance...
No package files given... Grabbing a set.
 * Running kbuildsycoca4 to build global database ...                                                                                                                     [ ok ]
>>> Original instance of package unmerged safely.
 * Running kbuildsycoca4 to build global database ...                                                                                                                     [ ok ]
>>> Auto-cleaning packages...

we can see that it compiles and does nothing.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Thu Jan 15, 2009 8:32 am    Post subject: Reply with quote

hunky wrote:
what do you do to get amarok2 to have sound? Everything else seems to work - smplayer, audacity, vlc. I have xine-lib installed and phonon and phonon-kde, I emerged amarok with these use flags:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="ipod kdeprefix mp4 mtp opengl semantic-desktop -daap -debug -ifp -mp3tunes -njb"

I don't have gstreamer installed.

It works here with these settings:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="mp4 opengl -daap -debug -ifp -ipod -kdeprefix -mp3tunes -mtp -njb -semantic-desktop"
[I--] [ ~] kde-base/phonon-kde-4.1.96 (4.2)
[I--] [ ~] media-sound/phonon-4.2.96 (0)
[I--] [  ] media-libs/xine-lib-1.1.16 (1)

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
PuckPoltergeist
Apprentice
Apprentice


Joined: 28 Jul 2004
Posts: 189

PostPosted: Thu Jan 15, 2009 2:07 pm    Post subject: Reply with quote

Since kde-4.1.87 I can't logout from kde anymore. Neither the context menu with the right mouse button works, nor the K-menu in the panel. When I try it, panel and windows disappear, the background fades out to grey and then nothing happens. I can move the mouse and when I click, I'm back to the desktop.

Second problem since 4.1.87 are the fonts in the panel, which are very dark and not readable.
a screenshot: http://www.stud.tu-ilmenau.de/~johi-in/darkcolor.jpg

Anyone a hint how this can be solved?

EDIT: Ok, the unreadable fonts are because the color is not changed when disabling desktop-effects. With enabled effects the panel is transparent, so the black font is readable. I only have to find out which color must be changed.

EDIT2: The logout problem is also related to disabled desktop effects. The window to choice logoff, reboot or shutdown is only showed when desktop effects are enabled. So, who can I get the old behavior with disabled effects? AIGLX isn't really usable with the fglrx driver.
_________________
printk(KERN_CRIT "Whee.. Swapped out page in kernel page table\n");
linux-2.6.6/mm/vmalloc.c
Back to top
View user's profile Send private message
Terq
n00b
n00b


Joined: 01 Sep 2007
Posts: 4
Location: Finland

PostPosted: Thu Jan 15, 2009 4:52 pm    Post subject: Transparent taskbar Reply with quote

The taskbar in KDE4 became transparent. This error first appeared after upgrade to kde-4.1.87 from kde-4.1.85, the taskbar (or " task manager" as KDE calls it) became completely transparent after the upgrade (see screenshot. The problem persisted after upgrade to kde-4.1.96.
I've tried downgrading my nvidia-drivers, first from 180.22 (berkano overlay) to 180.18 and as last: 177.82 I've too tried disabling
desktop effects with the effect that the taskbar becomes normal but the text is blurred. The "K-menu" becomes black without desktop-effects
on.
I've run out of ideas to fix this annoying problem.
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Thu Jan 15, 2009 5:43 pm    Post subject: Reply with quote

the kdevplattform-0.9.85.ebuild is faulty. The download-path should actually read

Quote:
SRC_URI="mirror://kde/unstable/kdevelop/3.9.85/src/${P}.tar.bz2"


instead of 3.9.84
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Thu Jan 15, 2009 5:54 pm    Post subject: Re: Transparent taskbar Reply with quote

Terq wrote:
The taskbar in KDE4 became transparent. This error first appeared after upgrade to kde-4.1.87 from kde-4.1.85, the taskbar (or " task manager" as KDE calls it) became completely transparent after the upgrade (see screenshot. The problem persisted after upgrade to kde-4.1.96.
I've tried downgrading my nvidia-drivers, first from 180.22 (berkano overlay) to 180.18 and as last: 177.82 I've too tried disabling
desktop effects with the effect that the taskbar becomes normal but the text is blurred. The "K-menu" becomes black without desktop-effects
on.
I've run out of ideas to fix this annoying problem.


Try to install kde-base/kdebase-desktoptheme
_________________
hidentity.org
Back to top
View user's profile Send private message
PuckPoltergeist
Apprentice
Apprentice


Joined: 28 Jul 2004
Posts: 189

PostPosted: Thu Jan 15, 2009 6:03 pm    Post subject: Re: Transparent taskbar Reply with quote

KejPi wrote:
Terq wrote:
The taskbar in KDE4 became transparent. This error first appeared after upgrade to kde-4.1.87 from kde-4.1.85, the taskbar (or " task manager" as KDE calls it) became completely transparent after the upgrade (see screenshot. The problem persisted after upgrade to kde-4.1.96.
I've tried downgrading my nvidia-drivers, first from 180.22 (berkano overlay) to 180.18 and as last: 177.82 I've too tried disabling
desktop effects with the effect that the taskbar becomes normal but the text is blurred. The "K-menu" becomes black without desktop-effects
on.
I've run out of ideas to fix this annoying problem.


Try to install kde-base/kdebase-desktoptheme


Thanx, this solved the problems with panel and the logout dialog for me. :)
_________________
printk(KERN_CRIT "Whee.. Swapped out page in kernel page table\n");
linux-2.6.6/mm/vmalloc.c
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 154
Location: Czech Republic

PostPosted: Thu Jan 15, 2009 6:53 pm    Post subject: Plasma themes problems Reply with quote

Hi,
could someone confirm this bug?
http://bugs.kde.org/show_bug.cgi?id=179971

Thanks
Back to top
View user's profile Send private message
PuckPoltergeist
Apprentice
Apprentice


Joined: 28 Jul 2004
Posts: 189

PostPosted: Thu Jan 15, 2009 7:40 pm    Post subject: Re: Plasma themes problems Reply with quote

mkyral wrote:
Hi,
could someone confirm this bug?
http://bugs.kde.org/show_bug.cgi?id=179971

Thanks


Yes, this was the problem, I mentioned above. Solution was installing kde-base/kdebase-desktoptheme.
_________________
printk(KERN_CRIT "Whee.. Swapped out page in kernel page table\n");
linux-2.6.6/mm/vmalloc.c
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Thu Jan 15, 2009 7:45 pm    Post subject: Reply with quote

Or doint emerge -uNDv @world instead of @installed and hoping that this package was added to set.
Back to top
View user's profile Send private message
Terq
n00b
n00b


Joined: 01 Sep 2007
Posts: 4
Location: Finland

PostPosted: Thu Jan 15, 2009 8:06 pm    Post subject: Mouse cursor issue Reply with quote

Thx, it worked.
I've got another problem with KDE4 as well which is that I cannot change the mouse cursor because there are no other mouse cursor to choose. When I open the "Cursor Theme" tab from "Keyboard & Mouse", the only item in the list is "KDE Classic". I've installed other pointer themes so this issue shouldn't be caused by there being no other cursor available. I'm not completely certain whether this is problem caused by KDE4 but
it would be nice if this problem would be solved too.
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 154
Location: Czech Republic

PostPosted: Thu Jan 15, 2009 8:36 pm    Post subject: Re: Plasma themes problems Reply with quote

PuckPoltergeist wrote:
mkyral wrote:
Hi,
could someone confirm this bug?
http://bugs.kde.org/show_bug.cgi?id=179971

Thanks


Yes, this was the problem, I mentioned above. Solution was installing kde-base/kdebase-desktoptheme.


Thanks, it really helped. But I'm pretty sure, I've tested it :-(
Back to top
View user's profile Send private message
szachy
n00b
n00b


Joined: 14 Feb 2005
Posts: 31
Location: Tarnów, Poland

PostPosted: Thu Jan 15, 2009 9:56 pm    Post subject: Reply with quote

Hello is someone can tell me is samba working with dolphin ?
Back to top
View user's profile Send private message
sgao
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 149

PostPosted: Fri Jan 16, 2009 1:31 am    Post subject: Reply with quote

genstorm wrote:
hunky wrote:
what do you do to get amarok2 to have sound? Everything else seems to work - smplayer, audacity, vlc. I have xine-lib installed and phonon and phonon-kde, I emerged amarok with these use flags:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="ipod kdeprefix mp4 mtp opengl semantic-desktop -daap -debug -ifp -mp3tunes -njb"

I don't have gstreamer installed.

It works here with these settings:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="mp4 opengl -daap -debug -ifp -ipod -kdeprefix -mp3tunes -mtp -njb -semantic-desktop"
[I--] [ ~] kde-base/phonon-kde-4.1.96 (4.2)
[I--] [ ~] media-sound/phonon-4.2.96 (0)
[I--] [  ] media-libs/xine-lib-1.1.16 (1)


Can you show the build options for phonon-kde, phonon and xine-lib? I tried rebuilding these packages, but still not able to get sound play out.

xine works fine. I am using snd_hda_intel.
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Fri Jan 16, 2009 1:40 am    Post subject: Reply with quote

sgao wrote:
genstorm wrote:
hunky wrote:
what do you do to get amarok2 to have sound? Everything else seems to work - smplayer, audacity, vlc. I have xine-lib installed and phonon and phonon-kde, I emerged amarok with these use flags:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="ipod kdeprefix mp4 mtp opengl semantic-desktop -daap -debug -ifp -mp3tunes -njb"

I don't have gstreamer installed.

It works here with these settings:
Code:
[ebuild   R   ] media-sound/amarok-2.0.1.1  USE="mp4 opengl -daap -debug -ifp -ipod -kdeprefix -mp3tunes -mtp -njb -semantic-desktop"
[I--] [ ~] kde-base/phonon-kde-4.1.96 (4.2)
[I--] [ ~] media-sound/phonon-4.2.96 (0)
[I--] [  ] media-libs/xine-lib-1.1.16 (1)


Can you show the build options for phonon-kde, phonon and xine-lib? I tried rebuilding these packages, but still not able to get sound play out.

xine works fine. I am using snd_hda_intel.


Thanks for the info Genstorm,
I don't think I can use the -kdeprefix flag as it wants to then pull back in and apply the same flag to kdelibs, kdepimlibs, kdebase-data. Right now I'm running with kdeprefix as I've got 3.5.10 installed too. I may decide to ditch 3.5.10 soon and that would solve that little issue. I will try -semantic-desktop to see if there is any impact getting sound with that when I get home this evening. Otherwise I've got ~ on phonon, phonon-kde, and xine-lib as I'm running unstable.

cheers, jd
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Fri Jan 16, 2009 1:49 am    Post subject: Reply with quote

sgao wrote:
Can you show the build options for phonon-kde, phonon and xine-lib? I tried rebuilding these packages, but still not able to get sound play out.

Of course, here they are:
Code:
[ebuild   R   ] media-libs/xine-lib-1.1.16  USE="X a52 alsa dts dvd flac imagemagick mad mng modplug musepack nls opengl samba sdl theora truetype v4l vcd vorbis xcb xv xvmc -aac -aalib (-altivec) -arts -debug -directfb -dxr3 -esd -fbcon -gnome -gtk -ipv6 -jack -libcaca -mmap -oss -pulseaudio (-real) -speex (-vidix)(-vis) -wavpack (-win32codecs) -xinerama" 0 kB [0]
[ebuild   R   ] kde-base/phonon-kde-4.1.96  USE="-debug -kdeprefix" 0 kB [1]
[ebuild   R   ] media-sound/phonon-4.2.96  USE="xcb xine -debug -gstreamer" 0 kB [1]

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 38, 39, 40  Next
Page 8 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum