Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Mon Jan 19, 2009 2:19 pm    Post subject: Reply with quote

Probably it is bad place for bugs, but: app-text/kchmviewer-4.0 uses bad way for kdeprefix, and installs in wrong dir with 4.2
Code:

if use kdeprefix; then
   KDEDIR="/usr/kde/4.1"
else
   KDEDIR="/usr"
fi

I think it should be fixed.
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 568

PostPosted: Mon Jan 19, 2009 4:22 pm    Post subject: Reply with quote

I installed 4.1.96 from kde-testing, but my desktop has no oxygen theme, so the taskbar, folder view, etc are all invisible. Which package is it in?
Back to top
View user's profile Send private message
Useful Idiot
Guru
Guru


Joined: 30 Aug 2002
Posts: 329
Location: Finland

PostPosted: Mon Jan 19, 2009 4:50 pm    Post subject: Reply with quote

kdebase-desktoptheme
_________________
[size=9]We are all in the gutter, but some of us are looking at the stars.
Back to top
View user's profile Send private message
epsilon72
Guru
Guru


Joined: 20 Sep 2007
Posts: 568

PostPosted: Mon Jan 19, 2009 4:51 pm    Post subject: Reply with quote

Useful Idiot wrote:
kdebase-desktoptheme

Ah there it is. Thank you so much.
Back to top
View user's profile Send private message
Phobos666
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2006
Posts: 76
Location: Germany

PostPosted: Mon Jan 19, 2009 5:12 pm    Post subject: Reply with quote

can anyone help with this please:
https://forums.gentoo.org/viewtopic-p-5400503.html#5400503
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jan 19, 2009 5:52 pm    Post subject: Reply with quote

Phobos666 wrote:
can anyone help with this please:
https://forums.gentoo.org/viewtopic-p-5400503.html#5400503


Instead of hijacking threads not related to your problem, why not start one in a forum that may address the issue such as multimedia?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Mon Jan 19, 2009 6:45 pm    Post subject: Reply with quote

Finswimmer wrote:
marcus84 wrote:
I have resync the kde-testing overlay and deleted the kde-crazy overlay. I wanted to ask why when I do a emerge -uDNav world, the emerge try to compile kdelibs-9999 and it says it's masked. I don't have the @kde-live installed. I have @kde-4.2....

Thanks for all


Try it with --tree, then you will see which package wants to emerge kdelibs-9999.
I guess it is a special plasmoid.

tobi


Thanks guy, it was kepas.

I have another problem. When I try to update the system I get this:

Code:

 emerge -uDNav --tree --keep-going world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] media-sound/amarok-1.4.10 [1.98] USE="amazon ipod kde mp4 mysql opengl python -daap -debug -ifp -mtp -musicbrainz -njb -postgres (-real) -visualization -xinerama" LINGUAS="ca es -af -ar -az -be -bg -bn -br -cs -cy -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW"  [0]                                                                                                                                                                                                                                                                                                                                                                                                                         
[nomerge      ]  dev-python/PyQt-3.17.6  USE="-debug -doc -examples"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[nomerge      ]   x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4 -debug -doc -examples"  [0]                                                                                                                                                                                                                                                                                                                                                       
[ebuild  N    ]    dev-python/qscintilla-python-2.3.2  USE="qt4" 2,097 kB [0]                                                                                                                                                                                                                                                                                                                                                                         
[ebuild     U ]     x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4 -debug -doc -examples" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                 
[ebuild  NS   ] media-sound/amarok-1.4.10 [1.98] USE="amazon ipod kde mp4 mysql opengl python -daap -debug -ifp -mtp -musicbrainz -njb -postgres (-real) -visualization -xinerama" LINGUAS="ca es -af -ar -az -be -bg -bn -br -cs -cy -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                                                                     
[ebuild  N    ]  dev-python/PyQt-3.17.6  USE="-debug -doc -examples" 795 kB [0]                                                                                                                                                                                                                                                                                                                                                                       
[nomerge      ] kde-misc/lancelot-menu-1.0.3  USE="kdeprefix -debug"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]  kde-base/kscreensaver-4.1.4 [4.1.96] USE="kdeprefix opengl pam -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                       
[nomerge      ] games-util/playonlinux-3.2.2  [1]                                                                                                                                                                                                                                                                                                                                                                                                     
[ebuild     U ]  dev-python/wxpython-2.8.9.1-r2 [2.8.8.1] USE="cairo%* opengl" 27,315 kB [0]                                                                                                                                                                                                                                                                                                                                                           
[nomerge      ] kde-misc/lancelot-menu-1.0.3  USE="kdeprefix -debug"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]  kde-base/krunner-4.1.4 [4.1.96] USE="kdeprefix opengl xcomposite -debug -xscreensaver" 0 kB [0]                                                                                                                                                                                                                                                                                                                                       
[ebuild   R   ] kde-base/kdeplasma-addons-4.1.96  USE="kdeprefix opengl -debug% -xinerama" 0 kB [2]                                                                                                                                                                                                                                                                                                                                                   
[nomerge      ] dev-python/wxpython-2.8.9.1-r2 [2.8.8.1] USE="cairo%* opengl"  [0]                                                                                                                                                                                                                                                                                                                                                                     
[ebuild     U ]  x11-libs/wxGTK-2.8.9.1-r3 [2.8.8.1] USE="X gstreamer opengl sdl -debug -doc -gnome -odbc -pch" 0 kB [0]                                                                                                                                                                                                                                                                                                                               
[nomerge      ] kde-base/kdeplasma-addons-4.1.4  USE="kdeprefix opengl -xinerama"  [2]                                                                                                                                                                                                                                                                                                                                                                 
[nomerge      ]  kde-base/krunner-4.1.4 [4.1.96] USE="kdeprefix opengl xcomposite -debug -xscreensaver"  [0]                                                                                                                                                                                                                                                                                                                                           
[ebuild  NS   ]   kde-base/ksmserver-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]    kde-base/kcminit-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]     kde-base/ksplash-4.1.4 [4.1.96] USE="kdeprefix mmx sse sse2 -3dnow (-altivec) -debug -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                           
[ebuild  NS   ]   kde-base/ksysguard-4.1.4 [4.1.96] USE="kdeprefix -debug -htmlhandbook -lm_sensors -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]    kde-base/plasma-workspace-4.1.4 [4.1.96] USE="kdeprefix xcomposite -debug -htmlhandbook -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                         
[ebuild  NS   ]     kde-base/dolphin-4.1.4 [4.1.96] USE="kdeprefix semantic-desktop -debug -htmlhandbook" 0 kB [0]                                                                                                                                                                                                                                                                                                                                     
[ebuild  NS   ]      kde-base/nepomuk-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]      kde-base/libkonq-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix -debug -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                     
[ebuild  NS   ]     kde-base/kdeartwork-iconthemes-4.1.4 [4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]     kde-base/kde-menu-icons-4.1.4 [4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]     kde-base/soliduiserver-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]      kde-base/solid-4.1.4 [4.1.96] USE="bluetooth kdeprefix -networkmanager -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                           
[ebuild  N    ]     kde-base/libplasma-4.1.4  USE="kdeprefix opengl -debug -test -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]      kde-base/libtaskmanager-4.1.4 [4.1.96] USE="kdeprefix xcomposite -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                 
[ebuild  NS   ]      kde-base/libkworkspace-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]       kde-base/kdebase-data-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]        kde-base/kdepimlibs-4.1.4 [4.1.96] USE="kdeprefix ldap sasl -debug -htmlhandbook -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                               
[ebuild  NS   ]         kde-base/kdelibs-4.1.4 [3.5.9-r4, 4.1.96] USE="acl alsa bzip2 fam kdeprefix mmx nls opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) -bindist -debug -doc -htmlhandbook -jpeg2k -kerberos -openexr -test -zeroconf" 0 kB [0]                                                                                                                                                                                       
[nomerge      ] app-cdr/k3b-1.0.5-r3  USE="alsa dvdr dvdread encode hal mp3 vorbis -arts -css -debug -emovix -ffmpeg -flac -musepack -musicbrainz -sndfile -vcd -xinerama" LINGUAS="ca es -af -ar -bg -br -bs -cs -cy -da -de -el -en_GB -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW"  [0]                                 
[nomerge      ]  media-video/transcode-1.0.7  USE="X dvdread iconv jpeg mmx mp3 mpeg ogg oss quicktime sdl sse sse2 truetype vorbis xml -3dnow -a52 (-altivec) -dv -extrafilters -fame -imagemagick -lzo -mjpeg -network -nuv -theora -v4l2 -xvid"  [0]                                                                                                                                                                                               
[ebuild     U ]   media-libs/libmpeg2-0.5.1 [0.4.1] USE="X sdl" 513 kB [0]                                                                                                                                                                                                                                                                                                                                                                             
[nomerge      ] kde-base/kdelibs-4.1.4 [3.5.9-r4, 4.1.96] USE="acl alsa bzip2 fam kdeprefix mmx nls opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) -bindist -debug -doc -htmlhandbook -jpeg2k -kerberos -openexr -test -zeroconf"  [0]                                                                                                                                                                                                   
[ebuild     UD]  app-misc/strigi-0.5.11 [0.6.9999] USE="clucene dbus fam qt4 -debug -exif -hyperestraier -inotify -log -test" 0 kB [?=>0]                                                                                                                                                                                                                                                                                                             

Total: 29 packages (4 upgrades, 1 downgrade, 3 new, 20 in new slots, 1 reinstall), Size of downloads: 30,718 kB
Portage tree and overlays:                                                                                     
 [0] /usr/portage                                                                                             
 [1] /usr/portage/local/layman/local                                                                           
 [2] /usr/portage/local/layman/kde-testing                                                                     
 [?] indicates that the source repository could not be determined                                             

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

app-misc/strigi:0

  ('ebuild', '/', 'app-misc/strigi-0.5.11', 'merge') pulled in by
    >=app-misc/strigi-0.5.9 required by ('ebuild', '/', 'kde-base/plasma-workspace-4.1.4', 'merge')
    >=app-misc/strigi-0.5.10[qt4] required by ('ebuild', '/', 'kde-base/nepomuk-4.1.4', 'merge')   
    >=app-misc/strigi-0.5.11[qt4] required by ('ebuild', '/', 'kde-base/libplasma-4.1.4', 'merge')
    (and 1 more)                                                                                   

  ('installed', '/', 'app-misc/strigi-0.6.9999', 'nomerge') pulled in by
    >=app-misc/strigi-0.6.3[qt4,dbus] required by ('installed', '/', 'kde-base/kdelibs-4.1.96', 'nomerge')
    (and 4 more)                                                                                         

  Explanation:

    New USE for 'app-misc/strigi:0' are incorrectly set. In order to solve
    this, adjust USE to satisfy '>=app-misc/strigi-0.6.3[qt4,dbus]'.     


So I have unmerged @kde-4.1 but nothin change. The eix reponses are these:

Code:

eix nepomuk
[I] kde-base/nepomuk       
     Available versions:
        (4.1)   (~)4.1.4
        (4.2)   (~)4.1.96[1]
        (live)  {M}**9999!t[1]
        {debug kdeprefix}
     Installed versions:  4.1.96(4.2)[1](23:22:15 13/01/09)(kdeprefix -debug)
     Homepage:            http://www.kde.org/
     Description:         Nepomuk KDE4 client

[1] "kde" /usr/portage/local/layman/kde-testing
eix libplasma
* kde-base/libplasma
     Available versions:  (4.1)  (~)4.1.4!t
        {debug kdeprefix opengl test xinerama}
     Homepage:            http://www.kde.org/
     Description:         Plasma: KDE desktop framework

[I] kde-base/libplasmaclock [1]
     Available versions:
        (4.2)   (~)4.1.96
        (live)  {M}**9999!t
        {debug kdeprefix opengl xinerama}
     Installed versions:  4.1.96(4.2)(23:35:20 13/01/09)(kdeprefix opengl -debug -xinerama)
     Homepage:            http://www.kde.org/
     Description:         Libraries for KDE Plasma's clocks

[1] "kde" /usr/portage/local/layman/kde-testing




Any idea?
Back to top
View user's profile Send private message
zephir
n00b
n00b


Joined: 03 Jun 2008
Posts: 27
Location: near Barcelona (Spain)

PostPosted: Mon Jan 19, 2009 8:32 pm    Post subject: pykde4-4.1.96 fails Reply with quote

Hi everyone,
pykde4 fails in my system since 4.1.85. I've tried the tricks in this thread but none worked and since RC seems that the "containment.h" file is fixed.

Here is the error:
Code:
/usr/kde/4.2/include/kconfiggroup.h:619: aviso: 'virtual const KConfigGroup KConfigGroup::groupImpl(const QByteArray&) const' estaba escondido
sipkdecorepart7.cpp:4880: aviso:   por 'virtual KConfigGroup sipKConfigGroup::groupImpl(const QByteArray&)'
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfigGroup_changeGroup(PyObject*, PyObject*)':
sipkdecorepart7.cpp:5297: aviso: 'void KConfigGroup::changeGroup(const QString&)' es obsoleto (declarado en /usr/kde/4.2/include/kconfiggroup.h:148)
sipkdecorepart7.cpp:5314: aviso: 'void KConfigGroup::changeGroup(const char*)' es obsoleto (declarado en /usr/kde/4.2/include/kconfiggroup.h:155)
/usr/kde/4.2/include/kconfig.h: At global scope:
/usr/kde/4.2/include/kconfig.h:375: aviso: 'virtual const KConfigGroup KConfig::groupImpl(const QByteArray&) const' estaba escondido
sipkdecorepart7.cpp:8740: aviso:   por 'virtual KConfigGroup sipKConfig::groupImpl(const QByteArray&)'
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfig_setForceGlobal(PyObject*, PyObject*)':
sipkdecorepart7.cpp:9381: aviso: 'void KConfig::setForceGlobal(bool)' es obsoleto (declarado en /usr/kde/4.2/include/kconfig.h:343)
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfig_forceGlobal(PyObject*, PyObject*)':
sipkdecorepart7.cpp:9409: aviso: 'bool KConfig::forceGlobal() const' es obsoleto (declarado en /usr/kde/4.2/include/kconfig.h:353)
Linking CXX shared library ../../lib/pykde/kdecore.so
[ 10%] Built target python_module_PyKDE4_kdecore
make: *** [all] Error 2


Sorry about the spanish things. If someone needs to translate it, just tell me.
Thanks in advance ^^
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Tue Jan 20, 2009 6:51 am    Post subject: Reply with quote

hi, thanks
but i already have this situation:
Code:
krog@krogpc ~ $ eselect java-vm list
Available Java Virtual Machines:
  [1]   blackdown-jdk-1.4.2
  [2]   emul-linux-x86-java-1.6
  [3]   sun-jdk-1.6  system-vm user-vm
krog@krogpc ~ $




reavertm wrote:
Krog wrote:
as explained here: http://vizzzion.org/?blogentry=904
i'm triyng to use sesame/soprano/nepomuk with sesame2 backend (which is java, as i understand).
They say it is more fast than the default clucene backend.


I guess they ment sesame2 backend (java library accessed via JNI C++ wrapper) ifs faster than redland (using raptor or librdf).
Anyway, apparently you have some 'incompatible' java sdk. IBM Jdk is known to not be found by cmake FindJNI module. Try with sun-jdk instead if you want to make use of sesame2.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Jan 20, 2009 8:02 am    Post subject: Reply with quote

marcus84 wrote:
Finswimmer wrote:
marcus84 wrote:
I have resync the kde-testing overlay and deleted the kde-crazy overlay. I wanted to ask why when I do a emerge -uDNav world, the emerge try to compile kdelibs-9999 and it says it's masked. I don't have the @kde-live installed. I have @kde-4.2....

Thanks for all


Try it with --tree, then you will see which package wants to emerge kdelibs-9999.
I guess it is a special plasmoid.

tobi


Thanks guy, it was kepas.

I have another problem. When I try to update the system I get this:

Code:

 emerge -uDNav --tree --keep-going world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge      ] media-sound/amarok-1.4.10 [1.98] USE="amazon ipod kde mp4 mysql opengl python -daap -debug -ifp -mtp -musicbrainz -njb -postgres (-real) -visualization -xinerama" LINGUAS="ca es -af -ar -az -be -bg -bn -br -cs -cy -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW"  [0]                                                                                                                                                                                                                                                                                                                                                                                                                         
[nomerge      ]  dev-python/PyQt-3.17.6  USE="-debug -doc -examples"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[nomerge      ]   x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4 -debug -doc -examples"  [0]                                                                                                                                                                                                                                                                                                                                                       
[ebuild  N    ]    dev-python/qscintilla-python-2.3.2  USE="qt4" 2,097 kB [0]                                                                                                                                                                                                                                                                                                                                                                         
[ebuild     U ]     x11-libs/qscintilla-2.3.2 [2.1-r1] USE="python qt4 -debug -doc -examples" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                 
[ebuild  NS   ] media-sound/amarok-1.4.10 [1.98] USE="amazon ipod kde mp4 mysql opengl python -daap -debug -ifp -mtp -musicbrainz -njb -postgres (-real) -visualization -xinerama" LINGUAS="ca es -af -ar -az -be -bg -bn -br -cs -cy -da -de -el -en_GB -eo -et -eu -fa -fi -fr -ga -gl -he -hi -hu -id -is -it -ja -km -ko -ku -lo -lt -mk -ms -nb -nds -ne -nl -nn -pa -pl -pt -pt_BR -ro -ru -rw -se -sk -sl -sq -sr -sr@Latn -ss -sv -ta -tg -th -tr -uk -uz -zh_CN -zh_TW" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                                                                     
[ebuild  N    ]  dev-python/PyQt-3.17.6  USE="-debug -doc -examples" 795 kB [0]                                                                                                                                                                                                                                                                                                                                                                       
[nomerge      ] kde-misc/lancelot-menu-1.0.3  USE="kdeprefix -debug"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]  kde-base/kscreensaver-4.1.4 [4.1.96] USE="kdeprefix opengl pam -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                       
[nomerge      ] games-util/playonlinux-3.2.2  [1]                                                                                                                                                                                                                                                                                                                                                                                                     
[ebuild     U ]  dev-python/wxpython-2.8.9.1-r2 [2.8.8.1] USE="cairo%* opengl" 27,315 kB [0]                                                                                                                                                                                                                                                                                                                                                           
[nomerge      ] kde-misc/lancelot-menu-1.0.3  USE="kdeprefix -debug"  [0]                                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]  kde-base/krunner-4.1.4 [4.1.96] USE="kdeprefix opengl xcomposite -debug -xscreensaver" 0 kB [0]                                                                                                                                                                                                                                                                                                                                       
[ebuild   R   ] kde-base/kdeplasma-addons-4.1.96  USE="kdeprefix opengl -debug% -xinerama" 0 kB [2]                                                                                                                                                                                                                                                                                                                                                   
[nomerge      ] dev-python/wxpython-2.8.9.1-r2 [2.8.8.1] USE="cairo%* opengl"  [0]                                                                                                                                                                                                                                                                                                                                                                     
[ebuild     U ]  x11-libs/wxGTK-2.8.9.1-r3 [2.8.8.1] USE="X gstreamer opengl sdl -debug -doc -gnome -odbc -pch" 0 kB [0]                                                                                                                                                                                                                                                                                                                               
[nomerge      ] kde-base/kdeplasma-addons-4.1.4  USE="kdeprefix opengl -xinerama"  [2]                                                                                                                                                                                                                                                                                                                                                                 
[nomerge      ]  kde-base/krunner-4.1.4 [4.1.96] USE="kdeprefix opengl xcomposite -debug -xscreensaver"  [0]                                                                                                                                                                                                                                                                                                                                           
[ebuild  NS   ]   kde-base/ksmserver-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]    kde-base/kcminit-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]     kde-base/ksplash-4.1.4 [4.1.96] USE="kdeprefix mmx sse sse2 -3dnow (-altivec) -debug -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                           
[ebuild  NS   ]   kde-base/ksysguard-4.1.4 [4.1.96] USE="kdeprefix -debug -htmlhandbook -lm_sensors -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]    kde-base/plasma-workspace-4.1.4 [4.1.96] USE="kdeprefix xcomposite -debug -htmlhandbook -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                         
[ebuild  NS   ]     kde-base/dolphin-4.1.4 [4.1.96] USE="kdeprefix semantic-desktop -debug -htmlhandbook" 0 kB [0]                                                                                                                                                                                                                                                                                                                                     
[ebuild  NS   ]      kde-base/nepomuk-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]      kde-base/libkonq-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix -debug -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                     
[ebuild  NS   ]     kde-base/kdeartwork-iconthemes-4.1.4 [4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]     kde-base/kde-menu-icons-4.1.4 [4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]     kde-base/soliduiserver-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]      kde-base/solid-4.1.4 [4.1.96] USE="bluetooth kdeprefix -networkmanager -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                                           
[ebuild  N    ]     kde-base/libplasma-4.1.4  USE="kdeprefix opengl -debug -test -xinerama" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                   
[ebuild  NS   ]      kde-base/libtaskmanager-4.1.4 [4.1.96] USE="kdeprefix xcomposite -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                 
[ebuild  NS   ]      kde-base/libkworkspace-4.1.4 [4.1.96] USE="kdeprefix -debug" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]       kde-base/kdebase-data-4.1.4 [3.5.9, 4.1.96] USE="kdeprefix" 0 kB [0]                                                                                                                                                                                                                                                                                                                                                             
[ebuild  NS   ]        kde-base/kdepimlibs-4.1.4 [4.1.96] USE="kdeprefix ldap sasl -debug -htmlhandbook -test" 0 kB [0]                                                                                                                                                                                                                                                                                                                               
[ebuild  NS   ]         kde-base/kdelibs-4.1.4 [3.5.9-r4, 4.1.96] USE="acl alsa bzip2 fam kdeprefix mmx nls opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) -bindist -debug -doc -htmlhandbook -jpeg2k -kerberos -openexr -test -zeroconf" 0 kB [0]                                                                                                                                                                                       
[nomerge      ] app-cdr/k3b-1.0.5-r3  USE="alsa dvdr dvdread encode hal mp3 vorbis -arts -css -debug -emovix -ffmpeg -flac -musepack -musicbrainz -sndfile -vcd -xinerama" LINGUAS="ca es -af -ar -bg -br -bs -cs -cy -da -de -el -en_GB -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW"  [0]                                 
[nomerge      ]  media-video/transcode-1.0.7  USE="X dvdread iconv jpeg mmx mp3 mpeg ogg oss quicktime sdl sse sse2 truetype vorbis xml -3dnow -a52 (-altivec) -dv -extrafilters -fame -imagemagick -lzo -mjpeg -network -nuv -theora -v4l2 -xvid"  [0]                                                                                                                                                                                               
[ebuild     U ]   media-libs/libmpeg2-0.5.1 [0.4.1] USE="X sdl" 513 kB [0]                                                                                                                                                                                                                                                                                                                                                                             
[nomerge      ] kde-base/kdelibs-4.1.4 [3.5.9-r4, 4.1.96] USE="acl alsa bzip2 fam kdeprefix mmx nls opengl semantic-desktop spell sse sse2 ssl -3dnow (-altivec) -bindist -debug -doc -htmlhandbook -jpeg2k -kerberos -openexr -test -zeroconf"  [0]                                                                                                                                                                                                   
[ebuild     UD]  app-misc/strigi-0.5.11 [0.6.9999] USE="clucene dbus fam qt4 -debug -exif -hyperestraier -inotify -log -test" 0 kB [?=>0]                                                                                                                                                                                                                                                                                                             

Total: 29 packages (4 upgrades, 1 downgrade, 3 new, 20 in new slots, 1 reinstall), Size of downloads: 30,718 kB
Portage tree and overlays:                                                                                     
 [0] /usr/portage                                                                                             
 [1] /usr/portage/local/layman/local                                                                           
 [2] /usr/portage/local/layman/kde-testing                                                                     
 [?] indicates that the source repository could not be determined                                             

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

app-misc/strigi:0

  ('ebuild', '/', 'app-misc/strigi-0.5.11', 'merge') pulled in by
    >=app-misc/strigi-0.5.9 required by ('ebuild', '/', 'kde-base/plasma-workspace-4.1.4', 'merge')
    >=app-misc/strigi-0.5.10[qt4] required by ('ebuild', '/', 'kde-base/nepomuk-4.1.4', 'merge')   
    >=app-misc/strigi-0.5.11[qt4] required by ('ebuild', '/', 'kde-base/libplasma-4.1.4', 'merge')
    (and 1 more)                                                                                   

  ('installed', '/', 'app-misc/strigi-0.6.9999', 'nomerge') pulled in by
    >=app-misc/strigi-0.6.3[qt4,dbus] required by ('installed', '/', 'kde-base/kdelibs-4.1.96', 'nomerge')
    (and 4 more)                                                                                         

  Explanation:

    New USE for 'app-misc/strigi:0' are incorrectly set. In order to solve
    this, adjust USE to satisfy '>=app-misc/strigi-0.6.3[qt4,dbus]'.     


So I have unmerged @kde-4.1 but nothin change. The eix reponses are these:

Code:

eix nepomuk
[I] kde-base/nepomuk       
     Available versions:
        (4.1)   (~)4.1.4
        (4.2)   (~)4.1.96[1]
        (live)  {M}**9999!t[1]
        {debug kdeprefix}
     Installed versions:  4.1.96(4.2)[1](23:22:15 13/01/09)(kdeprefix -debug)
     Homepage:            http://www.kde.org/
     Description:         Nepomuk KDE4 client

[1] "kde" /usr/portage/local/layman/kde-testing
eix libplasma
* kde-base/libplasma
     Available versions:  (4.1)  (~)4.1.4!t
        {debug kdeprefix opengl test xinerama}
     Homepage:            http://www.kde.org/
     Description:         Plasma: KDE desktop framework

[I] kde-base/libplasmaclock [1]
     Available versions:
        (4.2)   (~)4.1.96
        (live)  {M}**9999!t
        {debug kdeprefix opengl xinerama}
     Installed versions:  4.1.96(4.2)(23:35:20 13/01/09)(kdeprefix opengl -debug -xinerama)
     Homepage:            http://www.kde.org/
     Description:         Libraries for KDE Plasma's clocks

[1] "kde" /usr/portage/local/layman/kde-testing




Any idea?


As I understand it: kde-misc/lancelot-menu-1.0.3 needs a kde-4.1.4 Version. So you need to modify this ebuild, or uninstall it.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ok
Guru
Guru


Joined: 11 Jul 2006
Posts: 390
Location: germany

PostPosted: Tue Jan 20, 2009 8:13 am    Post subject: Reply with quote

lancelot is in kde-base/kdeplasma-addons, so you can unmerge lancelot and install kdeplasma-addons.
Back to top
View user's profile Send private message
lmarcini
Guru
Guru


Joined: 21 Jul 2004
Posts: 531
Location: Champagne sur Seine (France)

PostPosted: Tue Jan 20, 2009 10:35 am    Post subject: Reply with quote

Hello,

Does QT 4.5 beta works with KDE 4.1.96 or is it recommended to stay in 4.4.2 version ? I tried to upgrade QT and some parts of KDE worked very well (faster and with better fonts) but some others parts didn't worked (kdm crashed, imap part of kmail crashed). Will the future stable QT 4.5 work with the future stable KDE 4.2 ? Or with the 4.3 version ?

Thank you.
_________________
umount /dev/brain
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6944
Location: Austria

PostPosted: Tue Jan 20, 2009 12:08 pm    Post subject: Reply with quote

Does anyone else get strange konsole behaviour with 4.1.96? Two friends of mine have non-functioning right click there while there are no issues otherwise. I can't reproduce it on my own systems.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Tue Jan 20, 2009 12:43 pm    Post subject: Reply with quote

while using "emerge -uDNav world" the output shows this:
Code:
[blocks B     ] <=kde-base/kdebase-startkde-3.5.10 ("<=kde-base/kdebase-startkde-3.5.10" is blocking kde-base/kdelibs-4.1.96)


and in kdelibs's ebuild this is what is reported:
Code:
# Blockers added for !kdeprefix? due to packages from old versions,
# removed in the meanwhile
# kde-base/libplasma
# kde-base/knewsticker
# kde-base/kpercentage
# kde-base/ktnef
COMMONDEPEND="
        !<=kde-base/kdebase-3.5.9-r4
        !<=kde-base/kdebase-startkde-3.5.10 [...]


is this a valid block or I can remove it without any trouble?
or maybe this block will soon be removed as seems to be written in the ebuild?

thanks for answers :)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Tue Jan 20, 2009 1:05 pm    Post subject: Reply with quote

>>> Unpacking source...
* subversion update start -->
* repository: svn://anonsvn.kde.org/home/kde/trunk/koffice
svn: Can't connect to host 'anonsvn.kde.org': Connection refused



anybody?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6944
Location: Austria

PostPosted: Tue Jan 20, 2009 1:34 pm    Post subject: Reply with quote

lmarcini wrote:
Does QT 4.5 beta works with KDE 4.1.96 or is it recommended to stay in 4.4.2 version ?

KDE-4.1.96 @Qt-4.5 is still a mixed bag, I wouldn't recommend it for production use.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bartek
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2004
Posts: 83
Location: Poland, Pysznica

PostPosted: Tue Jan 20, 2009 3:44 pm    Post subject: Reply with quote

tranquilcool wrote:
>>> Unpacking source...
* subversion update start -->
* repository: svn://anonsvn.kde.org/home/kde/trunk/koffice
svn: Can't connect to host 'anonsvn.kde.org': Connection refused



anybody?

I have the same problem
Back to top
View user's profile Send private message
jarealist
Apprentice
Apprentice


Joined: 07 Oct 2002
Posts: 228

PostPosted: Tue Jan 20, 2009 6:38 pm    Post subject: Reply with quote

genstorm wrote:

Quote:
Does anyone else get strange konsole behaviour with 4.1.96? Two friends of mine have non-functioning right click there while there are no issues otherwise. I can't reproduce it on my own systems.


Happened to me one time, but went away after restarting konsole.

Question:

There is an update to kdebluetooth4 (0.3) that requires bluez4. Any guess to when all the issues will get resolved and we switch over from bluez3? I know there is a lot of activity in bugzilla, just curious. Right now I'm using gnome-bluetooth (with kde4) to transfer files to my pda.

http://www.kde-apps.org/content/show.php/kdebluetooth4?content=84761
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 821
Location: Alaska

PostPosted: Wed Jan 21, 2009 3:15 am    Post subject: Reply with quote

I just upgraded world and it ended with the emerge @preserved-rebuild on a couple packages/libraries. So I ran it and it wanted to re-install amarok and kipi-plugins.

kipi-plugins-0.2.0_beta6 fails with:
Code:
[ 59%] Building CXX object calendar/CMakeFiles/kipiplugin_calendar.dir/monthwidget.o                                                                           
/var/tmp/portage/media-plugins/kipi-plugins-0.2.0_beta6/work/kipi-plugins-0.2.0-beta6/ipodexport/IpodExportDialog.cpp: In member function 'void KIPIIpodExportPlugin::UploadDialog::startTransfer()':                                           
/var/tmp/portage/media-plugins/kipi-plugins-0.2.0_beta6/work/kipi-plugins-0.2.0-beta6/ipodexport/IpodExportDialog.cpp:399: warning: suggest explicit braces to avoid ambiguous 'else'                                                           
/var/tmp/portage/media-plugins/kipi-plugins-0.2.0_beta6/work/kipi-plugins-0.2.0-beta6/ipodexport/IpodExportDialog.cpp: In member function 'void KIPIIpodExportPlugin::UploadDialog::ipodItemSelected(QTreeWidgetItem*)':                       
/var/tmp/portage/media-plugins/kipi-plugins-0.2.0_beta6/work/kipi-plugins-0.2.0-beta6/ipodexport/IpodExportDialog.cpp:425: error: 'ITDB_THUMB_PHOTO_SMALL' was not declared in this scope                                                       
/var/tmp/portage/media-plugins/kipi-plugins-0.2.0_beta6/work/kipi-plugins-0.2.0-beta6/ipodexport/IpodExportDialog.cpp:425: error: 'itdb_artwork_get_thumb_by_type' was not declared in this scope                                               
make[2]: *** [ipodexport/CMakeFiles/kipiplugin_ipodexport.dir/IpodExportDialog.o] Error 1                                                                       
make[1]: *** [ipodexport/CMakeFiles/kipiplugin_ipodexport.dir/all] Error 2     
make[1]: *** Waiting for unfinished jobs....                                   
[ 60%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/imagegenerationfunctor.o                                                             
[ 60%] Building CXX object calendar/CMakeFiles/kipiplugin_calendar.dir/kipiplugin_calendar_automoc.o                                                           
Linking CXX shared module ../lib/kipiplugin_calendar.so                         
[ 60%] Built target kipiplugin_calendar                                         
[ 60%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/intthemeparameter.o                                                                 
[ 60%] [ 60%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/invisiblebuttongroup.o                                                       
Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/listthemeparameter.o                                                                       
[ 60%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/plugin.o                                                                             
[ 61%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/stringthemeparameter.o                                                               
[ 61%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/theme.o                                                                             
[ 61%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/wizard.o                                                                             
[ 61%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/htmlexportconfig.o                                                                   
[ 62%] Building CXX object htmlexport/CMakeFiles/kipiplugin_htmlexport.dir/kipiplugin_htmlexport_automoc.o                                                     
Linking CXX shared module ../lib/kipiplugin_htmlexport.so                       
[ 62%] Built target kipiplugin_htmlexport                                       
make: *** [all] Error 2                 


It is probably the libgpod that is causing problems - though not sure about that.

amarok fails with:
Code:
/var/tmp/portage/media-sound/amarok-2.0.1.1/work/amarok-2.0.1.1/src/collection/ipodcollection/handler/IpodHandler.cpp:1429: warning: unused paramet$
make[2]: ***[src/collection/ipodcollection/CMakeFiles/amarok_collection-ipodcollection.dir/handler/IpodHandler.o] Error 1
<snip>
e.cpp: In member function 'virtual QPixmap QtScriptShell_QWindowsStyle::standardPixmap(QStyle::StandardPixmap, const QStyleOption*, const QWidget*) const':     
/var/tmp/portage/media-sound/amarok-2.0.1.1/work/amarok_build/src/scriptengine/generator/generator/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWindowsStyle.cpp:342: warning: control reaches end of non-void function                   
[ 92%] Building CXX object src/scriptengine/generator/generator/CMakeFiles/qtscript_gui.dir/generated_cpp/com_trolltech_qt_gui/qtscriptshell_QWorkspace.o       
Linking CXX shared module ../../../../lib/libqtscript_gui.so                   
[ 92%] Built target qtscript_gui                                               
make: *** [all] Error 2


[EDIT] the amarok package compiles if I remove the ipod flag.


Last edited by hunky on Wed Jan 21, 2009 6:51 am; edited 2 times in total
Back to top
View user's profile Send private message
paulbiz
Guru
Guru


Joined: 01 Feb 2004
Posts: 506
Location: St. Louis, Missouri, USA

PostPosted: Wed Jan 21, 2009 3:32 am    Post subject: Reply with quote

bartek wrote:
tranquilcool wrote:
>>> Unpacking source...
* subversion update start -->
* repository: svn://anonsvn.kde.org/home/kde/trunk/koffice
svn: Can't connect to host 'anonsvn.kde.org': Connection refused



anybody?

I have the same problem


Server is down & owner is in a different part of the Earth right now. see here:

http://people.fruitsalad.org/adridg/bobulate/index.php?/archives/697-AnonSVN-down.html
Back to top
View user's profile Send private message
paulbiz
Guru
Guru


Joined: 01 Feb 2004
Posts: 506
Location: St. Louis, Missouri, USA

PostPosted: Wed Jan 21, 2009 3:49 am    Post subject: Re: pykde4-4.1.96 fails Reply with quote

zephir wrote:
Hi everyone,
pykde4 fails in my system since 4.1.85. I've tried the tricks in this thread but none worked and since RC seems that the "containment.h" file is fixed.

Here is the error:
Code:
/usr/kde/4.2/include/kconfiggroup.h:619: aviso: 'virtual const KConfigGroup KConfigGroup::groupImpl(const QByteArray&) const' estaba escondido
sipkdecorepart7.cpp:4880: aviso:   por 'virtual KConfigGroup sipKConfigGroup::groupImpl(const QByteArray&)'
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfigGroup_changeGroup(PyObject*, PyObject*)':
sipkdecorepart7.cpp:5297: aviso: 'void KConfigGroup::changeGroup(const QString&)' es obsoleto (declarado en /usr/kde/4.2/include/kconfiggroup.h:148)
sipkdecorepart7.cpp:5314: aviso: 'void KConfigGroup::changeGroup(const char*)' es obsoleto (declarado en /usr/kde/4.2/include/kconfiggroup.h:155)
/usr/kde/4.2/include/kconfig.h: At global scope:
/usr/kde/4.2/include/kconfig.h:375: aviso: 'virtual const KConfigGroup KConfig::groupImpl(const QByteArray&) const' estaba escondido
sipkdecorepart7.cpp:8740: aviso:   por 'virtual KConfigGroup sipKConfig::groupImpl(const QByteArray&)'
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfig_setForceGlobal(PyObject*, PyObject*)':
sipkdecorepart7.cpp:9381: aviso: 'void KConfig::setForceGlobal(bool)' es obsoleto (declarado en /usr/kde/4.2/include/kconfig.h:343)
sipkdecorepart7.cpp: In function 'PyObject* meth_KConfig_forceGlobal(PyObject*, PyObject*)':
sipkdecorepart7.cpp:9409: aviso: 'bool KConfig::forceGlobal() const' es obsoleto (declarado en /usr/kde/4.2/include/kconfig.h:353)
Linking CXX shared library ../../lib/pykde/kdecore.so
[ 10%] Built target python_module_PyKDE4_kdecore
make: *** [all] Error 2


Sorry about the spanish things. If someone needs to translate it, just tell me.
Thanks in advance ^^


I have a different problem in the same package. Mine is even worse (doesn't even get going)
Code:
>>> Compiling source in /dev/shm/portage/kde-base/pykde4-4.1.96/work/pykde4-4.1.96 ...
make
Scanning dependencies of target compile_python_files


[  0%] Built target compile_python_files
[  1%] Generating sip/akonadi/sipakonadipart0.cpp, sip/akonadi/sipakonadipart1.cpp, sip/akonadi/sipakonadipart2.cpp, sip/akonadi/sipakonadipart3.cpp, sip/akonadi/sipakonadipart4.cpp, sip/akonadi/sipakonadipart5.cpp, sip/akonadi/sipakonadipart6.cpp, sip/akonadi/sipakonadipart7.cpp

sip: Unable to find file "QtGui/QtGuimod.sip"
make[2]: *** [python/pykde4/sip/akonadi/sipakonadipart0.cpp] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_akonadi.dir/all] Error 2
make: *** [all] Error 2
 


SOLVED thanks to Ben de Groot on the mailing list, the solution was to recompile PyQt4. After that pykde4 compiled okay.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Wed Jan 21, 2009 3:30 pm    Post subject: Reply with quote

I tried again this morning on the svn: "Can't connect to host 'anonsvn.kde.org': Connection refused" problem with the server reported by tranquilcool and others, and still no luck.

However, I remembered that some time ago I had to put the line
Quote:
131.174.31.25 anonsvn.kde.org
in my /etc/hosts file in order to connect with anonsvn.

Commenting this line out apparently has resolved the issue, and I am somehow automatically using a different default server. After changing the overlay from kde-crazy to kde-testing and re-setting up the /etc/portage symlinks as instructed, I am now able to update from anonsvn. This makes sense, as I found it strange that kde was relying on only one server at the link paulbiz posted. I guess it was at 131.174.31.25.

This was also confirmed by looking at webvsvn, where everything was still being constantly updated, as usual.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
paulbiz
Guru
Guru


Joined: 01 Feb 2004
Posts: 506
Location: St. Louis, Missouri, USA

PostPosted: Wed Jan 21, 2009 4:44 pm    Post subject: Reply with quote

wrc1944 wrote:
I tried again this morning on the svn: "Can't connect to host 'anonsvn.kde.org': Connection refused" problem with the server reported by tranquilcool and others, and still no luck.

However, I remembered that some time ago I had to put the line
Quote:
131.174.31.25 anonsvn.kde.org
in my /etc/hosts file in order to connect with anonsvn.

Commenting this line out apparently has resolved the issue, and I am somehow automatically using a different default server. After changing the overlay from kde-crazy to kde-testing and re-setting up the /etc/portage symlinks as instructed, I am now able to update from anonsvn. This makes sense, as I found it strange that kde was relying on only one server at the link paulbiz posted. I guess it was at 131.174.31.25.

This was also confirmed by looking at webvsvn, where everything was still being constantly updated, as usual.


yes, it seems to be working again. i guess they pointed the DNS to a new host to cope with the mirror being down.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Wed Jan 21, 2009 5:29 pm    Post subject: Reply with quote

Couldn't merge kdebase-live.
Code:
emerge -pv1 @kdebase-live
These are the packages that would be merged, in order:

Calculating dependencies   * waiting for lock on /var/db/.pkg.portage_lockfile
 ...                                   [ ok ]
... done!
emerge: there are no ebuilds built with USE flags to satisfy ">=dev-python/PyQt4-4.4.4-r1[webkit]".
!!! One of the following packages is required to complete your request:
- dev-python/PyQt4-4.4.4-r1 (Change USE: +webkit)
(dependency required by "kde-base/pykde4-9999" [ebuild])
(dependency required by "kde-base/plasma-workspace-9999" [ebuild])
(dependency required by "@kdebase-live" [argument])

Had to add
Quote:
dev-python/PyQt4 webkit
to /etc/package.use. Shouldn't webkit already be in the PyQt4 ebuild USE flags?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6944
Location: Austria

PostPosted: Wed Jan 21, 2009 6:18 pm    Post subject: Reply with quote

jarealist wrote:
genstorm wrote:
Does anyone else get strange konsole behaviour with 4.1.96? Two friends of mine have non-functioning right click there while there are no issues otherwise. I can't reproduce it on my own systems.


Happened to me one time, but went away after restarting konsole.

Unfortunately it persists there...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 38, 39, 40  Next
Page 10 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum