Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Wed Feb 25, 2009 10:50 am    Post subject: Reply with quote

Well, I would love to post here some problems that I'm having, but everytime that it should display an error message it just closes and drops to kdm, so I don't know what to report, and neither what to look for in google.
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Wed Feb 25, 2009 12:55 pm    Post subject: Reply with quote

coolsnowmen wrote:

No, that isn't what revdep-rebuild looks for. It looks for missing dependancies using ldd; it does not look for undefined external symbols.

It would be greate if it looked for missed symbols also. Is it possible at all? Maybe there is another tool for it?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed Feb 25, 2009 3:19 pm    Post subject: Reply with quote

Update on my kmail problem towards the bottom on page 20.
It seems to only occur on ~amd64. I have two identical Gentoo installs on this box (hardware in sig)- one 32bit and one 64 bit. The kmail failure doesn't occur on the 32bit install. I'm pretty new to ~amd64- any advice on how to trace down this problem?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Thu Feb 26, 2009 5:22 pm    Post subject: Reply with quote

kmail-9999 just built for me, I am using ~amd64.

Are you sure you rebuilt kdepimlibs?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Thu Feb 26, 2009 9:17 pm    Post subject: Reply with quote

Yes- kmail fails after building kdedeps-live and kdebase-live. Must be something wrong here, but as far as I can tell all my apps (and system APPS), kernel, and all configs are identical on both the 32bit and 64bit Gentoo installs. I'll give it another look, but AFAIK the only diff is ~amd64.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
chl
n00b
n00b


Joined: 13 May 2003
Posts: 70
Location: Munich

PostPosted: Fri Feb 27, 2009 7:04 am    Post subject: Reply with quote

aTan wrote:
Failed to install knemo-0.5.0

Code:

...
-- Could NOT find iwconfig  (missing:  PATH_IWCONFIG)
-- Found route: /sbin/route
-- Could NOT find libiw  (missing:  LIBIW_LIBRARY)
...
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LIBIW_LIBRARY-- Looking for dgettext
...


You need to install wireless-tools, which provide iwconfig and libiw. The new ebuild seems to make no difference whether a wlan-adapter is present or not.

If you should encounter further problems due to missing KDE4Workspace__solidcontrol, have a look at the discussion at http://www.kde-apps.org/content/show.php/KNemo?content=12956, in particular the posting of jstamp as of Feb 24.

For me the following worked:

First unpack the source with 'ebuild [path to ebuild]/knemo.0.5.0-ebuild unpack'.
Then edit the sources files unter /var/tmp/portage/net-misc/knemo/ as recommended by jstamp.
Then compile the package with 'ebuild [path to ebuild]/knemo.0.5.0-ebuild install' and merge it with 'ebuild [path to ebuild]/knemo.0.5.0-ebuild qmerge'.

CHL
_________________
The difficulty in designing something completely foolproof, is not to underestimate the ingenuity of complete fools.
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Fri Feb 27, 2009 12:18 pm    Post subject: Reply with quote

wrc1944 wrote:
Yes- kmail fails after building kdedeps-live and kdebase-live.


On my system I have

kde-base/libkdepim

as well as

kde-base/kdepimlibs

Your problem is definitely related to pim libs somewhere. @kdedeps-live DOES NOT include libkdepim but it does include kde-base/kdepimlibs.

I rebuild the entire kde-live set each time.
Back to top
View user's profile Send private message
GD
Tux's lil' helper
Tux's lil' helper


Joined: 11 May 2005
Posts: 134
Location: Greece

PostPosted: Fri Feb 27, 2009 1:55 pm    Post subject: Reply with quote

Hi all,

I have been updating kde-live often the last few weeks but I'm getting a few bugs and was wondering whether others experience the same too:

a) the panel gets completely transparent when kwin desktop-effects are enabled. It looks a little ugly (especially the system tray area) so i'm guessing it's some sort of bug... I'm using ati-drivers atm (Radeon HD3200, 780G chipset)

b) There are no phonon backends... I do get sound in flash, mplayer and vlc but not in juk. Also the test button in the "Multimedia" section of systemsettings produces no output no matter which playback device is used... The "backends" tab doesn't list any backends (xine and gstreamer USE flags are enabled for phonon, xine-lib and gstreamer packages have been successfully emerged)

EDIT: Forgot to mention, I'm using the live qt-copy ebuilds from the qting-edge overlay.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Fri Feb 27, 2009 5:26 pm    Post subject: Reply with quote

so, now there is a 4.2.1 kde in our beloved overlay.
what is it? which qt version is suggested to use for it?
Back to top
View user's profile Send private message
skazi
Apprentice
Apprentice


Joined: 01 Oct 2004
Posts: 219
Location: Cieszyn/Poland

PostPosted: Fri Feb 27, 2009 5:35 pm    Post subject: Reply with quote

Kde 4.2.1 will be released 4th march.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Fri Feb 27, 2009 8:14 pm    Post subject: Reply with quote

@mikedee,
Thanks for the info- I'll look on both the 32bit and 64bit installations- maybe somehow my 64bit is missing libkdepim, but the 32bit somehow has it included. If that's true, it's a real mystery to me. :wink:

UPDATE: A rebuild of libkdepim (it was on my 64bit partition after all) and then kmail compiled fine. I must have just missed it last time I rebuilt everything. I generally don't build all the kdepim packages (as well as not using a lot of other individual kde packages). Thanks again for pointing me in the right direction. :)

I got into the habit of picking only the split kde packages I actually use long ago, but I guess it really is better with kde-svn to go ahead and build everything to avoid little problems like this one. At least until 4.3 or 4.4 Final is released- I'm hoping by that time I'll be satisfied enough so that I won't want to do so much kde svn building.
I must say these last svn packages (r933018) are really nice! :D
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental


Last edited by wrc1944 on Fri Feb 27, 2009 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Fri Feb 27, 2009 8:23 pm    Post subject: Reply with quote

skazi wrote:
Kde 4.2.1 will be released 4th march.


thanks :-)
it will be full qt-4.5 ready?
btw, the weekly snapshot are in some other overlay or this possibility is abandoned?
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Fri Feb 27, 2009 8:59 pm    Post subject: Reply with quote

@wrc1944 : even if libkdepim is installed, make sure you have updated it because it is not in the sets that you said you updated.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sat Feb 28, 2009 1:43 pm    Post subject: Reply with quote

Krog wrote:
btw, the weekly snapshot are in some other overlay or this possibility is abandoned?

Weekly snapshots would be in kde-testing, but those will probably not be introduced until 4.2.70something as development has moved on to 4.3 branch and as such is far from matured.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Feb 28, 2009 2:18 pm    Post subject: Reply with quote

Hi to everybody.

I recently have update my amarok and I have no sound. The package is this:

Code:

[I] media-sound/amarok
     Available versions:
        (0)     1.4.8 1.4.9.1 ~1.4.9.1-r1 1.4.10 ~1.4.10-r1 ~1.4.10_p20090130 ~1.4.10_p20090130-r1 [M]**1.4.9999-r2
        (2)     (~*)2.0.1.1
        (live)  [M]**9999!t[1]
        {amazon arts cdaudio daap debug elibc_FreeBSD ifp ipod kde kdeprefix linguas_af linguas_ar linguas_az linguas_be linguas_bg linguas_bn linguas_br linguas_ca linguas_cs linguas_csb linguas_cy linguas_da linguas_de linguas_el linguas_en_GB linguas_eo linguas_es linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_ga linguas_gl linguas_he linguas_hi linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_km linguas_ko linguas_ku linguas_lo linguas_lt linguas_lv linguas_mk linguas_ms linguas_nb linguas_nds linguas_ne linguas_nl linguas_nn linguas_oc linguas_pa linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_rw linguas_se linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas_sr@Latn linguas_ss linguas_sv linguas_ta linguas_tg linguas_th linguas_tr linguas_uk linguas_uz linguas_zh_CN linguas_zh_TW mp3tunes mp4 mtp musicbrainz mysql njb opengl postgres python real semantic-desktop visualization xinerama}
     Installed versions:  2.0.1.1(2)(17:05:25 21/02/09)(ipod kdeprefix linguas_ca linguas_es mp3tunes mp4 opengl semantic-desktop -daap -debug -ifp -linguas_ar -linguas_be -linguas_bg -linguas_cs -linguas_csb -linguas_da -linguas_de -linguas_el -linguas_eo -linguas_et -linguas_eu -linguas_fi -linguas_fr -linguas_ga -linguas_gl -linguas_he -linguas_is -linguas_it -linguas_ja -linguas_km -linguas_ko -linguas_ku -linguas_lt -linguas_lv -linguas_nb -linguas_nds -linguas_ne -linguas_nl -linguas_nn -linguas_oc -linguas_pa -linguas_pl -linguas_pt -linguas_pt_BR -linguas_ro -linguas_ru -linguas_se -linguas_si -linguas_sk -linguas_sl -linguas_sv -linguas_th -linguas_tr -linguas_uk -linguas_zh_CN -linguas_zh_TW -mtp -njb)
     Homepage:            http://amarok.kde.org/
     Description:         Advanced audio player based on KDE framework.

I am with KDE4.2.0 and the new amarok doesn't reproduce any file... I try to play an mp3 or lastfm and the progress bar doens't show anything... Any idea?
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Sat Feb 28, 2009 3:27 pm    Post subject: Reply with quote

For any nvidia users, I would not recommend updating to 180.35. It seems to make random programs hang. I downgraded back to 180.29.
Back to top
View user's profile Send private message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Sat Feb 28, 2009 6:38 pm    Post subject: Reply with quote

True, most of processes are defunct with these drivers.
Back to top
View user's profile Send private message
tampakrap
Retired Dev
Retired Dev


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Sun Mar 01, 2009 8:15 pm    Post subject: Reply with quote

as i said before, we can't support weekly snapshots until upstream releases them again without the revision suffix as maintainance is very difficult. We have sent two emails to KDE upstream but we got no responce and today there were tarballs again with that suffix
Back to top
View user's profile Send private message
NaiL
Apprentice
Apprentice


Joined: 13 Feb 2003
Posts: 228
Location: Spain/BCN

PostPosted: Mon Mar 02, 2009 6:49 pm    Post subject: Reply with quote

mikedee wrote:
For any nvidia users, I would not recommend updating to 180.35. It seems to make random programs hang. I downgraded back to 180.29.


+1

It breaks also 4.2.0
Back to top
View user's profile Send private message
Txukie
n00b
n00b


Joined: 02 Mar 2009
Posts: 5

PostPosted: Tue Mar 03, 2009 7:36 pm    Post subject: Reply with quote

Why does solid 4.2.1 keeps having (-networkmanager) use flags resolution? It says I need networkmanager-0.7 and I have just that....
Back to top
View user's profile Send private message
markus.doits
n00b
n00b


Joined: 11 Feb 2009
Posts: 2

PostPosted: Tue Mar 03, 2009 7:42 pm    Post subject: Reply with quote

anyone else being unable to use plasma-desktop since yesterday? did a live rebuild of alle kde-packages (emerge @live-rebuild), everthing went fine. but plasma-desktop does not start. trying to start it from konsole gives: http://pastebin.com/f35b87aae

i'm not sure about the X-errors (i never started plasma-desktop in console before), but the endless loop just before the "noreply"-error seems be the main failure.

so i'm sitting here with no panels nor desktop fortunately being able to start programs by "ALT+F2" :)

just rebuilt everything an hour ago (qt, too), still no change. clean profile ("rm -r .kdelive") does not work either.

using kdelive, nvidia 180.29, qt-4.5_rc1, xorg-x11-7.4 (, xorg-server 1.6.0)
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Mar 03, 2009 7:59 pm    Post subject: Reply with quote

Txukie wrote:
Why does solid 4.2.1 keeps having (-networkmanager) use flags resolution? It says I need networkmanager-0.7 and I have just that....

Just a guess: The networkmanager plasmoid for kde is still unfinished (alpha quality?) software.
Without this as an interface, you should probably be using something like nm-applet.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Txukie
n00b
n00b


Joined: 02 Mar 2009
Posts: 5

PostPosted: Tue Mar 03, 2009 10:41 pm    Post subject: Reply with quote

coolsnowmen wrote:
Txukie wrote:
Why does solid 4.2.1 keeps having (-networkmanager) use flags resolution? It says I need networkmanager-0.7 and I have just that....

Just a guess: The networkmanager plasmoid for kde is still unfinished (alpha quality?) software.
Without this as an interface, you should probably be using something like nm-applet.


Well, I used to use it in kde 4.2.0 rc from kde-testing overlay about a month ago, and it seemed to work ok... I actually want it to test an HSDPA device I have lying around here....
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Tue Mar 03, 2009 11:07 pm    Post subject: Reply with quote

I get this when trying to compile kdelibs:

Code:
[  7%] Building C object kdecore/CMakeFiles/kdecore.dir/fakes.o
Linking CXX shared library ../lib/libkdecore.so
CMakeFiles/kdecore.dir/localization/kcatalog.o: In function `kInitializeLocale()':
kcatalog.cpp:(.text+0x68): undefined reference to `qt_locale_initialized'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkdecore.so.5.3.0] Error 1
make[1]: *** [kdecore/CMakeFiles/kdecore.dir/all] Error 2
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/kdelibs-9999:
!!! In cmake-utils_src_make at line 1252
!!! Make failed!
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Mar 04, 2009 2:58 pm    Post subject: Reply with quote

I'm getting lots of these lately:

Quote:
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:44 (MESSAGE):
ERROR: Could not find KDE4 kde4-config
Call Stack (most recent call first):
CMakeLists.txt:6 (find_package)


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!


anything I need to change ?

many thanks in advance :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 20, 21, 22 ... 38, 39, 40  Next
Page 21 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum