Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 30, 31, 32 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Apr 23, 2009 7:21 pm    Post subject: Reply with quote

here a link to the error message(s) of amarok 2.0.90:

http://rafb.net/p/To9akG16.html

unfortunately it still crashes and it seems to be due to wrong lookup of (missing) libraries ...

thanks in advance for a look

edit:


this error message should be more accurate:

http://rafb.net/p/ncmQJV90.html
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Apr 24, 2009 3:37 pm    Post subject: Reply with quote

anyone getting the same results with latest konqueror from 4.3 / trunk ?

Quote:
From the 43 selectors 38 have passed, 1 are buggy and 4 are unsupported (Passed 573 out of 578 tests)


that is with qt 4.5.1
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sat Apr 25, 2009 8:13 am    Post subject: Reply with quote

i've just installed k3b-1.65.0_alpha1 and it tells that i have'nt MAD library so i cannot burn audio cd... but i HAVE it!
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sat Apr 25, 2009 8:30 am    Post subject: Reply with quote

same for k3b-9999:
Code:
Mp3 Audio Decoder plugin not found.
K3b could not load or find the Mp3 decoder plugin. This means that you will not be able to create Audio CDs from Mp3 files. Many Linux distributions do not include Mp3 support for legal reasons.
Solution: To enable Mp3 support, please install the MAD Mp3 decoding library as well as the K3b MAD Mp3 decoder plugin (the latter may already be installed but not functional due to the missing libmad). Some distributions allow installation of Mp3 support via an online update tool (e.g. SuSE's YOU).


but during compilation it says:

Code:
Calculating dependencies... done!
[ebuild   R   ] app-cdr/k3b-9999  USE="dvd emovix encode ffmpeg flac lame mad sndfile taglib vorbis wav -debug -musepack -musicbrainz -sox" 0 kB [1]     


and:

Code:
-----------------------------------------------------------------------------
-- The following dependencies were found.                                   
-----------------------------------------------------------------------------
   * libDVDRead - Libdvdread provides a simple foundation for reading DVD video disks.
   * Taglib - Read and write tags in audio files                                     
   * Samplerate - Audio sampling rate conversion.                                     
   * KCddb - KCddb is used to retrieve audio CD meta data from the internet.         
   * FFmpeg - Needed for the K3b FFmpeg decoder plugin which can decode virtually all audio types.
   * Flac - Needed for the Flac audio decoder plugin.
   * Flac++ - Needed for the Flac audio decoder plugin.
   * Mad mp3 - Needed for the mp3 audio decoder plugin.
   * Sndfile - Needed for the libsndfile audio decoder plugin.
   * Lame mp3 encoder - Needed for the lame mpf encoder encoder plugin.
   * Ogg Vorbis - Needed for the K3b Ogg Vorbis decoder and encoder plugins.

-----------------------------------------------------------------------------
-- Congratulations! All external packages have been found.
-----------------------------------------------------------------------------
Back to top
View user's profile Send private message
mikedee
Apprentice
Apprentice


Joined: 05 Jul 2006
Posts: 158

PostPosted: Sat Apr 25, 2009 11:14 am    Post subject: Reply with quote

kernelOfTruth - Your links are 404 :(
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 25, 2009 11:41 am    Post subject: Reply with quote

mikedee wrote:
kernelOfTruth - Your links are 404 :(


sorry,

well, then it got deleted meanwhile :(

I'll have a look at it later & try to re-compile it & run

thanks !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 25, 2009 2:26 pm    Post subject: Reply with quote

here's the error message of amarok 2.0.90:

http://nopaste.info/b26b87a636.html

many thanks in advance

Code:
USE="cdaudio daap gtk ipod mp3tunes mtp opengl semantic-desktop -debug"

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
appelgebak
Apprentice
Apprentice


Joined: 12 Sep 2004
Posts: 225
Location: Ruhrpott

PostPosted: Sun Apr 26, 2009 9:03 am    Post subject: Reply with quote

Krog wrote:
kde-base/kdepimlibs-4.2.70 does'nt compile for me!

Code:
       
[ 19%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/collectionfetchjob.o                                   
/var/tmp/portage/kde-base/kdepimlibs-4.2.70/work/kdepimlibs-4.2.70/akonadi/collectionfetchjob.cpp: In member function ‘virtual void Akonadi::CollectionFetchJob::doStart()’:                                                               
/var/tmp/portage/kde-base/kdepimlibs-4.2.70/work/kdepimlibs-4.2.70/akonadi/collectionfetchjob.cpp:134: error: expected `;' before ‘AKONADI_CMD_RID’                                                                                         
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/collectionfetchjob.o] Error 1                                       



Same error here..


My paludis --info:
Code:
jupp ~ # paludis --info kdepimlibs
paludis@1240736476: [WARNING e.ebuild.configuration.master_repository] In thread ID '28704':
  ... In program paludis --info kdepimlibs:                                                 
  ... When making environment from specification '':                                       
  ... When loading paludis environment:                                                     
  ... When creating repository from file '/etc/paludis/repositories/kde-testing.conf:       
  ... When making ebuild repository from repo_file '/etc/paludis/repositories/kde-testing.conf':
  ... Key 'master_repository' in '/etc/paludis/repositories/kde-testing.conf' will override '/var/paludis/repositories/kde-testing/metadata/layout.conf'.
paludis 0.36.1                                                                                                                                           
Paludis build information:                                                                                                                               
    Compiler:                                                                                                                                           
        CXX:                   x86_64-pc-linux-gnu-g++ 4.3.2                                                                                             
        CXXFLAGS:               -O2 -march=k8 -pipe                                                                                                     
        LDFLAGS:               -Wl,-O1                                                                                                                   
        DATE:                  2009-04-25T17:58:20+0200                                                                                                 

    Libraries:
        C++ Library:           GNU libstdc++ 20080827

    Reduced Privs:
        reduced_uid:           110
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /var/tmp/paludis
        reduced_gid:           1005           
        reduced_gid->name:     paludisbuild   

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib64
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc       
        PYTHONINSTALLDIR:                 
        RUBYINSTALLDIR:        /usr/lib64/ruby/site_ruby/1.8/x86_64-linux

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/db/portage/world

Repository layman:
    format:                    unavailable
    location:                  /usr/local/portage/layman
    sync:                      tar+http://git.exherbo.org/layman_repositories.tar.bz2
    sync_options:                                                                   

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /                 

Repository virtuals:
    format:                    virtuals

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false           
    binary_keywords:                           
    binary_uri_prefix:                         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /usr/portage/distfiles     
    eapi_when_unknown:         0                         
    eapi_when_unspecified:     0                         
    eclassdirs:                /usr/portage/eclass       
    ignore_deprecated_profiles: false                     
    layout:                    traditional               
    names_cache:               /var/cache/paludis/names   
    newsdir:                   /usr/portage/metadata/news
    profile_eapi_when_unspecified: 0                     
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0
    securitydir:               /usr/portage/metadata/glsa                     
    setsdir:                   /usr/portage/sets                               
    sync:                      rsync://rsync.gentoo.org/gentoo-portage         
    sync_options:                                                             
    use_manifest:              use                                             
    write_cache:               /var/empty                                     

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    names_cache:               /var/cache/paludis/names
    provides_cache:            /var/cache/paludis/provides
    root:                      /                         


Repository kde:
    format:                    ebuild
    location:                  /var/paludis/repositories/kde-testing
    append_repository_name_to_write_cache: true                     
    binary_destination:        false                               
    binary_keywords:                                               
    binary_uri_prefix:                                             
    builddir:                  /var/tmp/paludis                     
    cache:                     /var/empty                           
    distdir:                   /usr/portage/distfiles               
    eapi_when_unknown:         0                                   
    eapi_when_unspecified:     0                                   
    eclassdirs:                /usr/portage/eclass /var/paludis/repositories/kde-testing/eclass
    ignore_deprecated_profiles: false                                                         
    layout:                    traditional                                                     
    master_repository:         gentoo                                                         
    names_cache:               /var/paludis/repositories/kde-testing/.cache/names             
    newsdir:                   /var/paludis/repositories/kde-testing/metadata/news             
    profile_eapi_when_unspecified: 0                                                           
    profiles:                  /usr/portage/profiles/default/linux/amd64/2008.0               
    securitydir:               /var/paludis/repositories/kde-testing/metadata/glsa             
    setsdir:                   /var/paludis/repositories/kde-testing/sets                     
    sync:                      git://git.overlays.gentoo.org/proj/kde.git                     
    sync_options:                                                                             
    use_manifest:              use                                                             
    write_cache:               /var/cache/paludis/metadata                                     


Package kde-base/kdepimlibs-4.2.69::installed:

        >>> Running ebuild phase killold as paludisbuild:paludisbuild...
        bunzip2 < /var/db/pkg/kde-base/kdepimlibs-4.2.69/environment.bz2 > /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28714
        ebuild_scrub_environment /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28714                                         
        ebuild_safe_source /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28714                                               
        rm /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28714                                                               
        >>> Starting builtin_killold                                                                                                   
        >>> Done builtin_killold                                                                                                       
        >>> Completed ebuild phase killold                                                                                             
        >>> Running ebuild phases initmisc infovars info as paludisbuild:paludisbuild...                                               
        bunzip2 < /var/db/pkg/kde-base/kdepimlibs-4.2.69/environment.bz2 > /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28768
        ebuild_scrub_environment /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28768                                         
        ebuild_safe_source /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28768                                               
        rm /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28768                                                               
        >>> Starting builtin_initmisc                                                                                                   
        >>> Done builtin_initmisc                                                                                                       
        >>> Starting builtin_infovars                                                                                                   
        ACCEPT_KEYWORDS=amd64                                                                                                           
        CBUILD=x86_64-pc-linux-gnu                                                                                                     
        CFLAGS=-O2 -march=k8 -pipe                                                                                                     
        CHOST=x86_64-pc-linux-gnu                                                                                                       
        CONFIG_PROTECT=/usr/kde/4.2/share/config /usr/kde/4.2/env /usr/kde/4.2/shutdown /usr/share/config /usr/kde/4.3/share/config /usr/kde/4.3/env /usr/kde/4.3/shutdown /usr/kde/3.5/share/config /usr/kde/3.5/env /usr/kde/3.5/shutdown /etc                                                                                                                     
        CONFIG_PROTECT_MASK=/etc/gentoo-release /etc/sandbox.d /etc/env.d/java/ /etc/php/cli-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/udev/rules.d /etc/fonts/fonts.conf /etc/gconf /etc/terminfo /etc/ca-certificates.conf /etc/texmf/web2c /etc/revdep-rebuild /etc/env.d /etc/gconf                                   
        CPPFLAGS= -DQT_NO_DEBUG -DNDEBUG                                                                                                                                           
        CTARGET=                                                                                                                                                                   
        CXXFLAGS=-O2 -march=k8 -pipe                                                                                                                                               
        DISTDIR=/var/db/pkg/kde-base/kdepimlibs-4.2.69                                                                                                                             
        FEATURES=strict sfperms                                                                                                                                                   
        FFLAGS=                                                                                                                                                                   
        GENTOO_MIRRORS=                                                                                                                                                           
        INSTALL_MASK=                                                                                                                                                             
        LANG=                                                                                                                                                                     
        LC_ALL=C                                                                                                                                                                   
        LDFLAGS=-Wl,-O1                                                                                                                                                           
        LINGUAS=de                                                                                                                                                                 
        MAKEOPTS=-j3                                                                                                                                                               
        PORTAGE_COMPRESS=                                                                                                                                                         
        PORTAGE_COMPRESS_FLAGS=                                                                                                                                                   
        PORTAGE_CONFIGROOT=                                                                                                                                                       
        PORTAGE_RSYNC_EXTRA_OPTS=                                                                                                                                                 
        PORTAGE_RSYNC_OPTS=                                                                                                                                                       
        PORTAGE_TMPDIR=/var/tmp/paludis                                                                                                                                           
        PORTDIR=/var/db/pkg/kde-base/kdepimlibs-4.2.69                                                                                                                             
        PORTDIR_OVERLAY=                                                                                                                                                           
        SYNC=                                                                                                                                                                     
        USE=kdeprefix sasl amd64 alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_auth_digest apache2_modules_authn_anon apache2_modules_authn_dbd apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_dbd apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_ident apache2_modules_imagemap apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_proxy apache2_modules_proxy_ajp apache2_modules_proxy_balancer apache2_modules_proxy_connect apache2_modules_proxy_http apache2_modules_rewrite apache2_modules_setenvif apache2_modules_so apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias elibc_glibc input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_vmmouse kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text linguas_de userland_GNU video_cards_fbdev video_cards_glint video_cards_nv video_cards_nvidia video_cards_v4l video_cards_vesa video_cards_vmware amd64                                                                                                                                                   
        >>> Done builtin_infovars                                                                                                                                                 
        >>> Starting pkg_info                                                                                                                                                     
        >>> Done pkg_info                                                                                                                                                         
        >>> Completed ebuild phases initmisc infovars info                                                                                                                         
        >>> Running ebuild phase tidyup as paludisbuild:paludisbuild...                                                                                                           
        bunzip2 < /var/db/pkg/kde-base/kdepimlibs-4.2.69/environment.bz2 > /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28844                                           
        ebuild_scrub_environment /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28844                                                                                     
        ebuild_safe_source /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28844                                                                                           
        rm /var/tmp/paludis/environment-kde-base-kdepimlibs-4.2.69-28844                                                                                                           
        >>> Starting builtin_tidyup                                                                                                                                               
        rm -fr /var/tmp/paludis/kde-base-kdepimlibs-4.2.69-info                                                                                                                   
        >>> Done builtin_tidyup                                                                                                                                                   
        >>> Completed ebuild phase tidyup                                                                                                                                         

Package kde-base/kdepimlibs-4.2.70:4.3::kde:

        >>> Running ebuild phase killold as paludisbuild:paludisbuild...
        >>> Starting builtin_killold                                   
        >>> Done builtin_killold                                       
        >>> Completed ebuild phase killold                             
        >>> Running ebuild phases initmisc infovars as paludisbuild:paludisbuild...
        >>> Starting builtin_initmisc
        >>> Done builtin_initmisc
        >>> Starting builtin_infovars
        ACCEPT_KEYWORDS=amd64
        CBUILD=x86_64-pc-linux-gnu
        CFLAGS=-O2 -march=k8 -pipe
        CHOST=x86_64-pc-linux-gnu
        CONFIG_PROTECT=
        CONFIG_PROTECT_MASK=
        CPPFLAGS=
        CTARGET=
        CXXFLAGS=-O2 -march=k8 -pipe
        DISTDIR=/usr/portage/distfiles
        FEATURES=strict sfperms
        FFLAGS=
        GENTOO_MIRRORS=
        INSTALL_MASK=
        LANG=
        LC_ALL=C
        LDFLAGS=-Wl,-O1
        LINGUAS=de
        MAKEOPTS=-j3
        PORTAGE_COMPRESS=
        PORTAGE_COMPRESS_FLAGS=
        PORTAGE_CONFIGROOT=
        PORTAGE_RSYNC_EXTRA_OPTS=
        PORTAGE_RSYNC_OPTS=
        PORTAGE_TMPDIR=/var/tmp/paludis
        PORTDIR=/usr/portage
        PORTDIR_OVERLAY=
        SYNC=
        USE=kdeprefix amd64 alsa_cards_ali5451 alsa_cards_als4000 alsa_cards_atiixp alsa_cards_atiixp-modem alsa_cards_bt87x alsa_cards_ca0106 alsa_cards_cmipci alsa_cards_emu10k1x alsa_cards_ens1370 alsa_cards_ens1371 alsa_cards_es1938 alsa_cards_es1968 alsa_cards_fm801 alsa_cards_hda-intel alsa_cards_intel8x0 alsa_cards_intel8x0m alsa_cards_maestro3 alsa_cards_trident alsa_cards_usb-audio alsa_cards_via82xx alsa_cards_via82xx-modem alsa_cards_ymfpci alsa_pcm_plugins_adpcm alsa_pcm_plugins_alaw alsa_pcm_plugins_asym alsa_pcm_plugins_copy alsa_pcm_plugins_dmix alsa_pcm_plugins_dshare alsa_pcm_plugins_dsnoop alsa_pcm_plugins_empty alsa_pcm_plugins_extplug alsa_pcm_plugins_file alsa_pcm_plugins_hooks alsa_pcm_plugins_iec958 alsa_pcm_plugins_ioplug alsa_pcm_plugins_ladspa alsa_pcm_plugins_lfloat alsa_pcm_plugins_linear alsa_pcm_plugins_meter alsa_pcm_plugins_mmap_emul alsa_pcm_plugins_mulaw alsa_pcm_plugins_multi alsa_pcm_plugins_null alsa_pcm_plugins_plug alsa_pcm_plugins_rate alsa_pcm_plugins_route alsa_pcm_plugins_share alsa_pcm_plugins_shm alsa_pcm_plugins_softvol apache2_modules_actions apache2_modules_alias apache2_modules_auth_basic apache2_modules_auth_digest apache2_modules_authn_anon apache2_modules_authn_dbd apache2_modules_authn_dbm apache2_modules_authn_default apache2_modules_authn_file apache2_modules_authz_dbm apache2_modules_authz_default apache2_modules_authz_groupfile apache2_modules_authz_host apache2_modules_authz_owner apache2_modules_authz_user apache2_modules_autoindex apache2_modules_cache apache2_modules_dav apache2_modules_dav_fs apache2_modules_dav_lock apache2_modules_dbd apache2_modules_deflate apache2_modules_dir apache2_modules_disk_cache apache2_modules_env apache2_modules_expires apache2_modules_ext_filter apache2_modules_file_cache apache2_modules_filter apache2_modules_headers apache2_modules_ident apache2_modules_imagemap apache2_modules_include apache2_modules_info apache2_modules_log_config apache2_modules_logio apache2_modules_mem_cache apache2_modules_mime apache2_modules_mime_magic apache2_modules_negotiation apache2_modules_proxy apache2_modules_proxy_ajp apache2_modules_proxy_balancer apache2_modules_proxy_connect apache2_modules_proxy_http apache2_modules_rewrite apache2_modules_setenvif apache2_modules_so apache2_modules_speling apache2_modules_status apache2_modules_unique_id apache2_modules_userdir apache2_modules_usertrack apache2_modules_vhost_alias elibc_glibc input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_vmmouse kernel_linux lcd_devices_bayrad lcd_devices_cfontz lcd_devices_cfontz633 lcd_devices_glk lcd_devices_hd44780 lcd_devices_lb216 lcd_devices_lcdm001 lcd_devices_mtxorb lcd_devices_ncurses lcd_devices_text linguas_de userland_GNU video_cards_fbdev video_cards_glint video_cards_nv video_cards_nvidia video_cards_v4l video_cards_vesa video_cards_vmware amd64
        >>> Done builtin_infovars
        >>> Completed ebuild phases initmisc infovars
        >>> Running ebuild phase tidyup as paludisbuild:paludisbuild...
        >>> Starting builtin_tidyup
        rm -fr /var/tmp/paludis/kde-base-kdepimlibs-4.2.70-info
        >>> Done builtin_tidyup
        >>> Completed ebuild phase tidyup

Back to top
View user's profile Send private message
bianco
n00b
n00b


Joined: 21 Jun 2005
Posts: 54

PostPosted: Sun Apr 26, 2009 4:51 pm    Post subject: pykde4-4.2.70 ERROR Reply with quote

Same here.... :(
Still no solution???

rahulthewall wrote:
pykde4-4.2.70 hell! :(

Code:

sipkdeuipart2.cpp: In constructor 'sipKEditListBox::sipKEditListBox(QWidget*, const char*, bool, QFlags<KEditListBox::Button>)':                                                                                             
sipkdeuipart2.cpp:7743: warning: 'KEditListBox::KEditListBox(QWidget*, const char*, bool, QFlags<KEditListBox::Button>)' is deprecated (declared at /usr/include/keditlistbox.h:125)                                         
sipkdeuipart2.cpp: In constructor 'sipKEditListBox::sipKEditListBox(const QString&, QWidget*, const char*, bool, QFlags<KEditListBox::Button>)':                                                                             
sipkdeuipart2.cpp:7748: warning: 'KEditListBox::KEditListBox(const QString&, QWidget*, const char*, bool, QFlags<KEditListBox::Button>)' is deprecated (declared at /usr/include/keditlistbox.h:136)                         
sipkdeuipart2.cpp: In member function 'void sipKDatePicker::sipProtect_uncheckYearSelector()':                 
sipkdeuipart2.cpp:30064: error: 'uncheckYearSelector' is not a member of 'KDatePicker'                         
sipkdeuipart2.cpp: In constructor 'sipKCharSelect::sipKCharSelect(QWidget*, QFlags<KCharSelect::Control>)':   
sipkdeuipart2.cpp:44255: warning: 'KCharSelect::KCharSelect(QWidget*, QFlags<KCharSelect::Control>)' is deprecated (declared at /usr/include/kcharselect.h:112)                                                               
make[2]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdeui.dir/sip/kdeui/sipkdeuipart2.o] Error 1       
make[2]: *** Waiting for unfinished jobs....                                                                   
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Sun Apr 26, 2009 8:04 pm    Post subject: Reply with quote

pimlibs failed - recompile/update aconadi-server

pykde4 - no way to get this, afaik it's broken in 4.2.70, wait for another revision.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Mon Apr 27, 2009 8:12 am    Post subject: Reply with quote

nobody is able to compile k3b with audio cd support (libmad)?
Back to top
View user's profile Send private message
rufnut
Apprentice
Apprentice


Joined: 16 May 2005
Posts: 203

PostPosted: Mon Apr 27, 2009 1:09 pm    Post subject: Reply with quote

Krog wrote:
nobody is able to compile k3b with audio cd support (libmad)?


*** ACCEPT_KEYWORDS='-~amd64' emerge --nospinner =app-cdr/k3b-9999 ***

Code:
Installed versions:  9999(2)[1](23:11:05 04/27/09)(dvd encode ffmpeg flac mad vorbis wav -debug -emovix -lame -musepack-musicbrainz -sndfile -sox -taglib)


Seems ok to me :?
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Tue Apr 28, 2009 6:34 am    Post subject: gtk-engines-kde4-0.9b failed Reply with quote

Linking CXX executable gtk-kde4
[100%] Built target kcm_gk4
/bin/sh: sudo: command not found
make[2]: *** [daemon/gtk-kde4] Error 127
make[1]: *** [daemon/CMakeFiles/gtk-kde4.dir/all] Error 2
make: *** [all] Error 2

sudo ???....
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 821
Location: Alaska

PostPosted: Tue Apr 28, 2009 7:38 am    Post subject: Reply with quote

Krog wrote:
nobody is able to compile k3b with audio cd support (libmad)?


Mine compiles fine with mad but when I start the program it complains that mp3 support is not available and I can't make audio cds from mp3s. Just a data point because I don't do that much anyway. /jim
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue Apr 28, 2009 8:32 am    Post subject: Re: gtk-engines-kde4-0.9b failed Reply with quote

bers wrote:
Linking CXX executable gtk-kde4
[100%] Built target kcm_gk4
/bin/sh: sudo: command not found
make[2]: *** [daemon/gtk-kde4] Error 127
make[1]: *** [daemon/CMakeFiles/gtk-kde4.dir/all] Error 2
make: *** [all] Error 2

sudo ???....


Install app-admin/sudo.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Thu Apr 30, 2009 11:00 am    Post subject: Reply with quote

Code:
kde-base/akonadi-9999:                                                     
 * Detected file collision(s):                                           
 *                                                                       
 *      /usr/share/apps/nepomuk/ontologies/nco.trig                     
 *      /usr/share/apps/nepomuk/ontologies/nmo.trig                     
 *      /usr/share/apps/nepomuk/ontologies/nmo.desktop                   
 *      /usr/share/apps/nepomuk/ontologies/nco.desktop                   
 *                                                                       
 * Searching all installed packages for file collisions...               
 *                                                                       
 * Press Ctrl-C to Stop                                                 
 *                                                                       
 * kde-base/nepomuk-9999                                                 
 *      /usr/share/apps/nepomuk/ontologies/nco.desktop                   
 *      /usr/share/apps/nepomuk/ontologies/nco.trig                     
 *      /usr/share/apps/nepomuk/ontologies/nmo.desktop                   
 *      /usr/share/apps/nepomuk/ontologies/nmo.trig




what to do?
when i had file collisions with packages from kde 4.2.70 i just uninstalled kde 4.2.70, but what to do here?
Back to top
View user's profile Send private message
laughinggnome
n00b
n00b


Joined: 07 Mar 2006
Posts: 45

PostPosted: Thu Apr 30, 2009 4:15 pm    Post subject: Reply with quote

Dancingfire,

Building akonadi without the 'semantic-desktop' use-flag allows both it and nepomuk to be installed, but I'm not what, if any, consequences this has.
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri May 01, 2009 5:27 pm    Post subject: Reply with quote

Code:
googly rahul # emerge raptormenu                                                                               
Calculating dependencies... done!                                                                               

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) kde-misc/raptormenu-9999 from kde
 * checking ebuild checksums ;-) ...                                                                     [ ok ]
 * checking auxfile checksums ;-) ...                                                                    [ ok ]
 * checking miscfile checksums ;-) ...                                                                   [ ok ]
>>> Unpacking source...                                                                                       
 * GIT NEW clone -->                                                                                           
 *    repository:               git://github.com/ruphy/raptor.git                                             
Initialized empty Git repository in /usr/portage/distfiles/git-src/raptormenu/                                 
github.com[0: 65.74.177.129]: errno=Connection refused                                                         
fatal: unable to connect a socket (Connection refused)                                                         
 *                                                                                                             
 * ERROR: kde-misc/raptormenu-9999 failed.                                                                     
 * Call stack:                                                                                                 
 *               ebuild.sh, line   49:  Called src_unpack                                                     
 *             environment, line 3278:  Called git_src_unpack                                                 
 *             environment, line 2298:  Called git_fetch                                                       
 *             environment, line 2240:  Called die                                                             
 * The specific snippet of code:                                                                               
 *           ${EGIT_FETCH_CMD} ${EGIT_OPTIONS} "${EGIT_REPO_URI}" ${EGIT_PROJECT} || die "${EGIT}: can't fetch from ${EGIT_REPO_URI}.";                                                                                         
 *  The die message:                                                                                           
 *   git.eclass: can't fetch from git://github.com/ruphy/raptor.git.                                           
 *                                                                                                             
 * If you need support, post the topmost build error, and the call stack if relevant.                           
 * A complete build log is located at '/var/tmp/portage/kde-misc/raptormenu-9999/temp/build.log'.               
 * The ebuild environment file is located at '/var/tmp/portage/kde-misc/raptormenu-9999/temp/environment'.     
 * This ebuild used the following eclasses from overlays:                                                       
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                             
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'
 *

>>> Failed to emerge kde-misc/raptormenu-9999, Log file:

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri May 01, 2009 7:56 pm    Post subject: Reply with quote

Code:

* Missing digest for '/usr/local/portage/layman/kde-testing/x11-themes/gtk-engines-kde4/gtk-engines-kde4-0.9b.ebuild

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat May 02, 2009 4:49 am    Post subject: Reply with quote

kdepimlibs 4.2.71 does not compile with error
Code:
[ 85%] Building CXX object kcal/CMakeFiles/kcal.dir/kresult.o                                                                                                                   
[ 85%] [ 85%] Building CXX object kcal/CMakeFiles/kcal.dir/assignmentvisitor.o                                                                                                   
Building CXX object kcal/CMakeFiles/kcal.dir/comparisonvisitor.o                                                                                                                 
[ 85%] Building CXX object kcal/CMakeFiles/kcal.dir/htmlexportsettings.o                                                                                                         
Linking CXX shared library ../lib/libkcal.so                                                                                                                                     
[ 85%] Built target kcal                                                                                                                                                         
make: *** [all] Erreur 2                                                                                                                                                         
 *                                                                                                                                                                               
 * ERROR: kde-base/kdepimlibs-4.2.71 failed.                                                                                                                                     
 * Call stack:                                                                                                                                                                   
 *               ebuild.sh, line   49:  Called src_compile                                                                                                                       
 *             environment, line 3153:  Called kde4-base_src_compile                                                                                                             
 *             environment, line 2350:  Called cmake-utils_src_compile                                                                                                           
 *             environment, line  794:  Called cmake-utils_src_make                                                                                                             
 *             environment, line  873:  Called die                                                                                                                               
 * The specific snippet of code:                                                                                                                                                 
 *           emake "$@" || die "Make failed!";                                                                                                                                   
 *  The die message:                                                                                                                                                             
 *   Make failed!                                                                                                                                                               
 *                                                                                                                                                                               
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                                           
 * A complete build log is located at '/dev/shm/portage/kde-base/kdepimlibs-4.2.71/temp/build.log'.                                                                             
 * The ebuild environment file is located at '/dev/shm/portage/kde-base/kdepimlibs-4.2.71/temp/environment'.                                                                     
 * This ebuild used the following eclasses from overlays:                                                                                                                       
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                                                                                               
 *   /usr/local/portage/layman/kde-testing/eclass/cmake-utils.eclass                                                                                                             
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                                                                                         
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                                                                                         
 *

_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sat May 02, 2009 9:04 am    Post subject: Reply with quote

pykde4 ... again! :(

Code:

make -j3
[  1%] Scanning dependencies of target compile_python_files
Generating sip/dnssd/sipdnssdpart0.cpp, sip/dnssd/sipdnssdpart1.cpp, sip/dnssd/sipdnssdpart2.cpp, sip/dnssd/sipdnssdpart3.cpp, sip/dnssd/sipdnssdpart4.cpp, sip/dnssd/sipdnssdpart5.cpp, sip/dnssd/sipdnssdpart6.cpp, sip/dnssd/sipdnssdpart7.cpp
[  2%] 

Generating sip/kdecore/sipkdecorepart0.cpp, sip/kdecore/sipkdecorepart1.cpp, sip/kdecore/sipkdecorepart2.cpp, sip/kdecore/sipkdecorepart3.cpp, sip/kdecore/sipkdecorepart4.cpp, sip/kdecore/sipkdecorepart5.cpp, sip/kdecore/sipkdecorepart6.cpp, sip/kdecore/sipkdecorepart7.cpp


[  2%] Built target compile_python_files
[  3%] Generating sip/kdeui/sipkdeuipart0.cpp, sip/kdeui/sipkdeuipart1.cpp, sip/kdeui/sipkdeuipart2.cpp, sip/kdeui/sipkdeuipart3.cpp, sip/kdeui/sipkdeuipart4.cpp, sip/kdeui/sipkdeuipart5.cpp, sip/kdeui/sipkdeuipart6.cpp, sip/kdeui/sipkdeuipart7.cpp

Scanning dependencies of target python_module_PyKDE4_kdecore
[  4%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_kdecore.dir/sip/kdecore/sipkdecorepart0.o
In file included from /usr/include/python2.6/Python.h:8,
                 from /usr/include/python2.6/sip.h:28,
                 from /var/tmp/portage/kde-base/pykde4-4.2.71/work/pykde4-4.2.71_build/python/pykde4/sip/kdecore/sipAPIkdecore.h:11,
                 from /var/tmp/portage/kde-base/pykde4-4.2.71/work/pykde4-4.2.71_build/python/pykde4/sip/kdecore/sipkdecorepart0.cpp:7:
/usr/include/python2.6/pyconfig.h:1064:1: warning: "_XOPEN_SOURCE" redefined
<command-line>: warning: this is the location of the previous definition
sipkdecorepart0.cpp: In function 'void initkdecore()':
sipkdecorepart0.cpp:4691: error: 'SslErrorUiData' was not declared in this scope
sipkdecorepart0.cpp:4691: error: no matching function for call to 'qRegisterMetaType(const char [15])'
sipkdecorepart0.cpp: In function 'PyObject* meth_KUser_fullName(PyObject*, PyObject*)':
sipkdecorepart0.cpp:12930: warning: 'QString KUser::fullName() const' is deprecated (declared at /usr/include/kuser.h:179)
make[2]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdecore.dir/sip/kdecore/sipkdecorepart0.o] Error 1
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_kdecore.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat May 02, 2009 9:29 am    Post subject: Reply with quote

I am getting this error:

Code:


emerge -uDNav @kde-4.3

These are the packages that would be merged, in order:

Calculating dependencies - * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-4.2.9999.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1447
 * Expected: 1448
 | * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-4.2.71.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1046
 * Expected: 1047
 * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-9999.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1035
 * Expected: 1036
 - * Missing digest for '/usr/portage/local/layman/local/dev-cpp/eigen/eigen-2.0.51.ebuild'
... done!

emerge: there are no ebuilds to satisfy ">=kde-base/kdepim-kresources-4.2.71:4.3[kdeprefix]".
(dependency required by "kde-base/kdepim-wizards-4.2.71" [ebuild])
(dependency required by "@kde-4.3" [argument])

Back to top
View user's profile Send private message
lmmsci
Apprentice
Apprentice


Joined: 20 May 2006
Posts: 190

PostPosted: Sat May 02, 2009 12:31 pm    Post subject: Reply with quote

rahulthewall: Look, what I've found :?

https://www.ohloh.net/p/11375/commits/43018796

Probably someone missed this. Perhaps it's good idea to make a simple patch. I'm not familiar with this issue at all (writing patches I mean), so temporary I just cannot do that...
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat May 02, 2009 1:49 pm    Post subject: Reply with quote

marcus84 wrote:
I am getting this error:

Code:


emerge -uDNav @kde-4.3

These are the packages that would be merged, in order:

Calculating dependencies - * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-4.2.9999.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1447
 * Expected: 1448
 | * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-4.2.71.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1046
 * Expected: 1047
 * Digest verification failed:
 * /usr/portage/local/layman/kde-testing/kde-base/kdepim-kresources/kdepim-kreso
urces-9999.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 1035
 * Expected: 1036
 - * Missing digest for '/usr/portage/local/layman/local/dev-cpp/eigen/eigen-2.0.51.ebuild'
... done!

emerge: there are no ebuilds to satisfy ">=kde-base/kdepim-kresources-4.2.71:4.3[kdeprefix]".
(dependency required by "kde-base/kdepim-wizards-4.2.71" [ebuild])
(dependency required by "@kde-4.3" [argument])



solved re-syncing
Back to top
View user's profile Send private message
PurpleGecko
n00b
n00b


Joined: 16 Sep 2007
Posts: 14
Location: Germany

PostPosted: Sat May 02, 2009 2:15 pm    Post subject: Akonadi Fails Reply with quote

Akonadi-4.2.71 fails because of a bad include, already patched upstream. For those who know how the patch can be found here.

http://websvn.kde.org/trunk/KDE/kdepim/akonadi/akonadi_next/emaillineedit.cpp?r1=949011&r2=961805

Hope this helps :)
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 30, 31, 32 ... 38, 39, 40  Next
Page 31 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum