Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 31, 32, 33 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat May 02, 2009 3:16 pm    Post subject: Reply with quote

I re-synchronizes the overlay and now I have another error with kdepimlibs 4.2.71
Code:
>>> Emerging (1 of 1) kde-base/kdepimlibs-4.2.71 from kde
 * kdepimlibs-4.2.71.tar.lzma RMD160 SHA1 SHA256 size ;-) ...                                                                                                             [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                      [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                     [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                    [ ok ]
>>> Unpacking source...                                                                                                                                                         
>>> Unpacking kdepimlibs-4.2.71.tar.lzma to /dev/shm/portage/kde-base/kdepimlibs-4.2.71/work                                                                                   
>>> Source unpacked in /dev/shm/portage/kde-base/kdepimlibs-4.2.71/work                                                                                                         
>>> Preparing source in /dev/shm/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71 ...                                                                                 
>>> Source prepared.                                                                                                                                                           
>>> Configuring source in /dev/shm/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71 ...                                                                               
 * I was unable to locate CMakeLists.txt under:                                                                                                                                 
 * "/CMakeLists.txt"                                                                                                                                                           
 * You should consider not inheriting the cmake eclass.                                                                                                                         
 *                                                                                                                                                                             
 * ERROR: kde-base/kdepimlibs-4.2.71 failed.                                                                                                                                   
 * Call stack:                                                                                                                                                                 
 *               ebuild.sh, line   49:  Called src_configure                                                                                                                   
 *             environment, line 3154:  Called kde4-base_src_configure                                                                                                         
 *             environment, line 2370:  Called cmake-utils_src_configure                                                                                                       
 *             environment, line  797:  Called die                                                                                                                             
 * The specific snippet of code:                                                                                                                                               
 *           die "FATAL: Unable to find CMakeLists.txt";                                                                                                                       
 *  The die message:                                                                                                                                                           
 *   FATAL: Unable to find CMakeLists.txt     

_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Sun May 03, 2009 9:35 pm    Post subject: Reply with quote

Hi guys!
Are you able to get a non-empty music collection with Amarok-9999 and mysql-5.0.76-r1 ?
Thx :)
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Mon May 04, 2009 9:24 am    Post subject: Reply with quote

kdepimlibs-4.2.71 dosn't compile:

Code:

 ~ # MAKEOPTS="-j1" emerge kde-base/kdepimlibs
[...]
[ 21%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/itemdeletejob.o
/var/tmp/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71/akonadi/itemdeletejob.cpp: In member function »void Akonadi::ItemDeleteJobPrivate::selectResult(KJob*)«:
/var/tmp/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71/akonadi/itemdeletejob.cpp:59: Fehler: expected »,« or »;« before »AKONADI_CMD_ITEMDELETE«
/var/tmp/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71/akonadi/itemdeletejob.cpp: In member function »virtual void Akonadi::ItemDeleteJob::doStart()«:
/var/tmp/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71/akonadi/itemdeletejob.cpp:98: Fehler: expected `;' before »AKONADI_CMD_ITEMDELETE«
/var/tmp/portage/kde-base/kdepimlibs-4.2.71/work/kdepimlibs-4.2.71/akonadi/itemdeletejob.cpp:116: Fehler: expected `;' before »AKONADI_CMD_ITEMDELETE«
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/itemdeletejob.o] Fehler 1
make[1]: *** [akonadi/CMakeFiles/akonadi-kde.dir/all] Fehler 2
make: *** [all] Fehler 2
 *
 * ERROR: kde-base/kdepimlibs-4.2.71 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3094:  Called kde4-base_src_compile
 *             environment, line 2300:  Called cmake-utils_src_compile
 *             environment, line  781:  Called cmake-utils_src_make
 *             environment, line  860:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/kde-base:kdepimlibs-4.2.71:20090504-092021.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdepimlibs-4.2.71/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/portage/local/layman/kde-testing/eclass/kde4-base.eclass
 *   /usr/portage/local/layman/kde-testing/eclass/cmake-utils.eclass
 *   /usr/portage/local/layman/kde-testing/eclass/kde4-functions.eclass
 * This ebuild is from a repository named 'kde'
 *

>>> Failed to emerge kde-base/kdepimlibs-4.2.71, Log file:

>>>  '/var/log/portage/kde-base:kdepimlibs-4.2.71:20090504-092021.log'
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Mon May 04, 2009 5:46 pm    Post subject: Reply with quote

kdepimlibs compiled fine for me,
what are use flags, cflags, and arch?




though akonadi failed to compile for me with

Code:
[ 95%] Building CXX object akonadi/akonadi_next/CMakeFiles/akonadi_next.dir/emaillineedit.o                                                                   
/tmp/portage/kde-base/akonadi-4.2.71/work/akonadi-4.2.71/akonadi/akonadi_next/emaillineedit.cpp:34:33: error: entityupdateadapter.h: Нет такого файла или каталога                                                                                                                                                           
make[2]: *** [akonadi/akonadi_next/CMakeFiles/akonadi_next.dir/emaillineedit.o] Ошибка 1                                                                       
make[1]: *** [akonadi/akonadi_next/CMakeFiles/akonadi_next.dir/all] Ошибка 2                                                                                   
make: *** [all] Ошибка 2   
Back to top
View user's profile Send private message
laughinggnome
n00b
n00b


Joined: 07 Mar 2006
Posts: 45

PostPosted: Mon May 04, 2009 5:59 pm    Post subject: Reply with quote

TheDodger wrote:
kdepimlibs-4.2.71 dosn't compile:

...



Try rebuilding/updating akonadi-server.
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Mon May 04, 2009 7:57 pm    Post subject: Reply with quote

laughinggnome wrote:
TheDodger wrote:
kdepimlibs-4.2.71 dosn't compile:

...



Try rebuilding/updating akonadi-server.


THANX! :)
I only probed a update from the akonadi (without -server) pakage ...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Tue May 05, 2009 9:23 am    Post subject: Reply with quote

I just decided it would be time to move to 4.3 on my secondary system. Now compiling... ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bers
n00b
n00b


Joined: 28 Nov 2008
Posts: 49

PostPosted: Tue May 05, 2009 10:49 am    Post subject: Reply with quote

kde-base/kmail-4.2.71 dosn't compile

[ 86%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/replyphrases.o
[ 86%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/custommimeheader.o
[ 86%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/templatesconfiguration_kfg.o
[ 87%] Building CXX object kmail/CMakeFiles/kmailprivate.dir/customtemplates_kfg.o
Linking CXX shared library ../lib/libkmailprivate.so
CMakeFiles/kmailprivate.dir/popaccount.o: file not recognized: File truncated
collect2: выполнение ld завершилось с кодом возврата 1
make[2]: *** [lib/libkmailprivate.so.4.3.0] Ошибка 1
make[1]: *** [kmail/CMakeFiles/kmailprivate.dir/all] Ошибка 2
make: *** [all] Ошибка 2
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 05, 2009 10:53 am    Post subject: Reply with quote

for me lots of menus aren't displayed correctly only the border is shown:

http://img49.imageshack.us/img49/5218/snapshot1i.png (showing krunner)

http://img49.imageshack.us/img49/7214/snapshot2.png (showing the kde kickoff menu)

this is independent of compositing (opengl, xrender, non-compositing) and for those nvidia-drivers being able to run on 2.6.30-rc*

it could be an nvidia problem but I'm not sure

any ideas or similar experience ?

thanks
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Tue May 05, 2009 11:15 am    Post subject: Reply with quote

only on (stable) problem ... kde-base/pykde4

This package do not work (in my setup) ... since 4.2.69
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 05, 2009 11:39 am    Post subject: Reply with quote

TheDodger wrote:
only on (stable) problem ... kde-base/pykde4

This package do not work (in my setup) ... since 4.2.69


TheDodger you're referring to my post ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Tue May 05, 2009 12:20 pm    Post subject: Reply with quote

kernelOfTruth wrote:
TheDodger wrote:
only on (stable) problem ... kde-base/pykde4

This package do not work (in my setup) ... since 4.2.69


TheDodger you're referring to my post ?


Nope.
I reply genstorm ... but without reloading the thread.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Tue May 05, 2009 1:42 pm    Post subject: Reply with quote

TheDodger wrote:
only on (stable) problem ... kde-base/pykde4

Don't care about that, as I'm compiling with "-python" for ages. ;)

Well, right now anonsvn.kde.org seems to be off.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Tue May 05, 2009 1:46 pm    Post subject: Reply with quote

genstorm wrote:
TheDodger wrote:
only on (stable) problem ... kde-base/pykde4

Don't care about that, as I'm compiling with "-python" for ages. ;)


Yes ... thats my current action.
but many plasmaoids are not functionaly without python :-(
thats frustrating ;)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Tue May 05, 2009 1:50 pm    Post subject: Reply with quote

Really? Could you give me examples, because I haven't run into problems yet.

anonsvn.kde.org is up again, resuming emerge.

EDIT: Hmm, is there actually a KDE4.2.x stabilization tracker yet? Because I haven't stumbled over one yet.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Tue May 05, 2009 4:17 pm    Post subject: Reply with quote

kde-base/plasma-workspace-9999 fails. I just got this on an emerge -1 @kdebase-live:
Code:
 * Enabling experimental fake transparency support.
 * There are known issues with certain versions of Qt.
 * Do not report any bugs.

 * Applying plasma-workspace-fake-panel-transparency.patch ...

 * Failed Patch: plasma-workspace-fake-panel-transparency.patch !
 *  ( /usr/local/portage/layman/kde-testing/kde-base/plasma-workspace/files/plasma-workspace-fake-panel-transparency.patch )

I commented out the epatch and re-digested the ebuild, but it still fails at
Code:
[ 19%] Building CXX object plasma/applets/system-monitor/CMakeFiles/plasma_applet-system-monitor.dir/applet.o
Linking CXX shared library ../../../lib/libplasma_applet-system-monitor.so
[ 19%] Built target plasma_applet-system-monitor
make: *** [all] Error 2
 *
 * ERROR: kde-base/plasma-workspace-9999 failed.
 * Call stack:


What version of qt works on this and is recommended? I'm currently using qt-4.5.1 from portage. Do I need to go with something in the qting-edge overlay?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Tue May 05, 2009 11:14 pm    Post subject: Reply with quote

Hm. Try adding qting-edge overlay and emerge qt-*-4.5.9999. It should contain fixes from the KDE developers that could solve your problem.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Tue May 05, 2009 11:37 pm    Post subject: Reply with quote

Can't use printer configuration....

Code:

The service "Printer Configuration" does not provide an interface 'KCModule' with keyword 'system-config-printer-kde/system-config-printer-kde.py' The factory does not support creating components of the specified type


KDE-4.2.71 -> Any ideas what is the wrong?
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue May 05, 2009 11:40 pm    Post subject: Reply with quote

genstorm wrote:
Hm. Try adding qting-edge overlay and emerge qt-*-4.5.9999. It should contain fixes from the KDE developers that could solve your problem.


it definitely does !

finally I'm able to see the kickoff menu, krunner, notifications, ... again :D
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed May 06, 2009 1:44 am    Post subject: Reply with quote

@genstorm & kernelOfTruth,
Thanks, but I just did that earlier, and still get the same problems. On emerge @kde-base-live, these three still fail, same as with qt-4.5.1 from portage.
Code:
* The following 3 packages have failed to build or install:
 *
 *    ('ebuild', '/', 'kde-base/nepomuk-9999', 'merge')
 *    ('ebuild', '/', 'kde-base/plasma-workspace-9999', 'merge')
 *    ('ebuild', '/', 'kde-base/systemsettings-9999', 'merge')


The first time I did the qting-edge ovelay, I got:
Code:

kdesvn wrc # emerge -pv1 @qt-all-live-kde

These are the packages that would be merged, in order:

Calculating dependencies \ * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-svg-4.5.9999
 / * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-core-4.5.9999
 \ * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-opengl-4.5.9999
 \ * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-qt3support-4.5.9999
 / * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-test-4.5.9999
 \ * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-webkit-4.5.9999
 / * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-sql-4.5.9999
 \ * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-xmlpatterns-4.5.9999
 / * QA Notice: USE Flag 'qt-copy' not in IUSE for x11-libs/qt-gui-4.5.9999
... done!
[ebuild     U ] x11-libs/qt-core-4.5.9999 [4.5.1] USE="glib iconv qt-copy%* qt3support ssl -debug -doc -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-sql-4.5.9999 [4.5.1] USE="iconv mysql qt-copy%* qt3support sqlite -debug -firebird -odbc -pch -postgres (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-script-4.5.9999 [4.5.1] USE="iconv qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-dbus-4.5.9999 [4.5.1] USE="qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-test-4.5.9999 [4.5.1] USE="iconv qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-xmlpatterns-4.5.9999 [4.5.1] USE="qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-gui-4.5.9999 [4.5.1] USE="accessibility cups dbus glib gtkstyle qt-copy%* qt3support tiff -debug -mng -nas -nis -pch -raster -xinerama (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-qt3support-4.5.9999 [4.5.1] USE="accessibility qt-copy%* -debug -pch -phonon (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-webkit-4.5.9999 [4.5.1] USE="qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-svg-4.5.9999 [4.5.1-r1] USE="iconv qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-opengl-4.5.9999 [4.5.1] USE="qt-copy%* qt3support -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]
[ebuild     U ] x11-libs/qt-assistant-4.5.9999 [4.5.1] USE="qt-copy%* -debug -pch (-custom-cxxflags%)" 0 kB [0=>1]

Total: 12 packages (12 upgrades), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/qting-edge

I went ahead, and did it, but I only saw the QA Notices AFTER qt had completed, and I had already installed @kdedeps-live, and had the failures on kdebase-live.
I thought I should try with USE="qt-copy" emerge @qt-all-live-kde, which didn't display the QA Notices, and completed. However, equery l qt showed the same resuts both times.
Code:
kdesvn wrc # equery l qt
[ Searching for package 'qt' in all categories among: ]
 * installed packages
[I--] [ ~] dev-libs/poppler-qt4-0.10.6 (0)
[I--] [  ] net-libs/telepathy-qt-9999 (0)
[I--] [  ] net-voip/tapioca-qt-9999 (0)
[I--] [  ] sys-auth/policykit-qt-9999 (0)
[I--] [ ~] virtual/poppler-qt4-0.10.6 (0)
[I--] [  ] x11-libs/qt-3.3.8b-r1 (3)
[I--] [ ~] x11-libs/qt-4.5.1 (4)
[I--] [  ] x11-libs/qt-assistant-4.5.9999 (4)
[I--] [  ] x11-libs/qt-core-4.5.9999 (4)
[I--] [  ] x11-libs/qt-dbus-4.5.9999 (4)
[I--] [  ] x11-libs/qt-gui-4.5.9999 (4)
[I--] [  ] x11-libs/qt-opengl-4.5.9999 (4)
[I--] [  ] x11-libs/qt-qt3support-4.5.9999 (4)
[I--] [  ] x11-libs/qt-script-4.5.9999 (4)
[I--] [  ] x11-libs/qt-sql-4.5.9999 (4)
[I--] [  ] x11-libs/qt-svg-4.5.9999 (4)
[I--] [  ] x11-libs/qt-test-4.5.9999 (4)
[I--] [  ] x11-libs/qt-webkit-4.5.9999 (4)
I'm still wondering why that x11-libs/qt-4.5.1 is still there. :?

BTW, even though the qting-edge README says to mask qt-4.5.1 if I need to use qt-copy, if I do that I can't get 9999 to show up, even though it is keyworded.

I guess I must be doing something wrong, and very stupid/obvious with the overlay setup. :roll:

EDIT: Sorry, I should have mentioned this before, but forgot. :oops:
This is on a system I just completely moved to gcc-4.4.1_pre9999, with graphite enabled. The final emerge -e world went fine (605 packages), except for one non-critical gnome-doc package failure. System is working normally.

The reason I forgot was because users on the gcc-4.4.x testing thread reported they had also successfully rebuilt their kde-svn installs with no problems with gcc-4.4.1_pre9999/graphite, so in my haste to update my kde-svn on this box I just didn't think my problems could be gcc-4.4.1 related.
Perhaps I'm wrong?

UPDATE: I got the same errors as before, so it appears it has nothing to do with 32 or 64 bit, or gcc-4.3.3 or gcc-4.4.1_pre9999.
Please see here for details https://forums.gentoo.org/viewtopic-p-5707988.html#5707988

Basically, kde-base/plasma-workspace-9999-r1 keeps failing, whatever qt version I try.

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental


Last edited by wrc1944 on Wed May 06, 2009 5:52 pm; edited 2 times in total
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 821
Location: Alaska

PostPosted: Wed May 06, 2009 1:56 am    Post subject: Reply with quote

I see 4.2.3 is in kde-testing, when I did an update to layman. If I try to emerge -avuD @world, I get kde-base/kde-env wanting kde-env-4.2.9999 rather than 4.2.3. I see there is no ebuild for kde-env-4.2.3. Should I be patient - assuming this is just not yet uploaded? No problem - but just thought I would ask in case I'm missing something. If I unmask kde-env-4.2.9999 then that wants to pull in both kdelibs-4.2.3 and -4.2.9999.
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed May 06, 2009 9:21 am    Post subject: Reply with quote

hunky wrote:
I see 4.2.3 is in kde-testing, when I did an update to layman. If I try to emerge -avuD @world, I get kde-base/kde-env wanting kde-env-4.2.9999 rather than 4.2.3. I see there is no ebuild for kde-env-4.2.3. Should I be patient - assuming this is just not yet uploaded? No problem - but just thought I would ask in case I'm missing something. If I unmask kde-env-4.2.9999 then that wants to pull in both kdelibs-4.2.3 and -4.2.9999.


kde-env-4.2.3 now in the overlay! :)
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Wed May 06, 2009 11:48 am    Post subject: Reply with quote

Hey,
Is that possible to compile plasma-workspace-4.2.71 without using a live version of qt ? I've qt-4.5.1 and i don't really want to update it to a live version. :?
Thank you
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed May 06, 2009 12:09 pm    Post subject: Reply with quote

Tom_ wrote:
Hey,
Is that possible to compile plasma-workspace-4.2.71 without using a live version of qt ? I've qt-4.5.1 and i don't really want to update it to a live version. :?
Thank you

Yes, I did!
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Wed May 06, 2009 3:06 pm    Post subject: Reply with quote

Did you do something in particular to get it compiled ?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 31, 32, 33 ... 38, 39, 40  Next
Page 32 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum