Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 35, 36, 37, 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Fri May 22, 2009 6:45 am    Post subject: Reply with quote

skunk wrote:
Krog wrote:
kde-base/pykde4-4.2.87


Code:
/var/tmp/portage/kde-base/pykde4-4.2.87/work/pykde4-4.2.87/python/pykde4/sip/soprano/languagetag.sip:27:33: error: soprano/languagetag.h: No such file or directory                                                                                                                                                   


:-(


emerge =dev-libs/soprano-9999


thanks :-)
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Fri May 22, 2009 8:02 am    Post subject: Reply with quote

Black Shadow wrote:
https://bugs.gentoo.org/show_bug.cgi?id=270723
https://bugs.gentoo.org/show_bug.cgi?id=270726
https://bugs.gentoo.org/show_bug.cgi?id=270729


Thanx!

I grab the first bugzilla-entry and test a little Time with the included diffs.
I separate the 3 diff blocks in 3 patchfiles and put they in the akonadi/files dir.
Code:

cyberdeck kde-testing # ls -lah kde-base/akonadi/files/
insgesamt 20K
drwxr-xr-x 2 root root 4,0K 22. Mai 09:06 .
drwxr-xr-x 3 root root 4,0K 22. Mai 09:52 ..
-rw-r--r-- 1 root root 1,4K 22. Mai 09:51 10_rm_old_LibKNotificationItem.patch
-rw-r--r-- 1 root root 1,4K 22. Mai 09:51 20_add_LibKNotificationItem.patch
-rw-r--r-- 1 root root  474 22. Mai 09:52 30_change_cmake_LibKNotificationItem.patch


Then i modify the ebuild and include the 3 patches.
Code:

KMEXTRACTONLY="
        korganizer/version.h
"

PATCHES=( "$FILESDIR/10_rm_old_LibKNotificationItem.patch" "$FILESDIR/20_add_LibKNotificationItem.patch" "$FILESDIR/30_change_cmake_LibKNotificationItem.patch" )

src_prepare() {


Finaly i update the Manifest
Code:

ebuild kde-base/akonadi/akonadi-4.2.87.ebuild manifest


I thing, this is the right way to include the given Patches.


but ..., by an running emerge i got this error:

Code:

cyberdeck kde-testing # MAKEOPTS="-j1" emerge akonadi
WARNING: One or more repositories have missing repo_name entries:
               
Calculating dependencies... done!                                 

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) kde-base/akonadi-4.2.87 from kde
 * kdepim-4.2.87.tar.lzma RMD160 SHA1 SHA256 size ;-) ...                                                                                                                    [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                       [ ok ]
>>> Unpacking source...                                                                                                                                                           
 * Unpacking parts of kdepim-4.2.87.tar.lzma to /var/tmp/portage/kde-base/akonadi-4.2.87/work ...                                                                             [ ok ]
>>> Source unpacked in /var/tmp/portage/kde-base/akonadi-4.2.87/work                                                                                                               
>>> Preparing source in /var/tmp/portage/kde-base/akonadi-4.2.87/work/akonadi-4.2.87 ...                                                                                           
 * Applying 10_rm_old_LibKNotificationItem.patch ...                                                                                                                          [ ok ]
 * Applying 20_add_LibKNotificationItem.patch ...                                                                                                                             [ ok ]
 * Applying 30_change_cmake_LibKNotificationItem.patch ...                                                                                                                    [ ok ]
>>> Source prepared.
[...]
-- Found NEPOMUK: /usr/lib/libnepomuk.so                                                                                                                                           
CMake Warning at CMakeLists.txt:107 (find_package):                                                                                                                                 
  Could not find module FindLibKNotificationItem-1_New.cmake or a                                                                                                                   
  configuration file for package LibKNotificationItem-1_New.                                                                                                                       

  Adjust CMAKE_MODULE_PATH to find FindLibKNotificationItem-1_New.cmake or
  set LibKNotificationItem-1_New_DIR to the directory containing a CMake 
  configuration file for LibKNotificationItem-1_New.  The file will have one
  of the following names:                                                   

    LibKNotificationItem-1_NewConfig.cmake
    libknotificationitem-1_new-config.cmake



-- Found libassuan-config at /usr/bin/libassuan-config
[...]
-----------------------------------------------------------------------------
-- The following REQUIRED packages could NOT be located on your system.
-- You must install these packages before continuing.
-----------------------------------------------------------------------------
   * LibKNotificationItem-1  <svn://anonsvn.kde.org/home/kde/trunk/KDE/kdelibs/experimental>
     An experimental library
     LibKNotificationItem-1 is an unfinished library which is required by korgac and akonaditray.

-----------------------------------------------------------------------------

CMake Error at /usr/share/apps/cmake/modules/MacroLogFeature.cmake:141 (MESSAGE):
  Exiting: Missing Requirements
Call Stack (most recent call first):
  CMakeLists.txt:227 (macro_display_feature_log)


But, i have installed the libknotificationitem
Code:

cyberdeck kde-testing # qlist -Iv libknotificationitem
kde-base/libknotificationitem-4.2.87


The Patch is working
Code:

find /var/tmp/portage/ -name *LibKNotificationItem-1*
/var/tmp/portage/kde-base/akonadi-4.2.87/work/akonadi-4.2.87/akonadi-4.2.87/cmake/modules/FindLibKNotificationItem-1_New.cmake


I will put my diff into bugzilla, but she should to be functional ...

I'm Confused ...
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri May 22, 2009 3:15 pm    Post subject: Reply with quote

I do not understand too that the patch file - is the same as the +
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7113
Location: Austria

PostPosted: Fri May 22, 2009 3:22 pm    Post subject: Reply with quote

Good news! I saw there was a libknotificationitem ebuild update after a recent update, so:
Code:
layman -s kde-testing
emerge -1v libknotificationitem

made kget:4.3 and korganizer:4.3 build again! :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri May 22, 2009 3:45 pm    Post subject: Reply with quote

YEEEEESSSSSSS all work now
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Fri May 22, 2009 5:07 pm    Post subject: Reply with quote

titoucha wrote:
I do not understand too that the patch file - is the same as the +


exactly
Back to top
View user's profile Send private message
Black Shadow
n00b
n00b


Joined: 03 May 2009
Posts: 2

PostPosted: Fri May 22, 2009 6:36 pm    Post subject: Reply with quote

TheDodger wrote:
titoucha wrote:
I do not understand too that the patch file - is the same as the +


exactly


It is necessary, that the file from /usr/share/apps/cmake/modules was not used. I took this patch from upstream.
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Fri May 22, 2009 7:34 pm    Post subject: Reply with quote

I had just finished uptade to 4.3beta and had lost all the icons :(

any idea? Reemerging oxigen-icons don't resolve the problem and I don't want to remove .lde4 as I have a LOTs of emails there :S

EDIT: seems that recompiling twice oxygen-icons resolv my problem
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Fri May 22, 2009 11:25 pm    Post subject: Reply with quote

pykde4-4.2.87 file collisions - a bunch. Is there a way around that? I don't fully understand what has been going on with kdeprefix (which I'm using) so maybe something there - but I have kde-4.2.3 installed and hope to keep it working while I explore kde:4.3. Plus I don't know enough about FEATURES="-collision-protect" to try that. Recommendations? thx, Jim

[edit] as I look around for an answer, I'm wondering if I need kdeprefix in USE? I'm not really playing around with incremental versions within either 4.2 or 4.3 so maybe I could go -kdeprefix? Just not sure..

[edit-again] nope - looks like 4.2.3 blocks the 4.3 beta (4.2.87) if I go -kdeprefix since it is still an incremental of 4.2

[edit-3rd-time] bug: https://bugs.gentoo.org/show_bug.cgi?id=258027

[maybe final edit?] So I've put in -python for plasma-workspace and for marble, but pykde4-4.2.87 still wants to be pulled in. If I go emerge -avuDNt @world I get this:
Code:
<snip>
[nomerge      ] kde-base/printer-applet-4.2.87  USE="kdeprefix"  [1]
[ebuild  NS   ]  kde-base/pykde4-4.2.87 [4.2.3] USE="kdeprefix -akonadi -debug -examples -semantic-desktop" 0 kB [1]
[ebuild  N    ]  app-misc/hal-cups-utils-0.6.19  0 kB [1]
(printer-applet is further up the emerge list. Neither it nor hal-cups-utils have python flags.)

So I'm stuck.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat May 23, 2009 12:47 am    Post subject: Reply with quote

hunky,
As I understand it, in order to have multiple versions of kde installed you do need kdeprefix. I have put it in my /etc/make.conf USE flags, and have had no problems (for months).

As for the file collisions, I think I mentioned this before on one of the kde4 threads. I've been using this method, as I didn't want to do it globally in /etc/make.conf (didn't seem like a good idea to completely disable this- I'd rather deal with each one as they occur, which is almost never).

On the command line, manually use:
Code:
COLLISION_IGNORE="file1 file2 file3 etc. etc." emerge package

where the files are the ones listed in the emerge output, and "package" is the package that failed. I found you must copy/paste the ENTIRE path for each file mentioned for it to work. This method has always worked for me for any "file collisions" I have wished to get around.

Hope this helps. :)
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Sat May 23, 2009 1:00 am    Post subject: Reply with quote

thanks for that wrc1944. There was a very long list of collisions, or at least a long list of files that may have been collisions as I couldn't see the beginning of the list due to the scrollback buffer in my shell - using screen from a different location. However, if I get the itch, I'll give that a try. Maybe when I get to the machine I'll be able to see exactly how big that list is.

For now I'm moving along with re-masking pykde4 and printer-applet. That lets me progress (I sound like our governor). Plus my printer won't work with gentoo anyway if that printer-applet is about printing. (Getting the printer working is another story). So I'm off to the races for now.

cheers, jim
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Sat May 23, 2009 10:37 am    Post subject: Reply with quote

genstorm wrote:
Good news! I saw there was a libknotificationitem ebuild update after a recent update, so:
Code:
layman -s kde-testing
emerge -1v libknotificationitem

made kget:4.3 and korganizer:4.3 build again! :)


Yeah it works perfectly! :)

But now i have problems with the sound, i cant hear it ...
This is an other problem, not for kde ... for me . :}

edit
F*** ... my failure ... my kmix has a new(?) viewable controll for sound ...


Last edited by TheDodger on Sat May 23, 2009 12:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
brumgabrasch
n00b
n00b


Joined: 01 Jan 2008
Posts: 7

PostPosted: Sat May 23, 2009 11:46 am    Post subject: Reply with quote

I had a problem with libknotificationitem because my installed kdelibs were too old to install it. libknotificationitem is a dependency of kdelibs so emerge wanted to install libknotificationitem before updating kdelibs. After i had removed the dependency from the kdelibs-9999 ebuild i could update kdedeps-live set sucessfully.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat May 23, 2009 12:10 pm    Post subject: Reply with quote

if you know the consequences just emerge it with --nodeps and you should be fine to continue ;)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
m1k0
Apprentice
Apprentice


Joined: 27 Dec 2006
Posts: 180
Location: Radom/Poland

PostPosted: Sat May 23, 2009 4:44 pm    Post subject: kde-base/pykde4-4.2.87 failed. Reply with quote

I have problem with pykde4-4.2.87
Code:
[ 69%] Building CXX object python/pykde4/CMakeFiles/python_module_PyKDE4_nepomuk.dir/sip/nepomuk/sipnepomukpart6.o                                                                                               
In file included from /usr/include/python2.5/Python.h:13,                                                                                                                                                       
                 from /usr/include/python2.5/sip.h:28,                                                                                                                                                           
                 from /var/tmp/portage/kde-base/pykde4-4.2.87/work/pykde4-4.2.87_build/python/pykde4/sip/nepomuk/sipAPInepomuk.h:11,                                                                             
                 from /var/tmp/portage/kde-base/pykde4-4.2.87/work/pykde4-4.2.87_build/python/pykde4/sip/nepomuk/sipnepomukpart6.cpp:7:                                                                         
/usr/include/python2.5/pyconfig.h:976:1: warning: "_XOPEN_SOURCE" redefined                                                                                                                                     
<command-line>: warning: this is the location of the previous definition                                                                                                                                         
In file included from /var/tmp/portage/kde-base/pykde4-4.2.87/work/pykde4-4.2.87_build/python/pykde4/sip/nepomuk/sipnepomukpart6.cpp:7:                                                                         
sipAPInepomuk.h:1897:1: warning: "sipType_QList_27000600QPair_0100QString_0100QString" redefined                                                                                                                 
sipAPInepomuk.h:1631:1: warning: this is the location of the previous definition                                                                                                                                 
sipAPInepomuk.h:1903:1: warning: "sipType_QList_27000600QPair_0100QByteArray_0100QByteArray" redefined                                                                                                           
sipAPInepomuk.h:1629:1: warning: this is the location of the previous definition                                                                                                                                 
/var/tmp/portage/kde-base/pykde4-4.2.87/work/pykde4-4.2.87/python/pykde4/sip/soprano/languagetag.sip:27:33: error: soprano/languagetag.h: Nie ma takiego pliku ani katalogu                                     
make[2]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_nepomuk.dir/sip/nepomuk/sipnepomukpart6.o] Błąd 1                                                                                                   
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_nepomuk.dir/all] Błąd 2                                                                                                                             
make: *** [all] Błąd 2                                                                                                                                                                                           
 *                                                                                                                                                                                                               
 * ERROR: kde-base/pykde4-4.2.87 failed.                                                                                                                                                                         
 * Call stack:                                                                                                                                                                                                   
 *               ebuild.sh, line   49:  Called src_compile                                                                                                                                                       
 *             environment, line 3986:  Called kde4-meta_src_compile                                                                                                                                             
 *             environment, line 2948:  Called kde4-base_src_compile                                                                                                                                             
 *             environment, line 2665:  Called cmake-utils_src_compile                                                                                                                                           
 *             environment, line 1036:  Called cmake-utils_src_make                                                                                                                                             
 *             environment, line 1115:  Called die                                                                                                                                                               
 * The specific snippet of code:                                                                                                                                                                                 
 *           emake "$@" || die "Make failed!";                                                                                                                                                                   
 *  The die message:                                                                                                                                                                                             
 *   Make failed!                                                                                                                                                                                               
 *                                                                                                                                                                                                               
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                                                                           
 * A complete build log is located at '/var/tmp/portage/kde-base/pykde4-4.2.87/temp/build.log'.                                                                                                                 
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/pykde4-4.2.87/temp/environment'.                                                                                                         
 * This ebuild used the following eclasses from overlays:                                                                                                                                                       
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-meta.eclass                                                                                                                                               
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass                                                                                                                                               
 *   /usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass                                                                                                                                         
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                                                                                                                         
 *                                                                                                                                                                                                               

_________________
MSI GX-70
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Sun May 24, 2009 5:40 am    Post subject: Reply with quote

i have this error for every package from installed from kdepim-4.2.87.lzma
Code:
sed: no input files                                                                                                                               
 *                                                                                                                                                             
 * ERROR: kde-base/kmailcvt-4.2.87 failed.                                                                                                                     
 * Call stack:                                                                                                                                                 
 *               ebuild.sh, line   49:  Called src_prepare                                                                                                     
 *             environment, line 3735:  Called kde4-meta_src_prepare                                                                                           
 *             environment, line 2957:  Called kde4-meta_change_cmakelists                                                                                     
 *             environment, line 2687:  Called die                                                                                                             
 * The specific snippet of code:                                                                                                                               
 *           find "${S}"/${i} -name CMakeLists.txt -print0 | xargs -0 sed -i -e 's/^#DONOTCOMPILE //g' -e '/install(.*)/{s/^/#DONOTINSTALL /;}' -e '/^install(/,/)/{s/^/#DONOTINSTALL /;}' -e '/kde4_install_icons(.*)/{s/^/#DONOTINSTALL /;}' || die "${LINENO}: sed died in the KMCOMPILEONLY section while processing ${i}";                                                                                                                                                             
 *  The die message:                                                                                                                                           
 *   2687: sed died in the KMCOMPILEONLY section while processing cmake/modules/                                                                               
 *                                                                                                                                                             
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                         
 * A complete build log is located at '/var/tmp/portage/kde-base/kmailcvt-4.2.87/temp/build.log'.                                                             
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kmailcvt-4.2.87/temp/environment'.                                                     
 * This ebuild is from an overlay named 'kde': '/usr/local/portage/layman/kde-testing/'                                                                       
 *

Atm full list of failures is:
Code:
 * The following 27 packages have failed to build or install:                                                                                                 
 *                                                                                                                                                             
 *      ('ebuild', '/', 'kde-base/libkdepim-4.2.87', 'merge')                                                                                                 
 *      ('ebuild', '/', 'kde-base/kaddressbook-4.2.87', 'merge')                                                                                               
 *      ('ebuild', '/', 'kde-base/knotes-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/kontact-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/kleopatra-4.2.87', 'merge')                                                                                                 
 *      ('ebuild', '/', 'kde-base/konsolekalendar-4.2.87', 'merge')                                                                                           
 *      ('ebuild', '/', 'kde-base/akonadi-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/ktimetracker-4.2.87', 'merge')                                                                                               
 *      ('ebuild', '/', 'kde-base/kdepim-kresources-4.2.87', 'merge')                                                                                         
 *      ('ebuild', '/', 'kde-base/kdepim-wizards-4.2.87', 'merge')                                                                                             
 *      ('ebuild', '/', 'kde-base/kjots-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/akregator-4.2.87', 'merge')                                                                                                 
 *      ('ebuild', '/', 'kde-base/knode-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/kontact-specialdates-4.2.87', 'merge')                                                                                       
 *      ('ebuild', '/', 'kde-base/kmail-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/kpilot-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/kalarm-4.2.87', 'merge')                                                                                                     
 *      ('ebuild', '/', 'kde-base/korganizer-4.2.87', 'merge')                                                                                                 
 *      ('ebuild', '/', 'kde-base/kontactinterfaces-4.2.87', 'merge')                                                                                         
 *      ('ebuild', '/', 'kde-base/libkleo-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/libkpgp-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/libksieve-4.2.87', 'merge')                                                                                                 
 *      ('ebuild', '/', 'kde-base/kmailcvt-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/mimelib-4.2.87', 'merge')                                                                                                   
 *      ('ebuild', '/', 'kde-base/kdepim-strigi-analyzer-4.2.87', 'merge')                                                                                     
 *      ('ebuild', '/', 'kde-base/kdepim-icons-4.2.87', 'merge')                                                                                               
 *      ('ebuild', '/', 'kde-base/kabcclient-4.2.87', 'merge')


i've tried to compile them with overlay eclasses and without them, also recompiled sed in case it was broken by update - no luck.
Back to top
View user's profile Send private message
m1k0
Apprentice
Apprentice


Joined: 27 Dec 2006
Posts: 180
Location: Radom/Poland

PostPosted: Sun May 24, 2009 8:51 am    Post subject: Re: kde-base/pykde4-4.2.87 failed. Reply with quote

m1k0 wrote:
I have problem with pykde4-4.2.87

instaling soprano-9999 resolving this problem
_________________
MSI GX-70
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Mon May 25, 2009 7:36 pm    Post subject: Reply with quote

I get this error compiling dev-python/PyQt4-4.5_pre20090518-r1:


Code:

Error: This version of PyQt and the Desktop edition of Qt have incompatible                                                                                 
licenses.         


Any idea?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Mon May 25, 2009 9:49 pm    Post subject: Reply with quote

That's curious. Does the 20090520 snapshot do the same?
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Tue May 26, 2009 4:40 am    Post subject: Reply with quote

yngwin wrote:
That's curious. Does the 20090520 snapshot do the same?


I don't have this snapshot. I'm compiling this from qting-edge
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Tue May 26, 2009 5:05 am    Post subject: Reply with quote

I'm getting:
Code:
emerge: there are no ebuilds to satisfy ">=dev-python/PyQt4-4.5_pre[webkit]".
(dependency required by "kde-base/pykde4-4.2.87" [ebuild])                   
(dependency required by "kde-base/printer-applet-4.2.87" [ebuild])           
(dependency required by "@world" [argument])
when doing an emerge -avuD @world. That dependency is in the pykde4-4.2.87 ebuild. I had a PyQt4.5_pre20090518 installed but layman -s kde-testing deleted that ebuild. Before I knew I would have this problem I was getting blocks so unmerged it and downgraded.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue May 26, 2009 11:57 am    Post subject: Reply with quote

Hello,

I am trying kdebluetooth4, but it does not work:
Code:
$/usr/kde/4.2/bin/kbluetooth4
kbluetooth4(9987) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded:  "BlueZ"
kbluetooth4(9987) Solid::Control::BluetoothManager::buildDeviceList: UBI List  ()
kbluetooth4(9987) KBlueTray::offlineMode: offline Mode


There is no tray icon or something like that.

Code:
$/usr/kde/4.2/bin/kbluetooth4-inputwizard
kbluetooth4-wizard(10030) Solid::Control::ManagerBasePrivate::loadBackend: Backend loaded:  "BlueZ"
kbluetooth4-wizard(10030) BluezBluetoothManager::defaultInterface: Calling Backend Default Interface
QDBusObjectPath: invalid path ""
kbluetooth4-wizard(10030) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: findRegisteredBluetoothInterface  ""
kbluetooth4-wizard(10030) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: Creating New Interface  ""
kbluetooth4-wizard(10030) Solid::Control::BluetoothManagerPrivate::findRegisteredBluetoothInterface: Calling Backend to Creating New Interface  ""
process 10030: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file dbus-message.c line 1070.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
KCrash: Application 'kbluetooth4-inputwizard' crashing...
sock_file=/home/tobi/.kde4.2/socket-tobi-desktop/kdeinit4__0
kbluetooth4-wizard(10029): Communication problem with  "kbluetooth4-wizard" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "


So what is the right way to access a mobile phone via bluetooth and KDE?

Thanks
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 826
Location: Alaska

PostPosted: Tue May 26, 2009 11:02 pm    Post subject: Reply with quote

wrc1944 wrote:
hunky,
As for the file collisions, I think I mentioned this before on one of the kde4 threads. I've been using this method, as I didn't want to do it globally in /etc/make.conf (didn't seem like a good idea to completely disable this- I'd rather deal with each one as they occur, which is almost never).

On the command line, manually use:
Code:
COLLISION_IGNORE="file1 file2 file3 etc. etc." emerge package

where the files are the ones listed in the emerge output, and "package" is the package that failed. I found you must copy/paste the ENTIRE path for each file mentioned for it to work. This method has always worked for me for any "file collisions" I have wished to get around.

Hope this helps. :)

I solved my "where is PyQt4-4.5_pre by locating it in the qting-edge overlay.

But wrc1944 - if you're reading this, looks like I have a couple hundred or so collisions maybe for the installed pykde4 when trying to emerge pykde4-4.2.87. I just don't know if I can uninstall previous version and keep kde-4.2.3 running? Here's a brief example of the collisions (all within the /usr/lib/python2.6/site-packages/PyKDE4 and
/usr/share/sip/PyKDE4/ directories):
Code:
 <snip>
     /usr/lib/python2.6/site-packages/PyKDE4/ktexteditor.so
        /usr/lib/python2.6/site-packages/PyKDE4/kparts.so
        /usr/lib/python2.6/site-packages/PyKDE4/phonon.so
        /usr/lib/python2.6/site-packages/PyKDE4/__init__.py
        /usr/lib/python2.6/site-packages/PyKDE4/knewstuff.so
        /usr/share/sip/PyKDE4/glossary.html
        /usr/share/sip/PyKDE4/kio/netaccess.sip
        /usr/share/sip/PyKDE4/kio/kar.sip
        /usr/share/sip/PyKDE4/kio/kurlcompletion.sip
        /usr/share/sip/PyKDE4/kio/jobclasses.sip
        /usr/share/sip/PyKDE4/kio/job.sip
        /usr/share/sip/PyKDE4/kio/kbookmarkmanager.sip
        /usr/share/sip/PyKDE4/kio/kimageio.sip
        /usr/share/sip/PyKDE4/kio/kshellcompletion.sip
        /usr/share/sip/PyKDE4/kio/kabstractfilemodule.sip
        /usr/share/sip/PyKDE4/kio/kbookmarkdialog.sip
        /usr/share/sip/PyKDE4/kio/thumbcreator.sip
        /usr/share/sip/PyKDE4/kio/krecentdocument.sip
        /usr/share/sip/PyKDE4/kio/kacl.sip
<snip>
Back to top
View user's profile Send private message
Cereza
Guru
Guru


Joined: 14 Apr 2006
Posts: 428

PostPosted: Tue May 26, 2009 11:17 pm    Post subject: Reply with quote

Excuse me but... what is the difference between:

KDE-4.2 live (4.2.9999) in the kde-testing overlay.
KDE live (9999) in the kde-testing overlay.

ebuild versions? :?:

Thank you.
_________________
Mi web de cómics
"Xorg: antes muerto que sensillo, ai que sensillo..."
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Tue May 26, 2009 11:53 pm    Post subject: Reply with quote

hunky wrote:
Quote:
But wrc1944 - if you're reading this, looks like I have a couple hundred or so collisions maybe for the installed pykde4 when trying to emerge pykde4-4.2.87. I just don't know if I can uninstall previous version and keep kde-4.2.3 running? Here's a brief example of the collisions (all within the /usr/lib/python2.6/site-packages/PyKDE4 and
/usr/share/sip/PyKDE4/ directories):
I never have had more than 5-6 file collisions at one time (usually just 1-3 when it does rarely happen), so my manually method would be impractical with 200! :lol:

200 collisions seems pretty weird to me- must be something very basic wrong there. Just a thought, but have you updated python, and not run python-updater? If not, give maybe give that a try.

I haven´t had much time to play with kde-svn for the last few weeks, so have not really kept up on recent stuff that much.
I would think mixing the qting-edge overlay with kde-4.2.3 might present some strange conflicting problems. Are you by chance attempting to use portage qt and then other stuff from the qt overlay?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 35, 36, 37, 38, 39, 40  Next
Page 36 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum