Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers 180.22 STABLE release
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
langec
n00b
n00b


Joined: 10 Dec 2004
Posts: 21
Location: Bremen, Germany

PostPosted: Mon Jan 19, 2009 10:47 pm    Post subject: Reply with quote

Same for me: STR no longer working (on a ThinkPad T61):
Code:
Linux thinkpad 2.6.26-tuxonice-r4 #1 SMP Sat Jan 17 19:47:10 CET 2009 x86_64 Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz GenuineIntel GNU/Linux

Code:
01:00.0 VGA compatible controller: nVidia Corporation Device 0429 (rev a1)

Downgraded to 177.82 again. BTW, KDE 4.1.4 seems to have improved over 4.1.3.[/topic]
Back to top
View user's profile Send private message
michel7
Guru
Guru


Joined: 04 May 2006
Posts: 461
Location: localhost

PostPosted: Sun Jan 25, 2009 12:22 pm    Post subject: Reply with quote

comfirmed. suspend2ram is broken since 180.22 ... with old 177.82 it worked fine ... so we have to wait for the fixed release of nvidia-drivers
_________________
Software is like sex. It's better when it's free
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Jan 26, 2009 7:15 pm    Post subject: Reply with quote

jel wrote:
2) Firefox 3.0.5 crashes on launch. Work around: eselect opengl set xorg-x11, launch firefox, eselect opengl set nvidia.


I have no problems with 180.XX and firefox-3.0.5 64 bit built from source.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Fri Jan 30, 2009 10:51 pm    Post subject: nvidia-drivers-180.27 also fails for me Reply with quote

I have an up to date amd64~ system. The nvidia-drivers 180.22 and 180.27 fail to get gdm started. The failure gives no meaningful error messages. The 177.82 driver works just fine.
Is anyone else having trouble with these? Thanks,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Fri Jan 30, 2009 11:17 pm    Post subject: Reply with quote

I am using kdm-4.2. But I can easily try gdm-2.24

[EDIT]gnome-base/gdm-2.24.1 worked fine after a reboot. With nvidia-drivers-180.27

Code:
jmd0 ~ # equery list gdm
[ Searching for package 'gdm' in all categories among: ]
 * installed packages
[I--] [ ~] gnome-base/gdm-2.24.1 (0)
jmd0 ~ # equery list nvidia-drivers
[ Searching for package 'nvidia-drivers' in all categories among: ]
 * installed packages
[I--] [ ~] x11-drivers/nvidia-drivers-180.27 (0)


[/EDIT]
_________________
John

My gentoo overlay
Instructons for overlay


Last edited by drescherjm on Fri Jan 30, 2009 11:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Fri Jan 30, 2009 11:20 pm    Post subject: Reply with quote

For what it's worth I'm running gdm-2.20.9. Thanks,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sat Jan 31, 2009 3:41 am    Post subject: Reply with quote

Sorry gdm-2.24.1 is from the gnome overlay in layman. I thought this had hit portage with the rest of the 2.24 packages which seem to be getting into portage recently. I have been running 2.24 since late November and it has been quite stable for me.

Code:
Calculating dependencies... done!
[ebuild   R   ] gnome-base/gdm-2.24.1  USE="gnome-keyring tcpd -accessibility -afs -debug -ipv6 -policykit (-selinux) -xinerama" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /auto/portage
 [1] /auto/portage/local/layman/gnome

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sat Jan 31, 2009 5:20 am    Post subject: Reply with quote

Thanks. I'll just wait and give this a try when gdm 2.24 arrives.
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Fri Feb 27, 2009 11:34 pm    Post subject: Reply with quote

Hi drescherjm -- I've gotten tired of waiting for gdm 2.24, and decided to try what you recommend. Unfortunately I don't understand things well enough to know how to proceed.
I have installed layman and git, and added
Quote:
http://home.comcast.net/~drescherjm/jmdgentoo.xml
in the overlays of layman.cfg. I could use an expansion of the rest of the instructions. I'm not clear on how to "add the jmd-gentoo overlay". Also if I only want to add gdm to I need to specify that? Thanks,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 01, 2009 2:58 pm    Post subject: Reply with quote

After you add the link to my comcast site

Code:
layman -S
layman -a jmd-gentoo


Then
Code:
layman -l


Will list the overlays. Since I added gdm-2.24.1 this months ago it is now working in the gnome overlay.

Code:
 # emerge -av gdm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] gnome-base/gdm-2.24.1  USE="gnome-keyring tcpd -accessibility -afs -debug -ipv6 -policykit (-selinux) -xinerama" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /auto/portage
 [1] /auto/portage/local/layman/gnome



So to add the gnome overlay.

Code:
layman -a gnome

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 3:30 pm    Post subject: Reply with quote

Many thanks. I think I'm close, but I'm not quite there. Here is what I have so far from following your suggestions.
Quote:
mon layman # layman -S
mon layman # layman -a jmd-gentoo
* Running command "/usr/bin/git clone "git://github.com/drescherjm/jmdgentoooverlay.git" "/usr/local/portage/layman/jmd-gentoo""...
Initialized empty Git repository in /usr/local/portage/layman/jmd-gentoo/.git/
remote: Counting objects: 4006, done.
remote: Compressing objects: 100% (2265/2265), done.
remote: Total 4006 (delta 1859), reused 3532 (delta 1563)
Receiving objects: 100% (4006/4006), 6.63 MiB | 89 KiB/s, done.
Resolving deltas: 100% (1859/1859), done.
* Successfully added overlay "jmd-gentoo".
mon layman # layman -l
* jmd-gentoo [Git ] (git://github.com/drescherjm/jmdgen...)
mon layman # emerge -av gdm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] gnome-base/gdm-2.20.9-r1 USE="gnome-keyring ipv6 pam tcpd -accessibility -afs -branding -debug -dmx -remote (-selinux) -xinerama" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 01, 2009 3:39 pm    Post subject: Reply with quote

Sorry if I was not clear.

gdm-2.24.1 is now in the gnome overlay

so add that with this:

Quote:
layman -a gnome


And since most of this is masked there is a file in my overlay to unmask the packages.

It should be
/usr/portage/local/jmd-gentoo/Other/package.keywords/gnome-2.24

If you have /etc/portage/package.keywords as a file you want to

Code:
cat /usr/portage/local/jmd-gentoo/Other/package.keywords/gnome-2.24 >> /etc/portage/package.keywords


If /etc/portage/package.keywords is a folder

Code:
ln -s /usr/portage/local/jmd-gentoo/Other/package.keywords/gnome-2.24 /etc/portage/package.keywords/gnome-2.24

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 4:00 pm    Post subject: Reply with quote

It seems to me that you are about as clear as you can be. It seems that your stuff is ending up in different directories that you expected. Thus
Quote:
ll /usr/local/portage/layman/jmd-gentoo/gnome-base/gnome
total 12
-rw-r--r-- 1 root root 198 Mar 1 07:22 Manifest
-rw-r--r-- 1 root root 5426 Mar 1 07:22 gnome-2.24.1.ebuild

My package.keywords is a file. But I'm still not clear as to what goes into package.keywords. Using "/usr/local/portage/layman/jmd-gentoo/gnome-base/gnome/gnome-2.24" in package.keywrods complains about invalid atom.
Many thanks,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 01, 2009 4:06 pm    Post subject: Reply with quote

I wanted you to cat the contents of this file to the package.keywords file.

first edit package.keywords to remove the /usr/local/portage/layman/jmd-gentoo/gnome-base/gnome/gnome-2.24 line


then

Code:
cat /usr/local/portage/layman/jmd-gentoo/gnome-base/gnome/gnome-2.24 >> /etc/portage/package.keywords

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 4:17 pm    Post subject: Reply with quote

Your patience is much appreciated. May it last a little longer! As inidicated in my directory listing there is no file on my system named "/usr/local/portage/layman/jmd-gentoo/gnome-base/gnome/gnome-2.24". At this point I don't know if there is a file missing or if I need to use a different name. But all that I try fails to work. Thanks again,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 01, 2009 4:27 pm    Post subject: Reply with quote

That is my fault. Sorry.

/usr/portage/local/layman/jmd-gentoo/Other/portage/package.keywords/gnome-2.24

is the file. cat that to your package.keywords file.

One of my difficulties here was my portage and my layman are both not in their default locations.

Also we are getting really off topic for the original post here. Maybe we should open a new discussion on this.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 4:37 pm    Post subject: Reply with quote

And the saga continues. First on my system the gnome-2.24 that you reference is in "/usr/local/portage/layman/jmd-gentoo/Other/portage/package.keywords", and I can cat the contents of that file to /usr/portage/package.keywords. I'm guessing that of the files listed I only needed "=gnome-base/gdm-2.24*", but I left them all there. Unfortunately, emerge is still trying to emerge gdm-2.20.9-r1. Is there some path that needs to be added? Something else? Thanks,
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sun Mar 01, 2009 6:12 pm    Post subject: Reply with quote

type

Code:
emerge =gnome-base/gdm-2.24.1


And see what the problem is. I believe it may be masked. So to fix that

echo "=gnome-base/gdm-2.24*" >> /etc/portage/package.unmask
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 6:20 pm    Post subject: Reply with quote

I already had gnome-base/gdm in package.unmask, changing that to =gnome-base/gdm-2.24.1 made no difference. The emerge =gnome-base/gdm-2.24.1 gives
Quote:
emerge: there are no ebuilds to satisfy "=gnome-base/gdm-2.24.1".
. For some reason, the emerge is not seeing the files in /usr/local/portage/layman/jmd-gentoo/gnome-base/gnome. Many thanks,
Fred
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Mar 01, 2009 6:28 pm    Post subject: Reply with quote

drescherjm something's wrong with your overlay

I've just browsed through it and only found an ebuild for gnome-2.24*

no others in the gnome-base section
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 6:39 pm    Post subject: Reply with quote

Perhaps I can add even more to the confusion.
Quote:
ll /usr/local/portage/layman/gnome/gnome-base/gdm
total 24
-rw-r--r-- 1 root root 1637 Mar 1 07:41 Manifest
drwxr-xr-x 2 root root 4096 Mar 1 07:41 files/
-rw-r--r-- 1 root root 4654 Mar 1 07:41 gdm-2.24.1.ebuild
-rw-r--r-- 1 root root 4607 Mar 1 07:41 gdm-2.25.2.ebuild

which is different than I reported earler. I have no idea why. Also inside the ebuilds I find
Quote:
# $Header: /var/cvsroot/gentoo-x86/gnome-base/gdm/gdm-2.20.7.ebuild,v 1.5 2008/0
8/12 13:54:55 armin76 Exp $
Even though this is just a comment it seems to show a lack of care at some point along the line. Thanks for all the help,
Fred
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Sun Mar 01, 2009 7:49 pm    Post subject: Reply with quote

I kept thinking there was a path problem. After doing "ln -s /usr/local/portage/ /etc/portage/local" and then "emerge =gnome-base/gdm-2.24-1", I get
Quote:
Calculating dependencies \

!!! '=gnome-base/gdm-2.24-1' is not a valid package atom.
!!! Please check ebuild(5) for full details.
!!! (Did you specify a version but forget to prefix with '='?)
... done!

This lends some credence to what kernelOfTruth said. Assuming he is correct, where might I find an ebuild that works? I of course have no idea why things got stuck in an inappropriate directory in the first place. Thanks for all the help.
Fred
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 533

PostPosted: Sun Mar 01, 2009 10:44 pm    Post subject: Reply with quote

I have been using the unstable/untested nvidia drivers for quite a while now, and I just encountered my first problem with version 180.35 . Every version up until now has worked fine for me, but that version caused a couple weird problems.

First, the xscreensaver demo kept freezing. Whenever I tried to view a different screen saver, the application would freeze.

Second, pressing control+c in X terminal windows did nothing. Gnome-terminal and sakura both refused to quit doing whatever they were doing, no matter how many times I pressed this key combination. Please don't ask me how this could possibly be related to the new nvidia drivers, but the only thing that fixed it was switching to an older version.

Is anyone else having problems with version 180.35 ? By the way, I'm using gentoo-sources 2.6.28 because my main linux partitions are all ext4.. perhaps that's related.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Sun Mar 01, 2009 10:48 pm    Post subject: Reply with quote

Yes, stay away from 180.35, it breaks just about everything, for everyone.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Mar 02, 2009 12:22 am    Post subject: Reply with quote

kernelOfTruth wrote:
drescherjm something's wrong with your overlay

I've just browsed through it and only found an ebuild for gnome-2.24*

no others in the gnome-base section


I am very sorry about all the confusion. Currently there are no gnome ebuilds in my overlay because these are either in portage or the gnome overlay. In the past I did have a gdm ebuild but I removed than when the gnome overlay version worked. For gnome, the only thing in my overlay that is useful is the keywords file that is in

Other/portage/package.keywords/gnome-2.24

Again I am sorry for the confusion that this has caused.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum