Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia-drivers 180.22 STABLE release
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Mar 02, 2009 12:24 am    Post subject: Reply with quote

genstorm wrote:
Yes, stay away from 180.35, it breaks just about everything, for everyone.


For me the vdapu mplayer works and mythtv also works but gnome-terminal does not allow me to press ctrl-c. konsole-4.2 does however.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Mon Mar 02, 2009 12:25 am    Post subject: Reply with quote

genstorm wrote:
Yes, stay away from 180.35, it breaks just about everything, for everyone.


It works fine for me... i have quadro fx 570M.
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Mon Mar 02, 2009 4:53 am    Post subject: Reply with quote

No nvidia-driver after 177.82 will get started with gdm-2.20.9-r1 on my amd64 system. I still have an interest in trying to use gdm-2.24, if there are any out there with the patience to see me through the process. Something along the lines of "get the build here", "put it there", "anything else needed", and emerge gdm. thanks for all the help.
Fred
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Mon Mar 02, 2009 1:20 pm    Post subject: Reply with quote

Strange: I added the line

=x11-drivers/nvidia-drivers-180.35

to my /etc/portage/package_mask/monolithic file. Portage, however, still wants to install this driver. Why does that happen?
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Mar 02, 2009 2:38 pm    Post subject: Reply with quote

Do you have nvidia-drivers in the unmask file?
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon Mar 02, 2009 5:38 pm    Post subject: Reply with quote

dodo1122 wrote:
It works fine for me... i have quadro fx 570M.

Which X server?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7112
Location: Austria

PostPosted: Mon Mar 02, 2009 5:39 pm    Post subject: Reply with quote

Benni123 wrote:
to my /etc/portage/package_mask/monolithic file.

You do mean package.unmask instead, don't you?

Edit: Argh, that was an accident. Sorry for double post.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Mar 02, 2009 6:42 pm    Post subject: Reply with quote

that driver (180.35) is REALLY bad

I'm getting lots of well-known corruption from earlier versions in openoffice - AGAIN,

it feels somewhat slower, etc.

on geforce 8400M GS
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Mon Mar 02, 2009 6:54 pm    Post subject: Reply with quote

Quote:

Do you have nvidia-drivers in the unmask file?
Thanks. That was it!

Quote:
that driver (180.35) is REALLY bad
Yes. Ebuilds providing it should be masked in overlays and tree
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Mar 03, 2009 12:00 am    Post subject: Reply with quote

genstorm wrote:
dodo1122 wrote:
It works fine for me... i have quadro fx 570M.

Which X server?


nevermind, there are problems with it, which i at first thought of as kde4 bugs, since i use kde from svn :P I cannot shutdown/reboot from kmenu, and applications are disappearing from taskbar randomly. The rest seems fine but i downgraded anyway though.
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Tue Mar 03, 2009 4:55 am    Post subject: Reply with quote

http://www.nvnews.net/vbulletin/showthread.php?t=128959
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sat Mar 07, 2009 3:39 am    Post subject: Reply with quote

180.37 is out and fixes the 180.35 ^C bug. I just committed the ebuild to my overlay after some brief testing in x86_64.

Quote:
Fixed a problem that caused signals to be blocked in some applications.
* Fixed a problem that could cause Xid errors and display
corruption in certain cases when OpenGL is used to render to
redirected windows, for example when Java2D is used with the
-Dsun.java2d.opengl=true option.
* glGetStringi(GL_EXTENSIONS, i) no longer returns NULL in OpenGL
3.0 preview contexts.
* Fixed a problem that caused the screen to flicker momentarily
when OpenGL applications exit unexpectedly on GeForce 6 and 7
series GPUs.
* Fixed an X server crash when an X client attempts to draw
trapezoids and RenderAccel is disabled.
* Improved recovery from certain types of errors.
* VDPAU updates:
* Fixed corruption on some H.264 clips.
* Update documentation.
* Fixed VC-1 decoding on 64-bit platforms.
* Improved handling of invalid H.264 streams.
* Fixed a problem that caused surfaces to be marked as
visible too early when the blit presentation queue is in
use.

_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Mar 07, 2009 7:00 pm    Post subject: Reply with quote

anyone got nvidia-drivers 180.35 and 180.37 to run with 2.6.29-rc7-zen* zen-sources ?

everytime I want to run glxinfo, gdm, or any other accelerated app it causes an Segmentation fault :(
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Sat Mar 07, 2009 8:27 pm    Post subject: Reply with quote

I did not test that. I am stuck at 2.6.26 because I use openvz (even on the main desktop at home which doubles as a cvs server for work).
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Sun Mar 08, 2009 2:29 pm    Post subject: Reply with quote

kernelOfTruth wrote:
anyone got nvidia-drivers 180.35 and 180.37 to run with 2.6.29-rc7-zen* zen-sources ?

everytime I want to run glxinfo, gdm, or any other accelerated app it causes an Segmentation fault :(


Am using 180.37 with 2.6.29-rc7-zen1. I have not had any errors and so far everything is running
fine.
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Mar 08, 2009 2:46 pm    Post subject: Reply with quote

Jupiter1TX wrote:
kernelOfTruth wrote:
anyone got nvidia-drivers 180.35 and 180.37 to run with 2.6.29-rc7-zen* zen-sources ?

everytime I want to run glxinfo, gdm, or any other accelerated app it causes an Segmentation fault :(


Am using 180.37 with 2.6.29-rc7-zen1. I have not had any errors and so far everything is running
fine.


so it must be a part of my kernel-config or the changes from zen1 to zen2 (I'm running 2.6.29-rc7-zen2)

would it be demanded too much to post your kernel-config, please ?

thanks
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Sun Mar 08, 2009 3:04 pm    Post subject: Reply with quote

kernelOfTruth wrote:

so it must be a part of my kernel-config or the changes from zen1 to zen2 (I'm running 2.6.29-rc7-zen2)

would it be demanded too much to post your kernel-config, please ?

thanks

No problem at all.
http://pastebin.ca/raw/1355831
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
uvok
n00b
n00b


Joined: 14 Oct 2008
Posts: 26

PostPosted: Tue Mar 10, 2009 7:06 pm    Post subject: Reply with quote

I have following nvidia card:

Code:
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)



Unfortunately, the ebuild tells me that my card is not supported. (I am receiving it when trying to install versions >177)
When I build it, the module fails to load...

1. Why isn't my graphics card supported (I heard that it has to do with the I/O?)
2. Will it be suported in a higher version?
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Mar 10, 2009 7:16 pm    Post subject: Reply with quote

You need older drivers. nvidia has a several cutoffs on what card is supported with which driver.

Quote:
Will it be suported in a higher version?


Probably not. Use the highest nvidia-driver that works with your card and then mask higher versions in /etc/portage/package.mask
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Tue Mar 10, 2009 10:09 pm    Post subject: Reply with quote

My problems have disappeared with nvidia-drivers-180.37 (just out)
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Mar 21, 2009 3:51 pm    Post subject: Reply with quote

Jupiter1TX wrote:
kernelOfTruth wrote:

so it must be a part of my kernel-config or the changes from zen1 to zen2 (I'm running 2.6.29-rc7-zen2)

would it be demanded too much to post your kernel-config, please ?

thanks

No problem at all.
http://pastebin.ca/raw/1355831


thanks a lot !

unfortunately I'm still struggling to get it running,

180.35, 180.37, 180.41 and 185.13 are all affected and would generate segmentation fault / general protection fault with gtk+ apps

could you please also post your commands you append on boot to your kernel ? (e.g. are you using nopat ?)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Sat Mar 21, 2009 4:20 pm    Post subject: Reply with quote

kernelOfTruth wrote:

thanks a lot !

unfortunately I'm still struggling to get it running,

180.35, 180.37, 180.41 and 185.13 are all affected and would generate segmentation fault / general protection fault with gtk+ apps

could you please also post your commands you append on boot to your kernel ? (e.g. are you using nopat ?)

Am now using the new 180.41 driver and still working well.
I do have PAT enabled in the kernel and not experiencing
any weird behaviour so far. My kernel command is...
Code:
kernel /vmlinuz-29-rc7-zen1 root=/dev/sda2 video=uvesafb:1280x1024-24@60,ywrap,mtrr:3 splash=silent,theme:default quiet CONSOLE=/dev/tty1

_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 250
Location: Ukraine

PostPosted: Mon Mar 23, 2009 12:17 pm    Post subject: Reply with quote

BTW, does that VDPAU works with 9800 AGP card?
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1025
Location: Tujunga, CA

PostPosted: Mon Mar 23, 2009 9:47 pm    Post subject: Reply with quote

I had posted earlier that no nvidia-driver after 177.82 would get started. Then 180.37 came along and worked. But I just tried 180.41 and again it will not get started. At the end of ~/.xsession-errors I have
Quote:
** Message: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name

** (gnome-panel:1197): WARNING **: Could not connect to session manager: Could not get owner of name 'org.gnome.SessionManager': no such name
** Message: Could not connect to power manager: Could not get owner of name 'org.freedesktop.PowerManagement': no such name
** Message: Could not connect to power manager: Could not get owner of name 'org.freedesktop.PowerManagement': no such name
** Message: Could not connect to power manager: Could not get owner of name 'org.freedesktop.PowerManagement': no such name

(gnome-terminal:1201): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(gnome-terminal:1201): GLib-GObject-CRITICAL **: g_signal_emit_valist: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0. This shouldn't happen!


Perhaps this will suggest something to someone?
Fred
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Mon Mar 23, 2009 10:11 pm    Post subject: Reply with quote

Not sure of that error but for me 180.41 works with gnome-2.24 since I installed (nvidia-drivers-180.41) on Saturday and rebooted yesterday with the kernel and driver update.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum