Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ALSA]son via HDMI (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Sat Jan 10, 2009 5:35 pm    Post subject: [ALSA]son via HDMI (résolu) Reply with quote

Salut les gars,

bon en fait ce n'est pas un pb que j'ai c'est juste une info, comme ce n'est pas non plus un tutorial je passe juste l'info rapidement, comme me l'avait demandé el_goretto :)

donc j'ai un ecran LCD une HD4850 et je voulais le son via HDMI, en fait c'est pas méchant à faire.

il faut biensur les drivers audio INTEL HD dans le kernel avec le support ATI dedans.

ensuite je lance un aplay -l, je repère ma carte ATI en card 1 device 0

donc je crée un .asoundrc comme ceci :

Code:
pcm.!spdif {
     type hw
     card 1
     device 0
}

pcm.!default {
     type plug
     slave {
           pcm "spdif"
     }
}


rien de plus, maintenant c'est bien cette carte qui est utilisé par défaut !

voila voila
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3102
Location: Paris

PostPosted: Sat Jan 10, 2009 8:43 pm    Post subject: Reply with quote

Et... merci :)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
gregool
Guru
Guru


Joined: 26 Nov 2007
Posts: 336
Location: Lille

PostPosted: Sat Jan 10, 2009 10:00 pm    Post subject: Reply with quote

de rien :) tu l'as installé ta nouvelle carte?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3102
Location: Paris

PostPosted: Sun Jan 11, 2009 11:01 am    Post subject: Reply with quote

Ouep (Radeon 4530), mais devant les contraintes de temps (pas le PC sous la main chez moi, mais chez la famille) et le support super embryonnaire du Tuner Satellite sous Linux (la techno DVB-S2 n'est toujours pas figée dans le kernel), j'ai commencé par faire un media center sous ouinouin, avec mediaportal prévu le week-end prochain.
Des partitions ont déjà été prévues pour un autre OS, on verra dans 1 an quand les drivers seront un peu plus secs (fglrx et tuner satellite).

Ceci dit, je te rassure vu les problèmes que tu cites sur l'autre post, c'est pas nickel à 100% non plus sous ouinouin, ya pas le début des sons joués via le HDMI. Pour une video, c'est pas gênant de rater 0.5s du début du programme TV ou lors d'un changement de chaîne, mais ça jette un froid quand tu bootes ouinouin quand même :) et c'est pire quand il s'agit des bruits d'animation de menus (dans des softs mediacenter en particuliers).
Je passerai sous silence le plantage systématique de l'installation automatisée du pack de pilotes ATI (faute à Asus? ATI?) qu'il faut du coup faire à la main un par un ^^.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum