Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qt-creator problem (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Tue Jan 20, 2009 3:43 pm    Post subject: qt-creator problem (SOLVED) Reply with quote

When I run the new a GUI application from the "New" menu, I got the following error:
Quote:
The template file '/usr/bin/templates/qt4project/main.cpp' could not be opened for reading: No such file or directory

It is quite strange for me why it looks the /usr/bin/ directory? When I look the "show license" from the "About", I got a similar error:
Quote:
File '/usr/bin/license.txt' could not be read.

It also looks /usr/bin directory to find the required file. Did anybody have this problem before?
PS. the qt-creator comes from crazy-kde overlay


Last edited by essexer on Fri Jan 23, 2009 10:47 am; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Jan 20, 2009 8:37 pm    Post subject: Reply with quote

The kde-crazy overlay is dead. You want to use the new qting-edge overlay for Qt Creator.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jan 20, 2009 8:47 pm    Post subject: Reply with quote

yngwin wrote:
The kde-crazy overlay is dead. You want to use the new qting-edge overlay for Qt Creator.

Last time I checked (2 days ago) the ebuild for qt-creator and the patches it applies were absolutely out of sync, at least the -9999 one.

EDIT: nevermind, seems fixed. Nice.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Tue Jan 20, 2009 10:12 pm    Post subject: Reply with quote

Thank you for your replies.
But I got the exact same error after I change to qting-edge. :cry:
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Jan 22, 2009 11:17 am    Post subject: Re: qt-creator problem Reply with quote

essexer wrote:
When I run the new a GUI application from the "New" menu, I got the following error:
Quote:
The template file '/usr/bin/templates/qt4project/main.cpp' could not be opened for reading: No such file or directory

It is quite strange for me why it looks the /usr/bin/ directory? When I look the "show license" from the "About", I got a similar error:
Quote:
File '/usr/bin/license.txt' could not be read.

It also looks /usr/bin directory to find the required file. Did anybody have this problem before?
PS. the qt-creator comes from crazy-kde overlay


Which one? qt-creator-beta or -9999? qt-cretor git is quite broken on upstream. I would strongly recommend using qt-creator-beta. I m gonna look into the issues you mentioned
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Thu Jan 22, 2009 11:23 am    Post subject: Re: qt-creator problem Reply with quote

Hwoarang wrote:
Quote:
Which one? qt-creator-beta or -9999? qt-cretor git is quite broken on upstream. I would strongly recommend using qt-creator-beta. I m gonna look into the issues you mentioned

I am using qt-creator-0.9.1_beta. Please let me if you need any further information, thanks.
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Jan 22, 2009 11:30 am    Post subject: Reply with quote

No, the errors on post #1 are enough to investigate the issue . As long as I fix it i ll update the ebuild on qting-edge overlay. Thanks :)
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Jan 22, 2009 7:48 pm    Post subject: Reply with quote

Unfortunatelly seems to me that the build process of this package is broken buy upstream. It is not that critical though since you can create projects and do the basics ( I havent used it a lot though ).

Dont forget that this is a _beta1 package so any mulfunction is normal 8)

Maybe -9999 has some fixes but I cant be sure about this :)
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Thu Jan 22, 2009 8:12 pm    Post subject: Reply with quote

Hwoarang wrote:
Unfortunatelly seems to me that the build process of this package is broken buy upstream. It is not that critical though since you can create projects and do the basics ( I havent used it a lot though ).

Dont forget that this is a _beta1 package so any mulfunction is normal 8)

Maybe -9999 has some fixes but I cant be sure about this :)


No. I can emerge qt-creator successfully. But I can not create the projects, because after the error shown in #1, nothing created.
Thank you for your time anyway.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Jan 22, 2009 8:47 pm    Post subject: Reply with quote

We need to look into this issue. What appears to be happening is that it uses the directory where the binary is located as working directory, which obviously doesn't work for us. I think this is an issue with the install procedure and the paths QtCreator is (not) being told to use in its configuration.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Jan 22, 2009 8:50 pm    Post subject: Reply with quote

I am currently applying various fixes . If I make ti work I ll reply here. :)
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Jan 22, 2009 9:28 pm    Post subject: Reply with quote

qt-creator-0.9.1_beta-r1 is now available. Seems that all the previous mentioned issues are now fixed :)
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Fri Jan 23, 2009 9:20 am    Post subject: Reply with quote

Hwoarang wrote:
qt-creator-0.9.1_beta-r1 is now available. Seems that all the previous mentioned issues are now fixed :)


The "show licenses" error has been fixed. But the project error remains. You can regenerate the same error as the following procedure:
File-->New-->Projects-->Qt4 Gui Application. It's worthy mentioning that the rest types of projects can be created successfully.
Thank you again for you guys time.
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Jan 23, 2009 10:17 am    Post subject: Reply with quote

Your way to reproduce it was really helpful. I was trying to create some projects and worked fine but I ve never tried QtGui :).

This has been fixed on qt-creator-0.9.1_beta-r2 ebuild :)
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Fri Jan 23, 2009 10:29 am    Post subject: Solved Reply with quote

All errors have been solved, very efficient! Thanks.
Please mark this thread as SOLVED.
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Fri Jan 23, 2009 10:38 am    Post subject: Reply with quote

:D

You can do it your self by changing the title on your first post :)
Back to top
View user's profile Send private message
essexer
n00b
n00b


Joined: 17 Jul 2006
Posts: 43
Location: UK

PostPosted: Fri Jan 23, 2009 10:48 am    Post subject: Reply with quote

Hwoarang wrote:
:D

You can do it your self by changing the title on your first post :)

:lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum