Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[qt overlay] Qt beta and live ebuilds & Qt4 apps
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Wed Feb 11, 2009 12:43 am    Post subject: Reply with quote

Thanks for reporting this issue. I ll take a look as soon as possible

I am affraid I cant answer your question about kde4+100% cpu. You should ask guys on kde-testing topic -> https://forums.gentoo.org/viewtopic-t-722264.html



@ All

I will drop opengl use flag on qt-gui live ebuilds for now until I come up with a solution for the linking problem :roll:
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Feb 11, 2009 1:33 am    Post subject: Reply with quote

Hwoarang wrote:
Thanks for reporting this issue. I ll take a look as soon as possible

I am affraid I cant answer your question about kde4+100% cpu. You should ask guys on kde-testing topic -> https://forums.gentoo.org/viewtopic-t-722264.html


Regards to the kded4 using 100% CPU I had the same problem, however after rebuilding kdelibs, pykde and all plasma stuff, the problem disappeared. Since kded4 is part of kdelibs, I think rebuilding kdelibs would suffice.

Cheers
Rahul
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Wed Feb 11, 2009 8:03 am    Post subject: Reply with quote

Stumbled on this discussion on the Qt Labs blog, from Feb. 10 (by way of the Mandriva Cooker forum)- very interesting and informative: http://labs.trolltech.com/blogs/2009/02/10/why-kde-42-should-use-qt-45/

There's also this other one, from Dec. I found worth reading. http://labs.trolltech.com/blogs/2008/12/04/how-kde-4-is-blocking-qt-45/
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Wed Feb 11, 2009 10:17 am    Post subject: Reply with quote

not really an important issue, but the live builds seem to fail with +doc, getting loads of qdoc errors looking like this:
Code:

/var/tmp/portage/x11-libs/qt-core-4.5.9999/work/qt-x11-opensource-src-4.5.9999/doc/src/examples/svgalib.qdoc:133: Unexpected '\snippet (//! [0])' 
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Wed Feb 11, 2009 12:38 pm    Post subject: Reply with quote

I am aware of this but documentation installs fine in the end 8O
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Wed Feb 11, 2009 12:46 pm    Post subject: Reply with quote

drizzt wrote:
Hello,
I just stumbled over this overlay and thought to give it a try. 2 things came up:
- qt-qt3support-4.5.0_rc1 doesn't compile with phonon use flag, because phonon use flags implies gstreamer and this one isn't found although I installed it to test


Could you please provide more details about that?

Give us an error log, and tell us if you use qt-phonon or media-sound phonon
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Wed Feb 11, 2009 12:48 pm    Post subject: Reply with quote

testing this, wow.. the raster backend is noticably faster, even on my quad core system, I didn't think I'd notice but I really do.

And the only problems I've run into, is icons for non qt applications look a bit wrong in the systray (but kde ones now render fine, which they didn't before), and the bouncy icon for startup notification renders wrong.

So none of the widgets I use have any issues whatsoever :p
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Wed Feb 11, 2009 1:13 pm    Post subject: Reply with quote

Yeah systray and startup notifiction is a bit screwed here too with raster engine, indeed. And I saw dolphin crashing when right clicking things.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
no4b
Bodhisattva
Bodhisattva


Joined: 18 Jan 2004
Posts: 774
Location: Tarnów, Poland

PostPosted: Wed Feb 11, 2009 1:41 pm    Post subject: Reply with quote

Is this possible to enable raster in Qt-4.5.0_rc1?
_________________
GTK2/GNOME - The weakest link!
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Wed Feb 11, 2009 2:16 pm    Post subject: Reply with quote

Qt-4.5.0_rc1 will be on portage soon with raster support ;)
Back to top
View user's profile Send private message
no4b
Bodhisattva
Bodhisattva


Joined: 18 Jan 2004
Posts: 774
Location: Tarnów, Poland

PostPosted: Wed Feb 11, 2009 2:45 pm    Post subject: Reply with quote

I tried Qt-4.5.0_rc1 from overlay and fonts look much worse compared to Qt-4.2.2 from portage. They are thin. Have you noticed something similar?
_________________
GTK2/GNOME - The weakest link!
Back to top
View user's profile Send private message
drizzt
Guru
Guru


Joined: 21 Jul 2002
Posts: 416

PostPosted: Wed Feb 11, 2009 5:49 pm    Post subject: Reply with quote

Hwoarang wrote:
drizzt wrote:
Hello,
I just stumbled over this overlay and thought to give it a try. 2 things came up:
- qt-qt3support-4.5.0_rc1 doesn't compile with phonon use flag, because phonon use flags implies gstreamer and this one isn't found although I installed it to test


Could you please provide more details about that?

Give us an error log, and tell us if you use qt-phonon or media-sound phonon

Hello,
the problem with kded4 seems to be gone, although I changed nothing 8O

Here are the details as requested for the qt-qt3support problem:
Code:
*  media-sound/phonon
      Latest version available: 4.3.0
      Latest version installed: 4.3.0
      Size of files: 552 kB
      Homepage:      http://phonon.kde.org
      Description:   KDE multimedia API
      License:       LGPL-2.1


Code:
>>> Emerging (1 of 1) x11-libs/qt-qt3support-4.5.0_rc1 from qting-edge
 * qt-x11-opensource-src-4.5.0-rc1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                                                       [ ok ]

 * The 4.5.0_rc1 version ebuilds install a pre-release from Nokia Qt Software

>>> Unpacking source...
tar xjpf /var/tmp/portage/x11-libs/qt-qt3support-4.5.0_rc1/distdir/qt-x11-opensource-src-4.5.0-rc1.tar.bz2 qt-x11-opensource-src-4.5.0-rc1/configure qt-x11-opensource-src-4.5.0-rc1/LICENSE.GPL2 qt-x11-opensource-src-4.5.0-rc1/LICENSE.GPL3 qt-x11-opensource-src-4.5.0-rc1/projects.pro qt-x11-opensource-src-4.5.0-rc1/src/qbase.pri qt-x11-opensource-src-4.5.0-rc1/src/qt_targets.pri qt-x11-opensource-src-4.5.0-rc1/src/qt_install.pri qt-x11-opensource-src-4.5.0-rc1/bin qt-x11-opensource-src-4.5.0-rc1/config.tests qt-x11-opensource-src-4.5.0-rc1/mkspecs qt-x11-opensource-src-4.5.0-rc1/qmake qt-x11-opensource-src-4.5.0-rc1/src/qt3support qt-x11-opensource-src-4.5.0-rc1/src/tools/uic3 qt-x11-opensource-src-4.5.0-rc1/tools/designer/src/plugins/widgets qt-x11-opensource-src-4.5.0-rc1/tools/qtconfig qt-x11-opensource-src-4.5.0-rc1/tools/porting qt-x11-opensource-src-4.5.0-rc1/src/ qt-x11-opensource-src-4.5.0-rc1/include/ qt-x11-opensource-src-4.5.0-rc1/tools/                                                                                                   
>>> Source unpacked in /var/tmp/portage/x11-libs/qt-qt3support-4.5.0_rc1/work                                                                                                                                       
>>> Configuring source in /var/tmp/portage/x11-libs/qt-qt3support-4.5.0_rc1/work/qt-x11-opensource-src-4.5.0-rc1 ...                                                                                               
./configure -L/usr/lib64 -pch -release -no-separate-debug-info -arch x86_64 -stl -verbose -largefile -confirm-license -no-rpath -prefix /usr -bindir /usr/bin -libdir /usr/lib64/qt4 -datadir /usr/share/qt4 -docdir /usr/share/doc/qt-4.5.0_rc1 -headerdir /usr/include/qt4 -plugindir /usr/lib64/qt4/plugins -sysconfdir /etc/qt4 -translationdir /usr/share/qt4/translations -examplesdir /usr/share/qt4/examples -demosdir /usr/share/qt4/demos -silent -fast -no-exceptions -reduce-relocations -nomake examples -nomake demos -qt3support -gstreamer -phonon -accessibility                                                                           

This is the Qt/X11 Open Source Edition.

Determining system architecture... (Linux:2.6.28-gentoo-r1:x86_64)
    64-bit AMD 80x86 (x86_64)                                     
    'x86_64' is supported                                         
System architecture: 'x86_64'                                     
Symbol visibility control enabled.                               
Symbolic function binding enabled.                               
You are licensed to use this software under the terms of         
the GNU General Public License (GPL) versions 2 or 3.             

You have already accepted the terms of the  license.

floatmath auto-detection... ()
compiling floatmath.cpp       
floatmath.cpp:3: Warnung: unbenutzter Parameter »argc«
floatmath.cpp:3: Warnung: unbenutzter Parameter »argv«
linking floatmath                                     
floatmath enabled.                                   
mmx auto-detection... ()                             
compiling mmx.cpp                                     
linking mmx                                           
mmx enabled.                                         
3dnow auto-detection... ()                           
compiling 3dnow.cpp                                   
linking 3dnow                                         
3dnow enabled.                                       
sse auto-detection... ()                             
compiling sse.cpp                                     
linking sse                                           
sse enabled.                                         
sse2 auto-detection... ()                             
compiling sse2.cpp                                   
linking sse2                                         
sse2 enabled.                                         
zlib auto-detection... ()                             
compiling zlib.cpp                                   
linking zlib                                         
zlib enabled.                                         
libjpeg auto-detection... ()                         
compiling libjpeg.cpp                                 
libjpeg.cpp: In function »int main(int, char**)«:     
libjpeg.cpp:10: Warnung: »cinfo« wird in dieser Funktion uninitialisiert verwendet
linking libjpeg                                                                   
libjpeg enabled.                                                                 
libtiff auto-detection... ()                                                     
compiling libtiff.cpp                                                             
linking libtiff                                                                   
libtiff enabled.                                                                 
libmng auto-detection... ()                                                       
compiling libmng.cpp                                                             
linking libmng                                                                   
libmng enabled.                                                                   
libpng auto-detection... ()                                                       
compiling libpng.cpp                                                             
linking libpng                                                                   
libpng enabled.                                                                   
InterBase auto-detection... ()                                                   
compiling ibase.cpp                                                               
ibase.cpp:1:19: Fehler: ibase.h: Datei oder Verzeichnis nicht gefunden           
make: *** [ibase.o] Fehler 1                                                     
InterBase disabled.                                                               
MySQL (thread-safe) auto-detection... ()                                         
compiling ../mysql/mysql.cpp                                                     
linking mysql_r                                                                   
MySQL (thread-safe) enabled.                                                     
ODBC auto-detection... ()                                                         
compiling odbc.cpp                                                               
linking odbc                                                                     
ODBC enabled.                                                                     
PostgreSQL auto-detection... ()                                                   
compiling psql.cpp                                                               
psql.cpp:1:22: Fehler: libpq-fe.h: Datei oder Verzeichnis nicht gefunden         
psql.cpp: In function »int main(int, char**)«:                                   
psql.cpp:5: Fehler: »PQescapeBytea« wurde in diesem Gültigkeitsbereich nicht definiert
psql.cpp:6: Fehler: »PQunescapeBytea« wurde in diesem Gültigkeitsbereich nicht definiert
make: *** [psql.o] Fehler 1                                                             
PostgreSQL disabled.                                                                   
SQLite2 auto-detection... ()                                                           
compiling sqlite2.cpp                                                                   
linking sqlite2                                                                         
SQLite2 enabled.                                                                       
NIS auto-detection... ()                                                               
compiling nis.cpp                                                                       
linking nis                                                                             
NIS enabled.                                                                           
Cups auto-detection... ()                                                               
compiling cups.cpp                                                                     
linking cups                                                                           
Cups enabled.                                                                           
POSIX iconv auto-detection... ()                                                       
compiling iconv.cpp                                                                     
linking iconv                                                                           
POSIX iconv enabled.                                                                   
D-Bus auto-detection... ()                                                             
compiling dbus.cpp                                                                     
linking dbus                                                                           
D-Bus enabled.                                                                         
Glib auto-detection... ()                                                               
compiling glib.cpp                                                                     
glib.cpp: In function »int main(int, char**)«:                                         
glib.cpp:14: Warnung: »pollfd« wird in dieser Funktion uninitialisiert verwendet       
linking glib                                                                           
Glib enabled.                                                                           
GStreamer auto-detection... ()                                                         
compiling gstreamer.cpp                                                                 
gstreamer.cpp:1:21: Fehler: gst/gst.h: Datei oder Verzeichnis nicht gefunden           
gstreamer.cpp:2:42: Fehler: gst/interfaces/propertyprobe.h: Datei oder Verzeichnis nicht gefunden
gstreamer.cpp:3:37: Fehler: gst/interfaces/xoverlay.h: Datei oder Verzeichnis nicht gefunden     
gstreamer.cpp:7:4: Fehler: #error "No GST_VERSION_* macros"                                     
gstreamer.cpp:12: Warnung: unbenutzter Parameter »argc«                                         
gstreamer.cpp:12: Warnung: unbenutzter Parameter »argv«                                         
make: *** [gstreamer.o] Fehler 1                                                                 
GStreamer disabled.                                                                             
Gstreamer support cannot be enabled due to functionality tests!                                 
 Turn on verbose messaging (-v) to ./configure to see the final report.                         
 If you believe this message is in error you may use the continue                               
 switch (-continue) to ./configure to continue.

Code:
[ebuild   R   ] media-libs/gstreamer-0.10.21-r3  USE="nls -debug -test" 0 kB

Hope this helps

EDIT
Now after layman sync, qt-qt3support wants to pull in qt-phonon-4.5.0_rc1 which blocks media-sound/phonon. media-sound/phonon is required for kdelibs-4.2 :(
_________________
People don't have to earn my respect. I offer my respect to them, but be careful to lose my respect...
Back to top
View user's profile Send private message
no4b
Bodhisattva
Bodhisattva


Joined: 18 Jan 2004
Posts: 774
Location: Tarnów, Poland

PostPosted: Wed Feb 11, 2009 10:07 pm    Post subject: Reply with quote

no4b wrote:
I tried Qt-4.5.0_rc1 from overlay and fonts look much worse compared to Qt-4.2.2 from portage. They are thin. Have you noticed something similar?


This problem is easy to solve. I changed hinting style from medium to slight and everything looks good again.
_________________
GTK2/GNOME - The weakest link!
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Wed Feb 11, 2009 11:27 pm    Post subject: Reply with quote

drizzt wrote:
Now after layman sync, qt-qt3support wants to pull in qt-phonon-4.5.0_rc1 which blocks media-sound/phonon. media-sound/phonon is required for kdelibs-4.2 :(


Code:
PDEPEND="phonon? (
    || ( ~x11-libs/qt-phonon-${PV}[debug=] media-sound/phonon[gstreamer] ) )"

Means it needs one or the other, if USE=phonon is set.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Feb 12, 2009 12:01 am    Post subject: Reply with quote

My fellow Qt addicts 8)

Qt-4.5.0_rc1 + qt-creator-0.9.2_rc1 is now on tree.

Please fill bugs on bugzilla for those packages and not here :)

This thread remains strictly related with qting-edge overlay 8)
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Thu Feb 12, 2009 12:07 am    Post subject: Reply with quote

yngwin wrote:
drizzt wrote:
Now after layman sync, qt-qt3support wants to pull in qt-phonon-4.5.0_rc1 which blocks media-sound/phonon. media-sound/phonon is required for kdelibs-4.2 :(


Code:
PDEPEND="phonon? (
    || ( ~x11-libs/qt-phonon-${PV}[debug=] media-sound/phonon[gstreamer] ) )"

Means it needs one or the other, if USE=phonon is set.

I have USE="-gstreamer" and I'm using the xine backend instead. I'm getting the same blockage. Does this mean I have to re-emerge media-sound/phonon with gstreamer on?

Would it work if I modified the ebuild to avoid gstreamer?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Thu Feb 12, 2009 12:12 am    Post subject: Reply with quote

StringCheesian wrote:
I have USE="-gstreamer" and I'm using the xine backend instead. I'm getting the same blockage. Does this mean I have to re-emerge media-sound/phonon with gstreamer on?

You have these choices:
1) Disable USE=phonon on qt-qt3support
2) Use qt-phonon (which uses gstreamer), and not use kde4
3) Use media-sound/phonon with gstreamer useflag enabled

Quote:
Would it work if I modified the ebuild to avoid gstreamer?

No. It's there for a reason. You can only get phonon support in Qt by using gstreamer.
Tho you can avoid it by disabling the phonon useflag.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
JDieskau
n00b
n00b


Joined: 24 Jun 2005
Posts: 13
Location: Germany

PostPosted: Thu Feb 12, 2009 7:53 pm    Post subject: Reply with quote

Code:
 -> emerge -v qt-creator

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-util/qt-creator-9999  USE="-debug" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:                             
 [0] /usr/portage                                     
 [1] /usr/portage/local/layman/qting-edge             


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-util/qt-creator-9999
 * checking ebuild checksums ;-) ...                                                                                                 [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                [ ok ]
 * checking miscfile checksums ;-) ...                                                                                               [ ok ]
>>> Unpacking source...                                                                                                                   
 * git update start -->                                                                                                                   
 *    repository: git://labs.trolltech.com/qt-creator                                                                                     
 *    local clone: /usr/portage/distfiles/git-src/qt-creator                                                                               
 *    committish: master                                                                                                                   
>>> Unpacked to /var/tmp/portage/dev-util/qt-creator-9999/work/qt-creator-9999                                                             
>>> Source unpacked.                                                                                                                       
 * Applying fix_headers_git.patch ...                                                                                                     

 * Failed Patch: fix_headers_git.patch !
 *  ( /usr/portage/local/layman/qting-edge/dev-util/qt-creator/files/fix_headers_git.patch )
 *                                                                                         
 * Include in your bugreport the contents of:                                               
 *                                                                                         
 *   /var/tmp/portage/dev-util/qt-creator-9999/temp/fix_headers_git.patch-19607.out         

 *
 * ERROR: dev-util/qt-creator-9999 failed.
 * Call stack:                           
 *               ebuild.sh, line   49:  Called src_prepare
 *             environment, line 2481:  Called qt4-edge_src_prepare
 *             environment, line 2426:  Called base_src_prepare   
 *             environment, line  266:  Called base_src_util 'autopatch'
 *             environment, line  315:  Called epatch '/usr/portage/local/layman/qting-edge/dev-util/qt-creator/files/fix_headers_git.patch'
 *             environment, line 1300:  Called die                                                                                         
 * The specific snippet of code:                                                                                                           
 *                   die "Failed Patch: ${patchname}!";                                                                                     
 *  The die message:                                                                                                                       
 *   Failed Patch: fix_headers_git.patch!                                                                                                   
 *                                                                                                                                         
 * If you need support, post the topmost build error, and the call stack if relevant.                                                       
 * A complete build log is located at '/var/tmp/portage/dev-util/qt-creator-9999/temp/build.log'.                                           
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/qt-creator-9999/temp/environment'.                                 
 *


Whats wrong here?
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Feb 12, 2009 8:18 pm    Post subject: Reply with quote

Fixed

Thanks for reporting
Back to top
View user's profile Send private message
andriy155
n00b
n00b


Joined: 05 Feb 2006
Posts: 65
Location: Kyiv, Ukraine

PostPosted: Thu Feb 19, 2009 12:39 am    Post subject: Reply with quote

no4b wrote:
no4b wrote:
I tried Qt-4.5.0_rc1 from overlay and fonts look much worse compared to Qt-4.2.2 from portage. They are thin. Have you noticed something similar?


This problem is easy to solve. I changed hinting style from medium to slight and everything looks good again.


It's very interesting - I ran into a similar problem. My fonts turned completely unreadable. Changing the hinting style did not help. But I fixed the issue by changing subpixel rendering from 'Vertical RGB' to 'RGB'. Do you think, we should file a bug? If so, where do I go: Gentoo, KDE, Nokia?

Pozdrowienja z Kijowa!
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Thu Feb 19, 2009 11:58 am    Post subject: Reply with quote

It is up to you . I would say kde bugzilla but this is a rare situation and i dont know if you can reproduce it if they ask you to do. Upgrading Qt to 4.5 has different effects on different users so I am not sure if this is a bug or not. In fact i did upgrade Qt-4.4.2->Qt-4.5 on 4 machines and only one of them had some troubles , but remerging all applications that depend on qt-gui fixed the issue

So as you can see, its pretty confusing situation.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Feb 19, 2009 12:33 pm    Post subject: Reply with quote

sorry if i´m going to say sth. stupid but i installed qt-4.5.0-r1 because i thought i had read somewhere that nsplugin support was there already.
All i need is a browser that knows what flash is, so i tried arora from your overlay and it apparently doesn´t work.

What am i doing wrong ? or am i using the wrong version ?

thanks in advance for any advice !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Thu Feb 19, 2009 12:48 pm    Post subject: Reply with quote

gringo wrote:
sorry if i´m going to say sth. stupid but i installed qt-4.5.0-r1 because i thought i had read somewhere that nsplugin support was there already.
All i need is a browser that knows what flash is, so i tried arora from your overlay and it apparently doesn´t work.

What am i doing wrong ? or am i using the wrong version ?

thanks in advance for any advice !


Well, khtml will work fine with flash, and is the same codebase as webkit, so it's pretty fast. You can also use kmplayer with npp to handle flash plugins, qt4.5 is supposed to have flash working in webkit though, without any hacks. And it does work for me. Check file assosiations for shockwave flash.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Feb 19, 2009 3:26 pm    Post subject: Reply with quote

thanks for your answer neuron !

i´ve been using arora/midori for quite some time now ( but don´t use gnome or kde) and they worked quite well for me so far, specially arora looks more robust to me.
I just wanted to see how well the flash stuff works using one of these but I´m unable to get latest gtk-webkit stuff to compile so that i checked out latest arora.

Quote:
Check file assosiations for shockwave flash.


excuse my ignorance but where exactly do i look this up ? to be honest i haven´t digged into it seriously ... yet ...

thanks !
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Thu Feb 19, 2009 3:44 pm    Post subject: Reply with quote

gringo wrote:
thanks for your answer neuron !

i´ve been using arora/midori for quite some time now ( but don´t use gnome or kde) and they worked quite well for me so far, specially arora looks more robust to me.
I just wanted to see how well the flash stuff works using one of these but I´m unable to get latest gtk-webkit stuff to compile so that i checked out latest arora.

Quote:
Check file assosiations for shockwave flash.


excuse my ignorance but where exactly do i look this up ? to be honest i haven´t digged into it seriously ... yet ...

thanks !


That'd be a kde setting, kcontrol panel -> advanced -> file assosiations, but I doubt that'd affect arora/midori. I just tested arora, and it works fine on my system, with flash. That's qt4.5 rc1 and latest flash from portage. Keep in mind if you've got an old running system that they might not check .mozilla/plugins for the flash plugin.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 14, 15, 16  Next
Page 5 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum