Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[qt overlay] Qt beta and live ebuilds & Qt4 apps
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Fri Dec 18, 2009 2:23 am    Post subject: Reply with quote

Quote:
gdb --args "/usr/bin/python2" "/usr/lib64/python3.1/site-packages/eric4/eric4.py"

_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4410

PostPosted: Fri Dec 18, 2009 8:08 pm    Post subject: Reply with quote

Ok, sry, that was the output of the last test i did.
You can beleafe me, it was the same result debugging the eric4.py from python2.6-site-packages.
BTW, why are the eric4-files also installed to python3.1, although eric4 does not work with python3?
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Dec 19, 2009 3:51 am    Post subject: Reply with quote

The python eclasses are constantly changing lately, and now python apps will be installed for all available python versions. We've only very recently started to restrict python3 in eric ebuilds. So if you use the latest ebuilds, eric should no longer install to python3.1/site-packages/. That being said, in my opinion python3 should be hardmasked, as it is not yet ready for prime-time. But if you were using snapshots from the overlay, it is quite possible you happened to stumble on a bug in the development version. Which would be not unexpected...
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Sun Dec 20, 2009 7:09 pm    Post subject: Reply with quote

Is pyside in gentoo's tree? v0.2.2 has just disappeared from qting-edge
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Dec 22, 2009 2:11 am    Post subject: Reply with quote

regomodo wrote:
Is pyside in gentoo's tree?

Yes it is.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Tue Dec 22, 2009 11:33 am    Post subject: Reply with quote

yngwin wrote:
regomodo wrote:
Is pyside in gentoo's tree?

Yes it is.


It is now but it was gone for a day or 2.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Dec 22, 2009 9:32 pm    Post subject: Reply with quote

pyside and company were committed to the official tree on the 20th, and then removed from the overlay the same day.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Tue Dec 22, 2009 10:01 pm    Post subject: Reply with quote

yngwin wrote:
pyside and company were committed to the official tree on the 20th, and then removed from the overlay the same day.


Ah wait. I thought it had disappeared from qting-edge and then reappeared back in qting-edge. Just used eix and now see it's in portage. The delay for me is because i'm on Funtoo.

My mistake.
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Wed Dec 23, 2009 1:41 pm    Post subject: Reply with quote

qt-creator-9999 fails to build here:
Code:
>>> Unpacking source...                                                                                                                                                                               
 * GIT NEW clone -->                                                                                                                                                                                   
 *    repository:               git://gitorious.org/qt-creator/qt-creator.git                                                                                                                         
Initialized empty Git repository in /usr/portage/distfiles/git-src/qt-creator/.git/                                                                                                                   
remote: Counting objects: 71354, done.
remote: Compressing objects: 100% (20953/20953), done.
remote: Total 71354 (delta 59606), reused 60831 (delta 50268)
Receiving objects: 100% (71354/71354), 32.86 MiB | 206 KiB/s, done.
Resolving deltas: 100% (59606/59606), done.                       
 *    at the commit:            1c1394c1eb1d570fa91963d9a00eaf4e3e617124
 *    branch:                   master                                 
 *    storage directory:        "/usr/portage/distfiles/git-src/qt-creator"
fatal: Not a git repository (or any of the parent directories): .git       
fatal: Not a git repository (or any of the parent directories): .git       
fatal: Not a git repository (or any of the parent directories): .git       
>>> Unpacked to /var/tmp/portage/dev-util/qt-creator-9999/work/           
>>> Source unpacked in /var/tmp/portage/dev-util/qt-creator-9999/work
>>> Preparing source in /var/tmp/portage/dev-util/qt-creator-9999/work ...
 * Disabling bookmarks support
sed: can't read src/plugins/plugins.pro: No such file or directory
 * ERROR: dev-util/qt-creator-9999 failed:
 *   Failed to disable bookmarks plugin
 *
 * Call stack:
 *     ebuild.sh, line  55:  Called src_prepare
 *   environment, line 2964:  Called die
 * The specific snippet of code:
 *               sed -i "/plugin_${plugin}/s:^:#:" src/plugins/plugins.pro || die "Failed to disable ${plugin} plugin";
 *
 * If you need support, post the output of 'emerge --info =dev-util/qt-creator-9999',
 * the complete build log and the output of 'emerge -pqv =dev-util/qt-creator-9999'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/qting-edge/eclass/qt4-edge.eclass
 * This ebuild is from an overlay named 'qting-edge': '/usr/local/portage/layman/qting-edge/'
 * The complete build log is located at '/var/tmp/portage/dev-util/qt-creator-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/qt-creator-9999/temp/environment'.
 * S: '/var/tmp/portage/dev-util/qt-creator-9999/work/'
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7206
Location: Austria

PostPosted: Fri Dec 25, 2009 2:55 pm    Post subject: Reply with quote

For days, I get this very annoying error:

Code:
Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-core-4.6.9999-r1  USE="exceptions glib iconv kde-qt%* qt3support ssl -debug -doc -optimized-qmake -pch -stable-branch (-qt-copy%*)" 0 kB [1]

[snip]

>>> Emerging (1 of 12) x11-libs/qt-core-4.6.9999-r1 from qting-edge
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  x11-libs/qt-core-4.6.9999-r1                                         
 * REPO: qting-edge                                                           
 * USE:  amd64 elibc_glibc exceptions glib iconv kde-qt kernel_linux multilib qt3support ssl userland_GNU                                                                                               
 *                                                                                                 
 * Please file bugs on bugs.gentoo.org and prepend the summary with                                 
 * [qting-edge]. Alternatively, contact qt@gentoo.org.                                             
 * Thank you for using qting-edge overlay.                                                         
 *                                                                                                 

 * The 4.6.9999 version ebuilds with kde-qt USE flag install kde-qt from gitorious kde-qt repository.                                                                                                   

>>> Unpacking source...
 * GIT NEW clone -->   
 *    repository:               git://gitorious.org/+kde-developers/qt/kde-qt.git
Initialized empty Git repository in /usr/portage/distfiles/git-src/qt-4.6.9999/.git/
fatal: The remote end hung up unexpectedly                                         
fatal: early EOF                                                                   
fatal: index-pack failed                                                           
 * ERROR: x11-libs/qt-core-4.6.9999-r1 failed:                                     
 *   git.eclass: can't fetch from git://gitorious.org/+kde-developers/qt/kde-qt.git.
 *                                                                                 
 * Call stack:                                                                     
 *     ebuild.sh, line   48:  Called src_unpack                                     
 *   environment, line 3856:  Called qt4-build-edge_src_unpack                     
 *   environment, line 3523:  Called git_src_unpack                                 
 *   environment, line 2616:  Called git_fetch                                     
 *   environment, line 2545:  Called die                                           
 * The specific snippet of code:                                                   
 *           ${EGIT_FETCH_CMD} ${EGIT_OPTIONS} "${EGIT_REPO_URI}" ${GIT_DIR} || die "${EGIT}: can't fetch from ${EGIT_REPO_URI}.";                                                                     
 *                                                                                                 
 * If you need support, post the output of 'emerge --info =x11-libs/qt-core-4.6.9999-r1',           
 * the complete build log and the output of 'emerge -pqv =x11-libs/qt-core-4.6.9999-r1'.           
 * This ebuild used the following eclasses from overlays:                                           
 *   /usr/local/portage/layman/qting-edge/eclass/qt4-build-edge.eclass                             
 * This ebuild is from an overlay named 'qting-edge': '/usr/local/portage/layman/qting-edge/'       
 * The complete build log is located at '/var/tmp/portage/x11-libs/qt-core-4.6.9999-r1/temp/build.log'.                                                                                                 
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/qt-core-4.6.9999-r1/temp/environment'.                                                                                         
 * S: '/var/tmp/portage/x11-libs/qt-core-4.6.9999-r1/work/qt-x11-opensource-src-4.6.9999'

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Fri Dec 25, 2009 5:14 pm    Post subject: Reply with quote

@genstorm, rm -rf /usr/portage/distfiles/git-src/qt-4.6.9999 && layman -s qting-edge && emerge -1 qt-core ?
but seems it won't help
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7206
Location: Austria

PostPosted: Fri Dec 25, 2009 5:25 pm    Post subject: Reply with quote

I did that already, even layman -d qting-edge && layman -a qting-edge.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 09, 2010 1:24 pm    Post subject: Reply with quote

do you really need the qt 4.9999* ebuilds for kde 4.3.90 to build ?

I'm getting the following errors during build of kdelibs:
Quote:
In file included from /usr/include/qt4/QtTest/QtTest:4,
from /var/tmp/portage/kde-base/kdelibs-4.3.90/work/kdelibs-4.3.90/kdecore/util/qtest_kde.h:22,
from /var/tmp/portage/kde-base/kdelibs-4.3.90/work/kdelibs-4.3.90/kdecore/util/qtest_kde.cpp:1:
/usr/include/qt4/QtTest/qbenchmark.h:46:47: error: QtTest/private/qbenchmarkmetric_p.h: No such file or directory


and

Quote:
In file included from /usr/include/qt4/QtTest/QtTest:4,
from /var/tmp/portage/kde-base/kdelibs-4.3.90/work/kdelibs-4.3.90/kdecore/util/qtest_kde.h:22,
from /var/tmp/portage/kde-base/kdelibs-4.3.90/work/kdelibs-4.3.90/kdecore/util/qtest_kde.cpp:1:
/usr/include/qt4/QtTest/qbenchmark.h:91: error: ‘QBenchmarkMetric’ has not been declared
make[2]: *** [kdecore/CMakeFiles/kdecore.dir/util/qtest_kde.o] Error 1
make[1]: *** [kdecore/CMakeFiles/kdecore.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Jan 09, 2010 2:30 pm    Post subject: Reply with quote

kernelOfTruth wrote:
do you really need the qt 4.9999* ebuilds for kde 4.3.90 to build ?

Not that I know. Qt 4.6.0 should work just fine. But try the kde topic.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 09, 2010 4:24 pm    Post subject: Reply with quote

yngwin wrote:
kernelOfTruth wrote:
do you really need the qt 4.9999* ebuilds for kde 4.3.90 to build ?

Not that I know. Qt 4.6.0 should work just fine. But try the kde topic.


I already did ;)

I'll give 4.6.0 (official) a try

thanks yngwin, I just wanted to be sure to post in the right thread
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sun Jan 10, 2010 1:19 am    Post subject: Reply with quote

Hello!
I want to use the kde-qt patches with qt-4.6. So I added qting-edge with layman as suggested on the qting-edge site. After that I edited make.conf with
Code:

source /usr/local/portage/layman/make.conf

and synced layman. I expected that with an emerge --newuse all qt-packages would be updated, but nothing happened. Even with USE="kde-qt", nothing... Am I missing something here?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3260
Location: Gainesville, Florida

PostPosted: Sun Jan 10, 2010 6:56 am    Post subject: Reply with quote

Interesting.
In that qt and kde are so interrelated, is it now necessary and/or recommended to set the kde-qt USE flag in make.conf, or /etc/portage/package.use for whatever packages need it?

In fact, seeing as how I've never heard of the kde-qt USE flag, I have a feeling I might be missing a few of the latest required USE flags for either qt or kde in package.use. Is there any definitive documentation, other than what emerge -pv "whatever package" would report?

Or, can I assume the overlay ebuilds will generally cover any changes needed when I'm using them?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.30-r2, gcc-9.2.0 kernel-5.4.1-gentoo USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7206
Location: Austria

PostPosted: Sun Jan 10, 2010 10:04 am    Post subject: Reply with quote

Only thing the kde-qt flag does for you is downloading from the dev branch of qt that contains upstream bugfixes from the KDE developers which will make it into the official qt tree anyway, sooner or later.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7206
Location: Austria

PostPosted: Sun Jan 10, 2010 10:06 am    Post subject: Reply with quote

Martux wrote:
I expected that with an emerge --newuse all qt-packages would be updated, but nothing happened. Even with USE="kde-qt", nothing... Am I missing something here?

--newuse only recompiles packages where actual USE flags have changed, not their dependencies.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sun Jan 10, 2010 11:21 am    Post subject: Reply with quote

Well I guess something went wrong here...
When I try to recompile eg. qt-gui I get the following:
Code:

[ebuild   R   ] x11-libs/qt-gui-4.6.0-r2  USE="accessibility cups dbus glib mng pch qt3support tiff xinerama (-aqua) -debug -gtk -nas -nis -raster"

Shouldn´t that be a 9999 number?
Whatever, is that even the recommended way to get the qt-copy patches anyway?
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
xibo
Apprentice
Apprentice


Joined: 21 Aug 2007
Posts: 152
Location: moving between kubuntu and ubuntu kde edition

PostPosted: Sun Jan 10, 2010 11:42 am    Post subject: Reply with quote

Martux wrote:
Well I guess something went wrong here...
When I try to recompile eg. qt-gui I get the following:
Code:

[ebuild   R   ] x11-libs/qt-gui-4.6.0-r2  USE="accessibility cups dbus glib mng pch qt3support tiff xinerama (-aqua) -debug -gtk -nas -nis -raster"

Shouldn´t that be a 9999 number?
Whatever, is that even the recommended way to get the qt-copy patches anyway?


Have you unmasked/keyworded for qt?
What's the output of `emerge -av1 =x11-libs/qt-core-4.6.9999-r1` ?
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Sun Jan 10, 2010 12:01 pm    Post subject: Reply with quote

Ahh yes, that´s it. Is there a unmask list anywhere?
~amd64 here.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Mon Jan 11, 2010 2:22 am    Post subject: Reply with quote

You can use the qting-edge/sets/qt-all-4.6-live-nokia file also as unmask file.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
SpectreDragon
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2008
Posts: 92
Location: Germany

PostPosted: Mon Jan 18, 2010 7:42 pm    Post subject: Reply with quote

a patch for x11-libs/qt-assistant-4.6.9999 [USE="kde-qt stable-branch -debug -exceptions -pch"] fails here.

Code:
 * Messages for package x11-libs/qt-assistant-4.6.9999:

 *
 * Please file bugs on bugs.gentoo.org and prepend the summary with
 * [qting-edge]. Alternatively, contact qt@gentoo.org.             
 * Thank you for using qting-edge overlay.                         
 *                                                                 
 * The 4.6.9999 version ebuilds with kde-qt and stable-branch   USE flags install kde-qt from
 * gitorious kde-qt repository, '4.6-stable-patched' branch.                                 
 * GIT update -->                                                                           
 *    repository:               git://gitorious.org/+kde-developers/qt/kde-qt.git           
 *    at the commit:            de4d4af3023bde675283b42220d01ded692fdbc2                     
 *    branch:                   4.6-stable-patched                                           
 *    storage directory:        "/var/tmp/portage/distfiles/git-src/qt-4.6.9999"             
 * Failed Patch: qt-assistant-4.6.9999-kde-qt-tools.patch !                                 
 *  ( /usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch )
 *                                                                                                               
 * Include in your bugreport the contents of:                                                                   
 *                                                                                                               
 *   /var/tmp/portage/x11-libs/qt-assistant-4.6.9999/temp/qt-assistant-4.6.9999-kde-qt-tools.patch.out           
 * ERROR: x11-libs/qt-assistant-4.6.9999 failed:                                                                 
 *   Failed Patch: qt-assistant-4.6.9999-kde-qt-tools.patch!                                                     
 *                                                                                                               
 * Call stack:                                                                                                   
 *     ebuild.sh, line   48:  Called src_prepare                                                                 
 *   environment, line 3724:  Called epatch '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'
 *   environment, line 1638:  Called die                                                                                                               
 * The specific snippet of code:                                                                                                                       
 *               die "Failed Patch: ${patchname}!";                                                                                                   
 *                                                                                                                                                     
 * If you need support, post the output of 'emerge --info =x11-libs/qt-assistant-4.6.9999',                                                           
 * the complete build log and the output of 'emerge -pqv =x11-libs/qt-assistant-4.6.9999'.                                                             
 * This ebuild used the following eclasses from overlays:                                                                                             
 *   /usr/local/portage/layman/qting-edge/eclass/qt4-build-edge.eclass                                                                                 
 * This ebuild is from an overlay named 'qting-edge': '/usr/local/portage/layman/qting-edge/'                                                         
 * The complete build log is located at '/var/tmp/portage/x11-libs/qt-assistant-4.6.9999/temp/build.log'.                                             
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/qt-assistant-4.6.9999/temp/environment'.                                       
 * S: '/var/tmp/portage/x11-libs/qt-assistant-4.6.9999/work/qt-x11-opensource-src-4.6.9999'


qt-assistant-4.6.9999-kde-qt-tools.patch.out
Code:
***** qt-assistant-4.6.9999-kde-qt-tools.patch *****                                                                 

====================================================

PATCH COMMAND:  patch -p0 -g0 -E --no-backup-if-mismatch < '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'

====================================================
can't find file to patch at input line 5           
Perhaps you used the wrong -p or --strip option?   
The text leading up to this was:                   
--------------------------                         
|diff --git a/tools/tools.pro b/tools/tools.pro     
|index 87ba3c9..26a82ed 100644                     
|--- a/tools/tools.pro                             
|+++ b/tools/tools.pro                             
--------------------------                         
No file to patch.  Skipping patch.                 
1 out of 1 hunk ignored                             
====================================================

PATCH COMMAND:  patch -p1 -g0 -E --no-backup-if-mismatch < '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'

====================================================
patching file tools/tools.pro
Hunk #1 FAILED at 5.
1 out of 1 hunk FAILED -- saving rejects to file tools/tools.pro.rej
====================================================

PATCH COMMAND:  patch -p2 -g0 -E --no-backup-if-mismatch < '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'

====================================================
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/tools/tools.pro b/tools/tools.pro
|index 87ba3c9..26a82ed 100644
|--- a/tools/tools.pro
|+++ b/tools/tools.pro
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
====================================================

PATCH COMMAND:  patch -p3 -g0 -E --no-backup-if-mismatch < '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'

====================================================
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/tools/tools.pro b/tools/tools.pro
|index 87ba3c9..26a82ed 100644
|--- a/tools/tools.pro
|+++ b/tools/tools.pro
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
====================================================

PATCH COMMAND:  patch -p4 -g0 -E --no-backup-if-mismatch < '/usr/local/portage/layman/qting-edge/x11-libs/qt-assistant/files/qt-assistant-4.6.9999-kde-qt-tools.patch'

====================================================
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/tools/tools.pro b/tools/tools.pro
|index 87ba3c9..26a82ed 100644
|--- a/tools/tools.pro
|+++ b/tools/tools.pro
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
Back to top
View user's profile Send private message
Hwoarang
Retired Dev
Retired Dev


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Mon Jan 18, 2010 8:29 pm    Post subject: Reply with quote

It works for me. Try to resync your overlay. If it doesnt work please open a bug on our bugzilla as suggested by the warning message ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 14, 15, 16  Next
Page 10 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum