Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Update] Comprendre les packages bloqués
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Tue Jan 27, 2009 12:28 pm    Post subject: [Update] Comprendre les packages bloqués Reply with quote

Bonjour,

J'ai voulu faire un update de ma gentoo et lorsque j'affiche la liste des paquets qui seront mis à jour, j'ai bizarrement des paquets bloqués.
Alors pour le paquet qt-core je comprends vu que j'ai la version qt-4.3.3, mais pourquoi si il veut updater vers la 4.4.2, il veut mettre la 4.4.0_alpha :?

Quelqu'un peut -il m'aider

Code:
[ebuild  N    ] x11-libs/qt-assistant-4.4.2-r1  USE="webkit -debug -pch"
[ebuild     U ] dev-python/PyQt4-4.4.4-r1 [4.3.3] USE="X%* dbus%* opengl%* -qt3support% -svg% -webkit%"
[ebuild     U ] x11-libs/qt-4.4.2 [4.3.3] USE="-qt3support*"
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-assistant-4.4.2-r1, x11-libs/qt-sql-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)



D'avance merci
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Tue Jan 27, 2009 1:02 pm    Post subject: Reply with quote

Salut,

Quote:
[blocks b ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2

Il ne veut pas mettre la 4.4.0_alpha, il te dit que le paquet actuellement installé (<=4.4.0_alpha) bloque le paquet qu'il veut installer (4.4.2)
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Tue Jan 27, 2009 1:47 pm    Post subject: Reply with quote

Hello netfab,

Ok ca me parait plus clair dans ce sens, cependant je comprends tout de même pas pourquoi puisque je n'ai jamais installé la 4.4.0 alpha ^^.
Parcontre c'est bizarre car le sens de compréhension de la phrase me parait plus logique dans l'autre sens pour la ligne :

Code:
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)

Pour moi ca serait plutot le packages 4.3.3 qui bloque qt-core et non pas l'inverse comme pour l'autre

++


Last edited by bouriquo on Tue Jan 27, 2009 1:52 pm; edited 3 times in total
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Tue Jan 27, 2009 1:49 pm    Post subject: Reply with quote

<=4.4.0_alpha (plus petit ou égal à 4.4.0_alpha)
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Tue Jan 27, 2009 1:53 pm    Post subject: Reply with quote

Ok netfab et pour la ligne précédante tu as une explication ?
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Tue Jan 27, 2009 2:56 pm    Post subject: Reply with quote

Et bien emerge t'informe juste que lorsque qt-core sera installé, ce paquet bloquera x11-libs/qt-4.3.3.

Cela parait logique, puisque le paquet qt semble avoir été splité en plusieurs sous-paquets (qt-core, qt-xmlpattern, qt-xxx, qt-yyyy, etc...), et donc les versions les + récentes de qt sont de ce fait incompatibles avec les autres versions du même slot (je parierai sur toutes les versions <=x11-libs/qt-4.4.0_alpha)

Si je me souviens bien, ce blocage apparait en bleu foncé non ? Il me semble que cela n'empêche pas la mise à jour de se faire, ces blocages sont juste là à titre informatif, portage se débrouille tout seul.
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Tue Jan 27, 2009 5:48 pm    Post subject: Reply with quote

Salut Netfab,

Oui c'est bien ça, ça apparait en bleu foncer ...

Merci de ton aide
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum