Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kcometen4 Build fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Thu Jan 29, 2009 2:18 pm    Post subject: kcometen4 Build fails Reply with quote

Hi i am trying to build the kcometen4 screensaver on kde 4.2
I get the following error while compiling
Code:
o CMakeFiles/kcometen4.kss.dir/settings.o CMakeFiles/kcometen4.kss.dir/vec.o  -o kcometen4.kss -rdynamic -L/usr/kde/4.2/lib64 -lkio -lkscreensaver -lQtOpenGL -lGLU -Wl,-rpath,/usr/kde/4.2/lib64:::::::::::::::::::                                     
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lQtOpenGL                       
collect2: ld returned 1 exit status                                                                                         
make[2]: *** [src/kcometen4.kss] Error 1                                                                                     
make[2]: Leaving directory `/var/tmp/portage/kde-misc/kcometen4-1.0.3/work/kcometen4_build'                                 
make[1]: *** [src/CMakeFiles/kcometen4.kss.dir/all] Error 2                                                                 
make[1]: Leaving directory `/var/tmp/portage/kde-misc/kcometen4-1.0.3/work/kcometen4_build'                                 
make: *** [all] Error 2                                                                                                     
 *                                                                                                                           
 * ERROR: kde-misc/kcometen4-1.0.3 failed.                                                                                   
 * Call stack:                                                                                                               
 *               ebuild.sh, line   49:  Called src_compile                                                                   
 *             environment, line 3139:  Called kde4-base_src_compile                                                         
 *             environment, line 2280:  Called kde4-base_src_make                                                           
 *             environment, line 2340:  Called cmake-utils_src_make                                                         
 *             environment, line  801:  Called die                                                                           
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-misc/kcometen4-1.0.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-misc/kcometen4-1.0.3/temp/environment'.

My kde build is with the kdeprefix useflag.
Any idea whats causing this to fail?
Back to top
View user's profile Send private message
user
Tux's lil' helper
Tux's lil' helper


Joined: 08 Feb 2004
Posts: 145

PostPosted: Thu Jan 29, 2009 10:56 pm    Post subject: Reply with quote

Hi shaumux,
compiler hint is here
Code:
...
/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lQtOpenGL   
...

Solution search
Code:
# find /usr/lib64/ -name '*QtOpenGL*'
/usr/lib64/pkgconfig/QtOpenGL.pc
/usr/lib64/qt4/libQtOpenGL.so.4.4.2
/usr/lib64/qt4/libQtOpenGL.so
/usr/lib64/qt4/libQtOpenGL.so.4
/usr/lib64/qt4/libQtOpenGL.prl
/usr/lib64/qt4/libQtOpenGL.la
/usr/lib64/qt4/libQtOpenGL.so.4.4
# equery b /usr/lib64/qt4/libQtOpenGL.so.4.4.2
[ Searching for file(s) /usr/lib64/qt4/libQtOpenGL.so.4.4.2 in *... ]
x11-libs/qt-opengl-4.4.2 (/usr/lib64/qt4/libQtOpenGL.so.4.4.2)

Missing x11-libs/qt-opengl package?
Back to top
View user's profile Send private message
shaumux
l33t
l33t


Joined: 13 May 2005
Posts: 996
Location: Bangalore, India

PostPosted: Fri Jan 30, 2009 12:06 am    Post subject: Reply with quote

I thought so too but i have it installed.
I even tried recompiling it.
Didn't work.
Back to top
View user's profile Send private message
RoeR
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2002
Posts: 99
Location: Vienna, Austria

PostPosted: Mon Nov 22, 2010 12:44 am    Post subject: Reply with quote

Any solution to that?
I ran into the same error (but different program to compile)
Every file is in it's place - but no way to "detect" libQtOpenGL ..
Any hints on that?

regards
RoeR
_________________
Unix is user friendly, it's just very picky about who its friends are.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum