Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems to install amarok using paludis
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Sat Jan 31, 2009 2:53 pm    Post subject: [SOLVED] Problems to install amarok using paludis Reply with quote

Dear all,

since several days I've tried to install amarok-2.0.1.1 using paludis-0.34.1 but
I can't get rid of the below segmentation fault. Any ideas what
might cause this and how to fix it? Thanks a lot!

Code:
paludis -i amarok
Building target list...               
Building dependency list...paludis@1233413458: [WARNING dep_list.ignoring_dependencies] In thread ID '10124':
  ... In program paludis -i amarok:                                                                         
  ... When performing install action from command line:                                                     
  ... When executing install task:                                                                           
  ... When building dependency list:                                                                         
  ... When adding PackageDepSpec 'media-sound/amarok':                                                       
  ... When adding package 'media-sound/amarok-2.0.1.1:2::gentoo':                                           
  ... When adding build dependencies as pre dependencies:                                                   
  ... When adding PackageDepSpec '>=app-misc/strigi-0.5.7':                                                 
  ... When adding installed package 'app-misc/strigi-0.6.3:0::installed':                                   
  ... When adding run dependencies as post dependencies:                                                     
  ... When using new group to resolve dependencies:                                                         
  ... When adding PackageDepSpec 'x11-libs/qt-dbus:4':                                                       
  ... When adding installed package 'x11-libs/qt-dbus-4.4.2:4::installed':                                   
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '~x11-libs/qt-core-4.4.2':
  ... When adding installed package 'x11-libs/qt-core-4.4.2:4::installed':
  ... When adding post dependencies as post dependencies unless under a suggested label:
  ... When adding PackageDepSpec '~x11-libs/qt-gui-4.4.2':
  ... When adding installed package 'x11-libs/qt-gui-4.4.2-r2:4::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'net-print/cups':
  ... When adding installed package 'net-print/cups-1.3.9-r1:0::installed':
  ... When adding post dependencies as post dependencies unless under a suggested label:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec 'net-print/foomatic-filters-ppds':
  ... When adding installed package 'net-print/foomatic-filters-ppds-20080507:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'net-print/foomatic-filters':
  ... When adding installed package 'net-print/foomatic-filters-3.0.20080507:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'virtual/ghostscript':
  ... When adding installed package 'virtual/ghostscript-0:0::installed':
  ... Ignoring run dependencies due to exception 'Block: app-text/ghostscript-gpl' (paludis::BlockError)

DepList additional requirements not met error:
  * In program paludis -i amarok:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'media-sound/amarok':
  * When adding package 'media-sound/amarok-2.0.1.1:2::gentoo':
  * When adding build dependencies as pre dependencies:
  * Inside || ( ) block with other options:
  * When adding PackageDepSpec '>=dev-db/mysql-5.0[embedded,-minimal]':
  * Error searching for '>=dev-db/mysql-5.0[embedded,-minimal]': additional requirements are not met

Additional requirements are as follows:
Segmentation fault

_________________
Please, also have a look at:
Global Marshall Plan Initiative
http://www.globalmarshallplan.org/


Last edited by andyknownasabu on Sun Feb 01, 2009 6:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6308
Location: /usr/lib64/lv2

PostPosted: Sun Feb 01, 2009 5:18 pm    Post subject: Reply with quote

First, is phonon installed? This is what others told me a lot when I first tried messing with Amarok 2 (I stick with pre-2 now as it has some kinks to be worked out).

Second, try - if phonon is installed - using portage and see if that helps.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
andyknownasabu
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 281
Location: Zurich, Switzerland

PostPosted: Sun Feb 01, 2009 6:13 pm    Post subject: Reply with quote

Hi and thanks a lot for your help!
Yes, phonon is installed but I think it was a paludis bug:
After reinstalling dev-db/mysql with the "embedded" use flag everything
works fine, no segmentation fault anymore ;-)
_________________
Please, also have a look at:
Global Marshall Plan Initiative
http://www.globalmarshallplan.org/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum