Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
paludis: basic_filebuf::underflow error reading the file
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
appelgebak
Apprentice
Apprentice


Joined: 12 Sep 2004
Posts: 225
Location: Ruhrpott

PostPosted: Sat Feb 07, 2009 2:05 pm    Post subject: paludis: basic_filebuf::underflow error reading the file Reply with quote

Hi,

today i got a new problem:

Using paludis for query some packages there is a chrash with the error message:

basic_filebuf::underflow error reading the file

Re-installation of paludis works well (with paludis),

but curious behaviour when asking paludis about some packages:
Code:

jupp / # paludis -q knode
* kde-base/knode
    gentoo:                  3.5.9 3.5.10(~) {:3.5} 4.1.4(~) {:4.1} 4.2.0(~) {:4.2}
    installed:               4.2.0* {:4.2}
    kde:
Unhandled exception:
  * basic_filebuf::underflow error reading the file
jupp / #

but:
Code:
jupp / # paludis -q gcc
* sys-devel/gcc
    gentoo:                  (2.95.3-r9)K (2.95.3-r10)K {:2.95} (3.1.1-r2)K {:3.1} (3.2.2)K (3.2.3-r4)K {:3.2} 3.3.6-r1(~) {:3.3} 3.4.6-r2 {:3.4} (4.0.4)K {:4.0} 4.1.0-r1 4.1.2 {:4.1} 4.2.3(~) 4.2.4(~) 4.2.4-r1 {:4.2} (4.3.0)K 4.3.1(~) 4.3.1-r1(~) 4.3.2(~) (4.3.2-r2)U(~) (4.3.2-r3)U(~) (4.3.3)U(~) {:4.3}
    installed:               4.1.2 {:4.1} 4.2.4-r1 {:4.2} 4.3.2* {:4.3}
    layman:                  (4.3.2 (in ::THE))X {:4.3} (4.3.3_pre9999 (in ::dirtyepic))X {:4.3-svn} (4.4.0_pre9999 (in ::dirtyepic))X {:4.4-svn}
    Description:             The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking
    Homepage:                http://gcc.gnu.org/
    License:                 GPL-2 LGPL-2.1
    Installed time:          Sun Dec 21 12:31:58 2008
    Use flags:               (-altivec) (-bootstrap) (-build) (-doc) (-fixed-point) (fortran) (-gcj) (gtk) (-hardened) (-ip28) (-ip32r10k) (-libffi) (mudflap) (-multilib) (-multislot) (-n32) (-n64) (nls) (-nocxx) (-objc) (-objc++) (-objc-gc) (openmp) (-vanilla) (-test)
    From repositories:       gentoo
    Installed using:         paludis-0.32.3

Key to mask reasons:

* K: keyword
* U: user
* X: unavailable
* ~: keyword (unstable accepted)

works well..

Any hints welcome!

Appel
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Feb 07, 2009 3:53 pm    Post subject: Reply with quote

Edit: The problem is the package.mask directory it should be named package.mask.d
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
appelgebak
Apprentice
Apprentice


Joined: 12 Sep 2004
Posts: 225
Location: Ruhrpott

PostPosted: Sat Feb 07, 2009 5:53 pm    Post subject: Reply with quote

loftwyr wrote:
Edit: The problem is the package.mask directory it should be named package.mask.d


Which directory??
My paludis is in:
Code:
jupp paludis # ls -al
insgesamt 116
drwxr-xr-x   3 root root  4096  7. Feb 18:52 .
drwxrwxr-x 100 root root 12288  7. Feb 16:38 ..
-rw-r--r--   1 root root   254 20. Jan 17:13 bashrc
-rw-r--r--   1 root root    96 23. Aug 15:17 environment.conf
-rw-r--r--   1 root root  5486 27. Sep 10:53 kde
-rw-r--r--   1 root root 42756  1. Feb 15:22 keywords.conf
-rw-r--r--   1 root root   104 23. Aug 14:27 licenses.conf
-rw-r--r--   1 root root   345 24. Jan 18:19 mirrors.conf
-rw-r--r--   1 root root   412  2. Feb 19:28 package_mask.conf
-rw-r--r--   1 root root 13607 27. Jan 19:40 package_unmask.conf
-rw-r--r--   1 root root   195 23. Aug 15:25 paludis-overlay.conf
drwxr-xr-x   2 root root  4096  1. Feb 14:31 repositories
-rw-r--r--   1 root root  3249  1. Feb 15:4
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Feb 07, 2009 6:18 pm    Post subject: Reply with quote

Sorry, the profiles/package.mask file in the kde-testing overlay should be named package.mask.d

You'll then have to put the two files in the directory in your package.mask.conf.d with .conf extensions.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
appelgebak
Apprentice
Apprentice


Joined: 12 Sep 2004
Posts: 225
Location: Ruhrpott

PostPosted: Sat Feb 07, 2009 7:07 pm    Post subject: Reply with quote

Thanks, after deleting kde-testing work can go on...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum