Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] kde4.2 akonadi-server-1.1.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Sun Feb 08, 2009 5:48 pm    Post subject: [SOLVED] kde4.2 akonadi-server-1.1.1 Reply with quote

Hello,

I am attempting to install kdebase-startkde-4.2 and am having and issue with akonadi-server-1.1.1. The build log is below. I am using gcc-4.3.3. Is there away of setting boost to have it detected properly

Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found shared-mime-info version: 0.30
CMake Error at /usr/share/cmake/Modules/FindBoost.cmake:620 (message):
Unable to find the requested Boost libraries.

Boost version: 1.35.0

Boost include path: /usr/include/boost-1_35

The following Boost libraries could not be found:

boost_program_options

No Boost libraries were found. You may need to set Boost_LIBRARYDIR to the
directory containing Boost libraries or BOOST_ROOT to the location of
Boost.
Call Stack (most recent call first):
CMakeLists.txt:38 (find_package)


CMake Error at CMakeLists.txt:40 (message):
Akonadi requires the Boost C++ libraries.


-- Configuring incomplete, errors occurred!
*
* ERROR: app-office/akonadi-server-1.1.1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_configure
* environment, line 3004: Called cmake-utils_src_configure
* environment, line 706: Called cmake-utils_src_configureout
* environment, line 725: Called die
* The specific snippet of code:
* cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";
* The die message:
* Cmake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/app-office/akonadi-server-1.1.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-office/akonadi-server-1.1.1/temp/environment'.
*

>>> Failed to emerge app-office/akonadi-server-1.1.1, Log file:

>>> '/var/tmp/portage/app-office/akonadi-server-1.1.1/temp/build.log'

* Messages for package app-office/akonadi-server-1.1.1:

*
* ERROR: app-office/akonadi-server-1.1.1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_configure
* environment, line 3004: Called cmake-utils_src_configure
* environment, line 706: Called cmake-utils_src_configureout
* environment, line 725: Called die
* The specific snippet of code:
* cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" || die "Cmake failed";
* The die message:
* Cmake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/app-office/akonadi-server-1.1.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-office/akonadi-server-1.1.1/temp/environment'.
*

Jut24


Last edited by jut24 on Mon Feb 09, 2009 6:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
skazi
Apprentice
Apprentice


Joined: 01 Oct 2004
Posts: 219
Location: Cieszyn/Poland

PostPosted: Sun Feb 08, 2009 6:29 pm    Post subject: Reply with quote

Code:
Unable to find the requested Boost libraries.

Boost version: 1.35.0

Boost include path: /usr/include/boost-1_35

The following Boost libraries could not be found:

boost_program_options

No Boost libraries were found.

emerge -v boost
Back to top
View user's profile Send private message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Sun Feb 08, 2009 7:15 pm    Post subject: kde 4.2 akonadi server Reply with quote

Hi,
Here is the output of emerge -v boost
~ # emerge -pv boost
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] dev-libs/boost-1.35.0-r4 USE="mpi -debug -doc -expat -icu -tools" 0 kB


Thanks,

jut24
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sun Feb 08, 2009 7:24 pm    Post subject: Reply with quote

reinstall it anyway, it likely will fix the problem.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Sun Feb 08, 2009 7:36 pm    Post subject: kde-4.2 akonadi-server-1.1.1 Reply with quote

Hello,

I reinstalled boost and I still get the same error any other suggestions?
Thanks,

Jut24
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Sun Feb 08, 2009 10:40 pm    Post subject: Re: kde-4.2 akonadi-server-1.1.1 Reply with quote

jut24 wrote:
Hello,

I reinstalled boost and I still get the same error any other suggestions?
Thanks,

Jut24


Just try boost with all useflags, i cant recall but one package wanted expat useflag... just try :wink:
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Mon Feb 09, 2009 6:51 pm    Post subject: [CLOSE]akonadi server-1.1.1 Reply with quote

Hi,
Thanks, to everyone for the help I tried all the suggestions to no avail, I just skipped akonadi server and continued the kde-4.2 install seems to be okay so far. If anyone knows a way to install akonadi server I would appreciate the solution.

Jut
Back to top
View user's profile Send private message
doctork
Guru
Guru


Joined: 25 Apr 2004
Posts: 370
Location: Cleveland, OH

PostPosted: Mon Feb 09, 2009 8:23 pm    Post subject: Reply with quote

You need to add dev-libs/boost and dev-util/boost-build to /etc/portage/package.keywords and reemerge.

doc
Back to top
View user's profile Send private message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Tue Feb 10, 2009 4:01 pm    Post subject: akonadi server Reply with quote

Hi,

I recompiled boost and boost-build and still I get the same error. Just an update after recompiling I did an eselect boost set 1(index of version of boost I installed) to set boost and now it works fine.

Thanks for every ones help,

Jut :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum