Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
postgis
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
stevekatona
n00b
n00b


Joined: 03 Oct 2008
Posts: 8

PostPosted: Thu Feb 12, 2009 5:44 am    Post subject: postgis Reply with quote

i am having trouble trying to emerge postgis. when emerging, there is a dependency for postgres 8.0.15. I need postgres to be greater than 8.1 (which is in portage), but postgis will attempt to downgrade postgres when emerged.

when i attempt to use package.mask for postgresql 8.0.15, the dependency invokes postgresql 7.4.19!

is there some way i can build postgis 1.3.3 with postgresql 8.2.7.
Back to top
View user's profile Send private message
stevekatona
n00b
n00b


Joined: 03 Oct 2008
Posts: 8

PostPosted: Thu Feb 12, 2009 6:10 am    Post subject: Reply with quote

after a bit of hunting around, i solved it myself.

postgis depends upon the virtual/postgresql-server ebuild. for some reason emerging postgresql doesn't invoke an emerge of virtual/postgresql-server ebuild. so when postgis is emerged and sees virtual/postgresql-server at version 8.0, it attempts to build postgis against 8.0. so it attempts to downgrade packages (grrrrr).

by emerging virtual/postgresql-server to my installed version (8.2) all my problems are solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum