Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kms modsetting problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jut24
n00b
n00b


Joined: 14 Nov 2007
Posts: 20

PostPosted: Thu Feb 12, 2009 10:38 pm    Post subject: kms modsetting problem Reply with quote

Hello,
I just compiled vanilla-source-2.6.29-rc4 with kms enabled. Gentoo boots successfully but at the kdm login window the resolution does not appear to be right. The screen only displays a part of kdm but when I log in it displays the resolution correctly. I was wondering if there is a fix for this. My system uses xf86-video-intel-2.6.1 libdrm-2.4.4 xorg-server-1.6 r2, have an intel 945gm video card.

Any suggestions would be appreciated.

Jut
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Mon Feb 16, 2009 9:56 pm    Post subject: Reply with quote

I got the same probleme here, it's like the resolution is 1280x1280 but only the top 1280x800 is display.
kernel is 2.6.28-rc4 form git, xorg-server is 1.5.99.902 from x11 overlay and xf86-video-intel is 2.6.1 from x11 overlay.

it seems the cursor can be move on the hidden part of the screen, but the resolution report by xrandr is OK.
for now I disable, it with i915.modeset=0 in grub.conf


also, I noticed serious performance problem, the processor was use at 100% when switching desktop (e17) and redrawing xterm is really slow.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Mon Feb 16, 2009 10:39 pm    Post subject: Reply with quote

If you have kms enabled in the kernel you need to be using an X driver that supports kms. If you are using intel kms try using the git xf86-video-intel driver. You probably also need libdrm from git and possibly mesa from git.
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Tue Feb 17, 2009 4:32 pm    Post subject: Reply with quote

for me, libdrm and mesa are 9999 from x11 overlay
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Feb 17, 2009 5:17 pm    Post subject: Reply with quote

math_roc wrote:
for me, libdrm and mesa are 9999 from x11 overlay


well then this is where you should probably go on IRC and talk to the devs in #intel-gfx
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Mon Feb 23, 2009 10:46 pm    Post subject: Reply with quote

with kernel 2.6.29-rc6 and last svn mesa, the resolution problem is solved.
still have the performance/cpu usage issue
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Sun Apr 12, 2009 9:29 am    Post subject: Reply with quote

math_roc wrote:
I got the same probleme here, it's like the resolution is 1280x1280 but only the top 1280x800 is display.
kernel is 2.6.28-rc4 form git, xorg-server is 1.5.99.902 from x11 overlay and xf86-video-intel is 2.6.1 from x11 overlay.

it seems the cursor can be move on the hidden part of the screen, but the resolution report by xrandr is OK.
for now I disable, it with i915.modeset=0 in grub.conf


also, I noticed serious performance problem, the processor was use at 100% when switching desktop (e17) and redrawing xterm is really slow.

i had a slow xterm too, everything else was working fine.
minutes ago i switched from xf86-video-intel-2.6.3-r1 to 2.6.99.903 (renamed the .902 ebuild from the x11 overlay) and xterm is fast now.
just wanted to let you know.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum