Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Paludis and phonon block
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hurvajs
n00b
n00b


Joined: 31 Mar 2007
Posts: 3
Location: Czech republic, Prague

PostPosted: Tue Feb 17, 2009 7:10 am    Post subject: Paludis and phonon block Reply with quote

Hi guys,
I've a problem with Paludis and installing KDE 4.2. In the past I used KDE 3.5. Now I would like to upgrade to KDE 4, after unmerging all KDE 3.5 packages and fail try KDE4 instalation. I was unfortunate in this situation.

Can someone advise me, please? Thanks

Paludis finish with this:
Code:
spejbl ~ # paludis -pi kde-base/kdebase-startkde kde-base/kde-meta
Building target list...
Building dependency list...
Dependency error:
  * In program paludis -pi kde-base/kdebase-startkde kde-base/kde-meta:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'kde-base/kdebase-startkde':
  * When adding package 'kde-base/kdebase-startkde-4.2.0:4.2::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '>=kde-base/kdelibs-4.2.0[-kdeprefix]':
  * When adding package 'kde-base/kdelibs-4.2.0-r2:4.2::gentoo':
  * When adding build dependencies as pre dependencies:
  * When checking BlockDepSpec '!x11-libs/qt-phonon':
  * Block: x11-libs/qt-phonon (paludis::BlockError)
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5617
Location: Removed by Neddy

PostPosted: Tue Feb 17, 2009 12:47 pm    Post subject: Reply with quote

I'm not use to paludis's output but that looks like the package qt-phonon is blocking kdelibs

emerge -C qt-phonon and try again. There is an explicit: !x11-libs/qt-phonon in the ebuild

phonon has moved to: media-sound/phonon
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Tue Feb 17, 2009 2:39 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Tue Feb 17, 2009 10:05 pm    Post subject: Reply with quote

Naib wrote:
phonon has moved to: media-sound/phonon

That's not exactly right. There are two versions of phonon in portage: x11-libs/qt-phonon, which is the phonon module included in Qt4, and media-sound/phonon, which is the version from KDE. Obviously, KDE needs media-sound/phonon, and for that reason blocks the alternative version from Qt.

But if you have x11-libs/qt without defined slot in your world file, then this would pull in the qt-4 meta ebuild, which (using the testing branch) would prefer the qt-phonon package. You can circumvent this by installing media-sound/phonon first.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
hurvajs
n00b
n00b


Joined: 31 Mar 2007
Posts: 3
Location: Czech republic, Prague

PostPosted: Fri Feb 20, 2009 6:10 am    Post subject: Reply with quote

Thank you for the hints, resolved :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum