Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[DELUGE] crash au demarrage (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nOps34
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2006
Posts: 105
Location: France - Montpellier

PostPosted: Thu Feb 19, 2009 11:37 am    Post subject: [DELUGE] crash au demarrage (résolu) Reply with quote

Salut,
deluge crash au demarrage, voici le rapport d'erreur:
Code:
System: Linux 2.6.26-gentoo-r1 #1 SMP Fri Sep 12 11:06:54 CEST 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Glossy
Icon Theme: gnome

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



----------- .xsession-errors (288 sec old) ---------------------
** Message: another SSH agent is running at: /tmp/ssh-tVftR14864/agent.14864
Window manager warning: Failed to read saved session file /home/nops/.metacity/sessions/default0.ms: Failed to open file '/home/nops/.metacity/sessions/default0.ms': No such file or directory
Failed to play sound: File or data not found
Unable to open desktop file /usr/share/applications/lastfm-lastfmplayer.desktop for panel launcher: No such file or directory
** (nautilus:14999): WARNING **: Unable to add monitor: Not supported
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.
1.1.3
python: cairo.c:87: _cairo_error: Assertion `(status != CAIRO_STATUS_SUCCESS && status <= CAIRO_STATUS_INVALID_WEIGHT)' failed.
terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check
CalDAV Eplugin starting up ...
** (evolution:15099): DEBUG: mailto URL command: evolution %s
** (evolution:15099): DEBUG: mailto URL program: evolution


j'avoue que ça dépasse mes compétences..! :?


Last edited by nOps34 on Fri Feb 20, 2009 8:46 am; edited 2 times in total
Back to top
View user's profile Send private message
fb99
l33t
l33t


Joined: 09 Apr 2003
Posts: 998
Location: Le Locle (Suisse,Neuchâtel)

PostPosted: Thu Feb 19, 2009 7:53 pm    Post subject: Reply with quote

[quoteu]Window manager warning: Failed to read saved session file /home/nops/.metacity/sessions/default0.ms: Failed to open file '/home/nops/.metacity/sessions/default0.ms': No such file or directory[/quote]

est-ce que ce fichier existe ?

et puis c'est pas le messages complet ? (var/log/Xorg.0.log)

sinon il faut que tu teste les choses une par une:

- on dirait que certain fichier n'existe pas ?
- on dirait aussi que nvidia n'est pas charger ? changement de noyau ? est-ce que si tu met les drivers nv dans ton xorg.conf ça marche ?
- arrive -tu à lancer x tout seul (startx).

poste-nous ton xorg.conf , le message complet de Xorg.0.log, les autres log éventuellement,
et pour finir qu'as-tu fait dernièrement (mise à jour, ... )
_________________
L'ami aime en tout temps, et dans le malheur il se montre un frère ( Prov. 17,17 )
L'insensé même, quand il se tait, passe pour sage ( Prov. 17;28a )
Back to top
View user's profile Send private message
nOps34
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2006
Posts: 105
Location: France - Montpellier

PostPosted: Fri Feb 20, 2009 8:40 am    Post subject: Reply with quote

Aucun soucis avec X.
je pense que le noeud du problème est ici:

Code:
nops@casa ~ $ deluge
1.1.3
python: cairo.c:87: _cairo_error: Assertion `(status != CAIRO_STATUS_SUCCESS && status <= CAIRO_STATUS_INVALID_WEIGHT)' failed.
terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check



je n'ai pas d'erreur majeure en rapport avec deluge dans le Xorg.0.log:

Code:
nops@casa ~ $ sudo cat /var/log/Xorg.0.log | grep WW
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) Duplicate core pointer devices.  Removing core pointer attribute from "MX Revolution"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(WW) NVIDIA(GPU-0): Unable to read EDID for display device CRT-0


Il me semble que cela provient de cairo, j'ai testé avec les versions 1.8.6 et 1.8.4, je vais tester la 1.8.0
(le problème est survenu après une grosse mise à jour)


Last edited by nOps34 on Fri Feb 20, 2009 8:45 am; edited 1 time in total
Back to top
View user's profile Send private message
nOps34
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2006
Posts: 105
Location: France - Montpellier

PostPosted: Fri Feb 20, 2009 8:44 am    Post subject: Reply with quote

Le retour à la version 1.8.0 de cairo a solutionné le problème. :D
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Fri Feb 20, 2009 9:00 am    Post subject: Reply with quote

Salut.

hors sujet, mais:
Quote:
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.

semble indiquer que tu n'est pas dans le groupe video, donc à vérifier:

Code:
$ groups
disk wheel uucp cron audio cdrom video games usb users portage plugdev qemu vboxusers

$ ls /dev/nvidia* -l
crw-rw---- 1 root video 195,   0 fév 20 09:44 /dev/nvidia0
crw-rw---- 1 root video 195, 255 fév 20 09:44 /dev/nvidiactl


et pour t'ajouter:
Code:
$ gpasswd -a user video

puis re-connection de l'utilisateur pour mettre à jour les groupes

Bruno.
Back to top
View user's profile Send private message
nOps34
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2006
Posts: 105
Location: France - Montpellier

PostPosted: Fri Feb 20, 2009 12:01 pm    Post subject: Reply with quote

bien vu!
effectivement, je n'étais pas dans le groupe video.
j'ai modifié directement dans /etc/group
ceci dit, ma machine tournait correctement même sans cet ajout. Bizarre ou normal :?:
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8132
Location: ~Brussels - Belgique

PostPosted: Fri Feb 20, 2009 1:05 pm    Post subject: Reply with quote

normal : une machine ne va pas fonctionner bizarrement à cause du fait qu'un utilisateur n'est pas dans le bon groupe (surtout si c'est un utilisateur "normal" pour un groupe "hardware")
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Fri Feb 20, 2009 1:32 pm    Post subject: Reply with quote

Oui c'est juste, mais si il ne fait pas partie du groupe video, il n'aura pas l'accélération matériel du driver nvidia, du coup toutes applications utilisant opengl ne marcheront pas, cependant la partie 2D fonctionnera, c'est tout de même étonnant un tel découpage des droits ^^
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8132
Location: ~Brussels - Belgique

PostPosted: Fri Feb 20, 2009 1:38 pm    Post subject: Reply with quote

Welcome to UNIX ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
bouriquo
Guru
Guru


Joined: 29 May 2004
Posts: 304
Location: Collonges (01)

PostPosted: Fri Feb 20, 2009 2:02 pm    Post subject: Reply with quote

Merci merci :lol: :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum