Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server-1.6 and xf86-video-intel-2.6.2 please :D
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Wed Feb 25, 2009 9:30 pm    Post subject: xorg-server-1.6 and xf86-video-intel-2.6.2 please :D Reply with quote

They're out:
http://www.phoronix.com/scan.php?page=article&item=xorg_server_16&num=1
http://www.phoronix.com/scan.php?page=news_item&px=NzA5MA
Please, please, please put an ebuild at least in the x11 overlay :)
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Wed Feb 25, 2009 9:35 pm    Post subject: Reply with quote

You beat me to it, you did. Muaaaaa ...
So someone else loves to hang around phoronix. :P
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Wed Feb 25, 2009 9:36 pm    Post subject: Reply with quote

I hope this means faster video on my intel machines. I've been working backwards through xorg-server and xf86-intel-video to find the best combination for speed.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Wed Feb 25, 2009 9:38 pm    Post subject: Reply with quote

rahulthewall wrote:
You beat me to it, you did. Muaaaaa ...
So someone else loves to hang around phoronix. :P
I don't really hang around...it's not OTW :D But I do drop in fairly often ;]
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Thu Feb 26, 2009 6:15 am    Post subject: Reply with quote

The new server is in x11 :)

Now just waiting for the intel driver ;]
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Thu Feb 26, 2009 9:45 am    Post subject: Reply with quote

szczerb wrote:
The new server is in x11 :)

Now just waiting for the intel driver ;]


x11 where? git i guess. not in portage.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Feb 26, 2009 9:56 am    Post subject: Reply with quote

szczerb is referring to the x11 overlay, if that´s what you are asking for.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Thu Feb 26, 2009 11:50 am    Post subject: Reply with quote

http://dberkholz.wordpress.com/2009/02/26/xorg-server-16-preview-in-x11-overlay/
Quote:
To compete with Remi’s post about getting xorg-server 1.5.3 stable in Gentoo, here’s one about getting xorg-server 1.6, which was released today, into testing in the main tree. We’ve been maintaining the 1.6 release candidates in the x11 overlay for a while now. Tonight I added the final release to the overlay. What’s left before it can move to the main tree? Here’s what I can think of, offhand:
The new XRandR stuff needs to get released upstream (randrproto, libXrandr, xrandr). Right now we’ve got the xrandr userland tool depending on live git of libXrandr, which won’t work for the main tree.
We need to sort out the issue with XCB’s Xlib library renaming forcing recompiles of practically everything. This is becoming more and more of a blocker because now libXext 7.0.5 requires a new libX11. I think giving ourselves a hard blocker on 1.6 from this will help us get it fixed. See bug #248743 to track progress on this.
The server now has a fix to keep looking for HAL if it’s not running when started. Should we change /etc/init.d/xdm to compensate for this change by no longer depending on hald, thus allowing gdm/kdm/etc to start earlier? This will give us one of the steps taken by the fastboot work seen lately in Moblin and elsewhere.
I think Remi’s going to add xf86-video-intel 2.6.2.
Our xinit is crazy stale, mainly because we patch it like crazy and I don’t like porting those. I’d like to get it updated to a current release for 1.6. In the longer term, we need to merge distro-neutral parts of our work upstream, but that’s not a 1.6 blocker.

To sum up, you can try xorg-server 1.6 now by adding the x11 overlay with layman, or you can wait for the above issues to get solved, and it will show up soon in testing in your main tree.
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Fri Feb 27, 2009 12:51 am    Post subject: Reply with quote

Awesome, I hope this might improve the performance of my intel gma 4500 chip as it is doing pretty horribly right now
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Fri Feb 27, 2009 4:33 am    Post subject: Reply with quote

Anyone else unable to emerge randrproto-1.2.99.4?

Getting 404's from all the servers on that one when trying to emerge xorg-server-1.6.0


edit: got randrproto from a different location and installed it, now emerge fails on inputproto-9999 saying xorg-macros.m4 is too old
Code:
> checking if xorg-macros used to generate configure is at least 1.2... configure: error: configure built with too old of a version of xorg-macros.m4 - requires version 1.1.0 or newer


any ideas?

couldnt really find much on this elsewhere
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5387

PostPosted: Fri Feb 27, 2009 7:40 am    Post subject: Reply with quote

0000000000000 wrote:
Anyone else unable to emerge randrproto-1.2.99.4?

Getting 404's from all the servers on that one when trying to emerge xorg-server-1.6.0


edit: got randrproto from a different location and installed it, now emerge fails on inputproto-9999 saying xorg-macros.m4 is too old
Code:
> checking if xorg-macros used to generate configure is at least 1.2... configure: error: configure built with too old of a version of xorg-macros.m4 - requires version 1.1.0 or newer


any ideas?

couldnt really find much on this elsewhere


how I see it, the logical solution is to emerge latest m4 version and then emerge latest util-macros version and then retry emerging inputproto
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
pdw_hu
Apprentice
Apprentice


Joined: 02 Jun 2008
Posts: 200
Location: Budapest, Hungary

PostPosted: Fri Feb 27, 2009 3:09 pm    Post subject: Reply with quote

Does 2.6.2 work for anyone? My X just segfaults pointing to the intel driver, as foretold by the postinst message of the intel driver.
Back to top
View user's profile Send private message
mrsaccess
n00b
n00b


Joined: 03 Sep 2005
Posts: 30
Location: Greece

PostPosted: Fri Feb 27, 2009 3:36 pm    Post subject: Reply with quote

I tried 2.6.2 on xorg-server 1.5.3-r2. Painful experience. I had to do an interactive boot in order to avoid xdm loading so I could get to a console and revert to the bad yet working at least in some ways 2.6.1. :(

Card X3100 (GM965 that is I think).
_________________
Hardware: The parts of your pc you can kick.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Feb 27, 2009 4:31 pm    Post subject: Reply with quote

mrsaccess wrote:
I tried 2.6.2 on xorg-server 1.5.3-r2. Painful experience. I had to do an interactive boot in order to avoid xdm loading so I could get to a console and revert to the bad yet working at least in some ways 2.6.1. :(

Card X3100 (GM965 that is I think).


You might want to work backwards with xorg-server and the intel driver until you come across a combination that works well for your system, then freeze it with package.*.

I did this once and had the right combo. Now I've lost it. :(
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Fri Feb 27, 2009 4:53 pm    Post subject: Reply with quote

audiodef wrote:
mrsaccess wrote:
I tried 2.6.2 on xorg-server 1.5.3-r2. Painful experience. I had to do an interactive boot in order to avoid xdm loading so I could get to a console and revert to the bad yet working at least in some ways 2.6.1. :(

Card X3100 (GM965 that is I think).


You might want to work backwards with xorg-server and the intel driver until you come across a combination that works well for your system, then freeze it with package.*.

I did this once and had the right combo. Now I've lost it. :(


going backwards never helps anything in the long run, make sure you have xorg 1.6, latest intel driver, and latest libdrm with matching kernel drm module, then go to #intel-gfx and talk to the devs to fix any regressions
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Feb 27, 2009 5:49 pm    Post subject: Reply with quote

rmh3093 wrote:

going backwards never helps anything in the long run, make sure you have xorg 1.6, latest intel driver, and latest libdrm with matching kernel drm module, then go to #intel-gfx and talk to the devs to fix any regressions


I agree with this in theory, but in practice, machines are different and run best with different versions and configurations. I would like to run the latest everything, but the reality of machines is, like with humans, requirements are different for different machines. Also, I speak from experience. The latest xorg and intel drivers just don't always run the fastest or smoothest on certain machines, no matter how you tweak it.

Having said that, I'm all for developers being receptive to input and trying to make their software work for as many machines as possible.

What is comes down to is "whatever works is right".
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Fri Feb 27, 2009 6:05 pm    Post subject: Reply with quote

I just tried it and it's a bit better (Xv works) but still crap. Suspend hangs, hibernation hangs, compiz hangs, 3d games hang. I'm sticking with 1.5.3-r2 and 2.5.1-r1 until x11-7.5
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Sat Feb 28, 2009 2:57 am    Post subject: Reply with quote

just installed xorg-server-1.6.0 and xf86-video-intel-9999 and along with anholt's drm-intel kernel, all is working really smooth now when previously compiz was an unusable lag

even motion blur works now


oh, this is on an intel gma 4500 chip with the i915 kernel module

=^_^=
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Sat Feb 28, 2009 5:09 am    Post subject: Reply with quote

audiodef wrote:
rmh3093 wrote:

going backwards never helps anything in the long run, make sure you have xorg 1.6, latest intel driver, and latest libdrm with matching kernel drm module, then go to #intel-gfx and talk to the devs to fix any regressions


I agree with this in theory, but in practice, machines are different and run best with different versions and configurations. I would like to run the latest everything, but the reality of machines is, like with humans, requirements are different for different machines. Also, I speak from experience. The latest xorg and intel drivers just don't always run the fastest or smoothest on certain machines, no matter how you tweak it.

Having said that, I'm all for developers being receptive to input and trying to make their software work for as many machines as possible.

What is comes down to is "whatever works is right".


im not saying use latest because its faster, im saying use latest because that is what is currently being worked on by the developers, if everyone used older versions then bugs and regressions like this would never be fixed because the people who discover them just go back to using what worked better in the past, the developers wouldnt release code it didnt pass tests on their own development boxes
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Sat Feb 28, 2009 8:06 am    Post subject: Reply with quote

0000000000000 wrote:
anholt's drm-intel kernel
Is this available in any overlay?
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 249

PostPosted: Sat Feb 28, 2009 5:24 pm    Post subject: Reply with quote

I have a working KMS laptop with 2.6.29-rc6, xorg-server-1.6, xf86-video-intel-2.6.2, but I don't have a fbconsole. I mean, I can switch fast to a fbconsole, but I only get a distorsion in the screen. When I sitch back to VT7 I have my screen right. Does anyone knows about it? I suspect of my kernel configuration.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Sat Feb 28, 2009 9:32 pm    Post subject: Reply with quote

rmh3093 wrote:

im not saying use latest because its faster, im saying use latest because that is what is currently being worked on by the developers, if everyone used older versions then bugs and regressions like this would never be fixed because the people who discover them just go back to using what worked better in the past, the developers wouldnt release code it didnt pass tests on their own development boxes


I just rebuilt one of my machines, and I'm going to side with you on this one. I'm using ~arch and I plan to try to get it working with the latest therefrom. :D
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
pdw_hu
Apprentice
Apprentice


Joined: 02 Jun 2008
Posts: 200
Location: Budapest, Hungary

PostPosted: Sat Feb 28, 2009 10:28 pm    Post subject: Reply with quote

cruzki123 wrote:
I have a working KMS laptop with 2.6.29-rc6, xorg-server-1.6, xf86-video-intel-2.6.2, but I don't have a fbconsole. I mean, I can switch fast to a fbconsole, but I only get a distorsion in the screen. When I sitch back to VT7 I have my screen right. Does anyone knows about it? I suspect of my kernel configuration.


Works fine for me. Same userspace, amd64.

One minor problem is that `xset dpms force off` doesn't work for some reason. Did anyone experience this? Solutions?
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Sat Feb 28, 2009 11:22 pm    Post subject: Reply with quote

szczerb wrote:
0000000000000 wrote:
anholt's drm-intel kernel
Is this available in any overlay?

Code:
git clone git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel
cd drm-intel
make menuconfig
etc...


I also added:
Code:
Load "dri2"
to Section "Module"
and
Code:
Option "DRI2" "true"
Option "AccelMethod" "UXA"
Option "Tiling" "no"
to Section "Device"
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Sun Mar 01, 2009 10:24 am    Post subject: Reply with quote

Code:
One minor problem is that `xset dpms force off` doesn't work for some reason. Did anyone experience this? Solutions?


Got the same problem, allthough xorg.log says, it loaded dpms ok. xbacklight doesn't work, either. I've got this problem with my sony-laptop, according to some googleing, the problem is known and results from changes in the .29-rcX kernel, so should be fixed with the final .29 (I hope!).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum