Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zynaddsubfx in pro-audio fails to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6312
Location: /usr/lib64/lv2

PostPosted: Thu Mar 05, 2009 2:52 am    Post subject: Zynaddsubfx in pro-audio fails to emerge Reply with quote

I'm sorry to post outside the pro-audio thread, but I have the last 2 posts there. I don't think anybody is reading it any more.

Anyway, zynaddsubfx fails with this:

Code:

make[1]: fluid: Command not found
make[1]: *** [WidgetPDial.cc] Error 127
make[1]: Leaving directory `/var/tmp/portage/media-sound/zynaddsubfx-20070707-r1/work/ZynAddSubFX-20070707/src/UI'
make: *** [all] Error 2
 *
 * ERROR: media-sound/zynaddsubfx-20070707-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2347:  Called die
 * The specific snippet of code:
 *       emake -j1 ${myconf} || die "make failed with this options: ${myconf}";
 *  The die message:
 *   make failed with this options: FFTW_VERSION=3 ASM_F2I=YES LINUX_MIDIIN=ALSA LINUX_AUDIOOUT=JACK LINUX_USE_LASH=YES LINUX_USE_JACKMIDI=YES
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-sound/zynaddsubfx-20070707-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/zynaddsubfx-20070707-r1/temp/environment'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/local/portage/layman/pro-audio/eclass/exteutils.eclass
 *   /usr/local/portage/layman/pro-audio/eclass/jackmidi.eclass
 * This ebuild is from an overlay named 'proaudio': '/usr/local/portage/layman/pro-audio/'
 

_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
dotkev
n00b
n00b


Joined: 18 Aug 2009
Posts: 1
Location: Lyon

PostPosted: Sat Aug 22, 2009 12:13 pm    Post subject: Reply with quote

I had the same issue today morning and found this thread unanswered, so I here's the workaround I found.

I'm on gentoo ~x86 with pro-audio, freshly installed this week.
(It's my first try with gentoo, so I may be telling some crap.)

Fluid is the interface builder for FLTK, on my computer I had only FLTK version 2.0 and its interface builder called fluid2.
I first tried to
Code:
ln -s /usr/bin/fluid2 /usr/bin/fluid

but unsurprisingly it didn't work, so I installed the latest fltk-1.1.9 (1.1.7 versions asked for a glibc downgrade)
Code:
emerge -a =x11-libs/fltk-1.1.9-r1

then I tried to emerge Zyn again... and it worked.
Back to top
View user's profile Send private message
hurricane
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 107

PostPosted: Sun Jan 03, 2010 7:35 am    Post subject: Reply with quote

Guys, have you looked at the freakin’ version?? That thing is from 2007!

I had to mask >=media-sound/zynaddsubfx-2000. But hey, the 2.4.0 ebuild from pro-audio is also reeealy buggy! Can’t install shit. I had to force the normal portage one being installed.

But pff… I have worked with things like Absynth, Reaktor, Reason, etc… And zynadsubfx is utter crap!
Neither the interface, the effects or the sound quality are remotely acceptable. What a shame. I thought it would be cool synth like those from Native Instruments. :(

I don’t think there is any chance I can switch from my Windows DAW setup to Linux anytime soon. Which is sad. :/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum