Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skype breaks on libstdc++ under 'hardened' profile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
ial
Apprentice
Apprentice


Joined: 27 Dec 2008
Posts: 161
Location: Warsaw (Warszawa)

PostPosted: Thu Mar 05, 2009 4:54 pm    Post subject: Skype breaks on libstdc++ under 'hardened' profile Reply with quote

I have installed/emerged the Skype. It fails to run. When run
in e.g. xterm it yields the following output:
Code:
/opt/skype/skype: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /opt/skype/skype)
/opt/skype/skype: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by /opt/skype/skype)

The system isn't too much fresh, it has 4 years long history. But it
has been systematically updated.
The system's profile is 'hardened':
Code:
 # eselect profile list
Available profile symlink targets:
  [1]   hardened/x86/2.6 *
what prohibits upgrade to gcc-4* version...
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2674
Location: here, there or in transit

PostPosted: Thu Mar 05, 2009 7:19 pm    Post subject: Reply with quote

Moved from Portage & Programming to Other Things Gentoo.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
zorry
Developer
Developer


Joined: 30 Mar 2008
Posts: 380
Location: Umeå The north part of scandinavia

PostPosted: Fri Mar 06, 2009 12:24 am    Post subject: Re: Skype breaks on libstdc++ under 'hardened' profile Reply with quote

ial wrote:
I have installed/emerged the Skype. It fails to run. When run
in e.g. xterm it yields the following output:
Code:
/opt/skype/skype: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /opt/skype/skype)
/opt/skype/skype: /usr/lib/gcc/i686-pc-linux-gnu/3.4.6/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by /opt/skype/skype)

The system isn't too much fresh, it has 4 years long history. But it
has been systematically updated.
The system's profile is 'hardened':
Code:
 # eselect profile list
Available profile symlink targets:
  [1]   hardened/x86/2.6 *
what prohibits upgrade to gcc-4* version...

The Hardened gcc 4 is unstable and we still test it.
_________________
gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1)
Back to top
View user's profile Send private message
ial
Apprentice
Apprentice


Joined: 27 Dec 2008
Posts: 161
Location: Warsaw (Warszawa)

PostPosted: Fri Mar 06, 2009 3:16 am    Post subject: Re: Skype breaks on libstdc++ under 'hardened' profile Reply with quote

zorry wrote:
The Hardened gcc 4 is unstable and we still test it.

But is gcc 4 necessary for Skype to work?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum