Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.2 partly hard masked on Funtoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ChianasGeek
n00b
n00b


Joined: 13 Nov 2004
Posts: 45
Location: United Kingdom

PostPosted: Thu Mar 05, 2009 6:54 pm    Post subject: KDE 4.2 partly hard masked on Funtoo Reply with quote

As the topic says - anyone have any idea why?

Code:

chiana ~ # cat /etc/portage/package.unmask/kdebase-4.2
kde-base/kdebase-data:4.2
kde-base/kdelibs:4.2
kde-base/kdepimlibs:4.2
kde-base/plasma-workspace:4.2


Also, I've gone this far and it still complains but now about akonadi-server needing USE=mysql, so I don't know if there's other hard-masked packages. (Yet!)
TIA :)
_________________
Chiana's Geek :)
"We are Grey. We stand between the candle and the star."
(Backup Jabber ID: chianasgeek@xmpp.org.uk)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 06, 2009 1:24 am    Post subject: Reply with quote

Don't know, I will ask on the Funtoo IRC channel.
Back to top
View user's profile Send private message
ChianasGeek
n00b
n00b


Joined: 13 Nov 2004
Posts: 45
Location: United Kingdom

PostPosted: Fri Mar 06, 2009 11:25 am    Post subject: Reply with quote

Thanks :)

I've just sync'd this morning and 4.2.1 is now out. Which I knew was on its way; I was just wanting to prep a set for KDE base by seeing what kdebase-meta would pull in. Will see later on if there's any difference now.
_________________
Chiana's Geek :)
"We are Grey. We stand between the candle and the star."
(Backup Jabber ID: chianasgeek@xmpp.org.uk)
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Mar 06, 2009 12:34 pm    Post subject: Reply with quote

You should double check this : http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=tree;f=sets
Back to top
View user's profile Send private message
Jupiter1TX
Guru
Guru


Joined: 24 Feb 2006
Posts: 546
Location: 3rd Rock

PostPosted: Sun Mar 08, 2009 2:43 pm    Post subject: Reply with quote

I use funtoo repo and i was able to install qt-4.5 and kde-4.2.1
several days ago and did not have any blocking issues. Maybe
double check your /etc/portage/package.* files/folders to make
sure there is nothing blocking.
_________________
Core i7 920 D0 | Asus P6T DLX | Patriot Viper 1600 6GB | Antec Quattro 850W
Geforce 8800GTX OC2 768MB | Dell 22" LCD | Koolance Exos2/Swiftech GTZ
GCC 4.6.1 | 3.7.x-geek | Xorg-7.4-x | KDE-4.7.x | Compiz
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sun Mar 08, 2009 2:46 pm    Post subject: Reply with quote

In fact, maybe you had something inside /etc/portage/package.mask
Back to top
View user's profile Send private message
ChianasGeek
n00b
n00b


Joined: 13 Nov 2004
Posts: 45
Location: United Kingdom

PostPosted: Mon Mar 09, 2009 10:14 pm    Post subject: Reply with quote

This was a fresh install of Funtoo - I've emerged KDE 3.5.10 'cos I wanted to see if KDE4 still screws with 3.5 apps toolbars. The only thing in /etc/portage/package.mask/ before I started the kdebase-4.2 emerge was:

Code:

chiana ~ # cat /etc/portage/package.mask/nvidia
>=x11-drivers/nvidia-drivers-177.0.0


as I have a GeForce FX5200. What's been added to allow emerge @kdebase-4.2 to proceed:

Code:

chiana ~ # cat /etc/portage/package.unmask/kdebase-4.2
kde-base/kdebase-data:4.2
kde-base/kdelibs:4.2
kde-base/kdepimlibs:4.2
kde-base/kdnssd:4.2
kde-base/plasma-workspace:4.2


were required to allow anything to go ahead. And:

Code:

chiana ~ # cat /etc/portage/package.mask/mysql-community
dev-db/mysql-community


and

Code:

chiana ~ # cat /etc/portage/package.mask/kdebase-4.2
x11-libs/qt-phonon


Currently things are close to being done except it's balking on pykde4. eix-sync done as of a few minutes ago so there's no -r1 ebuilds for any of KDE 4.2.1 yet.
_________________
Chiana's Geek :)
"We are Grey. We stand between the candle and the star."
(Backup Jabber ID: chianasgeek@xmpp.org.uk)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum