Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Newer versions of Gnome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
aVirulence
Apprentice
Apprentice


Joined: 07 Feb 2006
Posts: 170

PostPosted: Mon Mar 09, 2009 2:51 pm    Post subject: Newer versions of Gnome Reply with quote

Well, I've been using the Gnome overlay for a while. However, the overlay masks all new releases. How can I, for instance, emerge Gnome 2.25 (and higher)?
Is there an easy way to unmask all packages that are necessary for 2.25? Normally I would use something like "autounmask gnome-base/gnome-2.26" or whatever, but there is no
meta-ebuild (yet). Is there even an easy method? Unmasking all ebuilds that are masked in the profiles/package.mask file in the Gnome overlay doesn't work, since it creates lots of problems with dependencies.

Thanks
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Mon Mar 09, 2009 3:59 pm    Post subject: Reply with quote

An overlay masks newer versions? I thought overlays in general served to unmask newer/experimental versions. Exactly which overlay is this - what is its exact name and does it have a home page somewhere?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
aVirulence
Apprentice
Apprentice


Joined: 07 Feb 2006
Posts: 170

PostPosted: Mon Mar 09, 2009 4:04 pm    Post subject: Reply with quote

It's just the Gnome overlay. (layman -a gnome). I could not find a website for it.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Mon Mar 09, 2009 4:22 pm    Post subject: Reply with quote

In gnome overlay in profiles dir you have package.mask file. Just copy/paste those 2.25 lines to your package.unmask. What problems do you have?
Back to top
View user's profile Send private message
aVirulence
Apprentice
Apprentice


Joined: 07 Feb 2006
Posts: 170

PostPosted: Mon Mar 09, 2009 4:32 pm    Post subject: Reply with quote

M wrote:
In gnome overlay in profiles dir you have package.mask file. Just copy/paste those 2.25 lines to your package.unmask. What problems do you have?


Yeah, that's what I did. Here's what's wrong:

Code:
[uninstall    ] dev-python/gnome-python-desktop-2.24.1
[blocks b     ] <dev-python/gnome-python-desktop-2.25 ("<dev-python/gnome-python-desktop-2.25" is blocking dev-python/gnome-desktop-python-2.25.90, dev-python/libgnomeprint-python-2.25.90, dev-python/librsvg-python-2.25.90, dev-python/libwnck-python-2.25.90, dev-python/gnome-media-python-2.25.90, dev-python/gnome-applets-python-2.25.90, dev-python/gnome-keyring-python-2.25.90)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

gnome-base/gnome-desktop:0

  ('ebuild', '/', 'gnome-base/gnome-desktop-2.25.91', 'merge') pulled in by
    >=gnome-base/gnome-desktop-2.25.5 required by ('ebuild', '/', 'gnome-base/nautilus-2.25.91', 'merge')
    >=gnome-base/gnome-desktop-2.25.6 required by ('ebuild', '/', 'gnome-base/gnome-settings-daemon-2.25.90', 'merge')
    >=gnome-base/gnome-desktop-2.25.1 required by ('ebuild', '/', 'gnome-base/gnome-control-center-2.25.90', 'merge')
    (and 4 more)

  ('installed', '/', 'gnome-base/gnome-desktop-2.24.3', 'nomerge') pulled in by
    =gnome-base/gnome-desktop-2.24* required by ('installed', '/', 'dev-dotnet/gnome-desktop-sharp-2.24.0-r10', 'nomerge')
    (and 4 more)
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 432

PostPosted: Mon Mar 09, 2009 9:16 pm    Post subject: Reply with quote

Well, that is a problem, I don't have whole gnome, I use mygnome set, I only had bluez-utils and libs blockers, and am using paludis. You can try to remove all versions of gnome-python-desktop and than just emerge --oneshot the latest version from overlay. gnome-desktop-python for example has this !<dev-python/gnome-python-desktop-2.25.
Back to top
View user's profile Send private message
aVirulence
Apprentice
Apprentice


Joined: 07 Feb 2006
Posts: 170

PostPosted: Mon Mar 09, 2009 9:59 pm    Post subject: Reply with quote

Hm, that seemed to work. However I'm now missing some files:

Code:
!!! Couldn't download 'gtk-doc-1.11.tar.bz2'. Aborting.
 * Fetch failed for 'dev-util/gtk-doc-am-1.11', Log file:
 *  '/var/tmp/portage/dev-util/gtk-doc-am-1.11/temp/build.log'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum