Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] probleme to mount ext4 with 2.6.29 kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Wed Mar 25, 2009 5:54 pm    Post subject: [SOLVED] probleme to mount ext4 with 2.6.29 kernel Reply with quote

Yesterday I have copy my gentoo to a new hard drive , I have created a /boot in xfs and / in ext4 using gentoo kernel 2.6.28-4
every things work fine
Today I have update kernel with gentoo-sources-2.6.29 using same .config
But when I boot with new kernel my / is now in read only have you got any idea why it's not working


Last edited by tomj44 on Mon Apr 06, 2009 4:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Wed Mar 25, 2009 8:17 pm    Post subject: Reply with quote

when I do a mount rw -t ext4 -o remount / with 2.6.29 it works very strange
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1979
Location: Poland

PostPosted: Thu Mar 26, 2009 7:36 am    Post subject: Reply with quote

do you use "rootfstype=ext4" in kernel boot parameters? (grub)
Back to top
View user's profile Send private message
ponciarello
Apprentice
Apprentice


Joined: 22 Jul 2008
Posts: 223
Location: beach of slack

PostPosted: Thu Mar 26, 2009 8:15 am    Post subject: Reply with quote

besides ext4, the root filesystem is usually remounted read only when you got input/error on writing: have you got anything on /var/log/messages?
_________________
look for monty python channel on youtube :D
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Thu Mar 26, 2009 9:12 am    Post subject: Reply with quote

yes I use rootfstype=ext4 in grub.conf
no error in messages , my hard drive is new and smart say nothing
Ext4 works fine with 2.6.28-r4 but not with 2.6.29
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Thu Mar 26, 2009 12:20 pm    Post subject: Reply with quote

I found this in messages using kernel 2.28-r4
Mar 26 13:59:14 tom-desktop EXT4-fs: barriers enabled
Mar 26 13:59:14 tom-desktop EXT4-fs: delayed allocation enabled
Mar 26 13:59:14 tom-desktop EXT4-fs: file extents enabled
Mar 26 13:59:14 tom-desktop EXT4-fs: mballoc enabled
Mar 26 13:59:14 tom-desktop EXT4-fs: mounted filesystem with ordered data mode.
Mar 26 13:59:14 tom-desktop VFS: Mounted root (ext4 filesystem) readonly.

but I m not in read only
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Sat Mar 28, 2009 11:16 am    Post subject: Reply with quote

The read only thing is normal (you probably have "ro" in the same place you have "rootfstype=ext4"). Gentoo should be remounting it read-write later on in the boot process.
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Sun Apr 05, 2009 9:04 am    Post subject: Reply with quote

not working with 2.29-r1 sames error

why ext4 works with 2.28-r4 but not with 2.29 onlu things i have change is kernel version
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Sun Apr 05, 2009 9:06 am    Post subject: Reply with quote

my grub.conf

default 0
timeout 5
splashimage=(hd0,1)/boot/grub/sword_splash.xpm.gz
title=Windows VISTA
rootnoverify (hd1,0)
makeactive
chainloader +1

title=gentoo-sources 2.6.28-gentoo-r4
root (hd0,1)
kernel /boot/vmlinuz-2.6.28-gentoo-r4 root=/dev/sda3 rootfstype=ext4

title=gentoo-sources 2.6.29-gentoo-r1
root (hd0,1)
kernel /boot/vmlinuz-2.6.29-gentoo-r1 root=/dev/sda3 rootfstype=ext4


my /etc/fstab

none /dev/shm tmpfs nodev,nosuid,noexec 0 0
none /proc proc defaults 0 0
/dev/sdc2 none swap rw 0 0
/dev/sda3 / ext4 defaults,extents 0 1
/dev/sda2 /boot xfs defaults 0 0

I use same .config
Back to top
View user's profile Send private message
ok
Guru
Guru


Joined: 11 Jul 2006
Posts: 390
Location: germany

PostPosted: Sun Apr 05, 2009 9:06 pm    Post subject: Reply with quote

I had a similar problem after updating from vanilla 2.6.28.9 to gentoo-sources 2.6.29-r1, but I got an error message with dmesg.
Setting CONFIG_LBD in the kernel config:
Code:
-*- Enable the block layer  --->
  [*]   Support for large block devices and files

solved it for me.
Back to top
View user's profile Send private message
tomj44
n00b
n00b


Joined: 12 Sep 2005
Posts: 37
Location: Nantes France

PostPosted: Mon Apr 06, 2009 4:49 pm    Post subject: Reply with quote

I have found kernel 2.6.29 won't support extends options in fstab

I just remove extends option from my fstab and it's SOLVED
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum