Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg-server-1.5 and r128
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ndansmith
n00b
n00b


Joined: 01 Aug 2005
Posts: 60

PostPosted: Sat Mar 28, 2009 11:48 pm    Post subject: [SOLVED] xorg-server-1.5 and r128 Reply with quote

I have a Rage128 PCI card. After upgrading to xorg-server-1.5, X won't start.

Xorg.log -> http://rafb.net/p/wunnMp93.html
xorg.conf -> http://rafb.net/p/j6gDgg36.html

Here is the pertinent section of the log:
Code:
(II) Loading /usr/lib/xorg/modules/linux//libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 0.0.2
   ABI class: X.Org Video Driver, version 4.1
(WW) open /dev/fb1: No such file or directory
(WW) open /dev/fb2: No such file or directory
(WW) open /dev/fb3: No such file or directory
(WW) open /dev/fb4: No such file or directory
(WW) open /dev/fb5: No such file or directory
(WW) open /dev/fb6: No such file or directory
(WW) open /dev/fb7: No such file or directory
(EE) Unable to find a valid framebuffer device
(EE) R128(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
   (you may have to look at the server log to see warnings)
(II) UnloadModule: "r128"
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/lib/xorg/modules/linux//libfbdevhw.so
(EE) Screen(s) found, but none have a usable configuration.
 
Fatal server error:
no screens found

And xorg.conf device:
Code:
Section "Device"
   Identifier   "Card0"
   ### Available Driver options:
   Option "DMAForXv"   "true"  # Use DMA for XV, reduces CPU usage
               # Can cause stability problems
   #Option "SWcursor"   "false" # Use Software Cursor
   #Option "NoAccel"   "false" # Disable Hardware Acceleration
   #Option "Display"   "FP"   # Display mode for devices which
               # support Flat Panels.  Modes:
               # "FP" - Use Flat Panel
               # "CRT" - Use CRT
               # "Mirror" - Use both FP and CRT
   ### See "man r128" for additional options
 
   ### Warning: If your r128 has less than 10MB of ram, you will only be
   ###         able to use dri in 16bit color.
   Driver   "r128"
#   BusID   "PCI:16:18:0"
EndSection


This exact setup worked with 1.3. Ideas?


Last edited by ndansmith on Sun Mar 29, 2009 12:15 am; edited 1 time in total
Back to top
View user's profile Send private message
ndansmith
n00b
n00b


Joined: 01 Aug 2005
Posts: 60

PostPosted: Sun Mar 29, 2009 12:00 am    Post subject: Reply with quote

Never mind. :-)

Adding this to my xorg.conf fixed it.
Code:
Option "UseFBDev" "false"
Option "NoInt10" "true"


Perhaps UseFBDev is on by default now? At any rate, I'm good.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum