Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Reiser4-patch for 2.6.29
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sun Mar 29, 2009 5:59 pm    Post subject: Reiser4-patch for 2.6.29 Reply with quote

Hi there,

on kernel.org there's still no official reiser4-patch for 2.6.29 available:
http://www.kernel.org/pub/linux/kernel/people/edward/reiser4/reiser4-for-2.6/

Does anyone know something about that. Is the patch of the zen-sources or mm-sources suitable?
Back to top
View user's profile Send private message
justinkb
Apprentice
Apprentice


Joined: 23 Dec 2008
Posts: 160

PostPosted: Sun Mar 29, 2009 6:05 pm    Post subject: Reply with quote

looking at the prev dates, e.g. patch for 2.6.28, that took about two weeks. patience is a virtue ;)
Back to top
View user's profile Send private message
StringCheesian
l33t
l33t


Joined: 21 Oct 2003
Posts: 887

PostPosted: Sun Mar 29, 2009 6:58 pm    Post subject: Reply with quote

Helium Sources is using Reiser4 from mm-sources:
http://hirakendu.mooo.com/helium-sources/2.6.29-helium0/broken-out/01_reiser4-2.6.29-mm-das.patch

Beware, it has had only minimal testing:
hirakendu wrote:
3) The reiser4 is from yet unreleased 2.6.29-mm. (Tested ok for at least simple mounts, read, writes, deletes, unmounts etc.)


Sorry, I can't find where zen-sources links to the patches it uses.
Back to top
View user's profile Send private message
DestroyFX
n00b
n00b


Joined: 05 Dec 2005
Posts: 38

PostPosted: Mon Mar 30, 2009 12:33 am    Post subject: Reply with quote

Here is it!

http://www.gentoo-quebec.org/index/Config_Mathieu/patches/reiser4-for-2.6.29.patch

Its the 2.6.28 patch from edward section in kernel.org + some fixes for 2.6.29 compatibility. I use it for my 3 Reiser4 partitions with cryptocompress plugins.

Beware : I juste tested it on 5 different computers.
PS : USE the ~ version of sys-fs/reiser4progs (1.0.7). Especially if you use cryptocompress plugins. This version fixed a bug in fsck (segfault) corrupting your partition after a big system crash. (This was reversible and the fsck 1.0.7 fixed my fs)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum