Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vsftpd not setting permissions correctly.
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message

Joined: 14 Aug 2006
Posts: 58

PostPosted: Wed Apr 01, 2009 11:12 pm    Post subject: vsftpd not setting permissions correctly. Reply with quote

whenever i upload a file via ftp (using vsftpd) it sets incorrect permissions on said files. Causing me to have to ssh in and chmod the file to the right permissions so it can be accessed by a browser.

Below are samples of my configs.

bigbubba htdocs # cat /etc/vsftpd/vsftpd.conf
# Example config file /etc/vsftpd/vsftpd.conf
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
# Listen on IPv4. xinet users must set NO or comment out
# otherwise it must be set YES
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
# Uncomment this to allow local users to log in.
# Uncomment this to enable any form of FTP write command.
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# Activate logging of uploads/downloads.
# Make sure PORT transfer connections originate from port 20 (ftp-data).
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
# You may override where the log file goes if you like. The default is shown
# below.
# If you want, you can have your log file in standard ftpd xferlog format
# You may change the default value for timing out an idle session.
# You may change the default value for timing out a data connection.
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
# You may fully customise the login banner string:
ftpd_banner=Welcome to BigBubba, Upload with care.
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
# (default follows)
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (default follows)
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.

output of ls -la on htdocs (chat.txt is the file i've uploaded with ftp. The other files have already been chmod'd to the right permissions.
bigbubba htdocs # ls -la
total 6503600
drwxrwxr-x 3 http root       4096 Apr  1 15:48 .
drwxr-xr-x 6 root root       4096 Mar 16 09:28 ..
-rwxrwxr-x 1 http ftp  6652690476 Mar 19 20:08 Data.tar.bz2
-rw-rw-r-- 1 http ftp        4420 Apr  1 15:48 chat.txt
-rwxrwxr-x 1 http ftp      454656 Mar 19 12:58 putty.exe
drwxrwxr-x 2 root root       4096 Apr  1 14:55 torrents

Basically what it looks like is that umask = 002 is giving me chmod = 664

The odd thing is that the browser should be able to read the file is its set for 664, but it will only read the file if said file is set for everyones allowed to execute, which doesn't make sense to me. Could it be because the owner of the file is ftp but the ftp login i use to upload is http?

I've asked a friend of mine who works in SOC and he's as baffled as i am. Any information is appreciated and if any new information is needed please feel free to ask.

Thank you!
Back to top
View user's profile Send private message
Bones McCracker

Joined: 14 Mar 2006
Posts: 1611
Location: U.S.A.

PostPosted: Mon Apr 06, 2009 12:22 am    Post subject: Reply with quote

It looks to me like vsftpd is working properly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum