Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Chromium Live Ebuild] last-update: 2009-05-31-04-20
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Mon Apr 06, 2009 9:56 pm    Post subject: [Chromium Live Ebuild] last-update: 2009-05-31-04-20 Reply with quote

This is going to be my official thread for the chromium ebuild I am maintaining.

Ebuild Location: THE overlay
layman -a THE
playman -a THE


To Install:
emerge chromium
paludis -i chromium


NOTE-0: Fetching the complete chromium source repo via svn can be slow... seed the process by using a snapshot from http://build.chromium.org/buildbot/archives/chromium_tarball.html
Extract this tarball in ${DISTFILES/gclient-src/chromium

NOTE-1: The google-chrome ebuild was renamed to chromium, make sure you move ${DISFILES}/gclient-src/google-chrome to ${DISFILES}/gclient-src/chromium to avoid re-downloading everything.

NOTE-2: The chromium should now be build with all your gentoo cflags and ldflags.

NOTE-3: The chromium-9999 ebuild requires gclient, a tool google uses to pull in source from multiple repos. The ebuild is for gclient is also live. The gclient tool does get updates now and then so it would be a good habit to rebuild gclient when you rebuild chromium.

About 64-bit support:
I almost have it working! Maybe in the next week or so I create a newer emul-linux-x86-xlibs ebuild that will let google-chrome build. Until then be patient.
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.


Last edited by rmh3093 on Sun May 31, 2009 8:15 am; edited 4 times in total
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 756

PostPosted: Tue Apr 07, 2009 8:00 pm    Post subject: Reply with quote

it's
Code:

FEATURES="-sandbox" emerge -v google-chrome


please read up on the official package management tool for the distro. Accept no substitutes.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Apr 07, 2009 8:17 pm    Post subject: Reply with quote

truekaiser wrote:
it's
Code:

FEATURES="-sandbox" emerge -v google-chrome


please read up on the official package management tool for the distro. Accept no substitutes.


LOL... I'm not reading up on a package manager I dont use any more. Substitutes/choices/options/freedom... is the Linux way!
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
truekaiser
l33t
l33t


Joined: 05 Mar 2004
Posts: 756

PostPosted: Tue Apr 07, 2009 10:07 pm    Post subject: Reply with quote

rmh3093 wrote:
truekaiser wrote:
it's
Code:

FEATURES="-sandbox" emerge -v google-chrome


please read up on the official package management tool for the distro. Accept no substitutes.


LOL... I'm not reading up on a package manager I dont use any more. Substitutes/choices/options/freedom... is the Linux way!


i was hoping someone would get the joke.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Apr 07, 2009 11:56 pm    Post subject: Reply with quote

truekaiser wrote:
rmh3093 wrote:
truekaiser wrote:
it's
Code:

FEATURES="-sandbox" emerge -v google-chrome


please read up on the official package management tool for the distro. Accept no substitutes.


LOL... I'm not reading up on a package manager I dont use any more. Substitutes/choices/options/freedom... is the Linux way!


i was hoping someone would get the joke.


never can tell with crowds around here
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Wed Apr 08, 2009 11:00 pm    Post subject: Re: Google-Chome - Live Chromium Ebuild Reply with quote

rmh3093 wrote:
This is going to be my official thread for the google-chrome ebuild I am maintaining.


Great! I was awaiting someone to do that for quite some time now. Thanks, rmh3093!
Back to top
View user's profile Send private message
uaeb
n00b
n00b


Joined: 28 May 2008
Posts: 27

PostPosted: Wed Apr 08, 2009 11:43 pm    Post subject: Reply with quote

Anyone able to tell me how large the current source is before I decide to take a dip ?

Thanks.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Thu Apr 09, 2009 1:23 am    Post subject: Reply with quote

uaeb wrote:
Anyone able to tell me how large the current source is before I decide to take a dip ?

Thanks.


About 2 GiB. I've compiled it and currently it does nothing but showing a window. You cannot access a site, for example. YMMV.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Apr 09, 2009 5:03 am    Post subject: Reply with quote

pilla wrote:
uaeb wrote:
Anyone able to tell me how large the current source is before I decide to take a dip ?

Thanks.


About 2 GiB. I've compiled it and currently it does nothing but showing a window. You cannot access a site, for example. YMMV.


if you cant get to a website then there is most likely a font issue, run chrome from a console and let me know if you see a font error
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Thu Apr 09, 2009 9:17 am    Post subject: Re: Google-Chome - Live Chromium Ebuild Reply with quote

My joy came too early :/

Code:
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
scons: *** [/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/sconsbuild/Release/chrome] /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/sconsbuild/Release/.sconsign.dblite: No such file or directory


I got this same error three times when trying to emerge. The chromium repository was in revisions 1682, 13391 and at the last try 13410.

Any clues? Need my system info?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Thu Apr 09, 2009 11:47 am    Post subject: Reply with quote

rmh3093 wrote:
pilla wrote:
uaeb wrote:
Anyone able to tell me how large the current source is before I decide to take a dip ?

Thanks.


About 2 GiB. I've compiled it and currently it does nothing but showing a window. You cannot access a site, for example. YMMV.


if you cant get to a website then there is most likely a font issue, run chrome from a console and let me know if you see a font error


I get several "unimplemented" messages, I'll post them when I sit at the computer where it is installed.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Thu Apr 09, 2009 1:00 pm    Post subject: Reply with quote

Code:

[7389:7389:119844032225:ERROR:common/temp_scaffolding_stubs.cc(188)] Not implemented reached in static bool FirstRun::IsChromeFirstRun()
[7389:7389:119844245804:ERROR:browser/metrics/metrics_service.cc(699)] Not implemented reached in static std::string MetricsService::GenerateClientID()
[7389:7389:119844548380:ERROR:browser/tab_contents/web_contents_view_gtk.cc(74)] Not implemented reached in virtual void WebContentsViewGtk::CreateView()
[7389:7389:119844748415:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(257)] Not implemented reached in virtual void RenderWidgetHostViewGtk::DidBecomeSelected()
[7389:7389:119844748667:ERROR:browser/tab_contents/web_contents_view_gtk.cc(184)] Not implemented reached in virtual void WebContentsViewGtk::RestoreFocus() --  need to restore the focus position on this page.
[7389:7389:119845359990:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(420)] Not implemented reached in void RenderWidgetHostViewGtk::Paint(const gfx::Rect&)
[7389:7389:119845409552:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(343)] Not implemented reached in virtual void RenderWidgetHostViewGtk::RenderViewGone()
[7389:7389:119845409770:ERROR:/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/chrome/common/temp_scaffolding_stubs.h(190)] Not implemented reached in bool printing::PrintViewManager::OnRenderViewGone(RenderViewHost*)
[7389:7389:119845409950:ERROR:browser/tab_contents/web_contents_view_gtk.cc(143)] Not implemented reached in virtual void WebContentsViewGtk::Invalidate()
[7389:7389:119845410102:ERROR:/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/chrome/common/temp_scaffolding_stubs.h(532)] Not implemented reached in static void HungRendererWarning::HideForWebContents(WebContents*)
[7389:7389:119849883573:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(420)] Not implemented reached in void RenderWidgetHostViewGtk::Paint(const gfx::Rect&)
[7389:7389:119852097608:ERROR:browser/gtk/location_bar_view_gtk.cc(122)] Not implemented reached in virtual void LocationBarViewGtk::OnInputInProgress(bool)
[7389:7389:119855666207:ERROR:browser/gtk/location_bar_view_gtk.cc(122)] Not implemented reached in virtual void LocationBarViewGtk::OnInputInProgress(bool)
[7389:7389:119855710024:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(420)] Not implemented reached in void RenderWidgetHostViewGtk::Paint(const gfx::Rect&)
[7389:7389:119855774845:ERROR:browser/renderer_host/render_widget_host_view_gtk.cc(343)] Not implemented reached in virtual void RenderWidgetHostViewGtk::RenderViewGone()
[7389:7389:119855774867:ERROR:/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/chrome/common/temp_scaffolding_stubs.h(190)] Not implemented reached in bool printing::PrintViewManager::OnRenderViewGone(RenderViewHost*)
[7389:7389:119855774882:ERROR:browser/tab_contents/web_contents_view_gtk.cc(143)] Not implemented reached in virtual void WebContentsViewGtk::Invalidate()
[7389:7389:119855774893:ERROR:/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/chrome/common/temp_scaffolding_stubs.h(532)] Not implemented reached in static void HungRendererWarning::HideForWebContents(WebContents*)


edit:

Code:

chrome[7399]: segfault at 4 ip 082e6f44 sp b7046390 error 4 in chrome[8048000+ff9000]
chrome[7407]: segfault at 4 ip 082e6f44 sp b6f47390 error 4 in chrome[8048000+ff9000]

_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Apr 09, 2009 1:24 pm    Post subject: Re: Google-Chome - Live Chromium Ebuild Reply with quote

.yankee wrote:
My joy came too early :/

Code:
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
scons: *** [/var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/sconsbuild/Release/chrome] /var/tmp/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/sconsbuild/Release/.sconsign.dblite: No such file or directory


I got this same error three times when trying to emerge. The chromium repository was in revisions 1682, 13391 and at the last try 13410.

Any clues? Need my system info?


my bad i changed the ebuild to only build the chrome app and not all the unit tests, i dont think you need that file and I dont know why its trying to install it, make sure you have the latest version of my ebuild
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Apr 09, 2009 1:26 pm    Post subject: Reply with quote

pilla wrote:
rmh3093 wrote:
pilla wrote:
uaeb wrote:
Anyone able to tell me how large the current source is before I decide to take a dip ?

Thanks.


About 2 GiB. I've compiled it and currently it does nothing but showing a window. You cannot access a site, for example. YMMV.


if you cant get to a website then there is most likely a font issue, run chrome from a console and let me know if you see a font error


I get several "unimplemented" messages, I'll post them when I sit at the computer where it is installed.


No i don't care about the unimplemented messages... I only care about a message that looks like this:

ERROR: unable to open font '401'
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Thu Apr 09, 2009 1:28 pm    Post subject: Reply with quote

rmh3093 wrote:

No i don't care about the unimplemented messages... I only care about a message that looks like this:

ERROR: unable to open font '401'


Nothing like that. I am emerging it again.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Apr 09, 2009 2:21 pm    Post subject: Reply with quote

pilla wrote:
rmh3093 wrote:

No i don't care about the unimplemented messages... I only care about a message that looks like this:

ERROR: unable to open font '401'


Nothing like that. I am emerging it again.


well i used to get some issues where pages wouldnt render, those pages that didnt render triggered font errors, i think you should be able to get to every website no problem, i think it was you that mentioned ymmv.org as an example of a site that didnt work... it works for me... i did uninstall every font on my computer though, then when i remerged chrome it pulled in corefonts and some other package, since then i havent had any font issues
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Thu Apr 09, 2009 2:26 pm    Post subject: Re: Google-Chome - Live Chromium Ebuild Reply with quote

rmh3093 wrote:
my bad i changed the ebuild to only build the chrome app and not all the unit tests, i dont think you need that file and I dont know why its trying to install it, make sure you have the latest version of my ebuild


I've synced THE overlay, it pulled an updated ebuild, but I still get the same error. So now I run emerge again, this time with the -u flag. It pulled an update to subversion-1.7_pre37032, but I doubt whether that could be the source of the problem. Anyway, will see when it finishes.
Oh, and this time, I also removed the whole google-chrome-9999 temporary build directory prior to starting the emerge.
Will report back soon.
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Thu Apr 09, 2009 3:07 pm    Post subject: Reply with quote

Still the same - maybe it's some scons issue - what version are you gys using? I am with the stable 1.0.0.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Apr 09, 2009 5:38 pm    Post subject: Reply with quote

.yankee wrote:
Still the same - maybe it's some scons issue - what version are you gys using? I am with the stable 1.0.0.


could be a scons issue, i am using 1.2.0-r1
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Thu Apr 09, 2009 8:51 pm    Post subject: Reply with quote

rmh3093 wrote:

could be a scons issue, i am using 1.2.0-r1


Yep, that seems to be it. It is being built now (passed swiftly far beyond the point where it used to fail). 8)
Guess you'll just need to update dependency information then.

Thanks for help!
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Thu Apr 09, 2009 10:41 pm    Post subject: Reply with quote

It got built OK.
It does not launch though.
Code:
[23758:23758:111359385731:ERROR:common/temp_scaffolding_stubs.cc(161)] Not implemented reached in static bool FirstRun::IsChromeFirstRun()
Illegal instruction


I'm now trying to rebuild it with (hopefully) a bit safer CFLAGS. The first try was with my default :
-pipe -O2 -march=pentium3m -mtune=pentium3m -fomit-frame-pointer -fno-ident

Now, I am trying :
-pipe -Os -march=pentium3m -mtune=pentium3m

(Yes, I know -Os is more aggressive than -O2, but I'd just like to try and see if leaving out the other ones can help. If it doesn't, I'll go for pure -O2.)

The next try is going to be switching back to gcc-4.1.2. (I am now using 4.3.2).

EDIT:
Now, with gcc-4.1.2 and safe CFLAGS (-pipe -O2 -march=pentium3m -mtune=pentium3m) - still the same error! Only the numbers change :
Code:
[19483:19483:145975733292:ERROR:common/temp_scaffolding_stubs.cc(157)] Not implemented reached in static bool FirstRun::IsChromeFirstRun()
Illegal instruction

Quite annoying...
(The LDFLAGS were reset to default as well.)

What comes to my mind is whether the app contains some binary blobs pre-compiled for a pentium4 processor. This would explain the "Illegal instruction" error and the notice that comes up at the end of compilation:
Code:
 * QA Notice: The following files contain executable stacks
 *  Files with executable stacks will not work properly (or at all!)
 *  on some architectures/operating systems.  A bug should be filed
 *  at http://bugs.gentoo.org/ to make sure the file is fixed.
 *  For more information, see http://hardened.gentoo.org/gnu-stack.xml
 *  Please include the following list of files in your report:
 *  Note: Bugs should be filed for the respective maintainers
 *  of the package in question and not hardened@
 * RWX --- --- opt/google-chrome/chrome


:/
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Fri Apr 10, 2009 7:38 pm    Post subject: Reply with quote

.yankee wrote:
It got built OK.
It does not launch though.
Code:
[23758:23758:111359385731:ERROR:common/temp_scaffolding_stubs.cc(161)] Not implemented reached in static bool FirstRun::IsChromeFirstRun()
Illegal instruction


I'm now trying to rebuild it with (hopefully) a bit safer CFLAGS. The first try was with my default :
-pipe -O2 -march=pentium3m -mtune=pentium3m -fomit-frame-pointer -fno-ident

Now, I am trying :
-pipe -Os -march=pentium3m -mtune=pentium3m

(Yes, I know -Os is more aggressive than -O2, but I'd just like to try and see if leaving out the other ones can help. If it doesn't, I'll go for pure -O2.)

The next try is going to be switching back to gcc-4.1.2. (I am now using 4.3.2).

EDIT:
Now, with gcc-4.1.2 and safe CFLAGS (-pipe -O2 -march=pentium3m -mtune=pentium3m) - still the same error! Only the numbers change :
Code:
[19483:19483:145975733292:ERROR:common/temp_scaffolding_stubs.cc(157)] Not implemented reached in static bool FirstRun::IsChromeFirstRun()
Illegal instruction

Quite annoying...
(The LDFLAGS were reset to default as well.)

What comes to my mind is whether the app contains some binary blobs pre-compiled for a pentium4 processor. This would explain the "Illegal instruction" error and the notice that comes up at the end of compilation:
Code:
 * QA Notice: The following files contain executable stacks
 *  Files with executable stacks will not work properly (or at all!)
 *  on some architectures/operating systems.  A bug should be filed
 *  at http://bugs.gentoo.org/ to make sure the file is fixed.
 *  For more information, see http://hardened.gentoo.org/gnu-stack.xml
 *  Please include the following list of files in your report:
 *  Note: Bugs should be filed for the respective maintainers
 *  of the package in question and not hardened@
 * RWX --- --- opt/google-chrome/chrome


:/


I had 2 builds a few days back that segfaulted but then a later build was working fine again. There are new commits every minute practically, so its possible you are pulling/building during a broken period... You WILL see lots of "unimplemented warnings", but it should run regardless. If its crashing try removing ~/.config/chromium and then try starting it again. I think that helped me once. I am using gcc 4.3.3 btw so I don't think its gcc related.
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Mon Apr 20, 2009 11:45 am    Post subject: Reply with quote

hello,
i get this messages when i try to compile google-chrome.
what am i missing?


Code:
 FEATURES="-sandbox" emerge -v google-chrome

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] www-client/google-chrome-9999  0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/THE


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) www-client/google-chrome-9999 from THE
 * checking ebuild checksums ;-) ...                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                       [ ok ]
>>> Unpacking source...
 * Using custom .gclient file: /usr/portage/local/layman/THE/www-client/google-chrome/files/.gclient
 * gclient update-->
 *      repository: http://src.chromium.org/svn/trunk/src

________ running 'svn update /usr/portage/distfiles/gclient-src/google-chrome/src' in '/usr/portage/distfiles/gclient-src/google-chrome'
At revision 14025.

 *    working copy: /usr/portage/distfiles/gclient-src/google-chrome/src

>>> Source unpacked in /var/tmp/portage/working/portage/www-client/google-chrome-9999/work
 * Updating file_version_info_linux.h
 * Applying disable_warnings.patch ...                                                        [ ok ]
Updating projects from gyp files...
>>> Configuring source in /var/tmp/portage/working/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/working/portage/www-client/google-chrome-9999/work/google-chrome-9999/src ...
Warning:  the -l option is not yet implemented
>>> Source compiled.
>>> Test phase [not enabled]: www-client/google-chrome-9999

>>> Install google-chrome-9999 into /var/tmp/portage/working/portage/www-client/google-chrome-9999/image/ category www-client
/var/tmp/portage/working/portage/www-client/google-chrome-9999/temp/environment: line 2209: cd: /var/tmp/portage/working/portage/www-client/google-chrome-9999/work/google-chrome-9999/src/src/sconsbuild/Release: No such file or directory
install: cannot stat `chrome.pak': No such file or directory
!!! doins: chrome.pak does not exist
install: cannot stat `locales/*': No such file or directory
!!! doins: locales/* does not exist
install: cannot stat `themes/*': No such file or directory
!!! doins: themes/* does not exist
install: cannot stat `chrome': No such file or directory
!!! doexe: chrome does not exist
>>> Completed installing google-chrome-9999 into /var/tmp/portage/working/portage/www-client/google-chrome-9999/image/

 * QA Notice: file does not exist:
 *
 *    doins: chrome.pak does not exist
 *    doins: locales/* does not exist
 *    doins: themes/* does not exist
 *    doexe: chrome does not exist

>>> Installing www-client/google-chrome-9999
 * checking 3 files for package collisions
--- /usr/
--- /usr/share/
--- /usr/share/applications/
>>> /usr/share/applications/google-chrome-icon.png
>>> /usr/share/applications/google-chrome.desktop
--- /opt/
--- /opt/bin/
--- /opt/google-chrome/
--- /opt/google-chrome/themes/
--- /opt/google-chrome/locales/
>>> /opt/bin/chrome -> /opt/google-chrome/chrome
>>> Safely unmerging already-installed instance...
No package files given... Grabbing a set.
--- replaced obj /usr/share/applications/google-chrome.desktop
--- replaced obj /usr/share/applications/google-chrome-icon.png
--- replaced dir /usr/share/applications
--- replaced dir /usr/share
--- replaced dir /usr
--- replaced dir /opt/google-chrome/themes
--- replaced dir /opt/google-chrome/locales
--- replaced dir /opt/google-chrome
--- replaced sym /opt/bin/chrome
--- replaced dir /opt/bin
--- replaced dir /opt
>>> Original instance of package unmerged safely.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.



Code:
emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r4-i686-Intel-R-_Core-TM-2_Quad_CPU_@_2.93GHz-with-glibc2.0
Timestamp of tree: Mon, 20 Apr 2009 07:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://mirror.switch.ch/ftp/mirror/gentoo/ http://gentoo.ynet.sk/pub http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j6 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/portage/working"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/dottout /usr/portage/local/layman/THE /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa bash-completion berkdb bzip2 cdr cli cracklib crypt cups dbus dri dvd ffmpeg flac fortran gdbm gif gpm gtk hal iconv isdnlog jpeg midi mozdevelop mp3 mudflap ncurses nls nptl nptlonly nvidia offensive openmp pam pcre perl png pppd python qt-static quicktime readline reflection session spl ssl ssse3 startup-notification sysfs tcpd tiff twolame unicode upnp vdpau vorbis win32codecs x86 xorg xscreensaver xulrunner xvmc zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia nv nouveau"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
.yankee
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: Polska

PostPosted: Tue Apr 21, 2009 11:01 am    Post subject: Reply with quote

rmh3093 wrote:
I had 2 builds a few days back that segfaulted but then a later build was working fine again. There are new commits every minute practically, so its possible you are pulling/building during a broken period... You WILL see lots of "unimplemented warnings", but it should run regardless. If its crashing try removing ~/.config/chromium and then try starting it again. I think that helped me once. I am using gcc 4.3.3 btw so I don't think its gcc related.

Removing the .config/chromium did not help. I've just come back to building chrome just yesterday and the new revisions showed no improvement.
To verify my suspicions, I've run analyse-x86.sh script (found somewhere on the forums) against the chrome binary. It seems to confirm my thoughts very well - a great number of sse2 instructions is used!
Having learned this, I took a read through some .scons file in the compilation directory and found it to set '-march=pentium4' CFLAG by force. Grepping through all the .scons files revealed dozens of both -march=pentium4 and -msse2 CFLAGs.

So now, I've replaced all the occurrences of -march=pentium4 with -march=pentium3m and -msse2 with -msse and started building chrome by hand. Should finish in about half an hour now...

BTW :
rmh3093, if you are managing the chrome ebuild, please update it to contain proper dev-util/scons dependency info (probably anything above 1.2.0).
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Apr 21, 2009 12:15 pm    Post subject: Reply with quote

.yankee wrote:
rmh3093 wrote:
I had 2 builds a few days back that segfaulted but then a later build was working fine again. There are new commits every minute practically, so its possible you are pulling/building during a broken period... You WILL see lots of "unimplemented warnings", but it should run regardless. If its crashing try removing ~/.config/chromium and then try starting it again. I think that helped me once. I am using gcc 4.3.3 btw so I don't think its gcc related.

Removing the .config/chromium did not help. I've just come back to building chrome just yesterday and the new revisions showed no improvement.
To verify my suspicions, I've run analyse-x86.sh script (found somewhere on the forums) against the chrome binary. It seems to confirm my thoughts very well - a great number of sse2 instructions is used!
Having learned this, I took a read through some .scons file in the compilation directory and found it to set '-march=pentium4' CFLAG by force. Grepping through all the .scons files revealed dozens of both -march=pentium4 and -msse2 CFLAGs.

So now, I've replaced all the occurrences of -march=pentium4 with -march=pentium3m and -msse2 with -msse and started building chrome by hand. Should finish in about half an hour now...

BTW :
rmh3093, if you are managing the chrome ebuild, please update it to contain proper dev-util/scons dependency info (probably anything above 1.2.0).


yes I know exactly where pentium4 is hardcoded... I will modify the scons file to pick up gentoo's cflags hows that... and yes I will add the scons dep and even the new sandbox version needed as a dep :)
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8  Next
Page 1 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum