Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage update masked...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Lord_Jeremy
n00b
n00b


Joined: 06 Apr 2009
Posts: 13

PostPosted: Fri Apr 10, 2009 2:14 am    Post subject: Portage update masked... Reply with quote

The PPC installation handbook at one point tells you to update portage by running "emerge --oneshot portage". This command fails on my install with the following output:
Code:
Calculating dependencies ?
!!! All ebuilds that could satisfy ">=virtual/poppler-utils-0.4.3-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- virtual/poppler-utils-0.10.5 (masked by: EAPI 2)
- virtual/poppler-utils-0.10.4 (masked by: EAPI 2)
- virtual/poppler-utils-0.8.7 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "net-print/cups-1.3.9-r1" [ebuild])

I took a look at the emerge manpage and the way I understand it I can't update portage because my current portage isn't new enough. When I downloaded portage I downloaded the file "portage-latest.tar.bz2" from the server "http://mirror.datapipe.net/gentoo". I already ran "emerge --sync". I have the flag ACCEPT_KEYWORDS="~ppc" set in my make.conf.

This is my second attempt at a Gentoo install on this machine (I messed up the first when I accidentally ran mkswap on the root partition) and the last time I don't remember having this problem. It's possible I just didn't notice the error or forgot to try to update portage.[/code]
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Fri Apr 10, 2009 2:26 am    Post subject: Reply with quote

try using a newer stage tarball...
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
Lord_Jeremy
n00b
n00b


Joined: 06 Apr 2009
Posts: 13

PostPosted: Fri Apr 10, 2009 2:30 am    Post subject: Reply with quote

Isn't the portage install separate from the stage tarball? And as far as I know I have the latest one...
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Fri Apr 10, 2009 2:34 am    Post subject: Reply with quote

Lord_Jeremy wrote:
Isn't the portage install separate from the stage tarball? And as far as I know I have the latest one...
portage tree is seperate from the stage tarball, but sys-apps/portage is in the stage tarball.

I would try unpacking a new portage tarball (the source tarball for the application, not the tree tarball) and using that emerge to emerge the new portage.
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
Lord_Jeremy
n00b
n00b


Joined: 06 Apr 2009
Posts: 13

PostPosted: Fri Apr 10, 2009 2:43 am    Post subject: Reply with quote

Crap. I don't know how to save all the configuration I've done already. I'd rather not have to reselect all those damn USE flags and somesuch. And I don't see why I wouldn't have the latest stage. Where should I get it from if not the link I posted above? Thanks for your patience and prompt replies!
Back to top
View user's profile Send private message
poly_poly-man
Advocate
Advocate


Joined: 06 Dec 2006
Posts: 2477
Location: RIT, NY, US

PostPosted: Fri Apr 10, 2009 2:55 am    Post subject: Reply with quote

Lord_Jeremy wrote:
Crap. I don't know how to save all the configuration I've done already. I'd rather not have to reselect all those damn USE flags and somesuch. And I don't see why I wouldn't have the latest stage. Where should I get it from if not the link I posted above? Thanks for your patience and prompt replies!
you don't need to.. it was just another option.

you should be able to get away with installing just portage... I don't know why it's not working...

can you give a emerge -av portage?
_________________
iVBORw0KGgoAAAANSUhEUgAAA

avatar: new version of logo - see topic 838248. Potentially still a WiP.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14062

PostPosted: Fri Apr 10, 2009 3:51 am    Post subject: Reply with quote

Also, while gathering information, throw in the output of emerge --info.
Back to top
View user's profile Send private message
Lord_Jeremy
n00b
n00b


Joined: 06 Apr 2009
Posts: 13

PostPosted: Fri Apr 10, 2009 3:02 pm    Post subject: Reply with quote

When I did "emerge -av portage" it spat this back out:
Code:
These are the packages that would be merged, in order:

Calculating dependencies /
!!! All ebuilds that could satisfy ">=virtual/poppler-utils-0.4.3-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- virtual/poppler-utils-0.10.5 (masked by: EAPI 2)
- virtual/poppler-utils-0.10.4 (masked by: EAPI 2)
- virtual/poppler-utils-0.8.7 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "net-print/cups-1.3.9-r1" [ebuild])
Back to top
View user's profile Send private message
earendilion
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2007
Posts: 115
Location: Meudon (92), France

PostPosted: Fri Apr 10, 2009 3:17 pm    Post subject: Reply with quote

@Lord_Jeremy : what's your portage version ?
Back to top
View user's profile Send private message
Lord_Jeremy
n00b
n00b


Joined: 06 Apr 2009
Posts: 13

PostPosted: Fri Apr 10, 2009 3:36 pm    Post subject: Reply with quote

"emerge --version" outputs the following:
Code:
Portage 2.1.4.4 (default/linux/powerpc/ppc32/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r3-ppc32 ppc)
Back to top
View user's profile Send private message
jamesk447
n00b
n00b


Joined: 02 Oct 2009
Posts: 1

PostPosted: Fri Oct 02, 2009 5:37 pm    Post subject: Reply with quote

I am following the installation guide and I got to step 6b at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=6

( I just did emerge --sync ) It told me that updates to portage are available, so like it says in step 6b, I did "emerge --oneshot portage" and got similar results to Lord_Jeremy:

Calculating dependencies /
!!! All ebuilds that could satisfy ">=app-admin/eselect-python-20090804" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-admin/eselect-python-99999999 (masked by: EAPI 2)
- app-admin/eselect-python-20090824 (masked by: EAPI 2)
- app-admin/eselect-python-20090814 (masked by: ~x86 keyword)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-lang/python-2.5.4-r3" [ebuild])



My portage version is:

emerge --version
Portage 2.1.4.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.30-gentoo-r6 i686)


I also downloaded the portage-latest.tar.bz2.

Is there something wrong with the installation guide? It tells me to get the stage3 tarball from the releases/x86/2008.0/ directory. This is what I did but while typing this, I noticed that there is a "current-stage3/" directory too. Do you think using the stage3 tarball from this directory will solve my problem? If so, can I just "tar xvjpf stage3-*.tar.bz2" the new tarball or will that leave stuff from the older one around?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9266

PostPosted: Sat Oct 03, 2009 1:14 am    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat Oct 03, 2009 3:57 am    Post subject: Reply with quote

The documentation is unfortunately somewhat out of date, you should be using the latest releases from:
http://distfiles.gentoo.org/releases/ppc/autobuilds/current-iso/

You can back up the configuration files that you've already set up by copying them with scp to another machine.

Sorry, I'm working on updating the documentation for the new autobuild releases, but it just isn't ready yet. :/
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum