Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] VirtualBox 2.2_OSEr18839 hangs on 1st startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Sun Apr 12, 2009 11:08 am    Post subject: [Solved] VirtualBox 2.2_OSEr18839 hangs on 1st startup Reply with quote

Does anyone else experience a blank window on VirtualBox startup, which, if I kill (hard) and re-start, causes VirtualBox to startup normally?

It's as though it's trying to phone home and doesnt' try to the second time.

I start VirtualBox as root (using sudo).

Anyone?
_________________
...Lyall


Last edited by lyallp on Thu Apr 16, 2009 12:38 am; edited 1 time in total
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Wed Apr 15, 2009 4:16 am    Post subject: Reply with quote

I alsa have this problem with Virtualbox-ose-2.2.0 from dev-jokey. I used 2.1.4 w/no problem like this, and I run as user. No ideas yet, but I havn't looked. Please post if you find anymore info.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
jmartos
Tux's lil' helper
Tux's lil' helper


Joined: 23 Mar 2008
Posts: 76

PostPosted: Wed Apr 15, 2009 11:42 am    Post subject: Reply with quote

I'm seeing this exact same problem. I'm using virtualbox-bin from the pokey repo. Nothing else changed otheer than the virtualbox-bin and virtualbox-modules upgrade. It only seems to do this on the first start. If I close virtualbox-bin and restart, it always works.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Thu Apr 16, 2009 12:38 am    Post subject: Reply with quote

Disable the Phone Home setting in preferfences, Update Tab

Seemed to fix it for me - and all pretty pointless anyway since I install by ebuild.
_________________
...Lyall
Back to top
View user's profile Send private message
jmartos
Tux's lil' helper
Tux's lil' helper


Joined: 23 Mar 2008
Posts: 76

PostPosted: Sat Apr 18, 2009 8:27 pm    Post subject: Reply with quote

Thanks. That fixed it for me. I wonder why 2.1.4 did not have this problem.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Apr 18, 2009 11:13 pm    Post subject: Reply with quote

jmartos wrote:
Thanks. That fixed it for me. I wonder why 2.1.4 did not have this problem.


++

:)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
mieses
Tux's lil' helper
Tux's lil' helper


Joined: 28 Feb 2004
Posts: 105

PostPosted: Mon Apr 20, 2009 7:50 am    Post subject: Reply with quote

If restarting VirtualBox does not solve the GUI display problem, then edit ~/.VirtualBox/VirtualBox.xml and set GUI/UpdateDate to "never":

Code:
      <ExtraDataItem name="GUI/UpdateDate" value="never"/>
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 377
Location: Chicago, USA

PostPosted: Mon Apr 20, 2009 9:51 pm    Post subject: Reply with quote

Wowee. I had the same problem, and setting GUI/UpdateDate to "never" fixed it for me, too. However, is this a bad thing? Should I/Can I set it back to something else?

Thanks, Mieses!
Back to top
View user's profile Send private message
mieses
Tux's lil' helper
Tux's lil' helper


Joined: 28 Feb 2004
Posts: 105

PostPosted: Mon Apr 20, 2009 10:03 pm    Post subject: Reply with quote

If you are using portage to update VirtualBox, then I don't think it is important whether VirtualBox checks for updates (what people refer to as "phone home").

If you need VirtualBox to notify you of updates, then try enabling the setting in VirtualBox Preferences GUI when a newer version of virtualbox is released to portage.
Back to top
View user's profile Send private message
jchau
n00b
n00b


Joined: 15 Mar 2007
Posts: 74

PostPosted: Tue Apr 21, 2009 9:41 pm    Post subject: the bug report Reply with quote

I know you have this solved already, but I thought I should link this to the bug report about this (#266939).
Back to top
View user's profile Send private message
col
l33t
l33t


Joined: 08 May 2002
Posts: 820
Location: Melbourne - Australia

PostPosted: Fri Apr 24, 2009 4:54 am    Post subject: Reply with quote

Yeah worked for me to....virtualbox was starting up with an empty grey screen.
Back to top
View user's profile Send private message
Condex
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2005
Posts: 95
Location: 42'24ºN/8'74ºW - Sol III - Sol System

PostPosted: Mon Apr 27, 2009 6:40 pm    Post subject: Reply with quote

mieses wrote:
If restarting VirtualBox does not solve the GUI display problem, then edit ~/.VirtualBox/VirtualBox.xml and set GUI/UpdateDate to "never":

Code:
      <ExtraDataItem name="GUI/UpdateDate" value="never"/>

+1. It was driving me crazy... :lol: Nice solution ;)
_________________
Carpe diem quam minimum credula postero.
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 497
Location: Maniago, Friûl, Italia

PostPosted: Thu Apr 30, 2009 9:58 pm    Post subject: Reply with quote

++ Edited the XML file and virtualbox-bin 2.2 started working again!!! Thanks.
_________________
Michele Beltrame
https://www.cattlegrid.info/
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 218
Location: Cali - Colombia

PostPosted: Wed May 13, 2009 8:37 pm    Post subject: Reply with quote

Thanks !!
_________________
abe
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Mon May 18, 2009 8:24 pm    Post subject: Reply with quote

mieses wrote:
If restarting VirtualBox does not solve the GUI display problem, then edit ~/.VirtualBox/VirtualBox.xml and set GUI/UpdateDate to "never":

Code:
      <ExtraDataItem name="GUI/UpdateDate" value="never"/>


Thanks so much. This issue has been bugging me for ages on 2 systems.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum