Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
intel video 2.7.0
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Fri Apr 17, 2009 12:09 pm    Post subject: intel video 2.7.0 Reply with quote

I see that a couple of days ago there was a major intel
video driver release (2.7.0):

http://lists.freedesktop.org/archives/xorg/2009-April/045117.html

No sign of this in the x11 overlay yet. Anyone know an ETA?

(I am eager to *not* have xine with xv video freeze up my computer :) )
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Fri Apr 17, 2009 1:23 pm    Post subject: Reply with quote

have you tried just renaming the latest ebuild?
that worked for me at least for 2.6.99.902 -> 2.6.99.903.
but as i read there are still some problems left.
2.6.99.903 solved a nasty problem i had with 2.6.99.902 (slow xterm), so there is definitely some progress.
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Fri Apr 17, 2009 8:05 pm    Post subject: Reply with quote

It's in x11.

But we still need xorg-server-1.6.1 which was released recently. And mesa 7.5 seems to be on the way (the wanted to release it last friday, but I guess something came up...).
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Fri Apr 17, 2009 11:20 pm    Post subject: Reply with quote

Quote:
It's in x11.


so it is ... thanks

But it still hard locks my machine (thinkpad x300 with
GM965/GL960 Integrated Graphics Controller running
2.6.29-tuxonice, xorg 1.6.0, mesa 7.4) when I try to
play video with xine using xv. Strangely, smplayer plays
just perfect but ... I like xine :?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Fri Apr 17, 2009 11:37 pm    Post subject: Reply with quote

I move from xine to vlc some time ago. It uses a lot less CPU with 720p stuff.

Anyway, I'm waiting for the new X to be in x11 before I try the new driver.

BTW rc3 and the 9999_pre gave me problems with randr (most of the time couldn't the VGA output on my 3000 N200 (so also 965))
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 661
Location: Belgium

PostPosted: Sat Apr 18, 2009 6:59 am    Post subject: Reply with quote

2.7.0 messes up my screen (hard to describe, I can roughly recognize things, but the pixels are all over the place, no problem displaying the mouse pointer correctly though). I had to revert to 2.6.99.902.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Sat Apr 18, 2009 7:59 am    Post subject: Reply with quote

Kobboi wrote:
2.7.0 messes up my screen (hard to describe, I can roughly recognize things, but the pixels are all over the place, no problem displaying the mouse pointer correctly though). I had to revert to 2.6.99.902.

same situation here.
i went back to my renamed ebuild 2.6.99.902 -> 2.6.99.903, because of the slow xterm with 2.6.99.902.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Apr 21, 2009 12:42 pm    Post subject: Reply with quote

it seems like there is a kernel patch needed to let 2.7 work correctly, see this.
i did not try it out so far.
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2542
Location: Near Toronto

PostPosted: Tue Apr 21, 2009 2:27 pm    Post subject: Reply with quote

Quote:
it seems like there is a kernel patch needed to let 2.7 work correctly, see this.
i did not try it out so far.


seems to work pretty well for me - GM965 - so far ...
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Tue Apr 21, 2009 9:45 pm    Post subject: Reply with quote

the patch works for me quite well too.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Tue Apr 21, 2009 11:32 pm    Post subject: Reply with quote

Confirmed, it works now with a customized git-sources-2.6.30_rc2-r7 ebuild to include the patch!
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Bakou
n00b
n00b


Joined: 05 Feb 2007
Posts: 42

PostPosted: Sun Apr 26, 2009 4:54 am    Post subject: Reply with quote

Can anyone confirm if the patch is still needed in the latest git sources, git-sources-2.6.30_rc3-r1?
_________________
--Laptop--
ThinkPad T500 Gentoo

--Desktop--
Intel Core Duo E6420 (8x333)
3 GB PC6400 DDR2 825mhz 4-4-4-15
nVidia 8800GT
Creative X-Fi (works in Gentoo)
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Sun Apr 26, 2009 5:04 am    Post subject: Reply with quote

Yes, needed.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
szczerb
Veteran
Veteran


Joined: 24 Feb 2007
Posts: 1701
Location: Poland => Lodz

PostPosted: Sun Apr 26, 2009 12:04 pm    Post subject: Reply with quote

Do you know if it will be incorporated in the final 2.6.30?
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Sun Apr 26, 2009 6:37 pm    Post subject: Reply with quote

szczerb wrote:
Do you know if it will be incorporated in the final 2.6.30?
the commit says
Code:
Requires a kernel patch for .29/.30-rc2 with 965 and newer chipsets.
so i guess it should be in the tree at the latest with .30-rc2.
Back to top
View user's profile Send private message
Bakou
n00b
n00b


Joined: 05 Feb 2007
Posts: 42

PostPosted: Mon Apr 27, 2009 7:23 pm    Post subject: Reply with quote

Would anyone be so kind as to post the patch, or better yet an ebuild to build patched .29-r1?
I go to this URL: http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git;a=commitdiff_plain;h=f544847fbaf099278343f875987a983f2b913134;hp=cd97824994042b809493807ea644ba26c0c23290x11-drivers/xf86-video-intel/xf86-video-intel-2.7.0

And it tells me
Reading git-diff-tree failed
and its given me the same message for the past 3 days.
They don't make this easy, do they?
_________________
--Laptop--
ThinkPad T500 Gentoo

--Desktop--
Intel Core Duo E6420 (8x333)
3 GB PC6400 DDR2 825mhz 4-4-4-15
nVidia 8800GT
Creative X-Fi (works in Gentoo)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Apr 27, 2009 7:31 pm    Post subject: Reply with quote

alex.blackbit wrote:
szczerb wrote:
Do you know if it will be incorporated in the final 2.6.30?
the commit says
Code:
Requires a kernel patch for .29/.30-rc2 with 965 and newer chipsets.
so i guess it should be in the tree at the latest with .30-rc2.

No, isn't even in rc3.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Bakou
n00b
n00b


Joined: 05 Feb 2007
Posts: 42

PostPosted: Wed Apr 29, 2009 3:57 pm    Post subject: Reply with quote

In the other thread people say it was committed last night. It should be in rc3-r6 if its not in r5. Please confirm!
_________________
--Laptop--
ThinkPad T500 Gentoo

--Desktop--
Intel Core Duo E6420 (8x333)
3 GB PC6400 DDR2 825mhz 4-4-4-15
nVidia 8800GT
Creative X-Fi (works in Gentoo)
Back to top
View user's profile Send private message
diri
n00b
n00b


Joined: 26 Aug 2005
Posts: 4

PostPosted: Wed Apr 29, 2009 6:54 pm    Post subject: Reply with quote

Right now im using on Toshiba Sattelite Pro U400 laptop::

xf86-video-intel-2.7.0
xorg-server-1.6.1
git-sources-2.6.30_rc3-r6
mesa-7.4

KMS enabled, xorg working with dri2, konsole is fast, switching to console and back to X working and its realy fast. And i did not patch the kernel tree. Just dont forget to reemerge xf86-input*, as i did:)
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Thu Apr 30, 2009 1:23 am    Post subject: Reply with quote

did anyone try the new intel driver 2.7.99.1 already?
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Thu Apr 30, 2009 5:57 am    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software.
_________________
KDE
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Fri May 01, 2009 12:24 pm    Post subject: Reply with quote

alex.blackbit wrote:
did anyone try the new intel driver 2.7.99.1 already?

More or less me, since I'm on 9999. What this new version basically does is strip out 'legacy' stuff such as DRI1 and XAA/EXA, soon also modesetting should be removed since we have that in the kernel now.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
kornhs4
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2004
Posts: 83
Location: Austria

PostPosted: Wed May 13, 2009 12:16 pm    Post subject: Reply with quote

I just tried out xf86-video-intel-2.7.0 from portage with gentoo-sources-2.6.29-r2 and xorg-server-1.5.3-r5 and it works very well. With xf86-video-intel-2.6.3-r1 I had the problem of crashing X when launching some wine apps involving 3D.

cheers.
_________________
_________________
Life would be easier
if i had the source code
Back to top
View user's profile Send private message
Bakou
n00b
n00b


Joined: 05 Feb 2007
Posts: 42

PostPosted: Wed May 13, 2009 6:22 pm    Post subject: Reply with quote

intel 2.7.1 ebuild please.
_________________
--Laptop--
ThinkPad T500 Gentoo

--Desktop--
Intel Core Duo E6420 (8x333)
3 GB PC6400 DDR2 825mhz 4-4-4-15
nVidia 8800GT
Creative X-Fi (works in Gentoo)
Back to top
View user's profile Send private message
Kobboi
l33t
l33t


Joined: 29 Jul 2005
Posts: 661
Location: Belgium

PostPosted: Thu May 14, 2009 8:28 am    Post subject: Reply with quote

These are forums. Try Bugzilla.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum