Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
<SOLVED> emerge: ACCESS DENIED open_wr sandbox errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Wire64
n00b
n00b


Joined: 30 Aug 2007
Posts: 10

PostPosted: Thu Apr 23, 2009 4:50 pm    Post subject: <SOLVED> emerge: ACCESS DENIED open_wr sandbox errors Reply with quote

[/code]Hi my emerge produces these errors, it can still emerge older packages.
I just switched from kde-crazy to kde-testing dont know if that is relevant.

any suggestions


example:
Code:
emerge -va kopete

ACCESS DENIED  open_wr:      /var/log/sandbox/sandbox-net-libs_-_xulrunner-1.9.1_beta3-6606.log
ACCESS DENIED  open_wr:      /var/log/sandbox/sandbox-www-client_-_mozilla-firefox-3.1_beta3-6630.log
ACCESS DENIED  open_wr:      /var/log/sandbox/sandbox-kde-base_-_kopete-4.2.2-8628.log
...* I cut lines to keep it readable *..

Sandboxed process killed by signal: Segmentation fault                        ... done!
[ebuild  NS   ] kde-base/kopete-3.5.10 [9999] USE="crypt irc slp ssl winpopup yahoo -addbookmarks -alias -autoreplace -connectionstatus -contactnotes -debug -gadu -groupwise -highlight -history (-jingle) -kdehiddenvisibility -latex -netmeeting -nowlistening -sametime -sms -statistics -texteffect -translator -webpresence -xscreensaver" 9,118 kB

Total: 1 package (1 in new slot), Size of downloads: 9,118 kB

Would you like to merge these packages? [Yes/No]



Code:

Sandbox# ls -al /var/log/sandbox/
total 8
drwxr-xr-x  2 root root 4096 Apr 20  2007 .
drwxr-xr-x 10 root root 4096 Apr 23 16:16 ..
-rw-r--r--  1 root root    0 Apr 23 10:29 .keep_sys-apps_sandbox-0




dmesg
Code:
bash[5771]: segfault at bf032b3c ip b7ee2ee1 sp bf032b40 error 6 in libsandbox.so[b7ee0000+e000]
bash[5813]: segfault at bf117bcc ip b7ec7ee1 sp bf117bd0 error 6 in libsandbox.so[b7ec5000+e000]
bash[8482]: segfault at bf67dad4 ip b7dda9e3 sp bf67da24 error 6 in libc-2.9.so[b7d9d000+13d000]
bash[8504]: segfault at bf458eec ip b7f08ee1 sp bf458ef0 error 6 in libsandbox.so[b7f06000+e000]
bash[9706]: segfault at bf3efcac ip b809fee1 sp bf3efcb0 error 6 in libsandbox.so[b809d000+e000]
bash[9725]: segfault at bf7ee05c ip b7f9dee1 sp bf7ee060 error 6 in libsandbox.so[b7f9b000+e000]
bash[12785]: segfault at bf3e2ecc ip b8092ee1 sp bf3e2ed0 error 6 in libsandbox.so[b8090000+e000]
bash[12808]: segfault at bf7c1bc4 ip b7e1e9e3 sp bf7c1b14 error 6 in libc-2.9.so[b7de1000+13d000]
bash[12863]: segfault at bf50f5cc ip b7fbfee1 sp bf50f5d0 error 6 in libsandbox.so[b7fbd000+e000]
bash[12867]: segfault at bf41bc7c ip b7fcbee1 sp bf41bc80 error 6 in libsandbox.so[b7fc9000+e000]
bash[13012]: segfault at bf157db4 ip b7db39e3 sp bf157d04 error 6 in libc-2.9.so[b7d76000+13d000]
bash[13015]: segfault at bf3a4fa4 ip b7f009e3 sp bf3a4ef4 error 6 in libc-2.9.so[b7ec3000+13d000]
bash[13017]: segfault at bf05c94c ip b7f0cee1 sp bf05c950 error 6 in libsandbox.so[b7f0a000+e000]
bash[13020]: segfault at bf0973fc ip b8047ee1 sp bf097400 error 6 in libsandbox.so[b8045000+e000]
bash[13022]: segfault at bf0ecc94 ip b7f489e3 sp bf0ecbe4 error 6 in libc-2.9.so[b7f0b000+13d000]
bash[13025]: segfault at bf5ef62c ip b7f9fee1 sp bf5ef630 error 6 in libsandbox.so[b7f9d000+e000]
bash[13027]: segfault at bf6d1f7c ip b7f81ee1 sp bf6d1f80 error 6 in libsandbox.so[b7f7f000+e000]
bash[13029]: segfault at bf61a6fc ip b7fcaee1 sp bf61a700 error 6 in libsandbox.so[b7fc8000+e000]
bash[13032]: segfault at bf477dcc ip b8027ee1 sp bf477dd0 error 6 in libsandbox.so[b8025000+e000]
bash[13035]: segfault at bf534d1c ip b7fe4ee1 sp bf534d20 error 6 in libsandbox.so[b7fe2000+e000]
bash[13037]: segfault at bf50387c ip b7fb3ee1 sp bf503880 error 6 in libsandbox.so[b7fb1000+e000]
bash[13039]: segfault at bf1d7afc ip b7f87ee1 sp bf1d7b00 error 6 in libsandbox.so[b7f85000+e000]
bash[13042]: segfault at bf53a61c ip b7eeaee1 sp bf53a620 error 6 in libsandbox.so[b7ee8000+e000]
bash[13044]: segfault at bf33eb8c ip b7feeee1 sp bf33eb90 error 6 in libsandbox.so[b7fec000+e000]
bash[13109]: segfault at bf30f5fc ip b7fbfee1 sp bf30f600 error 6 in libsandbox.so[b7fbd000+e000]
bash[13112]: segfault at bf2fad8c ip b80aaee1 sp bf2fad90 error 6 in libsandbox.so[b80a8000+e000]
bash[13114]: segfault at bf5f0fe0 ip b7f747ff sp bf5f0fe4 error 6 in libc-2.9.so[b7f10000+13d000]
bash[13116]: segfault at bf50663c ip b7fb6ee1 sp bf506640 error 6 in libsandbox.so[b7fb4000+e000]
bash[13119]: segfault at bf7a3fbc ip b8053ee1 sp bf7a3fc0 error 6 in libsandbox.so[b8051000+e000]
bash[13121]: segfault at bf4c9f3c ip b7f79ee1 sp bf4c9f40 error 6 in libsandbox.so[b7f77000+e000]
bash[13138]: segfault at bf281ec4 ip b7edd9e3 sp bf281e14 error 6 in libc-2.9.so[b7ea0000+13d000]
bash[13141]: segfault at bf296b7c ip b7f46ee1 sp bf296b80 error 6 in libsandbox.so[b7f44000+e000]
bash[13144]: segfault at bf7b5b2c ip b8065ee1 sp bf7b5b30 error 6 in libsandbox.so[b8063000+e000]
bash[13146]: segfault at bf562f7c ip b7f12ee1 sp bf562f80 error 6 in libsandbox.so[b7f10000+e000]
bash[13148]: segfault at bf6b6b94 ip b7e139e3 sp bf6b6ae4 error 6 in libc-2.9.so[b7dd6000+13d000]
bash[13150]: segfault at bf20aec4 ip b7d669e3 sp bf20ae14 error 6 in libc-2.9.so[b7d29000+13d000]
bash[13153]: segfault at bf7ccc44 ip b7f299e3 sp bf7ccb94 error 6 in libc-2.9.so[b7eec000+13d000]
bash[13155]: segfault at bf00cbf4 ip b7e699e3 sp bf00cb44 error 6 in libc-2.9.so[b7e2c000+13d000]
bash[6607]: segfault at bf0c0b8c ip b8070ee1 sp bf0c0b90 error 6 in libsandbox.so[b806e000+e000]
bash[6631]: segfault at bf2bdd2c ip b806dee1 sp bf2bdd30 error 6 in libsandbox.so[b806b000+e000]
bash[6703]: segfault at bf3b7e8c ip b7f67ee1 sp bf3b7e90 error 6 in libsandbox.so[b7f65000+e000]
bash[6705]: segfault at bf6b36fc ip b7f63ee1 sp bf6b3700 error 6 in libsandbox.so[b7f61000+e000]
bash[6749]: segfault at bf740fdc ip b7ef0ee1 sp bf740fe0 error 6 in libsandbox.so[b7eee000+e000]
bash[6751]: segfault at bf1823fc ip b8032ee1 sp bf182400 error 6 in libsandbox.so[b8030000+e000]
bash[7251]: segfault at bf51b80c ip b7ecbee1 sp bf51b810 error 6 in libsandbox.so[b7ec9000+e000]



emerge --info:
Code:
emerge --info
Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.25-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r6-i686-Intel-R-_Pentium-R-_4_CPU_3.06GHz-with-gentoo-2.0.0
Timestamp of tree: Thu, 23 Apr 2009 08:15:02 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/kde/live/env /usr/kde/live/share/config /usr/kde/live/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://gentoo.tiscali.nl/pub/mirror/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/mozilla /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac aiglx aim alsa arts avahi berkdb bzip2 cairo cdaudio cdparanoia cdr cdrom cdsound cli clock-screen cpufreq cracklib crypt cups curl dbus divx dri elf esd ffmpeg flac fortran gdbm gimp gimpprint gnome-print gpm gstreamer gtk gtkhtml hal hddtemp http iconv id3 ieee1394 ignore-case ipv6 irc irmc jack java javascript jbig jpeg jpeg2k kde kdepim kipi lame largenet libgs libwww logrotate mad mdnsresponder-compat midi mp3 mpeg mpeg2 mplayer msn mudflap mysql nas nautilus ncurses network nfs nls nntp nptl nptlonly ntfs ogg opengl openmp osc pam parport pcre pdf perl php pidgin png pop ppds pppd python qq qt3 qt3support qt4 quicktime rar readline realmedia reflection rss samba session skins slp snmp spl ssl sysfs syslog tcpd tiff truetype unicode vorbis wav winpopup wlm x86 xcb xfce xml xorg xulrunner xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Last edited by Wire64 on Fri Apr 24, 2009 4:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Thu Apr 23, 2009 7:33 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Wire64
n00b
n00b


Joined: 30 Aug 2007
Posts: 10

PostPosted: Fri Apr 24, 2009 4:40 pm    Post subject: Reply with quote

Changing status to <Solved>

I ran sandbox which crashed (ofcourse) but then i saw the first error.
In my case /usr/local/lib/libundel.so ( of e2undel-0.82) caused the errors.

Removing e2undel sovled my problem.

Wire64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum