Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Thu Oct 25, 2007 12:10 pm    Post subject: [PALUDIS] Support thread (current v. 0.26.*) - Part 4 Reply with quote

Continued from [PALUDIS] Support thread (current v. 0.24.6) - Part 3

Hi,

I'm trying to upgrade my Paludis installation to version 0.26_alpha1 but the process dies unexpectedly at this point with "Segmentation fault":

Code:

i686-pc-linux-gnu-g++ -I../../../.. -I../../../../src -DPALUDIS_HASH_IS_STD_TR1_UNORDERED=1 -DPALUDIS_TR1_MEMORY_IS_STD_TR1=1 -DPALUDIS_TR1_TYPE_TRAITS_IS_STD_TR1=1 -DPALUDIS_TR1_FUNCTIONAL_IS_STD_TR1=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -pedantic -march=prescott -O2 -pipe -o .libs/example_name example_name.o  libpaludisexamples.a ../../../../paludis/.libs/libpaludis.so ../../../../paludis/args/.libs/libpaludisargs.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/paludis/.libs/libpaludis.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/paludis/selinux/.libs/libpaludisselinux.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/paludis/util/.libs/libpaludisutil.so -ldl
creating example_name
make[6]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/cplusplus/examples'
make[5]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/cplusplus/examples'
Making all in .
make[5]: Entering directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/cplusplus'
doxygen doxygen.conf
make[5]: *** [cplusplus] Segmentation fault
make[5]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/cplusplus'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/cplusplus'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1'
make: *** [all] Error 2

!!! ERROR in sys-apps/paludis-0.26.0_alpha1:
!!! In src_compile at line 3387
!!! emake failed

!!! Call stack:
!!!    * src_compile (/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/temp/loadsaveenv:3387)
!!!    * ebuild_f_compile (/usr/libexec/paludis/src_compile.bash:51)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Install error:
  * In program paludis -i1 paludis:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-apps/paludis-0.26.0_alpha1':
  * Install error: Install failed for 'sys-apps/paludis-0.26.0_alpha1::paludis-overlay'


Resume command: paludis --log-level warning --preserve-world --dl-deps-default discard --install '=sys-apps/paludis-0.26.0_alpha1::paludis-overlay'


Apparently it's a problem with doxygen but this is just my guess... I have doxygen 1.5.2 (stable branch).
Is anyone else experiencing the same issue as I am? :?
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Thu Oct 25, 2007 1:58 pm    Post subject: Reply with quote

jordan83 wrote:
Apparently it's a problem with doxygen but this is just my guess... I have doxygen 1.5.2 (stable branch).

Use 1.5.3.
Back to top
View user's profile Send private message
shpena
n00b
n00b


Joined: 09 Nov 2002
Posts: 17
Location: between the divine and demonic

PostPosted: Fri Oct 26, 2007 1:54 am    Post subject: Reply with quote

Will the new paludis be able to work around the broken firefox 2.0.0.8 ebuild or will we still have to manually change the permissions in the folder?

---

That berlioz quote had me laughing. Thanks! :D
_________________
"Fighting over religion is like fighting to see who's imaginary friend is best."
"Undergrads think they know everything, graduates know they know nothing and Ph.D's know everyone else knows nothing."
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Sun Oct 28, 2007 6:24 pm    Post subject: Reply with quote

Kuroi Ryu wrote:
Will the new paludis be able to work around the broken firefox 2.0.0.8 ebuild or will we still have to manually change the permissions in the folder?

18:24:03 < ciaranm> https://forums.gentoo.org/viewtopic-p-4421264.html#4421264 <-- someone tell him yes
Back to top
View user's profile Send private message
zlin
Retired Dev
Retired Dev


Joined: 05 Dec 2005
Posts: 35
Location: Aalborg, Denmark

PostPosted: Sun Oct 28, 2007 6:26 pm    Post subject: Reply with quote

Kuroi Ryu wrote:
Will the new paludis be able to work around the broken firefox 2.0.0.8 ebuild or will we still have to manually change the permissions in the folder?

Yes, paludis now fixes bad permissions too.
Back to top
View user's profile Send private message
droidix
n00b
n00b


Joined: 16 Nov 2006
Posts: 8

PostPosted: Fri Nov 02, 2007 5:49 pm    Post subject: Reply with quote

Had the following error while building...

Code:

mkdir -p python
env \
            LD_LIBRARY_PATH=`echo "\`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/util/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/paludis/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/no_config/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/adapted/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/repositories/e/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/repositories/fake/.libs\`: \
            \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../python/.libs\`" \
            | tr -d ' '` \
            PYTHONPATH="./.libs" \
            epydoc -n Paludis -o python -u http://paludis.pioto.org --no-frames -c ./epydoc.css \
                ../../../python/paludis.so
env: epydoc: No such file or directory
make[5]: *** [python] Error 127
make[5]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/python'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api/python'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc/api'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/work/paludis-0.26.0_alpha1'
make: *** [all] Error 2

!!! ERROR in sys-apps/paludis-0.26.0_alpha1:
!!! In src_compile at line 3373
!!! emake failed

!!! Call stack:
!!!    * src_compile (/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha1/temp/loadsaveenv:3373)
!!!    * ebuild_f_compile (/usr/libexec/paludis/src_compile.bash:51)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Install error:
  * In program paludis --install =sys-apps/paludis-0.26.0_alpha1:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-apps/paludis-0.26.0_alpha1':
  * Install error: Install failed for 'sys-apps/paludis-0.26.0_alpha1::local_stuff'


Looks like dev-python/epydoc is needed.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Nov 04, 2007 8:14 pm    Post subject: Reply with quote

Whenever I run
Code:
paludis -i world --dl-upgrade always --dl-reinstall if-use-changed -p


It will always have app-editors/vim being reinstalled. Any ideas why this is happening?
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Sun Nov 04, 2007 10:31 pm    Post subject: Reply with quote

slycordinator wrote:
Whenever I run
Code:
paludis -i world --dl-upgrade always --dl-reinstall if-use-changed -p


It will always have app-editors/vim being reinstalled. Any ideas why this is happening?

Maybe
paludis -h:
...
--show-reasons         Show why packages are being (un)installed
      none                 Don't show any information (default)
      summary              Show a summary
      full                 Show full output (can be very verbose)
...

_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Nov 04, 2007 11:06 pm    Post subject: Reply with quote

Code:
paludis -i world --dl-upgrade always -p --show-reasons summary


Code:
These packages will be installed:

* app-editors/vim-7.1.042 {:0} [R] acl bash-completion -cscope gpm -minimal nls perl python -ruby -vim-pager -vim-with-x <*virtual/editor-7.1.042::virtuals (virtual for app-editors/vim-7.1.042:0::gentoo)>
* app-text/ghostscript-gpl-8.60-r1 {:0} [U 8.60] X -bindist -cjk cups -djvu gtk jpeg2k <virtual/ghostscript-0:0::installed>
* dev-lang/mono-1.2.5.1-r1 {:0} [U 1.2.4] X nptl <app-office/openoffice-2.3.0:0::installed, dev-dotnet/pe-format-0:0::installed>


The other 2 packages, I expected to be updated. But I had updated other packages already yesterday including letting it reinstall vim and now it wants to reinstall vim again.
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Mon Nov 05, 2007 1:02 am    Post subject: Reply with quote

slycordinator wrote:
The other 2 packages, I expected to be updated. But I had updated other packages already yesterday including letting it reinstall vim and now it wants to reinstall vim again.

You're using the paludis profile from the overlay? Sync and it should be fixed.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon Nov 05, 2007 8:14 am    Post subject: Reply with quote

dleverton wrote:
slycordinator wrote:
The other 2 packages, I expected to be updated. But I had updated other packages already yesterday including letting it reinstall vim and now it wants to reinstall vim again.

You're using the paludis profile from the overlay? Sync and it should be fixed.


Confirmed; it's all good now.
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Tue Nov 06, 2007 9:20 am    Post subject: Reply with quote

Hi,

Can Paludis build static packages? I need it for evms with genkernel.
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
Cottonee
n00b
n00b


Joined: 23 Sep 2003
Posts: 73
Location: Palmerston North, New Zealand

PostPosted: Thu Nov 08, 2007 6:36 am    Post subject: Reply with quote

Hi,
I tried to compile paludis-0.26.0_alpha3 but got error like this every time. :( Did I mess anything? Could someone help me please...
Cheers
-Nat

Code:

mkdir .libs
mv -f .deps/accerso.Tpo .deps/accerso.Po
/bin/sh ../../../libtool --tag=CXX   --mode=link i686-pc-linux-gnu-g++ -I../../.. -I../../../src -DPALUDIS_HASH_IS_STD_TR1_UNORDERED=1 -DPALUDIS_TR1_MEMORY_IS_STD_TR1=1 -DPALUDIS_TR1_TYPE_TRAITS_IS_STD_TR1=1 -DPALUDIS_TR1_FUNCTIONAL_IS_STD_TR1=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -pedantic  -march=prescott -O3 -pipe -fomit-frame-pointer   -o accerso command_line.o accerso.o ../../../paludis/libpaludis.la ../../../paludis/args/libpaludisargs.la ../../../paludis/util/libpaludisutil.la ../../../paludis/environments/no_config/libpaludisnoconfigenvironment.la ../../../src/output/liboutput.a -ldl
i686-pc-linux-gnu-g++ -I../../.. -I../../../src -DPALUDIS_HASH_IS_STD_TR1_UNORDERED=1 -DPALUDIS_TR1_MEMORY_IS_STD_TR1=1 -DPALUDIS_TR1_TYPE_TRAITS_IS_STD_TR1=1 -DPALUDIS_TR1_FUNCTIONAL_IS_STD_TR1=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -pedantic -march=prescott -O3 -pipe -fomit-frame-pointer -o .libs/accerso command_line.o accerso.o  ../../../paludis/.libs/libpaludis.so ../../../paludis/args/.libs/libpaludisargs.so ../../../paludis/util/.libs/libpaludisutil.so ../../../paludis/environments/no_config/.libs/libpaludisnoconfigenvironment.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/selinux/.libs/libpaludisselinux.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/util/.libs/libpaludisutil.so ../../../src/output/liboutput.a -ldl
../../../paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator==(paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const> const&) const'
../../../paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator*() const'
../../../paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::~WrappedForwardIterator()'
../../../paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator++()'
collect2: ld returned 1 exit status
make[5]: *** [accerso] Error 1
make[5]: *** Waiting for unfinished jobs....
i686-pc-linux-gnu-g++ -I../../.. -I../../../src -DPALUDIS_HASH_IS_STD_TR1_UNORDERED=1 -DPALUDIS_TR1_MEMORY_IS_STD_TR1=1 -DPALUDIS_TR1_TYPE_TRAITS_IS_STD_TR1=1 -DPALUDIS_TR1_FUNCTIONAL_IS_STD_TR1=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -pedantic -march=prescott -O3 -pipe -fomit-frame-pointer -o .libs/man-accerso man_accerso.o command_line.o  ../../../paludis/args/.libs/libpaludisargs.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/selinux/.libs/libpaludisselinux.so ../../../paludis/args/libpaludisman.a ../../../paludis/util/.libs/libpaludisutil.so ../../../paludis/.libs/libpaludismanpagethings.a /var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/util/.libs/libpaludisutil.so ../../../src/output/liboutput.a -ldl
/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator==(paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const> const&) const'
/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator*() const'
/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::~WrappedForwardIterator()'
/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/paludis/.libs/libpaludis.so: undefined reference to `paludis::WrappedForwardIterator<paludis::Sequence<std::tr1::shared_ptr<paludis::PackageID const> >::ReverseConstIteratorTag, std::tr1::shared_ptr<paludis::PackageID const> const>::operator++()'
collect2: ld returned 1 exit status
make[5]: *** [man-accerso] Error 1
make[5]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/src/clients/accerso'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/src/clients/accerso'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/src/clients'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/work/paludis-0.26.0_alpha3'
make: *** [all] Error 2

!!! ERROR in sys-apps/paludis-0.26.0_alpha3:
!!! In src_compile at line 3375
!!! emake failed

!!! Call stack:
!!!    * src_compile (/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha3/temp/loadsaveenv:3375)
!!!    * ebuild_f_compile (/usr/libexec/paludis/src_compile.bash:51)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Install error:
  * In program paludis -i paludis:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-apps/paludis-0.26.0_alpha3':
  * Install error: Install failed for 'sys-apps/paludis-0.26.0_alpha3::gentoo
Back to top
View user's profile Send private message
meka
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2003
Posts: 85
Location: Novi Sad / Vojvodina / Srbija

PostPosted: Thu Nov 08, 2007 10:35 am    Post subject: Reply with quote

Don't use -O3, or use SCM.
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Thu Nov 08, 2007 10:35 am    Post subject: Reply with quote

Cottonee wrote:
I tried to compile paludis-0.26.0_alpha3 but got error like this every time. :( Did I mess anything? Could someone help me please...

Don't use -O3. It breaks stuff. Or, if you insist on it, you could try -scm.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Nov 08, 2007 11:39 am    Post subject: Reply with quote

zlin wrote:
Kuroi Ryu wrote:
Will the new paludis be able to work around the broken firefox 2.0.0.8 ebuild or will we still have to manually change the permissions in the folder?

Yes, paludis now fixes bad permissions too.


wohoo !! - way to go, paludis 8)

what is -scm, btw ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Thu Nov 08, 2007 4:30 pm    Post subject: Reply with quote

kernelOfTruth wrote:
zlin wrote:
Kuroi Ryu wrote:
Will the new paludis be able to work around the broken firefox 2.0.0.8 ebuild or will we still have to manually change the permissions in the folder?

Yes, paludis now fixes bad permissions too.


wohoo !! - way to go, paludis 8)

what is -scm, btw ?


Live ebuilds similar to the version 9999 used in the portage tree
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Sun Nov 11, 2007 7:07 pm    Post subject: Reply with quote

Hi,

today I ran a paludis --report on my system to have a look on the current state of my installation and I got this:

Code:

# paludis --report
Current state of the system

* dev-java/sun-jdk-1.4.2.15::installed NOT OK
    No longer exists in its original repository 'gentoo'

* dev-java/sun-jdk-1.5.0.12::installed NOT OK
    No longer exists in its original repository 'gentoo'

Finished processing 1085 packages. 2 errors.


Being quite surprised by this output, I ran a query and got:
Code:

# paludis -q dev-java/sun-jdk
* dev-java/sun-jdk
    installed:               1.4.2.15 {:1.4} 1.5.0.12 {:1.5} 1.6.0.03* {:1.6}
    gentoo:                  1.4.2.16 {:1.4} 1.5.0.13 {:1.5} 1.6.0.03 {:1.6}
    Description:             Sun's J2SE Development Kit, version 1.6.0.03
    Homepage:                http://java.sun.com/javase/6/
    Relevant USE flags:      (X) (alsa) (doc) (-examples) (-jce) (nsplugin)
    License:                 dlj-1.1
    Installed time:          Sun Oct  7 10:14:32 2007
    Source repository:       gentoo
    Installed using:         paludis-0.24.6

Apparently Paludis updates the most recent slot but it does not update the other ones (namely 1.4.x and 1.5.x).
Is this a bug or is there any switch that I am not using properly? :?

Currently my PALUDIS_OPTIONS is:
Code:

export PALUDIS_OPTIONS="--log-level warning --dl-reinstall if-use-changed --show-use-descriptions changed --show-reasons summary"

_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Nov 11, 2007 7:15 pm    Post subject: Reply with quote

Try adding
Code:
--dl-deps-default pre-or-post
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Sun Nov 11, 2007 8:06 pm    Post subject: Reply with quote

slycordinator wrote:
Try adding
Code:
--dl-deps-default pre-or-post

This is the output I get:
Code:

# paludis -1i -p --dl-deps-default pre-or-post dev-java/sun-jdk
Building target list...
Building dependency list...

These packages will be installed:

* x11-misc/makedepend-1.0.1::gentoo {:0} [U 1.0.0] -debug <media-libs/mesa-6.5.2-r1:0::installed>
* dev-java/sun-jdk-1.6.0.03::gentoo {:1.6} [R] X alsa doc -examples -jce nsplugin <virtual/jdk-1.6.0:1.6::installed>

Total: 2 packages (1 upgrade, 1 rebuild)

Nothing changed, basically :|
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Nov 11, 2007 8:13 pm    Post subject: Reply with quote

So how are you sure you actually need the older versions?
Back to top
View user's profile Send private message
jordan83
Apprentice
Apprentice


Joined: 17 Apr 2006
Posts: 222
Location: check your closet...

PostPosted: Sun Nov 11, 2007 8:36 pm    Post subject: Reply with quote

slycordinator wrote:
So how are you sure you actually need the older versions?

I think that both the old versions are there because in the repository some programs require them in order to compile

Ignoring or working around the problem are not good solutions, though ;)

Thanks for the help :)
_________________
Time is a great teacher, but unfortunately it kills all its pupils.
Louis-Hector Berlioz
--
When the Boogeyman goes to sleep every night, he checks his closet for Chuck Norris.
chucknorrisfacts.com
Back to top
View user's profile Send private message
dleverton
Guru
Guru


Joined: 28 Aug 2006
Posts: 517

PostPosted: Sun Nov 11, 2007 9:34 pm    Post subject: Reply with quote

jordan83 wrote:

Apparently Paludis updates the most recent slot but it does not update the other ones (namely 1.4.x and 1.5.x).
Is this a bug or is there any switch that I am not using properly? :?

Funny you should say that... I'm hoping that ciaranm will fix it for 0.28. In the meantime, if you know there are packages where you want all slots to be updated, you can edit the world file and add them explicitly, for example
Code:

dev-java/sun-jdk
dev-java/sun-jdk:1.4
dev-java/sun-jdk:1.5

(you can leave off the first one if it's not there already, since presumably that means it's pulled in by something depending on it).
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon Nov 12, 2007 5:43 am    Post subject: Reply with quote

jordan83 wrote:
slycordinator wrote:
So how are you sure you actually need the older versions?

I think that both the old versions are there because in the repository some programs require them in order to compile


That's not what I asked though.
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Nov 13, 2007 3:52 pm    Post subject: Reply with quote

Hi, i just installed paludis, and i have to say, i love it :D

Just one problem though, with mesa + xorg.

xorg-server does not want to reinstall, because mesa has no nptl use flag, whereas xorg-server has...
I have 2007.0/desktop profile, and both nptl and nptlonly use flags in use.conf, and mesa has (-nptl) with paludis, but USE="nptl" with portage...

How can i fix this?


dodo
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 24, 25, 26  Next
Page 1 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum