Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pussi
l33t
l33t


Joined: 08 May 2004
Posts: 727
Location: Finland

PostPosted: Tue Jan 22, 2008 3:59 pm    Post subject: Reply with quote

dleverton wrote:
pussi wrote:
Is there some way I could prevent paludis from removing files in /lib/modules?

http://www.piotrj.org/index.php?/archives/13-UNINSTALL_PROTECT-in-Paludis-3.html

thanks!
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jan 22, 2008 4:22 pm    Post subject: Reply with quote

When parsing dependency string 'virtual/libc x86? ( x11-libs/libX11 x11-libs/libXi) dev-libs/atk dev-libs/glib x11-libs/gtk+ x11-libs/pango amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 ) >=app-arch/rpm2targz-9.0-r1' using EAPI '0':
* When parsing dependency string 'virtual/libc x86? ( x11-libs/libX11 x11-libs/libXi) dev-libs/atk dev-libs/glib x11-libs/gtk+ x11-libs/pango amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 ) >=app-arch/rpm2targz-9.0-r1':
When handling lexer token 'x11-libs/libXi)' (1):
* When parsing package dep spec 'x11-libs/libXi)' with eapi '0':
* When splitting out category and package names from 'x11-libs/libXi)':
* When validating package name part 'libXi)':
* Name 'libXi)' is not a valid package name part (paludis::PackageNamePartError)

just don't know how to handle this.
am a real new dude to paludis.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Wed Jan 23, 2008 4:26 am    Post subject: Reply with quote

Show us more of the output; as it is we can't see what package that info is coming from.

Also, try showing us what command you were actually trying to do.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Wed Jan 23, 2008 12:20 pm    Post subject: Reply with quote

slycordinator wrote:
Show us more of the output; as it is we can't see what package that info is coming from.

Also, try showing us what command you were actually trying to do.


it got past this point. at least so i think
then this is the problem now and i dont know how to solve this;


Query error:
* In program paludis --dl-upgrade as-needed --dl-new-slots as-needed -i world -p:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding PackageDepSpec 'sys-auth/policykit':
* All versions of 'sys-auth/policykit' are masked. Candidates are:
* sys-auth/policykit-0.6:0::gentoo: Masked by repository (/usr/portage/profiles/package.mask: Saleem Abdulrasool <compnerd@gentoo.org> (23 Nov 2007) These might break automounting, so keep them masked for now.), user
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Wed Jan 23, 2008 5:22 pm    Post subject: Reply with quote

tranquilcool wrote:
slycordinator wrote:
Show us more of the output; as it is we can't see what package that info is coming from.

Also, try showing us what command you were actually trying to do.


it got past this point. at least so i think
then this is the problem now and i dont know how to solve this;


Query error:
* In program paludis --dl-upgrade as-needed --dl-new-slots as-needed -i world -p:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding PackageDepSpec 'sys-auth/policykit':
* All versions of 'sys-auth/policykit' are masked. Candidates are:
* sys-auth/policykit-0.6:0::gentoo: Masked by repository (/usr/portage/profiles/package.mask: Saleem Abdulrasool <compnerd@gentoo.org> (23 Nov 2007) These might break automounting, so keep them masked for now.), user


OK so the last two lines explain that sys-auth/policykit is masked by /usr/portage/profiles/package.mask, since it might break automounting. You can check gentoo wiki and documentation for information about what masking is and why things are masked. For a temporary fix, you can use the following:
Code:

# echo "sys-auth/policykit" >> /etc/paludis/package_unmask.conf

This will unmask policykit, but may also break automounting. A better fix would be to see what needs that version of policykit, by running:
Code:

# paludis -ip world --dl-upgrade as-needed --dl-new-slots as-needed --show-reasons summary

or maybe
Code:

# paludis -ip world --dl-upgrade as-needed --dl-new-slots as-needed --show-reasons full

This will tell you what package wants that version of policykit, and you can decide from there what to do (maybe remove a use flag or the package).
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Wed Jan 23, 2008 8:08 pm    Post subject: Reply with quote

it doesn't show any reason. i was thinking if
there's a way i can make paludis proceed keeping the policykit
packaged masked.
anyway am updating paludis right now to alpha9.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Thu Jan 24, 2008 1:14 am    Post subject: Reply with quote

tranquilcool wrote:
it doesn't show any reason. i was thinking if
there's a way i can make paludis proceed keeping the policykit
packaged masked.
anyway am updating paludis right now to alpha9.


Code:

# paludis --help | grep mask
  --dl-override-masks    Zero or more mask kinds that can be overridden as
necessary (default: tilde-keyword and license)
      tilde-keyword        Keyword masks where accepting ~ would work
      unkeyworded          Keyword masks where a package is unkeyworded
      repository           Repository masks
      license              License masks


Also if you just want to unmask just this version you can specify the full packageID like so:
Code:

# echo "sys-auth/policykit-0.6.0::gentoo" >> /etc/paludis/package_unmask.conf
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Thu Jan 24, 2008 2:33 pm    Post subject: Reply with quote

well thanks.
solved the problem by adding, as you suggested,
the policykit package to package_unmask.conf
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
jorges
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2005
Posts: 114
Location: Barcelona, Spain

PostPosted: Thu Jan 24, 2008 5:03 pm    Post subject: Reply with quote

Hi,
I've been experiencing some weird behavior from paludis lately (3 or 4 days). It *might* be by the time I installed 0.26_alpha_something. I have received a few strange messages when installing, reinstalling, etc stuff. There don't seem to be a log of these messages, or at least I don't know where it lives. From what I recall:

- Installing nvidia-drivers failed with a message about failing to chown a file.
- Several packages failed in the uninstall phase, living a -reinstalling-package-bla-XXX in /var/db/pkg. The packages were correctly installed, apparently, as per the --version option given to the executable reflects the new version.
- I recall receiving several messages about a locked_pipe_command, maybe it was in the context of the uninstall phase described above.

What surprises me more is that I've searched and didn't find similar reports from people. Maybe I screwed something, but what?

jorges
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Thu Jan 24, 2008 5:35 pm    Post subject: Reply with quote

jorges wrote:
- Several packages failed in the uninstall phase, living a -reinstalling-package-bla-XXX in /var/db/pkg. The packages were correctly installed, apparently, as per the --version option given to the executable reflects the new version.


Most likely that's because you killed paludis w/ a CTRL+C during the install phase while it was reinstalling a package then when it goes to reinstall it says "WTF? Why does this directory I'm supposed to create already exist?"

I did that a couple times a while back.
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Fri Jan 25, 2008 4:08 pm    Post subject: Reply with quote

jorges wrote:
Hi,
I've been experiencing some weird behavior from paludis lately (3 or 4 days). It *might* be by the time I installed 0.26_alpha_something. I have received a few strange messages when installing, reinstalling, etc stuff. There don't seem to be a log of these messages, or at least I don't know where it lives. From what I recall:

- Installing nvidia-drivers failed with a message about failing to chown a file.
- Several packages failed in the uninstall phase, living a -reinstalling-package-bla-XXX in /var/db/pkg. The packages were correctly installed, apparently, as per the --version option given to the executable reflects the new version.
- I recall receiving several messages about a locked_pipe_command, maybe it was in the context of the uninstall phase described above.

What surprises me more is that I've searched and didn't find similar reports from people. Maybe I screwed something, but what?

jorges

With so little information its hard to pin down what's wrong. Here is some general cleaning to try and what information to post to see what is really wrong.

Do:
Code:

# rm -r /var/tmp/paludis/*
# paludis --sync
# paludis --regenerate-installed-cache


Then please post the output of:
Code:
paludis -V

Code:
paludis -i nvidia-drivers

Code:
paludis -u some-package-that-fails-uninstall
Back to top
View user's profile Send private message
jorges
Tux's lil' helper
Tux's lil' helper


Joined: 31 Oct 2005
Posts: 114
Location: Barcelona, Spain

PostPosted: Fri Jan 25, 2008 4:25 pm    Post subject: Reply with quote

micr0c0sm wrote:
With so little information its hard to pin down what's wrong. Here is some general cleaning to try and what information to post to see what is really wrong.

Do:
Code:

# rm -r /var/tmp/paludis/*
# paludis --sync
# paludis --regenerate-installed-cache


Then please post the output of:
Code:
paludis -V

Code:
paludis -i nvidia-drivers

Code:
paludis -u some-package-that-fails-uninstall


I've done many things that I didn't include in my post, but in summary:
- When I started getting those error messages I downgraded paludis to 0.24.latest
- The uninstalled errors appeared in the context of reinstalling things. As the installation phase seemed successful, I ended up removing from /var/db/pkg all entries that started with "-reinstalling-blabla-XXX".
- I synced as you suggested, then upgraded paludis (there was a new 0.26_alpha) and it seems ok for now)

I hope I didn't screwed my system, or leave garbage on it. So far everything seems ok. What annoys me is that I don't have a clue of the cause of this.
Thanks for the advice (same goes for slycordinator).

The output you requested, in case it is still relevant (but I upgraded paludis since my first post):
Code:
$ paludis -V
paludis 0.26.0_alpha9

Paludis comes with ABSOLUTELY NO WARRANTY. Paludis is free software, and you
are welcome to redistribute it under the terms of the GNU General Public
License, version 2.

Reinstalling nvidia went fine with 0.26_alpha9. I didn't try the uninstalling as I manually removed those entries from /var/db/pkg
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Fri Jan 25, 2008 5:15 pm    Post subject: Reply with quote

Glad everything is working for ya, even if you couldn't figure out why there were weird entried in world.
Back to top
View user's profile Send private message
binary_runner
n00b
n00b


Joined: 26 Oct 2003
Posts: 64

PostPosted: Sat Jan 26, 2008 2:08 pm    Post subject: executables installed with paludisbuild group set Reply with quote

I've noticed the some executables in /usr/bin have group paludisbuild, the oldest is from 22th October.
I don't like it and I want to know - is it a bug or a feature ? How can I change this ?
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Sat Jan 26, 2008 2:20 pm    Post subject: Re: executables installed with paludisbuild group set Reply with quote

binary_runner wrote:
I've noticed the some executables in /usr/bin have group paludisbuild, the oldest is from 22th October.
I don't like it and I want to know - is it a bug or a feature ? How can I change this ?


Which ones?
Code:
ls -al /usr/bin/ | grep paludisbuild

Shows none of mine are paludisbuild, so I'm pretty sure it would be safe to change it.
Back to top
View user's profile Send private message
binary_runner
n00b
n00b


Joined: 26 Oct 2003
Posts: 64

PostPosted: Sat Jan 26, 2008 3:24 pm    Post subject: Re: executables installed with paludisbuild group set Reply with quote

micr0c0sm wrote:

Which ones?
Code:
ls -al /usr/bin/ | grep paludisbuild

Shows none of mine are paludisbuild, so I'm pretty sure it would be safe to change it.



I'd better not to put the list here as there is almost two hundred of the files. I can change the group
but I want to be sure that the paludis will install files with the right group, permissions etc.
Back to top
View user's profile Send private message
micr0c0sm
Tux's lil' helper
Tux's lil' helper


Joined: 29 Oct 2005
Posts: 148
Location: New York

PostPosted: Sat Jan 26, 2008 5:22 pm    Post subject: Reply with quote

Then try:
Code:

# chown myuser:mygroup /usr/bin/foo
# paludis -i1 foo
# ls -al /usr/bin/foo

See if paludis overwrites with paludisbuild as owner. If it does, ask in #paludis on freenode, because mine doesn't do that and I'm not sure why it would.
Back to top
View user's profile Send private message
Zerodark
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2003
Posts: 83

PostPosted: Sat Jan 26, 2008 7:11 pm    Post subject: Reply with quote

I'm really new to paludis, but I think it's really cool. I have however run into a slight problem. Everytime I try to update my world, I get this output:

Code:

localhost xerodark # paludis -i world
Building target list...
Building dependency list...paludis@1201345175: [WARNING] Provides cache at '/var/db/pkg/.cache/provides' is not a regular file.
paludis@1201345177: [QA] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-accessibility/speech-tools':
  ... When adding package 'app-accessibility/speech-tools-1.2.96_beta:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/libX11':
  ... When adding package 'x11-libs/libX11-1.1.3:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/xtrans-1.0.1':
  ... When adding package 'x11-libs/xtrans-1.0.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=sys-devel/automake-1.10*':
  ... When adding package 'sys-devel/automake-1.10.1:1.10::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/perl':
  ... When adding package 'dev-lang/perl-5.8.8-r4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/db':
  ... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=virtual/jre-1.4':
  ... When loading entries for virtuals repository:
  ... When fetching versions of 'dev-lang/php' in gentoo:
  ... When loading versions for 'dev-lang/php' in gentoo:
  ... When extracting version from '/usr/portage/dev-lang/php/php-5.2.4_pre200708051230-r2.ebuild':
  ... When parsing version spec '5.2.4_pre200708051230-r2':
  ... Number part '200708051230' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1201345177: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-accessibility/speech-tools':
  ... When adding package 'app-accessibility/speech-tools-1.2.96_beta:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/libX11':
  ... When adding package 'x11-libs/libX11-1.1.3:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/xtrans-1.0.1':
  ... When adding package 'x11-libs/xtrans-1.0.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=sys-devel/automake-1.10*':
  ... When adding package 'sys-devel/automake-1.10.1:1.10::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/perl':
  ... When adding package 'dev-lang/perl-5.8.8-r4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/db':
  ... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=virtual/jre-1.4':
  ... When adding installed package 'virtual/jre-1.6.0:1.6::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec '=virtual/jdk-1.6.0*':
  ... When adding installed package 'virtual/jdk-1.6.0:1.6::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '=dev-java/sun-jdk-1.6.0*':
  ... When adding package 'dev-java/sun-jdk-1.6.0.04:1.6::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=dev-java/java-config-2*':
  ... When adding package 'dev-java/java-config-2.1.3:2::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/python':
  ... When adding package 'dev-lang/python-2.5.1-r5:2.5::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=dev-lang/tk-8.0':
  ... When adding package 'dev-lang/tk-8.4.16:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '~dev-lang/tcl-8.4.16':
  ... When adding package 'dev-lang/tcl-8.4.16:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-devel/autoconf-2.61':
  ... When adding package 'sys-devel/autoconf-2.61-r1:2.5::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-apps/texinfo-4.3':
  ... When adding package 'sys-apps/texinfo-4.11-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-devel/gettext':
  ... When adding package 'sys-devel/gettext-0.17:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-libs/libxml2':
  ... When adding package 'dev-libs/libxml2-2.6.30-r1:2::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/readline':
  ... When adding package 'sys-libs/readline-5.2_p12-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=app-shells/bash-2.05b-r2':
  ... When adding package 'app-shells/bash-3.2_p33:0::gentoo':
  ... Dropping run dependencies to post dependencies because of exception 'Block: <sys-apps/portage-2.1.4_rc1' (paludis::BlockError)
paludis@1201345177: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-accessibility/speech-tools':
  ... When adding package 'app-accessibility/speech-tools-1.2.96_beta:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/libX11':
  ... When adding package 'x11-libs/libX11-1.1.3:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/xtrans-1.0.1':
  ... When adding package 'x11-libs/xtrans-1.0.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=sys-devel/automake-1.10*':
  ... When adding package 'sys-devel/automake-1.10.1:1.10::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/perl':
  ... When adding package 'dev-lang/perl-5.8.8-r4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/db':
  ... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=virtual/jre-1.4':
  ... When adding installed package 'virtual/jre-1.6.0:1.6::installed':
  ... When adding run dependencies as post dependencies:
  ... When using already installed package to resolve dependencies:
  ... When adding PackageDepSpec '=virtual/jdk-1.6.0*':
  ... When adding installed package 'virtual/jdk-1.6.0:1.6::installed':
  ... Ignoring run dependencies due to exception 'Block: <sys-apps/portage-2.1.4_rc1' (paludis::BlockError)
paludis@1201345178: [QA] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-accessibility/speech-tools':
  ... When adding package 'app-accessibility/speech-tools-1.2.96_beta:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/libX11':
  ... When adding package 'x11-libs/libX11-1.1.3:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/xtrans-1.0.1':
  ... When adding package 'x11-libs/xtrans-1.0.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=sys-devel/automake-1.10*':
  ... When adding package 'sys-devel/automake-1.10.1:1.10::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/perl':
  ... When adding package 'dev-lang/perl-5.8.8-r4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/db':
  ... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=dev-java/java-config-2.0.31':
  ... When adding package 'dev-java/java-config-2.1.3:2::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/python':
  ... When adding package 'dev-lang/python-2.5.1-r5:2.5::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-libs/openssl':
  ... When adding package 'dev-libs/openssl-0.9.8g:0::gentoo':
  ... When adding post dependencies as post dependencies:
  ... When adding PackageDepSpec 'app-misc/ca-certificates':
  ... When adding package 'app-misc/ca-certificates-20070303-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-apps/portage-2.1.2':
  ... When adding package 'sys-apps/portage-2.1.4:0::gentoo':
  ... When adding post dependencies as post dependencies with cycle breaking:
  ... When adding PackageDepSpec '>=sys-apps/coreutils-6.4':
  ... When adding package 'sys-apps/coreutils-6.10-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-devel/automake-1.10.1':
  ... Dropping circular dependency on 'sys-devel/automake-1.10.1:1.10::gentoo'
paludis@1201345178: [QA] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-accessibility/speech-tools':
  ... When adding package 'app-accessibility/speech-tools-1.2.96_beta:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/libX11':
  ... When adding package 'x11-libs/libX11-1.1.3:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/xtrans-1.0.1':
  ... When adding package 'x11-libs/xtrans-1.0.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '=sys-devel/automake-1.10*':
  ... When adding package 'sys-devel/automake-1.10.1:1.10::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/perl':
  ... When adding package 'dev-lang/perl-5.8.8-r4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'sys-libs/db':
  ... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=dev-java/java-config-2.0.31':
  ... When adding package 'dev-java/java-config-2.1.3:2::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-lang/python':
  ... When adding package 'dev-lang/python-2.5.1-r5:2.5::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'dev-libs/openssl':
  ... When adding package 'dev-libs/openssl-0.9.8g:0::gentoo':
  ... When adding post dependencies as post dependencies:
  ... When adding PackageDepSpec 'app-misc/ca-certificates':
  ... When adding package 'app-misc/ca-certificates-20070303-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=sys-apps/portage-2.1.2':
  ... When adding package 'sys-apps/portage-2.1.4:0::gentoo':
  ... When adding post dependencies as post dependencies with cycle breaking:
  ... When using already installed group to resolve dependencies:
  ... When adding PackageDepSpec '>=dev-lang/python-2.5':
  ... Dropping circular dependency on 'dev-lang/python-2.5.1-r5:2.5::gentoo'
paludis@1201345179: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-admin/equo':
  ... Downgrade to 'app-admin/equo-0.10.12:0::sabayon' from 'app-admin/equo-9999-r2:0::installed' forced
paludis@1201345179: [WARNING] In program paludis -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-antivirus/klamav':
  ... When adding package 'app-antivirus/klamav-0.41.1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=kde-base/kdelibs-3.5':
  ... When adding package 'kde-base/kdelibs-3.5.8-r10:3.5::sabayon':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'x11-libs/qt[=3.3.8-r4|=3.3.8-r3|=3.3.8-r2|=3.3.8-r1|=3.3.8|=3.3.6-r5|=3.3.6-r4|=3.3.6-r3|=3.3.6-r2|=3.3.6-r1|=3.3.6|=3.3.5-r1|=3.3.5|=3.3.4-r9|=3.3.4-r8|=3.3.4-r7|=3.3.4-r6|=3.3.4-r5|=3.3.4-r4|=3.3.4-r3|=3.3.4-r2|=3.3.4-r1|=3.3.4|=3.3.3-r3|=3.3.3-r2|=3.3.3-r1|=3.3.3] (rewritten from { =x11-libs/qt-3.3.8-r4, =x11-libs/qt-3.3.8-r3, =x11-libs/qt-3.3.8-r2, =x11-libs/qt-3.3.8-r1, =x11-libs/qt-3.3.8, =x11-libs/qt-3.3.6-r5, =x11-libs/qt-3.3.6-r4, =x11-libs/qt-3.3.6-r3, =x11-libs/qt-3.3.6-r2, =x11-libs/qt-3.3.6-r1, =x11-libs/qt-3.3.6, =x11-libs/qt-3.3.5-r1, =x11-libs/qt-3.3.5, =x11-libs/qt-3.3.4-r9, =x11-libs/qt-3.3.4-r8, =x11-libs/qt-3.3.4-r7, =x11-libs/qt-3.3.4-r6, =x11-libs/qt-3.3.4-r5, =x11-libs/qt-3.3.4-r4, =x11-libs/qt-3.3.4-r3, =x11-libs/qt-3.3.4-r2, =x11-libs/qt-3.3.4-r1, =x11-libs/qt-3.3.4, =x11-libs/qt-3.3.3-r3, =x11-libs/qt-3.3.3-r2, =x11-libs/qt-3.3.3-r1, =x11-libs/qt-3.3.3 })':
  ... When adding package 'x11-libs/qt-3.3.8-r4:3::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'net-print/cups':
  ... When adding package 'net-print/cups-1.3.5:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'net-dns/avahi':
  ... When adding package 'net-dns/avahi-0.6.22-r1:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/gtk+-2.4.0':
  ... When adding package 'x11-libs/gtk+-2.12.5-r1:2::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/pango-1.17.3':
  ... When adding package 'x11-libs/pango-1.18.4:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-libs/cairo-1.2.6':
  ... When adding package 'x11-libs/cairo-1.4.14:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=media-libs/glitz-0.5.1':
  ... When adding installed package 'media-libs/glitz-0.5.6:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'virtual/opengl':
  ... When adding installed package 'virtual/opengl-7.0:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'media-libs/mesa':
  ... When adding package 'media-libs/mesa-7.0.2:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=x11-proto/glproto-1.4.8':
  ... When finding SLOT for 'x11-proto/glproto-1.4.6_alpha20060317::installed':
  ... No SLOT entry in '/var/db/pkg/x11-proto/glproto-1.4.6_alpha20060317', pretending '0'

Unhandled exception:
  * In program paludis -i world:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'app-antivirus/klamav':
  * When adding package 'app-antivirus/klamav-0.41.1:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '>=kde-base/kdelibs-3.5':
  * When adding package 'kde-base/kdelibs-3.5.8-r10:3.5::sabayon':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'x11-libs/qt[=3.3.8-r4|=3.3.8-r3|=3.3.8-r2|=3.3.8-r1|=3.3.8|=3.3.6-r5|=3.3.6-r4|=3.3.6-r3|=3.3.6-r2|=3.3.6-r1|=3.3.6|=3.3.5-r1|=3.3.5|=3.3.4-r9|=3.3.4-r8|=3.3.4-r7|=3.3.4-r6|=3.3.4-r5|=3.3.4-r4|=3.3.4-r3|=3.3.4-r2|=3.3.4-r1|=3.3.4|=3.3.3-r3|=3.3.3-r2|=3.3.3-r1|=3.3.3] (rewritten from { =x11-libs/qt-3.3.8-r4, =x11-libs/qt-3.3.8-r3, =x11-libs/qt-3.3.8-r2, =x11-libs/qt-3.3.8-r1, =x11-libs/qt-3.3.8, =x11-libs/qt-3.3.6-r5, =x11-libs/qt-3.3.6-r4, =x11-libs/qt-3.3.6-r3, =x11-libs/qt-3.3.6-r2, =x11-libs/qt-3.3.6-r1, =x11-libs/qt-3.3.6, =x11-libs/qt-3.3.5-r1, =x11-libs/qt-3.3.5, =x11-libs/qt-3.3.4-r9, =x11-libs/qt-3.3.4-r8, =x11-libs/qt-3.3.4-r7, =x11-libs/qt-3.3.4-r6, =x11-libs/qt-3.3.4-r5, =x11-libs/qt-3.3.4-r4, =x11-libs/qt-3.3.4-r3, =x11-libs/qt-3.3.4-r2, =x11-libs/qt-3.3.4-r1, =x11-libs/qt-3.3.4, =x11-libs/qt-3.3.3-r3, =x11-libs/qt-3.3.3-r2, =x11-libs/qt-3.3.3-r1, =x11-libs/qt-3.3.3 })':
  * When adding package 'x11-libs/qt-3.3.8-r4:3::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'net-print/cups':
  * When adding package 'net-print/cups-1.3.5:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'net-dns/avahi':
  * When adding package 'net-dns/avahi-0.6.22-r1:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '>=x11-libs/gtk+-2.4.0':
  * When adding package 'x11-libs/gtk+-2.12.5-r1:2::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'x11-base/xorg-server':
  * When adding package 'x11-base/xorg-server-1.4.0.90-r2:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'sys-apps/hal':
  * When adding package 'sys-apps/hal-0.5.10:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When using already installed package to resolve dependencies:
  * When adding PackageDepSpec '>=sys-fs/cryptsetup-luks-1.0.1':
  * When adding installed package 'sys-fs/cryptsetup-luks-1.0.4-r3:0::installed':
  * When adding run dependencies as post dependencies:
  * When querying use flag 'selinux' for 'sys-fs/cryptsetup-luks-1.0.4-r3:0::installed' in Paludis environment:
  * When parsing metadata key 'USE' from 'sys-fs/cryptsetup-luks-1.0.4-r3:0::installed':
  * When validating use flag name 'USE="udev':
  * Name 'USE="udev' is not a valid use flag name (paludis::UseFlagNameError)


When I switched over from portage, I used the automatic migration script to do so. I don't really understand what this is telling me, so anyone that can help, I would really appreciate it.
Back to top
View user's profile Send private message
pussi
l33t
l33t


Joined: 08 May 2004
Posts: 727
Location: Finland

PostPosted: Sat Jan 26, 2008 8:08 pm    Post subject: Reply with quote

Zerodark wrote:
Code:
  * When validating use flag name 'USE="udev':
  * Name 'USE="udev' is not a valid use flag name (paludis::UseFlagNameError)

probably an error in /etc/paludis/use.conf
Back to top
View user's profile Send private message
Zerodark
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2003
Posts: 83

PostPosted: Sat Jan 26, 2008 8:16 pm    Post subject: Reply with quote

I thought that as well, so I looked through use.conf and removed udev from it, yet the same error keeps coming up...
Back to top
View user's profile Send private message
tanderson
Retired Dev
Retired Dev


Joined: 11 Apr 2007
Posts: 193

PostPosted: Sat Jan 26, 2008 9:30 pm    Post subject: Reply with quote

pussi wrote:
Zerodark wrote:
Code:
  * When validating use flag name 'USE="udev':
  * Name 'USE="udev' is not a valid use flag name (paludis::UseFlagNameError)

probably an error in /etc/paludis/use.conf


The error is that you have
Code:
USE="udev'
This is wrong because you first use double quotes(") and then use single quotes(') to end it. I'd bet that if you changed the ' to " your problem would be fixed.
_________________
No Man is Just a Number!

--The Prisoner
Back to top
View user's profile Send private message
siddesu
n00b
n00b


Joined: 19 May 2007
Posts: 21
Location: japan

PostPosted: Mon Jan 28, 2008 1:59 am    Post subject: Reply with quote

just wanted to report that paludis installed and worked smoothly here, almost out of the box. the only thing that didn't 'work' for me was migrating keywords and mask settings from files in /etc/portage/ subdirectories. not a big deal, as moving stuff by hand was trivial enough though.

while i can't see much of a speed improvement overall, the important features i have used so far -- better dependency tracking, stricter handling of package specifications, and the overall flexibility of the tool -- look very nice.

thanks, guys.

now, having a sorta working setup, off to reading TFM (and, hopefully, grokking it) ;)
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Mon Jan 28, 2008 4:59 pm    Post subject: Reply with quote

pussi wrote:
Zerodark wrote:
Code:
  * When validating use flag name 'USE="udev':
  * Name 'USE="udev' is not a valid use flag name (paludis::UseFlagNameError)

probably an error in /etc/paludis/use.conf
Nope. /var/db/pkg/sys-fs/cryptsetup-luks-1.0.4-r3/USE.
Back to top
View user's profile Send private message
mihochan
Apprentice
Apprentice


Joined: 16 Apr 2002
Posts: 296
Location: Melbourne again

PostPosted: Tue Jan 29, 2008 12:05 pm    Post subject: Reply with quote

Hi,

I'm trying to install Paludis 0.26.0_alpha9 but get the following error.
Any clues as to what is going on?

Thanks

Code:

for s in  ; do make -C $s built-sources || exit 1 ; done
make[1]: Leaving directory `/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha9/work/paludis-0.26.0_alpha9/pkg-config'
touch automake-deps-built-hack.tmp
make: *** [automake-deps-built-hack.tmp] Killed

!!! ERROR in sys-apps/paludis-0.26.0_alpha9:
!!! In src_install at line 3488
!!! install failed

!!! Call stack:
!!!    * src_install (/var/tmp/paludis/sys-apps/paludis-0.26.0_alpha9/temp/loadsaveenv:3488)
!!!    * ebuild_f_install (/usr/libexec/paludis/src_install.bash:48)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:363)
!!!    * main (/usr/libexec/paludis/ebuild.bash:381)

die trap: exiting with error.

Install error:
  * In program paludis -i paludis --dl-upgrade as-needed:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-apps/paludis-0.26.0_alpha9':
  * Install error: Install failed for 'sys-apps/paludis-0.26.0_alpha9::gentoo'


Resume command: paludis --log-level qa --dl-deps-default discard --install '=sys-apps/paludis-0.26.0_alpha9::gentoo' --add-to-world-spec '( sys-apps/paludis )'

_________________
In the long run we are all dead - Keynes
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Sat Feb 02, 2008 2:47 pm    Post subject: [SOLVED] rsync overlay Reply with quote

  1. I have some troubles with centerim overlay. After sync I'm getting
    Quote:
    /usr/bin/paludis@1201962832: [QA] Couldn't open repo_name file in '/usr/portage/local/overlays/centerim/profiles/', falling back to generated name 'x-centerim' (ignore this message if you have yet to sync this repository).
    This happens because on each sync, rsync deletes profile as well as repo_name.
    Quote:
    sync centerim> ./
    sync centerim> deleting profiles/repo_name
    sync centerim> deleting profiles/
    sync centerim>
    I have defined repository as follow
    cat /etc/paludis/repositories/centerim.conf wrote:
    location = ${ROOT}/usr/portage/local/overlays/centerim
    sync = rsync://transacid.de/centerim
    #profiles = ${ROOT}/usr/portage/profiles/default-linux/x86/2007.0
    #eclassdirs = /usr/portage/eclass
    #distdir = /usr/local/portage/distfiles
    master_repository = gentoo
    format = ebuild
    names_cache = ${location}/.cache/namesBuilding dependency list.../usr/bin/paludis@1201963406: [QA] In program /
    write_cache = /var/cache/paludis/metadata
    Can I somehow alter repo definition or any other way prevent this behavior?
  2. Anytime I do some install, paludis throws plethora of warnings like
    paludis -ip evolution wrote:
    … When performing install action from command line:
    … When executing install task:
    … When building dependency list:
    … When adding PackageDepSpec 'mail-client/evolution':
    … When adding package 'mail-client/evolution-2.12.3:2.0::gentoo':
    … When adding build dependencies as pre dependencies:
    … When adding PackageDepSpec '>=x11-libs/gtk+-2.10':
    … When adding installed package 'x11-libs/gtk+-2.12.5-r1:2::installed':
    … When adding run dependencies as post dependencies:
    … When adding PackageDepSpec '>=dev-libs/glib-2.13.5':
    … When adding installed package 'dev-libs/glib-2.14.5:2::installed':
    … When adding run dependencies as post dependencies:
    … When adding PackageDepSpec 'virtual/libc':
    … When loading entries for virtuals repository:
    … When fetching versions of 'dev-lang/php' in gentoo:
    … When loading versions for 'dev-lang/php' in gentoo:
    … When extracting version from '/usr/portage/dev-lang/php/php-5.2.4_pre200708051230-r2.ebuild':
    … When parsing version spec '5.2.4_pre200708051230-r2':
    … Number part '200708051230' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)


    (it's like five times longer)
    Can I somehow suppress these warnings?


Last edited by Mr. Tao on Sun Feb 03, 2008 12:22 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 24, 25, 26  Next
Page 5 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum