Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Apr 10, 2008 4:47 pm    Post subject: Reply with quote

I'll give it a shot.

EDIT: Nope, didn't work.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Thu Apr 10, 2008 10:36 pm    Post subject: Reply with quote

loftwyr wrote:
I've gone through the thread but can't see if it's been addressed so I'm trying.

I (and the sunrise overlay) use g-cpan for a number of perl packages and I can't seem to get paludis to find them by default. I can get it if I add perl-gcpan to /usr/portage/profiles/categories but that's overwritten by going a gentoo repo sync. I can't seem to find it in the web page but is there a file like g-cpan uses (/etc/portage/categories) that paludis uses to reference any category extensions?

It's getting to be a pain having to manually add perl-gcpan to the default file every time I need to do an update or install a perl package.


Isn't g-cpan included in the gentoo repository?

Code:
  5:22PM % eix -c cpan                                                ~ (knute)
[I] app-portage/g-cpan (0.15.0-r1@07/21/07): g-cpan: generate and install CPAN modules using portage
[N] dev-perl/CPAN-Checksums (1.050): Write a CHECKSUMS file for a directory as on CPAN
[I] dev-perl/CPAN-Mini (0.562@07/21/07): create a minimal mirror of CPAN
[N] dev-perl/CPAN-Mini-Inject (0.18): Inject modules into a CPAN::Mini mirror.
[N] dev-perl/CPAN-Mini-Phalanx (0.01): create a minimal mirror of CPAN containing the modules in the Phalanx 100
[N] net-misc/secpanel (0.53): Graphical frontend for managing and running SSH and SCP connections
Found 6 matches.
  5:24PM %                                                            ~ (knute)

_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Apr 10, 2008 11:55 pm    Post subject: Reply with quote

g-cpan is in the gentoo repo.

It's the fact that the ebuilds it generates are placed in a category called perl-gcpan and not dev-perl.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Fri Apr 11, 2008 1:21 am    Post subject: Reply with quote

loftwyr wrote:
g-cpan is in the gentoo repo.

It's the fact that the ebuilds it generates are placed in a category called perl-gcpan and not dev-perl.


Couldn't you write a post_sync hook to add it?

I don't know too much about how the hooks work but maybe a command such as
Code:
echo "perl-gcpan" >> /usr/portage/profiles/categories

may work. Don't know what else that a hook needs, because I haven't needed to write one before, so if there's more needed, well... sorry.

Or even put a script in your /root/bin that will do it.
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Fri Apr 11, 2008 1:46 am    Post subject: Reply with quote

I can, I was just hoping the capability was always there.

I'll write a sync_post hook that will do it. That'll do for now.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
vladms
n00b
n00b


Joined: 26 Jul 2005
Posts: 54
Location: Romanian in Delft, Netherlands

PostPosted: Fri Apr 11, 2008 6:31 pm    Post subject: Reply with quote

I'm having a strange problem. From some time paludis reports just some packages when I give "paludis -ip world", even if there are more packages in the world file that could be updated.

Below is what happens. Any suggestions ?

Code:
localhost paludis # paludis -ip world
Building target list...
Building dependency list...

These packages will be installed:

* dev-scheme/guile :12 [U 1.8.2 -> 1.8.3-r2]
    Reasons: *app-office/gnucash-2.2.3:0::installed, sys-devel/autogen-5.9.2:0::installed
    -debug -debug-freelist -debug-malloc deprecated -discouraged -elisp -networking nls regex threads
    3.69 MBytes to download
* dev-scheme/slib [U 3.1.1-r1 -> 3.1.5-r1]
    Reasons: *app-office/gnucash-2.2.3:0::installed
    1.01 MBytes to download
* dev-java/java-config :2 [U 2.0.33-r1 -> 2.1.5]
    Reasons: *java-virtuals/javamail-1.0-r1:0::installed, app-text/jabref-2.3.1:0::installed, 30 more
    38.01 kBytes to download
* net-analyzer/aimsniff :0.9-r2 [S 0.9-r2] <world>
    -http -mysql samba -vhosts
    23.48 kBytes to download
* sys-kernel/gentoo-sources :2.6.24-r4 [S 2.6.24-r4] <world>
    -build symlink
    44.68 MBytes to download

Total: 5 packages (3 upgrades, 2 in new slots), at most 49.44 MBytes to download

General sets:

* world:           Packages that have been explicitly installed

 * No unread news items found

localhost paludis # paludis -ip pidgin
Building target list...
Building dependency list...

These packages will be installed:

* net-im/pidgin [U 2.4.0 -> 2.4.1] <target>
    -bonjour dbus debug doc eds -gadu -gnutls -groupwise gstreamer gtk -meanwhile ncurses -networkmanager nls perl -prediction -qq -sasl -silc spell -tcl -tk -zephyr
    9.02 MBytes to download

Total: 1 package (1 upgrade), at most 9.02 MBytes to download

 * No unread news items found
localhost paludis # grep pidgin /var/db/pkg/world
net-im/pidgin



EDIT: It seems I missed some updates. It works if I do "paludis -ip world --dl-upgrade always"
_________________
Vlad-Mihai Sima


Last edited by vladms on Sun Apr 20, 2008 6:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Sun Apr 13, 2008 2:17 am    Post subject: Reply with quote

Paludis over version 0.26.0-alpha4 is not in the Manifest file of the paludis-overlay.

How can I bypass this Manifest error?

Code:
paludis -i --dl-deps-default discard paludis
Building target list...
Building dependency list...

These packages will be installed:

* sys-apps/paludis::paludis-overlay [U 0.26.0_alpha4 -> 0.26.0_pre1] <target>
    bash-completion -doc glsa inquisitio pink portage* python qa -ruby vim-syntax visibility -zsh-completion

Total: 1 package (1 upgrade)

Use flags:

* portage:         Enable experimental support for Portage configuration formats

(1 of 1) Installing sys-apps/paludis-0.26.0_pre1:0::paludis-overlay

Checking 'paludis-0.26.0_pre1.tar.bz2'... not in Manifest

Fetch error:
  * In program paludis -i --dl-deps-default discard paludis:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'sys-apps/paludis-0.26.0_pre1:0::paludis-overlay':
  * Fetch error: Fetch of 'sys-apps/paludis-0.26.0_pre1:0::paludis-overlay' failed

  * File 'paludis-0.26.0_pre1.tar.bz2': failed integrity checks: Not in Manifest


Resume command: paludis --log-level qa --install --add-to-world-spec '( sys-apps/paludis )' --dl-deps-default discard '=sys-apps/paludis-0.26.0_pre1:0::paludis-overlay'

_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Sun Apr 13, 2008 2:58 am    Post subject: Reply with quote

paludis-overlay doesn't even /have/ a Manifest ...
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Sun Apr 13, 2008 3:08 am    Post subject: Reply with quote

tecknojunky wrote:
Paludis over version 0.26.0-alpha4 is not in the Manifest file of the paludis-overlay.

How can I bypass this Manifest error?

Code:
paludis -i --dl-deps-default discard paludis



What happens if you just
Code:
paludis -i paludis
???
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Sun Apr 13, 2008 11:00 am    Post subject: Reply with quote

checking for Python installation dir... ${exec_prefix}/lib/python2.5/site-packages
checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required

!!! ERROR in sys-apps/paludis-0.26.0_pre1:
!!! In econf at line 1628
!!! econf failed

!!! Call stack:
!!! * econf (/var/tmp/paludis/sys-apps/paludis-0.26.0_pre1/temp/loadsaveenv:1628)
!!! * src_compile (/var/tmp/paludis/sys-apps/paludis-0.26.0_pre1/temp/loadsaveenv:3666)
!!! * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!! * ebuild_main (/usr/libexec/paludis/ebuild.bash:462)
!!! * main (/usr/libexec/paludis/ebuild.bash:480)

diefunc: making ebuild PID 7081 exit with error
die trap: exiting with error.

can't finf boost.python.
anybody?
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Apr 13, 2008 11:36 am    Post subject: Reply with quote

tranquilcool wrote:
checking for Python installation dir... ${exec_prefix}/lib/python2.5/site-packages
checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required


I solved this 1 minute ago, by re-installing dev-libs/boost. :)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Sun Apr 13, 2008 12:12 pm    Post subject: Reply with quote

mikkoc wrote:
tranquilcool wrote:
checking for Python installation dir... ${exec_prefix}/lib/python2.5/site-packages
checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required


I solved this 1 minute ago, by re-installing dev-libs/boost. :)


my problem was with gcc-4.3.0.
paludis and boost doesn't compile with gcc-4.3.0.
if you want to compile latest paludis switch back to other gcc.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Apr 13, 2008 12:39 pm    Post subject: Reply with quote

tranquilcool wrote:

my problem was with gcc-4.3.0.
paludis and boost doesn't compile with gcc-4.3.0.
if you want to compile latest paludis switch back to other gcc.


I'm using gcc-4.3.0 too.
boost in portage doesn't compile, but get the ebuild in the gcc-porting overlay: it will compile.
Paludis does compile with gcc-4.3
Back to top
View user's profile Send private message
semdornus
n00b
n00b


Joined: 13 Sep 2007
Posts: 58
Location: Tokyo

PostPosted: Sun Apr 13, 2008 1:43 pm    Post subject: Reply with quote

I've been getting these bash errors in /var/tmp/paludis/environment-(package-installing) and these
Code:
/usr/libexec/paludis/source_functions.bash: debug trap: line 39: syntax error in conditional expression: unexpected token `('
/usr/libexec/paludis/source_functions.bash: debug trap: line 39: syntax error near `@(*'
/usr/libexec/paludis/source_functions.bash: debug trap: line 39: `[[ ${BASH_COMMAND%%[[:space:]]*} != @(*=*|export|declare) ||'
/usr/libexec/paludis/ebuild.bash: debug trap: line 234: syntax error in conditional expression: unexpected token `('
/usr/libexec/paludis/ebuild.bash: debug trap: line 234: syntax error near `@(*'
/usr/libexec/paludis/ebuild.bash: debug trap: line 234: `[[ ${BASH_COMMAND%%[[:space:]]*} != @(*=*|export|declare) ||'
/usr/libexec/paludis/ebuild.bash: debug trap: line 235: syntax error in conditional expression: unexpected token `('

after
Code:

>>> Running ebuild phases loadenv postrm tidyuprm as root:root...
bunzip2 < /var/db/pkg/(package-installing)/environment.bz2 > /var/tmp/paludis/environment-(package-installing)
ebuild_scrub_environment /var/tmp/paludis/environment-(package-installing)

I have bash-3.2_p33 installed and at the moment sh is linked to dash, but if I switch it back
to bash the same thing happens. I tried rebuilding bash and paludis itself as well to no avail.
Does anybody have an idea? Thanks.
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Sun Apr 13, 2008 5:05 pm    Post subject: Reply with quote

Knute wrote:
tecknojunky wrote:
Paludis over version 0.26.0-alpha4 is not in the Manifest file of the paludis-overlay.

How can I bypass this Manifest error?

Code:
paludis -i --dl-deps-default discard paludis



What happens if you just
Code:
paludis -i paludis
???
Code:
# paludis -ip paludis
Building target list...
Building dependency list...paludis@1208105723: [WARNING] Not writing cache file to '/var/cache/paludis/metadata/local/app-office/openoffice-bin-1.1.0' due to exception 'Bad dependency string 'LGPL-2 | SISSL-1.1': in lex phase: '|' should be followed by '|'' (paludis::erepository::DepStringLexError)


These packages will be installed:

* dev-lang/python :2.4 [U 2.4.4-r6 -> 2.4.4-r9]
    Reasons: app-editors/vim-7.1.266:0::gentoo, dev-libs/libxml2-2.6.31:2::installed, 4 more
    berkdb -bootstrap -build -doc -examples -gdbm* ipv6 -ncurses* -nocxx -nothreads readline ssl -tk -ucs2 elibc: (-uclibc)+
* sys-apps/paludis::paludis-overlay [U 0.26.0_alpha4 -> 0.26.0_pre1] <target>
    Reasons: app-admin/python-updater-0.2:0::installed
    bash-completion -doc glsa inquisitio pink portage* python qa -ruby vim-syntax visibility -zsh-completion
* app-editors/vim-core [U 7.1.123 -> 7.1.266]
    Reasons: *app-editors/vim-7.1.266:0::gentoo, sys-apps/paludis-0.26.0_pre1:0::paludis-overlay
    acl bash-completion -livecd nls
* app-editors/vim [U 7.1.123 -> 7.1.266]
    Reasons: app-vim/gentoo-syntax-20070506:0::installed
    acl bash-completion cscope gpm -minimal nls perl python -ruby -vim-pager -vim-with-x

Total: 4 packages (4 upgrades)

Use flags:

* gdbm:            Adds support for sys-libs/gdbm (GNU database libraries)
* ncurses:         Adds ncurses support (console display library)
* portage:         Enable experimental support for Portage configuration formats

elibc:

* uclibc:          ELIBC setting for systems that use the uClibc C library
I use --dl-deps-default discard to avoid pulling python that can't compile on that system (a whole different problem).

creidiki wrote:
paludis-overlay doesn't even /have/ a Manifest ...

I think different...
Code:
# tail /var/paludis/repositories/paludis-overlay/sys-apps/paludis/Manifest
SHA256 309eb2f90241c052a21107e9ac2fffbf601883c5a2f531249ed6e67aca26053a files/digest-paludis-0.26.0_alpha1 271
MD5 8c8198b82dd6c9b75e0ab2593a8672e5 files/digest-paludis-0.26.0_alpha2 271
RMD160 58eb614c5862da6b3acef1e66848e289bbc34705 files/digest-paludis-0.26.0_alpha2 271
SHA256 9821a201993bc89707bd9a4f51296d181d3148164453ae3b4c8ce78b28bacf18 files/digest-paludis-0.26.0_alpha2 271
MD5 5cee2c24f97d6cda515aafa2482ee2ba files/digest-paludis-0.26.0_alpha3 271
RMD160 bd40e60927f8e0c307e6ff35cb486d75fa9a066f files/digest-paludis-0.26.0_alpha3 271
SHA256 48ddc383514789221f2ae9a4a6e7f8b75ff5d4d4a3fab6c0c39425c6933a2998 files/digest-paludis-0.26.0_alpha3 271
MD5 2b0131073106612b4bb4da73d00fe67d files/digest-paludis-0.26.0_alpha4 271
RMD160 cfb022ede3171f3e1aaa49858cfaa30b69630d28 files/digest-paludis-0.26.0_alpha4 271
SHA256 92cc71e8a1a78d41491c0fb0bddab52bc579505f63ddef417f6d2b3cb5944a23 files/digest-paludis-0.26.0_alpha4 271

_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
sotn3m
n00b
n00b


Joined: 01 Oct 2004
Posts: 45

PostPosted: Sun Apr 13, 2008 8:30 pm    Post subject: Reply with quote

Hi all!

Any ideas what might be done to such a problem?
paludis - 0.26.0_alpha6

Code:
>>> Starting src_unpack
>>> Unpacking m4-1.4.11.tar.lzma to /var/tmp/paludis/sys-devel/m4-1.4.11/work
Skipping unpack for /home/sotn3m/portage/distfiles/m4-1.4.11.tar.lzma
chmod: missing operand after `a+rX,u+w,go-w'
Try `chmod --help' for more information.
>>> Done src_unpack
>>> Starting src_compile

!!! ERROR in sys-devel/m4-1.4.11:
!!! In econf at line 957
!!! No configure script for econf

!!! Call stack:
!!!    * econf (/var/tmp/paludis/sys-devel/m4-1.4.11/temp/loadsaveenv:957)
!!!    * src_compile (/var/tmp/paludis/sys-devel/m4-1.4.11/temp/loadsaveenv:1321)
!!!    * ebuild_f_compile (/usr/libexec/paludis/0/src_compile.bash:51)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:479)
!!!    * main (/usr/libexec/paludis/ebuild.bash:497)

_________________
M3ntos
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Sun Apr 13, 2008 8:33 pm    Post subject: Reply with quote

I have the exact same problem and this is why I thought upgrading paludis to the pre version. I'm wondering if Paludis can unpack an lzma file.
Code:
...
Skipping unpack for /var/paludis/distfiles/coreutils-6.10-patches-1.2.tar.lzma
...
Seem coreutils and m4 now comes in lzma instead of bz2 or gz.
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Mon Apr 14, 2008 2:17 am    Post subject: Reply with quote

tecknojunky wrote:
Paludis over version 0.26.0-alpha4 is not in the Manifest file of the paludis-overlay.

How can I bypass this Manifest error?

Code:
paludis -i --dl-deps-default discard paludis
Building target list...
Building dependency list...

These packages will be installed:

* sys-apps/paludis::paludis-overlay [U 0.26.0_alpha4 -> 0.26.0_pre1] <target>
    bash-completion -doc glsa inquisitio pink portage* python qa -ruby vim-syntax visibility -zsh-completion

Total: 1 package (1 upgrade)

Use flags:

* portage:         Enable experimental support for Portage configuration formats

(1 of 1) Installing sys-apps/paludis-0.26.0_pre1:0::paludis-overlay

Checking 'paludis-0.26.0_pre1.tar.bz2'... not in Manifest

Fetch error:
  * In program paludis -i --dl-deps-default discard paludis:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'sys-apps/paludis-0.26.0_pre1:0::paludis-overlay':
  * Fetch error: Fetch of 'sys-apps/paludis-0.26.0_pre1:0::paludis-overlay' failed

  * File 'paludis-0.26.0_pre1.tar.bz2': failed integrity checks: Not in Manifest


Resume command: paludis --log-level qa --install --add-to-world-spec '( sys-apps/paludis )' --dl-deps-default discard '=sys-apps/paludis-0.26.0_pre1:0::paludis-overlay'


So, anyone who had the same problem has me, I think all you need is to add this line in the Manifest file:
Code:
DIST paludis-0.26.0_pre1.tar.bz2 1490131 RMD160 479614eb8de04b42f2d584940a1b0ba9c05fa6e5 SHA1 d172394283a664d654c79e71cb1eea053e623103 SHA256 1be589bd2e071bc63872f91006ea7310eaa080045180c4d3d4bf88a7ce6c6350

What eludes me is howcome nobody exept me had this problem, or why is that line missing from the Manifest in the paludis-overlay?
_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Mon Apr 14, 2008 6:20 am    Post subject: Reply with quote

Code:
holy_fire ~ # ls /var/paludis/repositories/paludis-overlay/sys-apps/paludis
files  paludis-0.24.6.ebuild  paludis-0.26.0_alpha13.ebuild  paludis-0.26.0_alpha14.ebuild  paludis-0.26.0_pre1.ebuild  paludis-scm.ebuild

Really. Its not there. Kill the manifest already.
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon Apr 14, 2008 7:19 am    Post subject: Reply with quote

That "Manifest" file definitely isn't in the actual paludis overlay

http://paludis.pioto.org/trac/browser/overlay/sys-apps/paludis
Back to top
View user's profile Send private message
nivw
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 261

PostPosted: Mon Apr 14, 2008 8:06 pm    Post subject: can no longer add new packages using paludis Reply with quote

hi all,
I ran paludis -i world and was told that coreutils-6.10-r1 is blocked by mktemp. so I went on to remove it using the force option. then I had the 6.10 installed. but since then , I can no longer install any package:
Quote:
These packages will be installed:

* sys-apps/coreutils::installed [! blocking]
Reasons: sys-apps/mktemp-1.5:0::gentoo
* sys-apps/mktemp [N 1.5] <target>
"allow safe temporary file creation from shell scripts."
68.88 kBytes to download

Total: 1 package (1 new), at most 68.88 kBytes to download, 1 error

* Cannot continue with install due to the errors indicated above
Segmentation fault

I tried to download the coreutils-6.9.tbz2 , managed to install it using emerge , then I had two coreutils on the system - still paludis would say segmantation fault - when ever tring to install. I now removed both coreutils , and my system is cripled - help me pls.
niv
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Mon Apr 14, 2008 8:13 pm    Post subject: Reply with quote

I had mktemp block the coreutils 6.10 as well.

I didn't forceably remove them, I simply masked the new coreutils-6.10 both r1 and r2.

So what happens if you manually reinstall your old coreutils???
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
nivw
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 261

PostPosted: Mon Apr 14, 2008 8:54 pm    Post subject: Reply with quote

Quote:
paludis -i Desktop/coreutils-6.9-r1.tbz2
Building target list...
Unhandled exception:
* In program paludis -i Desktop/coreutils-6.9-r1.tbz2:
* When performing install action from command line:
* When adding install target 'Desktop/coreutils-6.9-r1.tbz2':
* When parsing package dep spec 'Desktop/coreutils-6.9-r1.tbz2':
* When splitting out category and package names from 'Desktop/coreutils-6.9-r1.tbz2':
* When validating package name part 'coreutils-6.9-r1.tbz2':
* Name 'coreutils-6.9-r1.tbz2' is not a valid package name part (paludis::PackageNamePartError)

notice I got no coreutils installed:
Quote:
eix coreutils
* sys-apps/coreutils
Available versions: 6.9-r1 6.10-r1 ~6.10-r2 {acl nls selinux static vanilla xattr}
Homepage: http://www.gnu.org/software/coreutils/
Description: Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)

Quote:
# paludis -i =sys-apps/coreutils-6.9-r1
Building target list...
Building dependency list...paludis@1208206279: [WARNING] Can't use provides cache at '/var/db/pkg/.cache/provides' because format 'paludis-2' is not 'paludis-3'
paludis@1208206279: [WARNING] Skipping VDB PROVIDE entry for 'games-fps/ut2004-demo-3334::installed' due to exception 'Error running stat() on '/var/db/pkg/games-fps/ut2004-demo-3334/EAPI': Input/output error' (paludis::FSError)
paludis@1208206282: [QA] In program paludis -i =sys-apps/coreutils-6.9-r1:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding PackageDepSpec '=sys-apps/coreutils-6.9-r1':
... When adding package 'sys-apps/coreutils-6.9-r1:0::gentoo':
... When adding build dependencies as pre dependencies:
... When adding PackageDepSpec '>=sys-devel/automake-1.10':
... When adding installed package 'sys-devel/automake-1.10.1:1.10::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'dev-lang/perl':
... When adding installed package 'dev-lang/perl-5.8.8-r4:0::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '~sys-devel/libperl-5.8.8':
... When adding installed package 'sys-devel/libperl-5.8.8-r1:1::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'sys-libs/db':
... When adding installed package 'sys-libs/db-4.5.20_p2:4.5::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=virtual/jre-1.4':
... When adding installed package 'virtual/jre-1.6.0:1.6::installed':
... When adding run dependencies as post dependencies:
... When using already installed package to resolve dependencies:
... When adding PackageDepSpec '=virtual/jdk-1.6.0*':
... When adding installed package 'virtual/jdk-1.6.0:1.6::installed':
... When adding run dependencies as post dependencies:
... When using already installed package to resolve dependencies:
... When adding PackageDepSpec '=dev-java/sun-jdk-1.6.0*':
... When adding installed package 'dev-java/sun-jdk-1.6.0.05:1.6::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '=dev-java/java-config-2*':
... When adding installed package 'dev-java/java-config-2.1.4:2::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec 'dev-lang/python':
... When adding installed package 'dev-lang/python-2.4.4-r9:2.4::installed':
... When adding run dependencies as post dependencies:
... When using already installed package to resolve dependencies:
... When adding PackageDepSpec 'sys-libs/db:4.3':
... When adding installed package 'sys-libs/db-4.3.29-r2:4.3::installed':
... When adding run dependencies as post dependencies:
... When adding PackageDepSpec '>=sys-apps/portage-2.1_pre1':
... When adding installed package 'sys-apps/portage-2.1.4.4:0::installed':
... When adding post dependencies as post dependencies with cycle breaking unless under a suggested label:
... When adding PackageDepSpec '>=sys-apps/coreutils-6.4':
... Dropping circular dependency on 'sys-apps/coreutils-6.9-r1:0::gentoo'
paludis@1208206284: [WARNING] Stale cache file at '/usr/portage/metadata/cache/app-admin/perl-cleaner-1.05'


These packages will be installed:

* sys-apps/coreutils [N 6.9-r1] <target>
"Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
acl nls (-selinux) -static -xattr

Total: 1 package (1 new)

Use flags:

* acl: Adds support for Access Control Lists
* nls: Adds Native Language Support (using gettext - GNU locale utilities)
* selinux: !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
* static: !!do not set this during bootstrap!! Causes binaries to be statically linked instead of dynamically
* xattr: Adds support for extended attributes (filesystem-stored metadata)
Segmentation fault
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Mon Apr 14, 2008 8:59 pm    Post subject: Reply with quote

er, Desktop/coreutils-foo /isnt/ a valid package name.. what exactly are you trying to do there?
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Tue Apr 15, 2008 4:54 am    Post subject: Reply with quote

He was told to manually install the package and mistakenly thought that meant to use paludis to install it.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 10, 11, 12 ... 24, 25, 26  Next
Page 11 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum