Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
nivw
Apprentice
Apprentice


Joined: 09 Nov 2005
Posts: 261

PostPosted: Tue Apr 15, 2008 8:04 am    Post subject: Reply with quote

I am tring to install the tbz2 file of the coreutils
Back to top
View user's profile Send private message
Knute
Guru
Guru


Joined: 28 Jun 2004
Posts: 362
Location: Fargo, ND

PostPosted: Tue Apr 15, 2008 1:20 pm    Post subject: Reply with quote

Manually installing a package means that you unpack the tbz2 (or whatever format the package is in), then manually compile and install it.
_________________
Knute
----------
The human race has one really effective weapon, and that is laughter.
-- Mark Twain

If you want proof of that, take a look at windows sometime. :)
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Tue Apr 15, 2008 7:08 pm    Post subject: Reply with quote

I'm confused as to how you were able to install a new version of coreutils with portage/emerge and have it leave the old version intact.

If you really have the newest version installed then you should be able to safely remove both the old version and mktemp (since everything that mktemp provides is part of the new coreutils).

And the fact that paludis segfaults is probably not related to this.
Back to top
View user's profile Send private message
tecknojunky
Veteran
Veteran


Joined: 19 Oct 2002
Posts: 1937
Location: Montréal

PostPosted: Tue Apr 15, 2008 10:21 pm    Post subject: Reply with quote

creidiki wrote:
Code:
holy_fire ~ # ls /var/paludis/repositories/paludis-overlay/sys-apps/paludis
files  paludis-0.24.6.ebuild  paludis-0.26.0_alpha13.ebuild  paludis-0.26.0_alpha14.ebuild  paludis-0.26.0_pre1.ebuild  paludis-scm.ebuild

Really. Its not there. Kill the manifest already.

That's strange. Here is what I have:
Code:
$ ls /var/paludis/repositories/paludis-overlay/sys-apps/paludis/
files                  paludis-0.24.5.ebuild          paludis-0.26.0_alpha2.ebuild
Manifest               paludis-0.24.6.ebuild          paludis-0.26.0_alpha3.ebuild
paludis-0.22.1.ebuild  paludis-0.26.0_alpha13.ebuild  paludis-0.26.0_alpha4.ebuild
paludis-0.22.2.ebuild  paludis-0.26.0_alpha14.ebuild  paludis-0.26.0_pre1.ebuild
paludis-0.24.2.ebuild  paludis-0.26.0_alpha1.ebuild   paludis-scm.ebuild

_________________
(7 of 9) Installing star-trek/species-8.4.7.2::talax.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Wed Apr 16, 2008 1:16 am    Post subject: Reply with quote

Pretty much every file you listed there no longer exists in the official repository/overlay. How are you updating your overlay? It would seem you aren't using "paludis --sync" otherwise the files that aren't in the upstream repo would've been deleted already.
Back to top
View user's profile Send private message
sotn3m
n00b
n00b


Joined: 01 Oct 2004
Posts: 45

PostPosted: Wed Apr 16, 2008 6:42 am    Post subject: m4 Reply with quote

I don't really see the relation with my problem; I am not using paludis overlay, but portage version of paludis..

m4 package can't be installed still; I can't upgrade paludis or coreutils to do that, because they depend on m4 and the vicious circle ends...
_________________
M3ntos
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Wed Apr 16, 2008 3:39 pm    Post subject: Re: m4 Reply with quote

sotn3m wrote:
I don't really see the relation with my problem; I am not using paludis overlay, but portage version of paludis..


No one implied that it was related to your problem.

We were responding to someone who said paludis complains that the new version of paludis isn't in the Manifest (when in reality the paludis overlay doesn't even have a Manifest).

Quote:
m4 package can't be installed still; I can't upgrade paludis or coreutils to do that, because they depend on m4 and the vicious circle ends...


I believe a simple workaround would be:
1) Mask the new version of m4 (the version you can't get installed that has an lzma file).
2) Do "paludis -i1 coreutils" which should install the new version of coreutils that supports lzma.
3) Remove the mask from earlier
4) Upgrade m4
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Thu Apr 17, 2008 10:34 am    Post subject: Reply with quote

I have a problem installing paludis from portage
Code:
[ebuild  N    ] sys-apps/paludis-0.26.0_pre2  USE="bash-completion inquisitio python visibility -doc -glsa -pink -portage -qa -ruby -vim-syntax -zsh-completion" 0 kB ....

...checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required


of course boost is installed

Code:
emerge -vp boost

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/boost-1.34.1-r2  USE="-debug -doc -icu -pyste -tools" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Thu Apr 17, 2008 11:18 am    Post subject: Reply with quote

phoenix_me wrote:
I have a problem installing paludis from portage
Code:
[ebuild  N    ] sys-apps/paludis-0.26.0_pre2  USE="bash-completion inquisitio python visibility -doc -glsa -pink -portage -qa -ruby -vim-syntax -zsh-completion" 0 kB ....

...checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required


See page 11 of this thread :)
Back to top
View user's profile Send private message
Dr.Willy
Guru
Guru


Joined: 15 Jul 2007
Posts: 500
Location: NRW, Germany

PostPosted: Thu Apr 17, 2008 12:23 pm    Post subject: Reply with quote

I recently noticed that my paludis has a little problem with some packages i have installed (or not)
Code:
~ # paludis -r
Current state of the system

* dev-java/asm-3.0::installed NOT OK
    Not used by any package in world

* dev-java/javacc-4.0-r4::installed NOT OK
    Not used by any package in world

* dev-java/lucene-2.3.1:2.3::installed NOT OK
    Not used by any package in world

* dev-java/tomcat-servlet-api-6.0.16:2.5::installed NOT OK
    Not used by any package in world

Finished processing 644 packages. 4 errors.

~ # paludis --uninstall-unused
Building unmerge list... done

These packages will be uninstalled:

* dev-java/asm-3.0::installed
* dev-java/javacc-4.0-r4::installed
* dev-java/lucene-2.3.1:2.3::installed
* dev-java/tomcat-servlet-api-6.0.16:2.5::installed


Total: 4 packages

[...]

~ # paludis -pi everything
Building target list...
Building dependency list...

These packages will be installed:

* dev-java/asm :3 [S 3.0] <everything>
    -doc -source elibc: (-FreeBSD)
* dev-java/javacc [N 4.0-r4]
    Reasons: *dev-java/lucene-2.3.1:2.3::gentoo
    "Java Compiler Compiler - The Java Parser Generator"
    -doc -examples -source -test elibc: (-FreeBSD)
* dev-java/lucene :2.3 [S 2.3.1] <everything>
    -doc -source -test elibc: (-FreeBSD)
* dev-java/tomcat-servlet-api :2.5 [S 6.0.16] <everything>
    -source elibc: (-FreeBSD)

Total: 4 packages (1 new, 3 in new slots)


Does anyone have an idea what causes this behaviour and why paludis wants to pull them?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Thu Apr 17, 2008 1:32 pm    Post subject: Reply with quote

Because "paludis -i world" and "paludis -i everything" behave differently.

The former looks at the world file. The latter looks at everything installed in /var/db/pkg

So if you have some stuff installed that you don't need/want then using the everything set will guarantee that the stuff stays.
Back to top
View user's profile Send private message
Dr.Willy
Guru
Guru


Joined: 15 Jul 2007
Posts: 500
Location: NRW, Germany

PostPosted: Thu Apr 17, 2008 3:27 pm    Post subject: Reply with quote

slycordinator wrote:
Because "paludis -i world" and "paludis -i everything" behave differently.

The former looks at the world file. The latter looks at everything installed in /var/db/pkg

So if you have some stuff installed that you don't need/want then using the everything set will guarantee that the stuff stays.

Ah, ok.
So I have say dev-java/asm installed as a dependency
Code:
~ $ equery d dev-java/asm
[ Searching for packages depending on dev-java/asm... ]
dev-java/jarjar-0.9 (=dev-java/asm-2.0*)

then 'paludis -i everything' updates it to the newest version available and 'paludis --uninstall-unused' removes it again, because it is not needed ... right?

That brings up the question how I update world + all dependencies without installing useless packages. The paludis faq suggests setting --dl-installed-deps-pre to ... ?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Thu Apr 17, 2008 3:36 pm    Post subject: Reply with quote

Dr.Willy wrote:
That brings up the question how I update world + all dependencies without installing useless packages. The paludis faq suggests setting --dl-installed-deps-pre to ... ?


I use
Code:
paludis -i world --dl-upgrade always --dl-reinstall if-use-changed --dl-installed-deps-pre pre-or-post
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Fri Apr 18, 2008 9:24 am    Post subject: Reply with quote

mikkoc wrote:
phoenix_me wrote:
I have a problem installing paludis from portage
Code:
[ebuild  N    ] sys-apps/paludis-0.26.0_pre2  USE="bash-completion inquisitio python visibility -doc -glsa -pink -portage -qa -ruby -vim-syntax -zsh-completion" 0 kB ....

...checking for boost.python... no
configure: error: boost.python (http://www.boost.org/libs/python/doc/) is required


See page 11 of this thread :)


Thank you.
In my case it was gcc-4.3.0 (paludis don't like it :) ) and Python2.5, (looks like paludis need to have 2.4).
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Apr 18, 2008 6:47 pm    Post subject: Reply with quote

Is it possible to stop showing this warning: [QA version_spec.too_long]

Thanks
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Sat Apr 19, 2008 4:14 pm    Post subject: Reply with quote

Can someone tell me what is paludis equivalent for
emerge --resume --skip-first

//edit

already have answer

creidiki wrote:
There is no such thing because --skipfirst is an utterly broken concept.

--continue-on-failure if-independent is miles better, but unfortunately its currently borken (there's an open ticket and its a blocker for 0.26 final).

_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Sat Apr 19, 2008 4:34 pm    Post subject: Reply with quote

Finswimmer wrote:
Is it possible to stop showing this warning: [QA version_spec.too_long]

Thanks
Tobi


That probably will not be displayed when you specify "--log-level warning". Not sure though.
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Sat Apr 19, 2008 6:34 pm    Post subject: Reply with quote

I am using sajinet overlay. It sync ok, but in ./profiles directory there is no repo_name file. Because of that paludis is giving this repository a x-sajinet name.
But every time it sync an overlay it shows me:
Code:
 * Done cleaning write cache for ebuild format repositories
paludis@1208627156: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/overlays/sajinet/profiles/', falling back to generated name 'x-sajinet' (ignore this message if you have yet to sync this repository).


I have 10 files *.conf (repositories configuration files) and this message is show to me 10 times after syncing.

Will it be enough if owner of the repository will add a repo_name file (in profiles dir) to his repository?

//edit

I ask the owner of overaly for creation of repo_name file, he did it and now paludis is not complain anymore. :)
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Sun Apr 20, 2008 5:42 pm    Post subject: Reply with quote

Isn't it an error of paludis.
Code:
paludis -ip gentoo-sources

Building dependency list...

These packages will be installed:

* sys-kernel/gentoo-sources :2.6.25-r1 [S 2.6.25-r1] <target>
    -build symlink
    43.08 kBytes to download

Total: 1 package (1 in new slot), at most 43.08 kBytes to download

 * No unread news items found

As I read output in good way, paludis want to download 43.08 kBytes and install gentoo-sources 2.6.25-r1 which is already installed. While this is not true. Because last installed version it's gentoo-sources-2.6.25 which paludis was installed yesterday!

Code:
ls -la /usr/src/
razem 7
drwxr-xr-x  8 root root  272 kwi 19 00:24 .
drwxr-xr-x 18 root root 4096 kwi 18 23:12 ..
-rw-r--r--  1 root root    0 lut 14  2006 .keep
lrwxrwxrwx  1 root root   19 kwi 19 00:24 linux -> linux-2.6.25-gentoo
drwxr-xr-x 19 root root 1200 kwi 19 00:20 linux-2.6.24-gentoo-r3
drwxr-xr-x 21 root root 1448 kwi 17 16:10 linux-2.6.24-gentoo-r5
drwxr-xr-x 21 root root  752 kwi 19 00:24 linux-2.6.25-gentoo
drwx------  2 root root   48 paź  7  2006 .reiserfs_priv
drwxr-xr-x  7 root root  168 cze  4  2007 rpm

_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sun Apr 20, 2008 6:11 pm    Post subject: Reply with quote

It has to re-download the gentoo-patches file portion as they had to fix up a number of the patches to work with 2.6.25 properly.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Mon Apr 21, 2008 6:15 am    Post subject: Reply with quote

phoenix_me wrote:
Isn't it an error of paludis.
Code:
paludis -ip gentoo-sources

Building dependency list...

These packages will be installed:

* sys-kernel/gentoo-sources :2.6.25-r1 [S 2.6.25-r1] <target>
    -build symlink
    43.08 kBytes to download

Total: 1 package (1 in new slot), at most 43.08 kBytes to download

 * No unread news items found

As I read output in good way, paludis want to download 43.08 kBytes and install gentoo-sources 2.6.25-r1 which is already installed. While this is not true. Because last installed version it's gentoo-sources-2.6.25 which paludis was installed yesterday!

Code:
ls -la /usr/src/
razem 7
drwxr-xr-x  8 root root  272 kwi 19 00:24 .
drwxr-xr-x 18 root root 4096 kwi 18 23:12 ..
-rw-r--r--  1 root root    0 lut 14  2006 .keep
lrwxrwxrwx  1 root root   19 kwi 19 00:24 linux -> linux-2.6.25-gentoo
drwxr-xr-x 19 root root 1200 kwi 19 00:20 linux-2.6.24-gentoo-r3
drwxr-xr-x 21 root root 1448 kwi 17 16:10 linux-2.6.24-gentoo-r5
drwxr-xr-x 21 root root  752 kwi 19 00:24 linux-2.6.25-gentoo
drwx------  2 root root   48 paź  7  2006 .reiserfs_priv
drwxr-xr-x  7 root root  168 cze  4  2007 rpm


It would be helpful to show the output of the paludis command; maybe you're misunderstanding what it's displaying?
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Mon Apr 21, 2008 7:05 am    Post subject: Reply with quote

The main tree has silent package changes, and paludis uses the tree ebuild when you do a -pi. Get used to it :D
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Mon Apr 21, 2008 12:46 pm    Post subject: Reply with quote

creidiki wrote:
The main tree has silent package changes, and paludis uses the tree ebuild when you do a -pi. Get used to it :D


I think what he's trying to say is that paludis CLAIMS the package (version 2.6.25-r1) is installed already when it is not (note how he said the latest version he installed was 2.6.25 and not 2.6.25-r1).

AFAIK,

1) There was no "silent add" of anything in this case
2) 2.6.25-r1 was created because 2.6.25 had a bad patch that failed on all x86/32-bit boxes

So again, phoenix_me show us the output of paludis
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4473

PostPosted: Mon Apr 21, 2008 2:20 pm    Post subject: Reply with quote

phoenix_me wrote:
Isn't it an error of paludis.
Code:
paludis -ip gentoo-sources

Building dependency list...

These packages will be installed:

* sys-kernel/gentoo-sources :2.6.25-r1 [S 2.6.25-r1] <target>
    -build symlink
    43.08 kBytes to download

Total: 1 package (1 in new slot), at most 43.08 kBytes to download

 * No unread news items found

As I read output in good way, paludis want to download 43.08 kBytes and install gentoo-sources 2.6.25-r1 which is already installed. While this is not true. Because last installed version it's gentoo-sources-2.6.25 which paludis was installed yesterday!

Huh, the output doesn't say that gentoo-sources-2.6.25-r1 is installed. The output say that this version gets installed in a different slot. There is a "S" (Slotted) instead a "R"(Reinstall) in the "[]"
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Rion
Guru
Guru


Joined: 12 Oct 2006
Posts: 377
Location: Ekaterinburg, Russia

PostPosted: Tue Apr 22, 2008 12:54 pm    Post subject: Reply with quote

i'm to lazy to read all 12 pages.. and i've not found answer in faq or bug tracker..

how to disable bunch of warnings i get on every time i use paludis
Code:
Building target list... paludis@1208868056: [QA version_spec.too_long] In program paludis -i kwin:
  ... When performing install action from command line:                                           
  ... When adding install target 'kwin':                                                         
  ... When disambiguating package name 'kwin':                                                   
  ... When finding category names containing package 'kwin':                                     
  ... When loading names for virtuals repository:                                                 
  ... When finding provided packages for 'installed':                                             
  ... When loading VDB PROVIDEs map the slow way:                                                 
  ... When loading package names from '/var/db/pkg' in category 'media-libs':                     
  ... When parsing package dep spec '=media-libs/libcaptury-0.3.0_pre200712251':                 
  ... When parsing version spec '0.3.0_pre200712251':
  ... Number part '200712251' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1208868056: [QA version_spec.too_long] In program paludis -i kwin:
  ... When performing install action from command line:
  ... When adding install target 'kwin':
  ... When disambiguating package name 'kwin':
  ... When finding category names containing package 'kwin':
  ... When loading names for virtuals repository:
  ... When finding provided packages for 'installed':
  ... When loading VDB PROVIDEs map the slow way:
  ... When loading package names from '/var/db/pkg' in category 'media-libs':
  ... When parsing package dep spec '=media-libs/capseo-0.3.0_pre200712251-r1':
  ... When parsing version spec '0.3.0_pre200712251-r1':
  ... Number part '200712251' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1208868057: [QA version_spec.too_long] In program paludis -i kwin:
  ... When performing install action from command line:
  ... When adding install target 'kwin':
  ... When disambiguating package name 'kwin':
  ... When finding category names containing package 'kwin':
  ... When loading names for virtuals repository:
  ... When finding provided packages for 'installed':
  ... When loading VDB PROVIDEs map the slow way:
  ... When loading package names from '/var/db/pkg' in category 'sys-apps':
  ... When parsing package dep spec '=sys-apps/net-tools-1.60_p20071202044231-r1':
  ... When parsing version spec '1.60_p20071202044231-r1':
  ... Number part '20071202044231' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)

i know there are ebuilds with invalid names in portage and i don't want to see these warnings every time
_________________
~amd64
rion-overlay
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13 ... 24, 25, 26  Next
Page 12 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum