Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Sun May 04, 2008 10:05 pm    Post subject: Reply with quote

slycordinator wrote:
The output shows that the problem has nothing to do with the ebuild in the tree and everything to do with the installed package in /var/db/pkg

So what you should do is
Code:
paludis -i1 =dev-java/java-config-2.1.6

That should fix your slot issue.


Thanks a lot, I'm trying it right know. In the meanwhile, can you help me to get rid of these messages?

Quote:
paludis@1209938520: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/maintainer/profiles/', falling back to generated name 'x-maintainer' (ignore this message if you have yet to sync this repository).
paludis@1209938520: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/miei/profiles/', falling back to generated name 'x-miei' (ignore this message if you have yet to sync this repository).


The overlay "miei" contains ebuilds downloaded by internet so it's been configured by me, but maintainer is a layman overlay
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Sun May 04, 2008 10:14 pm    Post subject: Reply with quote

slycordinator wrote:
The output shows that the problem has nothing to do with the ebuild in the tree and everything to do with the installed package in /var/db/pkg

So what you should do is
Code:
paludis -i1 =dev-java/java-config-2.1.6

That should fix your slot issue.


Didn't work :(

Quote:
paludis -i1 =dev-java/java-config-2.1.6
paludis@1209939160: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/maintainer/profiles/', falling back to generated name 'x-maintainer' (ignore this message if you have yet to sync this repository).
paludis@1209939160: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/miei/profiles/', falling back to generated name 'x-miei' (ignore this message if you have yet to sync this repository).
Building target list...
Building dependency list...paludis@1209939160: [QA version_spec.too_long] In program paludis -i1 =dev-java/java-config-2.1.6:
... When performing install action from command line:
... When executing install task:
... When building dependency list:
... When adding PackageDepSpec '=dev-java/java-config-2.1.6':
... When fetching versions of 'dev-java/java-config' in installed:
... When loading package names from '/var/db/pkg' in category 'dev-java':
... When parsing package dep spec '=dev-java/antlr-netbeans-cnd-2.7.7_p20071124024617':
... When parsing version spec '2.7.7_p20071124024617':
... Number part '20071124024617' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)

Unhandled exception:
* In program paludis -i1 =dev-java/java-config-2.1.6:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding PackageDepSpec '=dev-java/java-config-2.1.6':
* When finding SLOT for 'dev-java/java-config-2.1.6::installed':
* When validating slot name '':
* Name '' is not a valid slot name (paludis::SlotNameError)
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Sun May 04, 2008 10:40 pm    Post subject: Reply with quote

Thanks for the hint however, I solved by manually setting its SLOT (the file was empty!)
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon May 05, 2008 6:54 am    Post subject: Reply with quote

Since my command didn't work (and it fell back to the installed version) that makes me think you've made
Code:
--dl-fall-back as-needed


be specified by default. And since it fell back to using the installed version without appearing to even try to use the one in the tree, this makes me think something's wrong with either your portage tree or you set up paludis incorrectly so that it doesn't access your local tree.
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Mon May 05, 2008 7:37 am    Post subject: Reply with quote

I didn't change paludis default options
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon May 05, 2008 2:50 pm    Post subject: Reply with quote

cerebro84 wrote:
In the meanwhile, can you help me to get rid of these messages?

Quote:
paludis@1209938520: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/maintainer/profiles/', falling back to generated name 'x-maintainer' (ignore this message if you have yet to sync this repository).
paludis@1209938520: [QA e.repo_name.unusable] Couldn't open repo_name file in '/usr/portage/local/layman/miei/profiles/', falling back to generated name 'x-miei' (ignore this message if you have yet to sync this repository).


The overlay "miei" contains ebuilds downloaded by internet so it's been configured by me, but maintainer is a layman overlay


For the "miei" repository you need to create a file /usr/portage/local/layman/miei/profiles/repo_name with which simply is a text file containing the name you want the repository to have. Since you've already named it "miei" then you could just do

Code:
echo miei >> /usr/portage/local/layman/miei/profiles/repo_name


And with the maintainer overlay you should first sync the repository (since they may have fixed this problem already) and if that doesn't fix the issue contact the guy in charge of that repository and ask him to create a similar file.
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Mon May 05, 2008 3:18 pm    Post subject: Reply with quote

Thanks a lot, all solved, I'm starting to like paludis :)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue May 06, 2008 8:36 am    Post subject: Reply with quote

I thought Paludis does not need creating a Manifest (that was ebuild *.ebuild used to do)?
But I copied an ebuild to a higher date and now it fails:

Code:
--2008-05-06 10:28:24--  ftp://ftp.trolltech.com/qt/snapshots/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
           => `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-'
Resolving ftp.trolltech.com... 62.70.27.67
Connecting to ftp.trolltech.com|62.70.27.67|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /qt/snapshots ... done.
==> SIZE qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... 53926067
==> PASV ... done.    ==> RETR qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... done.
Length: 53926067 (51M)

100%[==================================================================================================>] 53,926,067   305K/s   in 2m 30s

2008-05-06 10:30:55 (352 KB/s) - `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-' saved [53926067]

mv -f /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL- /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
Checking 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz'... not in Manifest

Fetch error:
  * In program /usr/bin/paludis --log-level warning --dl-reinstall-scm weekly --continue-on-failure if-satisfied -i1 qt:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev':
  * Fetch error: Fetch of 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev' failed

  * File 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz': failed integrity checks: Not in Manifest


How can I do this now? If I run ebuld qt digest then portage first will change all the permissions, then create the Manifest. After that I had to re-change all the permissions...

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Tue May 06, 2008 8:57 am    Post subject: Reply with quote

Finswimmer wrote:
I thought Paludis does not need creating a Manifest (that was ebuild *.ebuild used to do)?
But I copied an ebuild to a higher date and now it fails:

Code:
--2008-05-06 10:28:24--  ftp://ftp.trolltech.com/qt/snapshots/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
           => `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-'
Resolving ftp.trolltech.com... 62.70.27.67
Connecting to ftp.trolltech.com|62.70.27.67|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /qt/snapshots ... done.
==> SIZE qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... 53926067
==> PASV ... done.    ==> RETR qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... done.
Length: 53926067 (51M)

100%[==================================================================================================>] 53,926,067   305K/s   in 2m 30s

2008-05-06 10:30:55 (352 KB/s) - `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-' saved [53926067]

mv -f /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL- /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
Checking 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz'... not in Manifest

Fetch error:
  * In program /usr/bin/paludis --log-level warning --dl-reinstall-scm weekly --continue-on-failure if-satisfied -i1 qt:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev':
  * Fetch error: Fetch of 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev' failed

  * File 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz': failed integrity checks: Not in Manifest


How can I do this now? If I run ebuld qt digest then portage first will change all the permissions, then create the Manifest. After that I had to re-change all the permissions...

Tobi

I did not try this, but probably it helps:
app-paludis/paludis-hooks-generate-metadata
from paludis-extras-repository.

// edit:
no, it doesn't...
Sry
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Tue May 06, 2008 11:36 am    Post subject: Reply with quote

Finswimmer wrote:
I thought Paludis does not need creating a Manifest (that was ebuild *.ebuild used to do)?
But I copied an ebuild to a higher date and now it fails:

Code:
--2008-05-06 10:28:24--  ftp://ftp.trolltech.com/qt/snapshots/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
           => `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-'
Resolving ftp.trolltech.com... 62.70.27.67
Connecting to ftp.trolltech.com|62.70.27.67|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /qt/snapshots ... done.
==> SIZE qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... 53926067
==> PASV ... done.    ==> RETR qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz ... done.
Length: 53926067 (51M)

100%[==================================================================================================>] 53,926,067   305K/s   in 2m 30s

2008-05-06 10:30:55 (352 KB/s) - `/usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL-' saved [53926067]

mv -f /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz.-PARTIAL- /usr/portage/distfiles/qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz
Checking 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz'... not in Manifest

Fetch error:
  * In program /usr/bin/paludis --log-level warning --dl-reinstall-scm weekly --continue-on-failure if-satisfied -i1 qt:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev':
  * Fetch error: Fetch of 'x11-libs/qt-core-4.4.1_pre20080506:4::qt44dev' failed

  * File 'qt-x11-opensource-src-4.4.1-snapshot-20080506.tar.gz': failed integrity checks: Not in Manifest


How can I do this now? If I run ebuld qt digest then portage first will change all the permissions, then create the Manifest. After that I had to re-change all the permissions...

Tobi


Set "use_manifest = ignore" in your repository config file. Or just remove the Manifest file.
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Tue May 06, 2008 12:36 pm    Post subject: Reply with quote

Hi,
this is what I get when I try to install docutils:

Code:
>>> Finished writing VDB entry
>>> Checking whether we can merge to / ..............................
!!! Cannot overwrite file '/usr/lib64/python2.5/site-packages/docutils-0.4-py2.5.egg-info' with directory '/var/tmp/paludis/dev-python-docutils-0.4-r3/image/usr/lib64/python2.5/site-packages/docutils-0.4-py2.5.egg-info'


Install error:
  * In program paludis (--continue-on-failure if-satisfied) --continue-on-failure if-satisfied --checks none --log-level qa --install --add-to-world-spec sys-apps/paludis --serialised 0.25 package;=sys-fs/fuse-2.7.3:0::gentoo;installed;has_all_deps;S package;=dev-perl/XML-Parser-2.36:0::gentoo;installed;has_all_deps;S package;=x11-wm/metacity-2.23.8:0::gnome;installed;has_all_deps;S package;=gnome-extra/evolution-data-server-2.22.1.1:0::gentoo;installed;has_all_deps;S package;=media-video/totem-2.22.2:0::gentoo;installed;has_all_deps;S package;=app-text/aspell-0.60.6:0::gentoo;installed;has_all_deps;S package;=gnome-base/nautilus-2.23.1:0::gnome;installed;has_all_deps;S package;=gnome-base/gnome-desktop-2.23.1:0::gnome;installed;has_all_deps;S package;=dev-libs/libgweather-2.23.1:0::gnome;installed;has_all_deps;S package;=gnome-base/gnome-menus-2.23.1:0::gnome;installed;has_all_deps;S package;=gnome-base/gnome-panel-2.23.1:0::gnome;installed;has_all_deps;S package;=dev-python/docutils-0.4-r3:0::gentoo;installed;has_all_deps;P package;=sys-apps/ed-0.9:0::gentoo;installed;has_all_deps;P package;=sys-apps/paludis-0.26.1:0::gentoo;installed;has_all_deps;P:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'dev-python/docutils-0.4-r3:0::gentoo':
  * When merging 'dev-python/docutils-0.4-r3:0::gentoo' at '/var/tmp/paludis/dev-python-docutils-0.4-r3/image' to VDB repository 'installed':
  * Install error: Not proceeding with install due to merge sanity check failing

How do I disable collision-protection in paludis?
Back to top
View user's profile Send private message
vetienne
n00b
n00b


Joined: 18 May 2004
Posts: 17
Location: France

PostPosted: Thu May 08, 2008 12:45 pm    Post subject: How to use contrarius. Need help Reply with quote

Hello,

i try to build a arm cross complier but when i "emerge" the compiler with
contraius -t arm-unknown-linux-gnu -s full
it always failed with "No versions of 'cross-arm-unknown-linux-gnu/binutils' are available"
unless i first do crossdev -t arm-unknown-linux-gnu

How should i use it (if i still need crossdev -t what's the point of contrarius) ?

A second question :
i need to setup a minimal binary image so with emerge normally
First, emerge in /usr/arm-unknown-linux-gnu first with a ROOT=/usr/arm-unknown-linux-gnu and xmerge script file with setup arch and so on
Second, rebuild it in a second root ( say /image with ROOT=/image and INSTALL_MASK to avoid man pages, include headers file, ... )

I have try to setup a specpath.conf
- first one is arm with root=/usr/arm-unknown-linux-gnu : ok work like emerge
- second one with root=/image : root is not use like only the target destination but like achroot root => end up with a copy of /usr/arm-...

To circumvent the problem, for the moment i have mounted ( mount -o bind ) /etc/paludis from usr/arm root in /image root and the same for /usr/include, /usr/share, /var/cache and some other directory. Seems more or less equivalent but a bit complex ( and likely to produce problem : not sure i have not forget a link so my image could have more files than needed... )

Someone has some experienced with this and could perhaps help me ?
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Thu May 08, 2008 12:50 pm    Post subject: Reply with quote

Finswimmer wrote:
I thought Paludis does not need creating a Manifest

How can I do this now? If I run ebuld qt digest then portage first will change all the permissions, then create the Manifest. After that I had to re-change all the permissions...

It will use the manifest files if its there, though it wont do all the checks portage does.

As to how to create a manifest: first you need to set userpriv to off in make.conf, then you just run 'ebuild bleh.ebuild manifest' :)
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Thu May 08, 2008 1:48 pm    Post subject: Reply with quote

cerebro84 wrote:
How do I disable collision-protection in paludis?


Code:
eselect paludis-hook disable collision-protect
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Thu May 08, 2008 4:35 pm    Post subject: Reply with quote

Code:
 sudo eselect paludis-hook disable collision-protect
Password:
!!! Error: Can't load module paludis-hook
Killed


Where do I find paludis-hook module?
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Thu May 08, 2008 5:26 pm    Post subject: Reply with quote

cerebro84 wrote:
Code:
 sudo eselect paludis-hook disable collision-protect
Password:
!!! Error: Can't load module paludis-hook
Killed


Where do I find paludis-hook module?

Set the eselect useflag in use.conf
Code:
*/* PALUDIS_HOOKS: eselect........

and update with
Code:
paludis --dl-reinstall if-use-changed -1 paludis-hooks

_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu


Last edited by zxy on Thu May 08, 2008 5:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Thu May 08, 2008 5:27 pm    Post subject: Reply with quote

How did you enable collision protection to begin with then?
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Fri May 09, 2008 6:20 am    Post subject: Reply with quote

I didn't. It was already enabled, and I'm sure it wasn't imported by the script from portage configuration because I disabled it there...
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Fri May 09, 2008 7:17 am    Post subject: Reply with quote

You're all barking up the wrong tree.

That 'sanity check' stuff has nothing to do with dleverton's collision-protect hook.
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Fri May 09, 2008 1:51 pm    Post subject: Reply with quote

That's what I was alluding to. Collision protection is NOT enabled (or even existent to be enabled) by default.

And you should definitely not disable sanity checks
Back to top
View user's profile Send private message
radum
n00b
n00b


Joined: 09 May 2008
Posts: 1

PostPosted: Fri May 09, 2008 3:14 pm    Post subject: Reply with quote

When I try
Code:
paludis -pi world
I get the following exception:
Code:
 # paludis -pi world
paludis@1210345427: [WARNING portage_environment.dodgy] Use of Portage configuration files will lead to sub-optimal performance and loss of functionality. Full support for Portage configuration formats is not guaranteed; issues should be reported via trac.
Building target list...
Building dependency list...paludis@1210345428: [QA version_spec.too_long] In program paludis -pi world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding NamedSetDepSpec 'system':
  ... When adding PackageDepSpec 'sys-apps/net-tools':
  ... When fetching versions of 'sys-apps/net-tools' in gentoo:
  ... When loading versions for 'sys-apps/net-tools' in gentoo:
  ... When creating ID for 'sys-apps/net-tools' from '/usr/portage/sys-apps/net-tools/net-tools-1.60_p20071202044231-r1.ebuild':
  ... When extracting version from '/usr/portage/sys-apps/net-tools/net-tools-1.60_p20071202044231-r1.ebuild':
  ... When parsing version spec '1.60_p20071202044231-r1':
  ... Number part '20071202044231' exceeds 8 digit limit permitted by the Package Manager Specification (Paludis supports arbitrary lengths, but other package managers do not)
paludis@1210345428: [WARNING e.cache.failure] Couldn't use the cache file at '/usr/portage/metadata/cache/dev-lang/perl-5.8.8-r5'
paludis@1210345428: [QA e.ebuild.cache.no_usable] No usable cache entry for 'dev-lang/perl-5.8.8-r5::gentoo
paludis@1210345429: [WARNING dep_list.ignoring_dependencies] In program paludis -pi world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'app-cdr/k3b':
  ... When adding installed package 'app-cdr/k3b-1.0.4:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'media-video/ffmpeg':
  ... When adding installed package 'media-video/ffmpeg-0.4.9_p20070616:0::installed':
  ... Ignoring run dependencies due to exception 'Error searching for '>=media-libs/x264-svn-20061014': no available versions' (paludis::AllMaskedError)
 

Apparently media-libs/x264 is no longer used, but even after removing it with
Code:
 # paludis --uninstall-unused --with-unused-dependencies
I get the same error.

Any idea why this is happening?
Back to top
View user's profile Send private message
creidiki
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 283
Location: Varese (Italy)

PostPosted: Fri May 09, 2008 3:57 pm    Post subject: Reply with quote

The package changed name from x264-svn to x264.

Reinstall ffmpeg to update the relevant dependency block to the one currently in portage, which uses the correct package name.

Hint: in these cases 'paludis -qD package' (to look at deps of installed version) followed by 'paludis -qD cat/pkg::repo' (to look at deps of tree ebuild) is invaluable for debugging this kind of issue.
_________________
'((eINIT) (soor overlay))
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Fri May 09, 2008 4:15 pm    Post subject: Reply with quote

slycordinator wrote:
That's what I was alluding to. Collision protection is NOT enabled (or even existent to be enabled) by default.

And you should definitely not disable sanity checks


So the only correct way is to manually delete the to-be-overrwritten file?
Back to top
View user's profile Send private message
wobble
n00b
n00b


Joined: 11 May 2008
Posts: 2

PostPosted: Sun May 11, 2008 4:27 pm    Post subject: Re: How to use contrarius. Need help Reply with quote

vetienne wrote:
Hello,

i try to build a arm cross complier but when i "emerge" the compiler with
contraius -t arm-unknown-linux-gnu -s full
it always failed with "No versions of 'cross-arm-unknown-linux-gnu/binutils' are available"
unless i first do crossdev -t arm-unknown-linux-gnu

How should i use it (if i still need crossdev -t what's the point of contrarius) ?

...

Someone has some experienced with this and could perhaps help me ?


I found this on the web, can't remember where, but it helped me.(added the NO_ & _SPAM to the embedded email)

Quote:

How to setup a full cross toolchain with contrarius.
====================================================
2007, René Nussbaumer <NO_killerfox_SPAM@gentoo.org>

1. Create a new repository as usual, in the ebuild format.
The name doesn't matter. I named my “cross-toolchains”.
2. Inside the new created repository you now create a category named
after your CTARGET with a “cross-”-prefix.
e.g.: cross-powerpc-unknown-linux-gnu or cross-i586-pc-linux-gnu
The CTARGETÂ is in the form:
${ARCHITECTURE}-${MANUFACTURER}-${KERNEL}-${USERSPACE}
3. Add this category to the categories file by running:
echo "cross-${CTARGET}" >> profiles/categories

4. Copy over the following packages:
sys-devel/binutils, sys-devel/gcc

Instead of using the original-category you now use cross-${CTARGET}
as category
5. Copy over your desired headers (e.g. linux-headers, freebsd-lib) and
your desired libc (e.g. glibc, uclibc)

NOTE: As in paludis 0.24.X and above you can just symlink the package directory
instead of copy it over. This has the advantage, that you don't have to bother
about actuality of your ebuilds and no work to maintain a hook.

6. Now we need to complete the repository, paludis wishes a name for this
repository. If you leave that out, paludis will create a name on its
own. So we create one:
echo 'cross-toolchains' > ${YOUR_FRESH_REPO}/profiles/repo_name
7. Create an repository configuration in /etc/paludis/repositories/.
The profile doesn't matter. So just copy&paste your profile line from your master repository.
8. Instead of copying over thirdpartymirror and arch.list from
${PORTDIR}/profiles/ as well, we set “master_repository = gentoo” in the
configuration file for our repository.
9. Check wheter paludis recognize your repository by running:
paludis --list-repositories

10. When all of this is done run contrarius:
contrarius --target ${CTARGET}
11. Have fun!
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun May 11, 2008 5:30 pm    Post subject: Reply with quote

So every time a new binutils or gcc is released you have to copy the ebuilds to your other repository?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 15, 16, 17 ... 24, 25, 26  Next
Page 16 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum