Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Thu May 15, 2008 7:57 pm    Post subject: Reply with quote

unstable gnome depends on unstable non-gnome packages ;)
Back to top
View user's profile Send private message
kaildio
n00b
n00b


Joined: 14 May 2008
Posts: 3

PostPosted: Fri May 16, 2008 5:52 pm    Post subject: Reply with quote

I've added the following lines in package_mask

Code:
x11-libs/qt::gentoo
x11-libs/qt-assistant::gentoo
[...]


but package like x11-libs/qt-4.4.0::gentoo are still installed.

Where i'm doing wrong? How should i mask them?
Thanks in advance.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri May 16, 2008 6:35 pm    Post subject: Reply with quote

You have them in package_unmask.conf.

Since split qt is currently masked by the profile, just remove it from package_unmask.conf.
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Sun May 18, 2008 2:05 pm    Post subject: Reply with quote

Hi,
Paludis reports me this message everytime I try to update world:

Code:

Building dependency list.../usr/bin/paludis@1211119460: [WARNING virtuals.no_match] In program /usr/bin/paludis (--show-reasons summary --show-use-descriptions changed --dl-downgrade warning --dl-installed-deps-pre pre-or-post --log-level warning --dl-upgrade always) -i world:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding NamedSetDepSpec 'system':
  ... When adding PackageDepSpec 'sys-apps/baselayout':
  ... When adding installed package 'sys-apps/baselayout-1.12.11.1:0::installed':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'virtual/os-headers':
  ... When loading entries for virtuals repository:
  ... No packages matching 'sys-fs/python-fuse' for virtual 'virtual/fuse-python'


I don't know how to fix it. Could you please help me?

Thanks in advance!

Regards,
Petr

EDIT: after paludis -s the message is not there any more :-)
_________________
hidentity.org
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Tue May 20, 2008 8:21 am    Post subject: Reply with quote

I had problems building package net-dns/avahi; configuration failed with not being able to find QT 3.

Filed a bug report about it: 222803.

As it turned out, there was no problem when using portage. Only if I used paludis.

I did get it built with paludis too, though, if I added the following to /etc/paludis/bashrc:
Code:
export PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"


The exact same problem, solved by the same measure, ensued with package kde-misc/kdnssd-avahi.

Haven't had any problems building other QT packages, so is it something with this particular ebuild; have I missed something in my paludis setup (which otherwise works just fine!), or what do you think?
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Tue May 20, 2008 2:10 pm    Post subject: Reply with quote

krisse wrote:
I had problems building package net-dns/avahi; configuration failed with not being able to find QT 3.

Filed a bug report about it: 222803.

As it turned out, there was no problem when using portage. Only if I used paludis.

I did get it built with paludis too, though, if I added the following to /etc/paludis/bashrc:
Code:
export PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"


The exact same problem, solved by the same measure, ensued with package kde-misc/kdnssd-avahi.

Haven't had any problems building other QT packages, so is it something with this particular ebuild; have I missed something in my paludis setup (which otherwise works just fine!), or what do you think?

It has something to do with the environment, because Paludis sources the environment less often than Portage does.
But it has not yet been found out, what exactly causes this.
I suggest, that you just disable the qt3 use flag, should be the easiest thing. ;)
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Tue May 20, 2008 3:20 pm    Post subject: Reply with quote

Berniyh wrote:
I suggest, that you just disable the qt3 use flag, should be the easiest thing. ;)
For sure. But I don't want to. :-S

Even though I can't recall what it was at the moment, I think I had a reason for it too. :) (I did build it without qt flags first, but then recompiled for some reason -- the reason I now don't remember. But it was there, I tell you. ;) (The reason, that is.))

Oh, and the above (PKG_CONFIG_PATH...) fixed that particular problem, so it's not like I need (more) workarounds. Just thought I'd mention it, if someone was inclined to see it as a problem and feel a need to do something about it. If not, that's fine by me. :-S
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Tue May 20, 2008 3:41 pm    Post subject: Reply with quote

krisse wrote:
Berniyh wrote:
I suggest, that you just disable the qt3 use flag, should be the easiest thing. ;)
For sure. But I don't want to. :-S

Even though I can't recall what it was at the moment, I think I had a reason for it too. :) (I did build it without qt flags first, but then recompiled for some reason -- the reason I now don't remember. But it was there, I tell you. ;) (The reason, that is.))

Oh, and the above (PKG_CONFIG_PATH...) fixed that particular problem, so it's not like I need (more) workarounds. Just thought I'd mention it, if someone was inclined to see it as a problem and feel a need to do something about it. If not, that's fine by me. :-S

BTW, if you export PKG_CONFIG_PATH, make sure that you append your path.
PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:foo/bar"
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Tue May 20, 2008 4:28 pm    Post subject: Reply with quote

Berniyh wrote:
BTW, if you export PKG_CONFIG_PATH, make sure that you append your path.
PKG_CONFIG_PATH="${PKG_CONFIG_PATH}:foo/bar"
I won't leave it in bashrc, but good point there! Thanks for the reminder.
Back to top
View user's profile Send private message
Smoothhound
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 149

PostPosted: Thu May 22, 2008 2:49 pm    Post subject: Reply with quote

Hi,

I want to upgrade to perl-5.10.0, and was going to have a go at installing it from the perl-experimental overlay. However I'm pretty sure running perl-cleaner would be fairly essential afterwords and it seems that perl-cleaner uses embedded calls to emerge.

Has anyone got any ideas on how to handle this in a Paludis setup? Ideally someone has a patched version stashed away that I can use :)

Cheers
Back to top
View user's profile Send private message
Smoothhound
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 149

PostPosted: Thu May 22, 2008 8:23 pm    Post subject: Reply with quote

Update:

I had look inside perl-cleaner script and there's nothing particularly clever happening inside so I used it to do the ph files and then shadowed the appropriate steps using paludis. Everything seemed to work fine until I tried to build mod_perl against 5.10 which blew up at the first compliation step! Anyway it seems the latest version of mod_perl should be ok but it's not currently in portage (bug). So back to 5.8.8 for me, when things stabilise a bit I might have a go at patching perl-cleaner to work with paludis

Cheers
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Fri May 23, 2008 11:20 am    Post subject: Reply with quote

Hi,
I've been using paludis for some time now and it works fine, but I have a few questions:

1) When I do paludis -i world, it floods me with warnings: http://pastebin.com/m18e0419d Is it normal?
2) What username should i chown /usr/portage/distfiles to? Now it gives me warnings that it can't enable some "userpriv" but gives me only group name.
3) Is there something like eclean for paludis?
4) Is there equivalent for emerge --prune in paludis?

Thanks ;]
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri May 23, 2008 11:43 am    Post subject: Reply with quote

peter4 wrote:
Hi,
I've been using paludis for some time now and it works fine, but I have a few questions:

1) When I do paludis -i world, it floods me with warnings: http://pastebin.com/m18e0419d Is it normal?

No, that is not normal. Maybe you forgot to unmask some things?

Quote:
2) What username should i chown /usr/portage/distfiles to? Now it gives me warnings that it can't enable some "userpriv" but gives me only group name.

The one you set in environment.conf. Standard is paludisbuild.
Quote:
3) Is there something like eclean for paludis?

There is a ruby script. Build paludis with use ruby enabled and look in the /usr/share/paludis/ruby folder.
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Fri May 23, 2008 12:14 pm    Post subject: Reply with quote

Berniyh wrote:

No, that is not normal. Maybe you forgot to unmask some things?

Nope, these packages paludis is complaining about don't even exist. (like '~kde-base/kde-env-3' or 'virtual/baselayout')
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri May 23, 2008 12:58 pm    Post subject: Reply with quote

peter4 wrote:
Berniyh wrote:

No, that is not normal. Maybe you forgot to unmask some things?

Nope, these packages paludis is complaining about don't even exist. (like '~kde-base/kde-env-3' or 'virtual/baselayout')

Maybe they are in your world file?
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Fri May 23, 2008 1:29 pm    Post subject: Reply with quote

Berniyh wrote:


Maybe they are in your world file?


Code:
Gentoo ~ # cat /var/db/pkg/world |grep kde-env
Gentoo ~ #

no... :(
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Fri May 23, 2008 1:38 pm    Post subject: Reply with quote

Maybe those are part of an overlay you haven't set up in paludis?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri May 23, 2008 2:20 pm    Post subject: Reply with quote

peter4 wrote:
Berniyh wrote:


Maybe they are in your world file?


Code:
Gentoo ~ # cat /var/db/pkg/world |grep kde-env
Gentoo ~ #

no... :(

Hm, not sure then.
All I know is that kde-env is dead for over a year, so there is something wrong on your system.
Is it actually installed?
What does
Code:
paludis -pu kde-base/kde-env

tell you?
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Fri May 23, 2008 4:22 pm    Post subject: Reply with quote

Code:
# paludis -pu kde-base/kde-env
Building unmerge list...
Query error:
  * In program paludis (--log-level warning --continue-on-failure if-satisfied --dl-reinstall-scm weekly --dl-new-slots as-needed) -pu kde-base/kde-env:
  * When performing uninstall action from command line:
  * When executing uninstall task:
  * When looking for target 'kde-base/kde-env':
  * Could not find 'kde-base/kde-env'. Looking for suggestions:
No suggestions found.

Quote:
All I know is that kde-env is dead for over a year

Yeah, some of these errors are for packages that are long gone. I think that those koffice warnings are there because some koffice packages in the tree are 1.6.2 and others 1.6.3.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sat May 24, 2008 12:57 am    Post subject: Reply with quote

I bet it's because paludis enforces dependencies of the installed package. So if you've got some package installed and when you installed it, it depended on kde-env then paludis will try to install kde-env because the ebuild in /var/db/pkg says it depends on it.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat May 24, 2008 4:23 pm    Post subject: find_unmanaged_files.rb Reply with quote

How accurate is find_unmanaged_files.rb in the demos directory? I'm asking because I've run it for the first time and it found over 14000 unmanaged files including much of perl 5.8.8

If they actually unused files, I'd love to free up that much space but I also don't want to kill my install losing perl and a lot of other things.

Is there a second test I can use to check and see if all of them are old and can be removed? Or can I just assume this is accurate and after 3 years I've accumulated that many orphaned files?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sat May 24, 2008 4:26 pm    Post subject: Re: find_unmanaged_files.rb Reply with quote

loftwyr wrote:
How accurate is find_unmanaged_files.rb in the demos directory? I'm asking because I've run it for the first time and it found over 14000 unmanaged files including much of perl 5.8.8

If they actually unused files, I'd love to free up that much space but I also don't want to kill my install losing perl and a lot of other things.

Is there a second test I can use to check and see if all of them are old and can be removed? Or can I just assume this is accurate and after 3 years I've accumulated that many orphaned files?

No, it doesn't work that way.
It finds everything, that has not been installed during the src_install phase of a package. BUT:
There are a lot of files, that are either created at runtime or maybe are created at post_install etc.

For example, if you just follow the list and remove everything on that list, you will brake your Qt-4.4 installation (if you have one).
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Sat May 24, 2008 5:15 pm    Post subject: Reply with quote

slycordinator wrote:
I bet it's because paludis enforces dependencies of the installed package. So if you've got some package installed and when you installed it, it depended on kde-env then paludis will try to install kde-env because the ebuild in /var/db/pkg says it depends on it.


That's right, I reinstalled those packages and the warnings are gone. Thanks.
Back to top
View user's profile Send private message
lucianolev
n00b
n00b


Joined: 19 Sep 2006
Posts: 31

PostPosted: Mon May 26, 2008 12:23 am    Post subject: Reply with quote

Hi!

I'm using paludis and I love it. I have a 2 simple questions:

1. How do I perform a fast search similar to eix? I try inquisitio but is slow as hell, or maybe I'm doing something wrong. I tried "inquisitio -s firefox" I have to wait like 5 minutes to see the results. 8O

2. Is there a way to list all packages which belong to a specific set? "paludis --list-packages --set genkdesvn-all" takes like a minute and list ALL packages instead of the packages from the set.

Thanks in advance.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon May 26, 2008 2:48 am    Post subject: Reply with quote

lucianolev wrote:
Hi!

I'm using paludis and I love it. I have a 2 simple questions:

1. How do I perform a fast search similar to eix? I try inquisitio but is slow as hell, or maybe I'm doing something wrong. I tried "inquisitio -s firefox" I have to wait like 5 minutes to see the results. 8O


You could just use eix. In the paludis-extras repository there's an "update-eix" hook which'll update your eix stuff to include all your repositories that paludis is using.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 24, 25, 26  Next
Page 18 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum