Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Wed Jun 04, 2008 8:29 am    Post subject: Reply with quote

can I make paludis not use the dependencies specified in the "installed" repository but the ones in the packages original repository? Or make it check for differences? Today, I synced my tree; the name of gnome-base/gnome2-user-docs had been changed to gnome-base/gnome-user-docs. I got an error because paludis still wanted for gnome the ebuild of gnome2-user docs, which didn't exist anymore. I had that problem before with VLC. VLC in "installed" depended on x264-svn which was replaced by x264. paludis complained, because x264-svn was missing but required.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Jun 04, 2008 9:15 am    Post subject: Reply with quote

MalleRIM wrote:
can I make paludis not use the dependencies specified in the "installed" repository but the ones in the packages original repository? Or make it check for differences? Today, I synced my tree; the name of gnome-base/gnome2-user-docs had been changed to gnome-base/gnome-user-docs. I got an error because paludis still wanted for gnome the ebuild of gnome2-user docs, which didn't exist anymore. I had that problem before with VLC. VLC in "installed" depended on x264-svn which was replaced by x264. paludis complained, because x264-svn was missing but required.

You need to reinstall these packages.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Jun 04, 2008 9:19 am    Post subject: Reply with quote

MalleRIM wrote:
@Berniyh:

just for comparison:
Code:
diff /usr/portage/net-print/cups/cups-1.3.7-r1.ebuild /var/paludis/repositories/private-overlay/net-print/cups/cups-1.3.7-r1.kdebuild-1
3d2
< # $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.3.7-r1.ebuild,v 1.6 2008/05/18 14:37:23 maekke Exp $
19c18
<    avahi? ( net-dns/avahi )
---
>    avahi? ( net-dns/avahi[mdnsresponder-compat] )
64,65d62
< PROVIDE="virtual/lpr"
<

what exactly did you change when you tried it?

Yes, I changed exactly that.
What came to my mind:
Are you using Paludis with a Portage config? That might not work.
Disable the portage use flag (if enabled) and put it on its own feet.
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Thu Jun 05, 2008 10:37 am    Post subject: Reply with quote

Berniyh wrote:
You need to reinstall these packages.

Can I somehow discover them, even when they still work?
Berniyh wrote:
Are you using Paludis with a Portage config? That might not work.

No, I'm using the paludis environment.
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Thu Jun 05, 2008 3:43 pm    Post subject: Reply with quote

I read on the paludis website that packages can be installed to other locations that the usual root. How do I do that? --destinations does not work.
Is there somewhere something like a wiki to paludis? On the paludis website there's just trac which doesn't seem to be including a real wiki.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Jun 05, 2008 5:33 pm    Post subject: Reply with quote

MalleRIM wrote:
Berniyh wrote:
You need to reinstall these packages.

Can I somehow discover them, even when they still work?

Paludis should spit out a warning, if a dep is no longer available (package removed and uninstalled).
Quote:
Berniyh wrote:
Are you using Paludis with a Portage config? That might not work.

No, I'm using the paludis environment.

Then I have no idea, why it doesn't work, it works fine here.

MalleRIM wrote:
I read on the paludis website that packages can be installed to other locations that the usual root. How do I do that? --destinations does not work.
Is there somewhere something like a wiki to paludis? On the paludis website there's just trac which doesn't seem to be including a real wiki.

Try export ROOT=some/dir.
Back to top
View user's profile Send private message
lucianolev
n00b
n00b


Joined: 19 Sep 2006
Posts: 31

PostPosted: Sat Jun 07, 2008 4:30 am    Post subject: Reply with quote

Hi! I've a problem with gstreamer and paludis

Eix reports the following use flags for package media-plugins/gst-plugins-meta:
"X a52 alsa dvb dvd esd ffmpeg flac mad mpeg mythtv ogg oss theora vorbis xv"
However, "paludis -q media-plugins/gst-plugins-meta" shows only:
"X alsa -esd -oss xv"

Any ideas?

Thanks!
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sat Jun 07, 2008 2:25 pm    Post subject: Reply with quote

From gst-plugins-meta-0.10-r1.ebuild

Code:
IUSE="alsa esd oss X xv dvb mythtv"


From gst-plugins-meta-0.10-r2.ebuild
Code:
IUSE="a52 alsa dvb dvd esd ffmpeg flac mad mpeg mythtv ogg oss theora vorbis X xv"


You have to look at the version it's trying to install
Back to top
View user's profile Send private message
lucianolev
n00b
n00b


Joined: 19 Sep 2006
Posts: 31

PostPosted: Sat Jun 07, 2008 5:05 pm    Post subject: Reply with quote

slycordinator wrote:
From gst-plugins-meta-0.10-r1.ebuild

Code:
IUSE="alsa esd oss X xv dvb mythtv"


From gst-plugins-meta-0.10-r2.ebuild
Code:
IUSE="a52 alsa dvb dvd esd ffmpeg flac mad mpeg mythtv ogg oss theora vorbis X xv"


You have to look at the version it's trying to install


:oops: I thought I've already check that, but indeed, unmasking 0.10-r2 did the trick.

Thanks!
Back to top
View user's profile Send private message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Sun Jun 08, 2008 11:47 am    Post subject: Reply with quote

Can someone tell me what's wrong with this bashrc snippet?:
Code:
if (echo "${CATEGORY}" | grep "kde" > /dev/null) then   # KDE should be debugable
if [[ "${CATEGORY}" == "kde-base" ||
        "${CATEGORY}" == "kde-misc" ||
        "${CATEGORY}/${PN}" == "media-sound/phonon" ]]
then
        CFLAGS="-O2 -march=native -pipe -fno-strict-aliasing"
else
       CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fno-strict-aliasing"
fi

Whenever I install a KDE package, I get "/etc/paludis/bashrc: line 26: syntax error: unexpected end of file" errors. The whole bashrc is 25 lines long
This snippet, without the else part:
Code:
if [[ "${CATEGORY}" == "kde-base" ||                               
        "${CATEGORY}" == "kde-misc" ||
        "${CATEGORY}/${PN}" == "media-sound/phonon" ]]
then
        CFLAGS="-O2 -march=native -pipe -fno-strict-aliasing"

fi
works
Back to top
View user's profile Send private message
MK24
n00b
n00b


Joined: 31 Dec 2004
Posts: 46

PostPosted: Sun Jun 08, 2008 2:14 pm    Post subject: Reply with quote

Im trying to install fuseiso from the sunrise overlay, but I allways get this error message. I don't know if it's a bug in the ebuild or in my configuration or something else. Maybe someone has an idea. Thanks.

Code:

Building target list...
Building dependency list...paludis@1212933657: [WARNING e.ebuild.cache_failure] In program paludis (--dl-upgrade as-needed) -ip fuseiso:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'sys-fs/fuseiso':
  ... When generating metadata for ID 'sys-fs/fuseiso-20070708::sunrise':
  ... Caught exception 'Configuration file error: Unknown command or broken variable 'Set', trailing text ' cache size limit to 2097152k
DEPEND=">=sys-fs/fuse-2.2.1 >=dev-libs/glib-2.4.2 "
RDEPEND=">=sys-fs/fuse-2.2.1 >=dev-libs/glib-2.4.2 "
PDEPEND=" "
IUSE=" "
SRC_URI="http://ubiz.ru/dm/fuseiso-20070708.tar.bz2"
RESTRICT=""
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86 "
INHERITED=" toolchain-funcs multilib portability eutils"
PROVIDE=""
HOMEPAGE="http://fuse.sourceforge.net/wiki/index.php/FuseIso"
DESCRIPTION="FUSE module to mount ISO9660 images"
DEPENDENCIES=""
E_IUSE=" "
E_DEPEND=" "
E_RDEPEND=" "
E_PDEPEND=" "
E_KEYWORDS=" "
PLATFORMS=""
E_PLATFORMS=""
MYOPTIONS=""
E_MYOPTIONS=""
E_DEPENDENCIES=""
BINARY_KEYWORDS=""
BINARY_URI=""
GENERATED_USING=""
GENERATED_TIME=""
BINARY_PLATFORMS=""
SLOT="0"
EAPI="0"
OPTIONS=""
USE=""
'' (paludis::ConfigFileError) when generating cache for 'sys-fs/fuseiso-20070708::sunrise', input is 'Set \n cache \n size \n limit \n to \n 2097152k \n DEPEND=">=sys-fs/fuse-2.2.1 \n >=dev-libs/glib-2.4.2 \n " \n RDEPEND=">=sys-fs/fuse-2.2.1 \n >=dev-libs/glib-2.4.2 \n " \n PDEPEND=" \n " \n IUSE=" \n " \n SRC_URI="http://ubiz.ru/dm/fuseiso-20070708.tar.bz2" \n RESTRICT="" \n LICENSE="GPL-2" \n KEYWORDS="~amd64 \n ~x86 \n " \n INHERITED=" \n toolchain-funcs \n multilib \n portability \n eutils" \n PROVIDE="" \n HOMEPAGE="http://fuse.sourceforge.net/wiki/index.php/FuseIso" \n DESCRIPTION="FUSE \n module \n to \n mount \n ISO9660 \n images" \n DEPENDENCIES="" \n E_IUSE=" \n " \n E_DEPEND=" \n " \n E_RDEPEND=" \n " \n E_PDEPEND=" \n " \n E_KEYWORDS=" \n " \n PLATFORMS="" \n E_PLATFORMS="" \n MYOPTIONS="" \n E_MYOPTIONS="" \n E_DEPENDENCIES="" \n BINARY_KEYWORDS="" \n BINARY_URI="" \n GENERATED_USING="" \n GENERATED_TIME="" \n BINARY_PLATFORMS="" \n SLOT="0" \n EAPI="0" \n OPTIONS="" \n USE=""'
paludis@1212933657: [WARNING e.ebuild.cache_failure] (same context) Could not generate cache for 'sys-fs/fuseiso-20070708::sunrise'
paludis@1212933657: [WARNING e.ebuild.metadata.unusable] No usable metadata for 'sys-fs/fuseiso-20070708::sunrise'

Query error:
  * In program paludis (--dl-upgrade as-needed) -ip fuseiso:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'sys-fs/fuseiso':
  * No versions of 'sys-fs/fuseiso' are available. Looking for suggestions:
No suggestions found.

 * No unread news items found
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sun Jun 08, 2008 2:24 pm    Post subject: Reply with quote

MK24 wrote:
Im trying to install fuseiso from the sunrise overlay, but I allways get this error message. I don't know if it's a bug in the ebuild or in my configuration or something else. Maybe someone has an idea. Thanks.

It's something in the config.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jun 08, 2008 4:09 pm    Post subject: Reply with quote

a.b. wrote:
Can someone tell me what's wrong with this bashrc snippet?:
Code:
if (echo "${CATEGORY}" | grep "kde" > /dev/null) then   # KDE should be debugable
if [[ "${CATEGORY}" == "kde-base" ||
        "${CATEGORY}" == "kde-misc" ||
        "${CATEGORY}/${PN}" == "media-sound/phonon" ]]
then
        CFLAGS="-O2 -march=native -pipe -fno-strict-aliasing"
else
       CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -fno-strict-aliasing"
fi


You have 2 "if's in this code snippet and only one "fi" for closing the if statement.

Essentially you've got

Code:
if (something)
then
if [something else]
then
      do something
else
      do something else
fi


Last edited by slycordinator on Sun Jun 08, 2008 5:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Sun Jun 08, 2008 5:21 pm    Post subject: Reply with quote

Berniyh wrote:
MalleRIM wrote:
I read on the paludis website that packages can be installed to other locations that the usual root. How do I do that? --destinations does not work.
Is there somewhere something like a wiki to paludis? On the paludis website there's just trac which doesn't seem to be including a real wiki.

Try export ROOT=some/dir.

That doesn't do it.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jun 08, 2008 5:39 pm    Post subject: Reply with quote

MalleRIM wrote:
Berniyh wrote:
MalleRIM wrote:
I read on the paludis website that packages can be installed to other locations that the usual root. How do I do that? --destinations does not work.
Is there somewhere something like a wiki to paludis? On the paludis website there's just trac which doesn't seem to be including a real wiki.

Try export ROOT=some/dir.

That doesn't do it.


This might work; I'm not sure though.

Code:
paludis --environment paludis:/other/root


Where /other/root is the directory you want to install to. Can't say I've tried it to check
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Mon Jun 09, 2008 6:41 am    Post subject: Reply with quote

Installing app-shells/bash-3.2_p39 made my paludis go boom. Be careful. I didn't understand anything about the error message but if I got it right there was no /bin/sh and Paludis needs it. I used emerge to install the previous version of bash because I had no time at all to try to actually fix the problem, so I'm sorry I have no good info to give :(
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon Jun 09, 2008 1:10 pm    Post subject: Reply with quote

Lepaca Kliffoth wrote:
Installing app-shells/bash-3.2_p39 made my paludis go boom. Be careful. I didn't understand anything about the error message but if I got it right there was no /bin/sh and Paludis needs it. I used emerge to install the previous version of bash because I had no time at all to try to actually fix the problem, so I'm sorry I have no good info to give :(

https://bugs.gentoo.org/show_bug.cgi?id=222721
Back to top
View user's profile Send private message
Bill Cosby
Guru
Guru


Joined: 22 Jan 2005
Posts: 430
Location: Aachen, Germany

PostPosted: Mon Jun 09, 2008 4:08 pm    Post subject: Reply with quote

Heyhey,

sorry, for the newb question, but how can I install gcc-3.3 with paludis? Or any specific version of a package (which is then slotted if supported)?

thanks in advance,
_________________
The Creature from Jekyll Island.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jun 09, 2008 4:17 pm    Post subject: Reply with quote

You can install any version using the same syntax as portage i.e.,
Code:

paludis -i =sys-devel/gcc-3.3

_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon Jun 09, 2008 4:43 pm    Post subject: Reply with quote

loftwyr wrote:
You can install any version using the same syntax as portage i.e.,
Code:

paludis -i =sys-devel/gcc-3.3

Not exactly.

Many portage users are used to things like =gcc-3.3. With paludis, you can't do this.
Dropping the category is only allowed for the plain package name.

So if you want a specific version or slot, you need to use cat/foo and not just foo.
That is what causes the confusion sometimes. :)
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Mon Jun 09, 2008 5:57 pm    Post subject: Reply with quote

I just upgraded gcc to version 4.3.1 and tried to remove the old version. I got this:
Code:
# paludis -u =sys-devel/gcc-4.2.4
Building unmerge list... done

These packages will be uninstalled:

* dev-libs/elfutils-0.131-r2::installed requires <sys-devel/gcc-4.2.4::installed>
* media-gfx/yafray-0.0.9-r1::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-libs/glibc-2.8_p20080602::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-libs/libstdc++-v3-3.3.6::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-functional-0::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-memory-0::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-type-traits-0::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-devel/gcc-4.2.4::installed


Total: 1 package and 7 errors
Use either --with-dependencies or --permit-unsafe-uninstalls

Cannot continue with uninstall due to the errors indicated above


What should I do?
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Mon Jun 09, 2008 8:05 pm    Post subject: Reply with quote

peter4 wrote:
What should I do?

First, switch to the gcc version you want to use and check if paludis still works. I wanted to do a gcc downgrade once and paludis didn't work anymore when the older version was used as the active compiler.
Paludis warns you about any package fitting to the dependencies of any installed package, even when satisfying version in another slot is installed. It's the same thing when you have optional dependencies (either ... or ...). Use --permit-unsafe-uninstalls if you are sure the uninstall won't break anything.
Back to top
View user's profile Send private message
MalleRIM
Guru
Guru


Joined: 23 Jul 2007
Posts: 563
Location: China

PostPosted: Mon Jun 09, 2008 8:08 pm    Post subject: Reply with quote

slycordinator wrote:
This might work; I'm not sure though.

Code:
paludis --environment paludis:/other/root


Where /other/root is the directory you want to install to. Can't say I've tried it to check

nope, it doesn't work :(
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Mon Jun 09, 2008 8:19 pm    Post subject: Reply with quote

MalleRIM wrote:
peter4 wrote:
What should I do?

(...)
Paludis warns you about any package fitting to the dependencies of any installed package, even when satisfying version in another slot is installed. It's the same thing when you have optional dependencies (either ... or ...).


Is it a feature or a bug? :P
Quote:
Use --permit-unsafe-uninstalls if you are sure the uninstall won't break anything.

How can I be sure, then? ;)
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Tue Jun 10, 2008 5:29 pm    Post subject: virtual/logger (how to get rid of metalog) Reply with quote

I have paludis installed system and I've encountered strange virtual/logger related problem. I wanted to uninstall metalog and switch to syslog-ng, but after paludis -u metalog, paludis -i syslog-ng whenever I did paludis -ip system it wanted to pull metalog back.

I had to install both with emerge and uninstall metalog (with emerge as well).
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 24, 25, 26  Next
Page 20 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum