Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 22, 23, 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jul 13, 2008 5:23 pm    Post subject: Reply with quote

The next line after the error says:
Code:
The bug is not reproducible, so it is likely a hardware or OS problem.


So that leads it to likely being any one of:
1) Overheating
2) Running out of ram/swap
3) Bad ram
And maybe other hardware stuff

Try reinstalling the package again (hardware problems lots of times only occur once). If it still fails try lowering your make opts (MAKEOPTS="-j1") and reinstall again; this way, it might not work as hard on your possibly overworked/overheated stuff.
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Sun Jul 13, 2008 9:33 pm    Post subject: Reply with quote

I'm already with -j1 :(
Damn...I've got to run memtest or something.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon Jul 14, 2008 4:31 am    Post subject: Reply with quote

NetCutter wrote:
I'm already with -j1 :(
Damn...I've got to run memtest or something.


You'll still need to try to install the package again. As it says, the bug is likely a hardware problem which are usually not reproducible. This is meant both in the sense that the devs can't reproduce it on their box (since they don't have the hardware that is failing) and the sense that you won't necessarily see the same failing every time.
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Mon Jul 14, 2008 7:39 pm    Post subject: Reply with quote

Paludis just stop listening to me :(...
To prevent downgrade of some package I was using --dl-downgrade error and it always works.. till now... now it's just stop processing....

Code:
Building dependency list...
Dependency error:
  * In program paludis -ip --dl-downgrade error cdrtools truecrypt glibmm sun-jre-bin faad2 xine-lib avidemux transcode dclib valknut lm_sensors paludis ntfs3g libwnck gtk-engines-qtcurve arj dpkg wireshark:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'media-video/transcode':
  * When adding package 'media-video/transcode-1.0.4-r3:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '<media-video/ffmpeg-0.4.9_p20080326':
  * Downgrade to 'media-video/ffmpeg-0.4.9_p20080206:0::gentoo' from 'media-video/ffmpeg-0.4.9_p20080326:0::installed' forbidden (paludis::DowngradeNotAllowedError)


 * No unread news items found


Any help welcome - how to prevent package from downgrade?
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Mon Jul 14, 2008 9:43 pm    Post subject: Reply with quote

Huh...second try...here is it the output:
Code:
creating example_version_spec
i686-pc-linux-gnu-g++ -DSYSCONFDIR=\"/etc\" -DDATADIR=\"/usr/share\" -DLIBEXECDIR=\"/usr/libexec\" -DLIBDIR=\"/usr/lib\" -I. -I../../../..    -I../../../.. -I../../../../src  -DPALUDIS_HAVE_EXTERN_TEMPLATE=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -march=prescott -O2 -pipe -fomit-frame-pointer -MT example_name.o -MD -MP -MF .deps/example_name.Tpo -c -o example_name.o example_name.cc
mv -f .deps/example_name.Tpo .deps/example_name.Po
/bin/sh ../../../../libtool --tag=CXX   --mode=link i686-pc-linux-gnu-g++ -I../../../.. -I../../../../src  -DPALUDIS_HAVE_EXTERN_TEMPLATE=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -march=prescott -O2 -pipe -fomit-frame-pointer  -Wl,-O1 -o example_name example_name.o libpaludisexamples.a ../../../../paludis/libpaludis.la ../../../../paludis/args/libpaludisargs.la
i686-pc-linux-gnu-g++ -I../../../.. -I../../../../src -DPALUDIS_HAVE_EXTERN_TEMPLATE=1 -Wall -Wextra -Wold-style-cast -Wredundant-decls -Wstrict-null-sentinel -Wmissing-noreturn -Woverloaded-virtual -Winit-self -Wunused -Wunused-function -Wshadow -Wwrite-strings -Wfloat-equal -march=prescott -O2 -pipe -fomit-frame-pointer -Wl,-O1 -o .libs/example_name example_name.o  libpaludisexamples.a ../../../../paludis/.libs/libpaludis.so ../../../../paludis/args/.libs/libpaludisargs.so /var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/paludis/.libs/libpaludis.so /var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/paludis/selinux/.libs/libpaludisselinux.so /var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/paludis/util/.libs/libpaludisutil.so -ldl
creating example_name
make[6]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/cplusplus/examples'
make[5]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/cplusplus/examples'
Making all in .
make[5]: Entering directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/cplusplus'
make[5]: Nothing to be done for `all-am'.
make[5]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/cplusplus'
make[4]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/cplusplus'
Making all in python
make[4]: Entering directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/python'
Making all in .
make[5]: Entering directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/python'
rm -fr python
mkdir python
env \
       LD_LIBRARY_PATH=`echo "\`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/util/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/paludis/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/no_config/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/environments/adapted/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/repositories/e/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../paludis/repositories/fake/.libs\`: \
       \`../../../paludis/repositories/e/ebuild/utils/canonicalise ../../../python/.libs\`" \
       | tr -d ' '` \
       PYTHONPATH="./.libs" \
       epydoc --name Paludis -o python --url http://paludis.pioto.org --no-frames --css ./epydoc.css \
           ../../../python/paludis.so
Traceback (most recent call last):
  File "/usr/bin/epydoc", line 6, in <module>
    from epydoc.cli import cli
ImportError: No module named epydoc.cli
make[5]: *** [python] Error 1
make[5]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/python'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api/python'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc/api'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/sys-apps-paludis-0.28.0/work/paludis-0.28.0'
make: *** [all] Error 2

!!! ERROR in sys-apps/paludis-0.28.0:
!!! In src_compile at line 3677
!!! emake failed

!!! Call stack:
!!!    * src_compile (/var/tmp/paludis/sys-apps-paludis-0.28.0/temp/loadsaveenv:3677)
!!!    * ebuild_f_compile (/usr/libexec/paludis/0/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 4990 exit with error
die trap: exiting with error.

Install error:
  * In program paludis (--checks none --dl-reinstall if-use-changed --dl-upgrade always --show-reasons summary) -i paludis:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'sys-apps/paludis-0.28.0:0::gentoo':
  * Install error: Install failed for 'sys-apps/paludis-0.28.0:0::gentoo'



Summary of failures:

* sys-apps/paludis-0.28.0:0::gentoo: failure

Total: 1 package, 0 successes, 0 skipped, 1 failure, 0 unreached

Resume command: paludis --log-level qa --install --add-to-world-spec 'sys-apps/paludis' --serialised 0.25 'package;=sys-apps/paludis-0.28.0:0::gentoo;installed;has_all_deps;P'

 * No unread news items found

 * Searching for configuration files requiring action...
 * No configuration file updates required

gentoo nc #


But now says:
Code:
ImportError: No module named epydoc.cli

...ideas?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Tue Jul 15, 2008 3:41 pm    Post subject: Reply with quote

Reinstall epydoc.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Tue Jul 15, 2008 3:49 pm    Post subject: Reply with quote

phoenix_me wrote:
Paludis just stop listening to me :(...
To prevent downgrade of some package I was using --dl-downgrade error and it always works.. till now... now it's just stop processing....

Code:
Building dependency list...
Dependency error:
  * In program paludis -ip --dl-downgrade error cdrtools truecrypt glibmm sun-jre-bin faad2 xine-lib avidemux transcode dclib valknut lm_sensors paludis ntfs3g libwnck gtk-engines-qtcurve arj dpkg wireshark:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'media-video/transcode':
  * When adding package 'media-video/transcode-1.0.4-r3:0::gentoo':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec '<media-video/ffmpeg-0.4.9_p20080326':
  * Downgrade to 'media-video/ffmpeg-0.4.9_p20080206:0::gentoo' from 'media-video/ffmpeg-0.4.9_p20080326:0::installed' forbidden (paludis::DowngradeNotAllowedError)


 * No unread news items found


Any help welcome - how to prevent package from downgrade?


The reason it's failing is:
1) You're telling it "Don't Downgrade"
2) But try installing a version of transcode that requires a downgrade of ffmpeg

So what you need to do is either:
1) stop caring about the downgrades
or
2) Install a newer version of transcode
Back to top
View user's profile Send private message
phoenix_me
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 281
Location: Lubliniec

PostPosted: Tue Jul 15, 2008 8:16 pm    Post subject: Reply with quote

slycordinator wrote:
phoenix_me wrote:

[code]Building dependency list...
Dependency error:
* In program paludis -ip --dl-downgrade error cdrtools truecrypt glibmm sun-jre-bin faad2 xine-lib avidemux transcode dclib valknut lm_sensors paludis ntfs3g libwnck gtk-engines-qtcurve arj dpkg wireshark:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding PackageDepSpec 'media-video/transcode':
* When adding package 'media-video/transcode-1.0.4-r3:0::gentoo':
* When adding build dependencies as pre dependencies:
* When adding PackageDepSpec '<media-video/ffmpeg-0.4.9_p20080326':
* Downgrade to 'media-video/ffmpeg-0.4.9_p20080206:0::gentoo' from 'media-video/ffmpeg-0.4.9_p20080326:0::installed' forbidden (paludis::DowngradeNotAllowedError)

Any help welcome - how to prevent package from downgrade?


The reason it's failing is:
1) You're telling it "Don't Downgrade"
2) But try installing a version of transcode that requires a downgrade of ffmpeg...


Sorry - My fault, I had to miss it !
_________________
phoenix
___
myslenie ma przyszlosc
___
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jul 17, 2008 11:51 am    Post subject: Reply with quote

What is the correct way to get rid of an old SLOT?

In this case I want to get rid of gcc-4.2.4 as gcc-4.3.1 proved to be working fine.
Code:
sirius tom # paludis -u =sys-devel/gcc-4.2.4
Building unmerge list... done

These packages will be uninstalled:

* dev-libs/elfutils-0.131-r2::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-libs/glibc-2.8_p20080602::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-libs/libstdc++-v3-3.3.6::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-functional-0::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-memory-0::installed requires <sys-devel/gcc-4.2.4::installed>
* virtual/c++-tr1-type-traits-0::installed requires <sys-devel/gcc-4.2.4::installed>
* sys-devel/gcc-4.2.4::installed


Total: 1 package and 6 errors
Use either --with-dependencies or --permit-unsafe-uninstalls

Same with paludis -u --all-versions '<sys-devel/gcc-4.3.1'

Now, I re-installed all packages mentioned above, and also I totally refuse to use --permit-unsafe-uninstalls

Is there maybe some virtual that still explicitly references gcc-4.2.4? And how do I find out what it is? Or is there some of that hundrets of deplist switches I can toggle?

Thanks in advance.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Jul 17, 2008 12:01 pm    Post subject: Reply with quote

Well, since --permit-unsafe-uninstalls is the only solution (I know, I've uninstalled gcc-4.2.4 the same way and it was fine) then there's no help.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jul 17, 2008 12:06 pm    Post subject: Reply with quote

loftwyr wrote:
Well, since --permit-unsafe-uninstalls is the only solution (I know, I've uninstalled gcc-4.2.4 the same way and it was fine) then there's no help.

Really? That's weird somehow, isn't it? If something depends on e.g. >=sys-devel/gcc-4.2.0 then it should be fine with 4.3.1 anyway, and we shouldn't get any dependency errors when uninstalling the old slot.

But good to know it worked out for you with unsafe uninstall.

Thanks! :)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
warpsychosis
n00b
n00b


Joined: 16 Nov 2007
Posts: 16
Location: France

PostPosted: Sat Jul 19, 2008 11:46 am    Post subject: Reply with quote

Hello, I've got a little problem with paludis and the configuration files that should have been caused by usage of both paludis and emerge, here it is :
each time an ebuild is installed with paludis, I got this
Code:
 # paludis -i what_ever_package
....
....
 * No unread news items found

 * Searching for configuration files requiring action...
 * Found 2 files in /etc
 * Found files in 1 directories
 * Your action is required


And with emerge, I've got the following :
Code:
# emergewhat_ever_package
 >>> No packages selected for removal by clean
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
...
 * Regenerating GNU info directory index...
 * Processed 195 info files; 1 errors.


Of course, I tried both etc-paludis and etc-update, and both say :
Code:
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)


Any idea about how can i get rid of those messages ?
I've took a look in /etc/conf.d/ and nothing seems suspicious..
thanks!
_________________
Linux toshibath 2.6.26-gentoo-r4 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GenuineIntel GNU/Linux powered by enlightenment DR17 & paludis
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sat Jul 19, 2008 5:39 pm    Post subject: Reply with quote

Perhaps if you reinstall something that WILL have actual files to change it'll reset itself.

If you haven't upgraded to openrc, baselayout will have some files in /etc/conf.d to edit

And if you did upgrade then openrc will have its own files to change

Code:
paludis -i1 baselayout


And it shouldn't take very long for the package to install
Back to top
View user's profile Send private message
warpsychosis
n00b
n00b


Joined: 16 Nov 2007
Posts: 16
Location: France

PostPosted: Sat Jul 19, 2008 11:17 pm    Post subject: Reply with quote

Yeah, obviously reinstalling the package which have the configuration files to update would do it, but since I don't know which package it is ! And honestly I prefer waiting an update of this package to come up rather than reinstalling the whole system...
For openrc, it is not installed.
I was just wondering if there was some kind of "find" command I could use to find it out.
_________________
Linux toshibath 2.6.26-gentoo-r4 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GenuineIntel GNU/Linux powered by enlightenment DR17 & paludis
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jul 20, 2008 7:25 am    Post subject: Reply with quote

You misunderstood me.

paludis appears to wrongly think that some config file needs to be updated.

So you reinstall any old package you want that installed a config file that you previously edited. So like if you edited /etc/conf.d/net then reinstalled baselayout, paludis would tell you that that file needs to be updated.

So doing this might reset whatever paludis is looking at so it'll only notice the new valid config file change.
Back to top
View user's profile Send private message
warpsychosis
n00b
n00b


Joined: 16 Nov 2007
Posts: 16
Location: France

PostPosted: Sun Jul 20, 2008 10:48 am    Post subject: Reply with quote

ok, sorry for my english... :roll:
I've tried reinstalling gpm fo example, and I've got :
Code:
 Found 3 files in /etc
instead of 2 files, so etc-paludis :
Code:
Scanning Configuration files...
The following is the list of files which need updating, each
configuration file is followed by a list of possible replacement files.
1) /etc/conf.d/gpm (1)
Please select a file to edit by entering the corresponding number.
              (don't use -3, -5, -7 or -9 if you're unsure what to do)
              (-1 to exit) (-3 to auto merge all remaining files)
                           (-5 to auto-merge AND not use 'mv -i')
                           (-7 to discard all updates)
                           (-9 to discard all updates AND not use 'rm -i'): -9
Are you sure that you want to delete all updates (type YES):YES

Deleting /etc/conf.d/._cfg0000_gpm

Exiting: Nothing left to do; exiting. :)


but then, a paludis -i whatever_package still says :
Code:
 * Searching for configuration files requiring action...
 * Found 2 files in /etc
 * Found files in 1 directories
 * Your action is required


Is there a way to know which files paludis want to update in order to check it by hand ?
_________________
Linux toshibath 2.6.26-gentoo-r4 i686 Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz GenuineIntel GNU/Linux powered by enlightenment DR17 & paludis
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jul 20, 2008 3:11 pm    Post subject: Reply with quote

I'm kind of satisfied with paludis, but there is one thing left: I'm missing a tool like eix for fast searching of ebuilds. Why is eix not able to work with paludis?
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jul 20, 2008 3:51 pm    Post subject: Reply with quote

Phlogiston wrote:
I'm kind of satisfied with paludis, but there is one thing left: I'm missing a tool like eix for fast searching of ebuilds. Why is eix not able to work with paludis?


eix works fine with paludis

If you install the paludis-extras repository it's got a package called "paludis-hooks" and it controls which hooks you get installed. And it's got USE flags for all the hooks it supports.

So you add:
Code:
PALUDIS_HOOKS: -* update-eix


to /etc/paludis/use.conf

then do
Code:
paludis -i paludis-hooks


And whenever you sync it'll update eix for you with everything paludis uses.

Though, I'd recommend doing
Code:
paludis -ip paludis-hooks

to get a look at the other PALUDIS_HOOKS variables it supports and which ones you might like.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Jul 20, 2008 3:56 pm    Post subject: Reply with quote

slycordinator wrote:


eix works fine with paludis



No, because it does not care about my mask and keywords files, furthermore it does not automatically find the overlays nor displaying packages from them. So a lot of features from eix get lost.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Sun Jul 20, 2008 4:10 pm    Post subject: Reply with quote

Phlogiston wrote:
No, because it does not care about my mask and keywords files


That's because the package was written specifically for working with portage. That's why it's "app-portage/eix". You could probably ask upstream if they could support those features for paludis.

Quote:
furthermore it does not automatically find the overlays nor displaying packages from them.


If you read the rest of my previous post you will see how you can get exactly what you want. The "update-eix" hook makes it so eix can see every package/overlay that paludis uses. All you do is "paludis --sync" and now at the end it'll update the eix database for you.
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Mon Jul 21, 2008 11:47 am    Post subject: Reply with quote

Argh! Now boost!
http://pastebin.com/f7bd1546c
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 21, 2008 11:56 am    Post subject: Reply with quote

Do you agree that the following warning is totally useless?

Code:
paludis -i everything -p
Building target list...                             
Building dependency list...paludis@1216641196: [QA e.query_use.not_in_iuse] In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --debug-build none) -i everything -p:                                                         
  ... When performing install action from command line:                                                                                               
  ... When executing install task:                                                                                                                   
  ... When building dependency list:                                                                                                                 
  ... When adding NamedSetDepSpec 'everything':                                                                                                       
  ... When adding PackageDepSpec 'app-cdr/k3b':                                                                                                       
  ... When adding installed package 'app-cdr/k3b-scm:kde-svn::installed':                                                                             
  ... When adding run dependencies as post dependencies:                                                                                             
  ... When adding PackageDepSpec 'media-libs/flac[cxx]':                                                                                             
  ... When finding all versions sorted from packages matching media-libs/flac[cxx] intersected with packages that might support action install with filter all matches:                                                                                                                                     
  ... When querying use flag 'cxx' for 'media-libs/flac-1.2.1-r1::gentoo' in Paludis environment:                                                     
  ... Was asked for the state of USE flag 'cxx' for ID 'media-libs/flac-1.2.1-r1:0::gentoo', but that flag is not listed in IUSE and is not a USE_EXPAND or ARCH value                                                                                                                                     


These packages will be installed:


Total: 0 packages

 * No unread news items found

machine # paludis -q flac
* media-libs/flac
    gentoo:                  (1.2.1-r1)U 1.2.1-r2 1.2.1-r3 {:0}
    installed:               1.2.1-r3* {:0}
    Description:             free lossless audio encoder and decoder
    Homepage:                http://flac.sourceforge.net
    Relevant USE flags:      (-3dnow) (-altivec) (cxx) (-debug) (-doc) (ogg) (sse)
    License:                 GPL-2 LGPL-2
    Installed time:          Mon Jul 21 11:52:00 2008
    Source repository:       gentoo
    Installed using:         paludis-0.28.0

Key to mask reasons:

* U: user

_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jul 21, 2008 1:50 pm    Post subject: Reply with quote

If you put "--log-level warning" into your PALUDIS_OPTIONS, that kind of thing will go away.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 21, 2008 2:09 pm    Post subject: Reply with quote

loftwyr wrote:
If you put "--log-level warning" into your PALUDIS_OPTIONS, that kind of thing will go away.


Yes, thats true, so it was on qa level before.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jul 21, 2008 7:32 pm    Post subject: Reply with quote

IS there such a thing as a cleaner for the paludis configuration files?

There are (or were) a number of utilities that could keep the files in /etc/portage up to date (remove stale masks, use, etc.).

Is there any way to do that with /etc/paludis?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 22, 23, 24, 25, 26  Next
Page 23 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum