Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 23, 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Mon Jul 21, 2008 9:35 pm    Post subject: Reply with quote

Phlogiston wrote:
Do you agree that the following warning is totally useless?


No. It's saying "You're trying to install a package that wants some other package to be built with USE=cxx but the package doesn't even use that flag at all."
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Jul 21, 2008 9:49 pm    Post subject: Reply with quote

slycordinator wrote:
Phlogiston wrote:
Do you agree that the following warning is totally useless?


No. It's saying "You're trying to install a package that wants some other package to be built with USE=cxx but the package doesn't even use that flag at all."


But that package is not relevant at all. At least not from the users perspective. Because a) it won't be used because there is a newer version available, and b) because the newer version is already installed, so everything should be fine.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Tue Jul 22, 2008 3:05 am    Post subject: Reply with quote

Touché
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Jul 22, 2008 9:08 am    Post subject: Reply with quote

Is gimme.rb broken for you as well?

Code:
gimme.rb =x11-base/x11-drm-20080710
/usr/local/sbin/gimme.rb:222:in `parse_user_package_dep_spec': parse_user_package_dep_spec expects three to four arguments, but got 2 (ArgumentError)
        from /usr/local/sbin/gimme.rb:222

_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Jul 22, 2008 12:07 pm    Post subject: Reply with quote

Why does or did paludis not update my sun-jdk from 1:5?

Code:
* dev-java/sun-jdk-1.5.0.13::installed NOT OK
    This package has following security issues:
    GLSA-200804-20: "Sun JDK/JRE: Multiple vulnerabilities"
        -> /usr/portage/metadata/glsa/glsa-200804-20.xml   
    No longer exists in its original repository 'gentoo'   
 

                                                                       
phlogsthink [~] # paludis -q sun-jdk                                                                                                                 
* dev-java/sun-jdk                                                                                                                                   
    gentoo:                  1.4.2.17 1.4.2.18 {:1.4} 1.5.0.15 (1.5.0.15-r1)K 1.5.0.16 {:1.5} 1.6.0.05 (1.6.0.05-r1)K 1.6.0.06 1.6.0.07 {:1.6}       
    installed:               1.5.0.13 {:1.5} 1.6.0.07* {:1.6}                                                                                         
    Description:             Sun's J2SE Development Kit, version 1.6.0.07                                                                             
    Homepage:                http://java.sun.com/javase/6/                                                                                           
    Relevant USE flags:      (X) (alsa) (-doc) (-examples) (-jce) (nsplugin) (-odbc)                                                                 
    License:                 dlj-1.1                                                                                                                 
    Installed time:          Fri Jul 18 11:38:03 2008                                                                                                 
    Source repository:       gentoo                                                                                                                   
    Installed using:         paludis-0.28.0                                                                                                           

Key to mask reasons:

* K: keywords


No updates on paludis -i everything or world....
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Jul 22, 2008 12:53 pm    Post subject: Reply with quote

Check your package_mask.conf to make sure its not locked off. There might also be an old installed package that needs tpo be updated to allow the sun-java update.

If all else fails, you may need to update it by manually updating the package.

That's the problem I run into. Since paludis uses the currently installed version of a package to cue it for updates, when a package is updated without an -r release, paludis never notices.

The devs like to blame the ebuild maintainers but won't take any responsibility to make the tool deal with the problem.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jul 22, 2008 1:03 pm    Post subject: Reply with quote

Same issue here, but the problem is not package_mask or anything else with user's influence.
Code:
# paludis -ai sun-jdk
...
* dev-java/sun-jdk :1.6 [R 1.6.0.07] <target>
    X alsa -doc -examples -jce (-nsplugin) -odbc

but
Code:
# paludis -ai sun-jdk:1.5
...
* dev-java/sun-jdk :1.5 [U 1.5.0.14 -> 1.5.0.16] <target>
    X alsa -doc -examples -jce (-nsplugin) -odbc
    42.01 MBytes to download


--dl-upgrade always --dl-new-slots always is default behaviour anyway.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Jul 22, 2008 1:09 pm    Post subject: Reply with quote

For me the above problem is a bug.

Anyone has an idea how to fix that?
Code:
Unhandled exception:
  * In program paludis (--show-reasons summary --show-use-descriptions new --continue-on-failure if-satisfied --dl-downgrade warning --debug-build none --log-level warning) --report:
  * When performing report action from command line:
  * When executing report task:
  * When validating repository name '':
  * Name '' is not a valid repository (paludis::RepositoryNameError)


happens on paludis --report
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Tue Jul 22, 2008 2:52 pm    Post subject: Reply with quote

Uh...it's me again. About this thing: http://pastebin.com/f7bd1546c

I've tried to recompile boost, cuz it's compiled with gcc-4.1.2, and now I'm with 4.2.3 But after recompiling of boost and libstdc++ it returns the same error, listed here
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jul 22, 2008 4:49 pm    Post subject: Reply with quote

Hi,

could one of you paludis-devs please fix the following BUG:

Quote:
cc1plus: note: -freorder-blocks-and-partition does not work with exceptions
mv -f .deps/console_task.Tpo .deps/console_task.Po
mv -f .deps/colour_formatter.Tpo .deps/colour_formatter.Po
mv -f .deps/mask_displayer.Tpo .deps/mask_displayer.Po
mv -f .deps/console_query_task.Tpo .deps/console_query_task.Po
In function ‘int open(const char*, int, ...)’,
inlined from ‘void paludis::ConsoleInstallTask::show_resume_command(const std::string&) const’ at console_install_task.cc:1832:
/usr/include/bits/fcntl2.h:51: error: call to ‘__open_missing_mode’ declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make[4]: *** [console_install_task.o] Error 1


this gets triggered when compiling paludis with >=gcc-4.3 and -D_FORTIFY_SOURCE=2

many thanks in advance :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
NetCutter
n00b
n00b


Joined: 26 Mar 2007
Posts: 25
Location: Bulgaria

PostPosted: Wed Jul 23, 2008 7:35 am    Post subject: Reply with quote

NetCutter wrote:
Uh...it's me again. About this thing: http://pastebin.com/f7bd1546c

I've tried to recompile boost, cuz it's compiled with gcc-4.1.2, and now I'm with 4.2.3 But after recompiling of boost and libstdc++ it returns the same error, listed here


My bad! Forgot to run python-updater -P paludis, after updating to python2.5!Everything is just great!

My problem is SOLVED :)
Back to top
View user's profile Send private message
krisse
Guru
Guru


Joined: 15 Mar 2005
Posts: 325
Location: Sweden

PostPosted: Wed Jul 23, 2008 12:51 pm    Post subject: Reply with quote

If I've got it right, paludis presently only automatically updates the latest slot. So if you've sun-jdk:1.5 and sun-jdk:1.6 installed, it'll only automatically update the 1.6 "branch".

A way to make paludis update both branches, is to make sure both are in your world file (/var/db/pkg/world by default). E g something like
Code:
dev-java/sun-jdk:1.5
dev-java/sun-jdk:1.6


Then a paludis -ia world should notice & update sun-jdk, both 1.5 and 1.6 branches.

I think I saw a bug-report about this on the paludis trac. Or here.
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Thu Jul 24, 2008 1:59 pm    Post subject: Reply with quote

krisse wrote:
If I've got it right, paludis presently only automatically updates the latest slot. So if you've sun-jdk:1.5 and sun-jdk:1.6 installed, it'll only automatically update the 1.6 "branch".

A way to make paludis update both branches, is to make sure both are in your world file (/var/db/pkg/world by default). E g something like
Code:
dev-java/sun-jdk:1.5
dev-java/sun-jdk:1.6


Then a paludis -ia world should notice & update sun-jdk, both 1.5 and 1.6 branches.

I think I saw a bug-report about this on the paludis trac. Or here.


It is again the problem with slots in paludis resolver. Currently in paludis there is a resolver which ignores other slots then the highest :-( I mentioned this already in mailing list and the response was, that this issue will be solved when new resolver will be available but probably nobody knows when :(
_________________
hidentity.org
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Wed Jul 30, 2008 5:59 pm    Post subject: Reply with quote

Hi,

I recently upgraded qt-3 to version 3.3.8b. Now Paludis wants to downgrade it when doing 'paludis -i world' :

Code:
# paludis -i world -p
Building target list...
Building dependency list...paludis@1217440238: [WARNING dep_list.downgrade] In program paludis (--log-level warning --continue-on-failure if-satisfied --dl-reinstall-scm weekly --dl-new-slots as-needed) -i world -p:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding NamedSetDepSpec 'world':
  ... When adding PackageDepSpec 'media-plugins/kipi-plugins':
  ... When adding installed package 'media-plugins/kipi-plugins-0.1.5:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec '>=media-libs/libkexiv2-0.1.5':
  ... When adding installed package 'media-libs/libkexiv2-0.1.7:0::installed':
  ... When adding run dependencies as post dependencies:
  ... When adding PackageDepSpec 'x11-libs/qt[=3.3.8-r4|=3.3.8-r3|=3.3.8-r2|=3.3.8-r1|=3.3.8|=3.3.6-r5|=3.3.6-r4|=3.3.6-r3|=3.3.6-r2|=3.3.6-r1|=3.3.6|=3.3.5-r1|=3.3.5|=3.3.4-r9|=3.3.4-r8|=3.3.4-r7|=3.3.4-r6|=3.3.4-r5|=3.3.4-r4|=3.3.4-r3|=3.3.4-r2|=3.3.4-r1|=3.3.4|=3.3.3-r3|=3.3.3-r2|=3.3.3-r1|=3.3.3|=3.3.2|=3.3.1-r2|=3.3.1-r1|=3.3.1|=3.3.0-r1|=3.3.0|=3.2.3-r1|=3.2.3|=3.2.2-r1|=3.2.2|=3.2.1-r2|=3.2.1-r1|=3.2.1|=3.2.0|=3.1.2-r4|=3.1.2-r3|=3.1.2-r2|=3.1.2-r1|=3.1.2|=3.1.1-r2|=3.1.1-r1|=3.1.1|=3.1.0-r3|=3.1.0-r2|=3.1.0-r1|=3.1.0] (rewritten from { =x11-libs/qt-3.3.8-r4, =x11-libs/qt-3.3.8-r3, =x11-libs/qt-3.3.8-r2, =x11-libs/qt-3.3.8-r1, =x11-libs/qt-3.3.8, =x11-libs/qt-3.3.6-r5, =x11-libs/qt-3.3.6-r4, =x11-libs/qt-3.3.6-r3, =x11-libs/qt-3.3.6-r2, =x11-libs/qt-3.3.6-r1, =x11-libs/qt-3.3.6, =x11-libs/qt-3.3.5-r1, =x11-libs/qt-3.3.5, =x11-libs/qt-3.3.4-r9, =x11-libs/qt-3.3.4-r8, =x11-libs/qt-3.3.4-r7, =x11-libs/qt-3.3.4-r6, =x11-libs/qt-3.3.4-r5, =x11-libs/qt-3.3.4-r4, =x11-libs/qt-3.3.4-r3, =x11-libs/qt-3.3.4-r2, =x11-libs/qt-3.3.4-r1, =x11-libs/qt-3.3.4, =x11-libs/qt-3.3.3-r3, =x11-libs/qt-3.3.3-r2, =x11-libs/qt-3.3.3-r1, =x11-libs/qt-3.3.3, =x11-libs/qt-3.3.2, =x11-libs/qt-3.3.1-r2, =x11-libs/qt-3.3.1-r1, =x11-libs/qt-3.3.1, =x11-libs/qt-3.3.0-r1, =x11-libs/qt-3.3.0, =x11-libs/qt-3.2.3-r1, =x11-libs/qt-3.2.3, =x11-libs/qt-3.2.2-r1, =x11-libs/qt-3.2.2, =x11-libs/qt-3.2.1-r2, =x11-libs/qt-3.2.1-r1, =x11-libs/qt-3.2.1, =x11-libs/qt-3.2.0, =x11-libs/qt-3.1.2-r4, =x11-libs/qt-3.1.2-r3, =x11-libs/qt-3.1.2-r2, =x11-libs/qt-3.1.2-r1, =x11-libs/qt-3.1.2, =x11-libs/qt-3.1.1-r2, =x11-libs/qt-3.1.1-r1, =x11-libs/qt-3.1.1, =x11-libs/qt-3.1.0-r3, =x11-libs/qt-3.1.0-r2, =x11-libs/qt-3.1.0-r1, =x11-libs/qt-3.1.0 })':
  ... Downgrade to 'x11-libs/qt-3.3.8-r4:3::gentoo' from 'x11-libs/qt-3.3.8b:3::installed' forced


How can I tell it to stop doing that?

When I remove or reinstall the given package - here libkexiv2 - another one jumps into its place.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jul 30, 2008 6:03 pm    Post subject: Reply with quote

kernelOfTruth wrote:
Hi,

could one of you paludis-devs please fix the following BUG:

Quote:
cc1plus: note: -freorder-blocks-and-partition does not work with exceptions
mv -f .deps/console_task.Tpo .deps/console_task.Po
mv -f .deps/colour_formatter.Tpo .deps/colour_formatter.Po
mv -f .deps/mask_displayer.Tpo .deps/mask_displayer.Po
mv -f .deps/console_query_task.Tpo .deps/console_query_task.Po
In function ‘int open(const char*, int, ...)’,
inlined from ‘void paludis::ConsoleInstallTask::show_resume_command(const std::string&) const’ at console_install_task.cc:1832:
/usr/include/bits/fcntl2.h:51: error: call to ‘__open_missing_mode’ declared with attribute error: open with O_CREAT in second argument needs 3 arguments
make[4]: *** [console_install_task.o] Error 1


this gets triggered when compiling paludis with >=gcc-4.3 and -D_FORTIFY_SOURCE=2

many thanks in advance :)


*bump*

was this fixed ?

if not I ask you paludis-devs to fix it (as time allows) & don't to flame about other (portage, pkgcore's devs) while it's not fixed ;) many many thanks in advance :D

(in the past I always got the impression that paludis should be superior than any of the other pkg-managers - so let it be :P )
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Tue Aug 05, 2008 9:01 pm    Post subject: Reply with quote

I just stumbled into something weird.

After a successful installation paludis gave me this:
Code:
Unhandled exception:
  * In program paludis (--log-level warning --continue-on-failure if-satisfied --dl-reinstall-scm weekly --dl-new-slots as-needed) --log-level warning--install --add-to-world-spec ( kde-base/dragonplayer kde-base/gwenview media-gfx/digikamkde-base/kde-l10n ) --continue-on-failure if-satisfied --serialised 0.25 package;=kde-base/dragonplayer-4.1.0:4.1::kde4-overlay;installed;has_all_deps;P package;=kde-base/gwenview-4.1.0:4.1::kde4-overlay;installed;has_all_deps;P package;=kde-base/libkexiv2-4.1.0:4.1::kde4-overlay;installed;has_all_deps;P package;=media-gfx/digikam-0.10.0_beta2:4.1::kde4-overlay;installed;has_all_deps;P package;=kde-base/kde-l10n-4.1.0:4.1::kde4-overlay;installed;has_all_deps;P:
  * When performing install action from command line:
  * When executing install task:
  * When parsing user package dep spec 'media-gfx/digikamkde-base/kde-l10n':
  * When parsing generic package dep spec 'media-gfx/digikamkde-base/kde-l10n':
  * When splitting out category and package names from 'media-gfx/digikamkde-base/kde-l10n':
  * When validating package name part 'digikamkde-base/kde-l10n':
  * Name 'digikamkde-base/kde-l10n' is not a valid package name part (paludis::PackageNamePartError)


WTF?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Wed Aug 06, 2008 2:51 am    Post subject: Reply with quote

You tried to install "media-gfx/digikamkde-base/kde-l10n" when it should be "media-gfx/digikam kde-base/kde-l10n" since they are separate packages.
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Wed Aug 06, 2008 10:37 am    Post subject: Reply with quote

slycordinator wrote:
You tried to install "media-gfx/digikamkde-base/kde-l10n" when it should be "media-gfx/digikam kde-base/kde-l10n" since they are separate packages.


The funny thing is, I didn't, because both packages installed fine ;)
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Wed Aug 06, 2008 10:53 am    Post subject: Reply with quote

peter4 wrote:
slycordinator wrote:
You tried to install "media-gfx/digikamkde-base/kde-l10n" when it should be "media-gfx/digikam kde-base/kde-l10n" since they are separate packages.


The funny thing is, I didn't, because both packages installed fine ;)


The even funnier thing is that you paste says you tried to install media-gfx/digikamkde-base/kde-l10n.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Wed Aug 06, 2008 11:00 am    Post subject: Reply with quote

Phlogiston wrote:
peter4 wrote:
slycordinator wrote:
You tried to install "media-gfx/digikamkde-base/kde-l10n" when it should be "media-gfx/digikam kde-base/kde-l10n" since they are separate packages.


The funny thing is, I didn't, because both packages installed fine ;)


The even funnier thing is that you paste says you tried to install media-gfx/digikamkde-base/kde-l10n.


I know, that's why I posted it ;)

But honestly, before you mentioned it, I didn't even noticed the 'typo' in add-to-world-spec part of the command line. It could be some bug in pretend-resume hook (which I use often and never had any problem with). Or maybe something with selecting and copying text in konsole from kde 4.1 which I installed yesterday?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Wed Aug 06, 2008 2:16 pm    Post subject: Reply with quote

My guess is it's a copy/paste error.
Back to top
View user's profile Send private message
numerodix
l33t
l33t


Joined: 18 Jul 2002
Posts: 743
Location: nl.eu

PostPosted: Thu Aug 07, 2008 12:57 pm    Post subject: Reply with quote

Has anyone had trouble building poppler-bindings lately? I've been unable to for months.

Does this ring a bell: https://bugs.gentoo.org/show_bug.cgi?id=234085 ?

Astonishingly portage builds it just fine, paludis chokes though.
_________________
undvd - ripping dvds should be as simple as unzip
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 359
Location: Wroclaw, Poland

PostPosted: Thu Aug 07, 2008 1:00 pm    Post subject: Reply with quote

How can I tell paludis to remove old and unused versions of slotted packages? In other words: how to do 'emerge --prune' with paludis?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3059
Location: Korea

PostPosted: Thu Aug 07, 2008 4:22 pm    Post subject: Reply with quote

Code:
paludis --uninstall-unused

should work assuming the older version you want to remove isn't depended on by some other package.
Back to top
View user's profile Send private message
jmanig
n00b
n00b


Joined: 20 Jun 2008
Posts: 4
Location: Montreal, QC

PostPosted: Thu Aug 07, 2008 8:37 pm    Post subject: Reply with quote

This is kind of silly:

Code:
myhost ~ # paludis -ip =dev-db/mysql-4.0.27-r1
Building target list...
Building dependency list...paludis@1218120794: [WARNING paludis_environment.use_conf.unknown_set] Set name 'bash-completion' does not exist
paludis@1218120795: [QA dep_list.dropping_circular] In program paludis (--dl-upgrade as-needed --checks none) -ip =dev-db/mysql-4.0.27-r1:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec '=dev-db/mysql-4.0.27-r1':
  ... When adding package 'dev-db/mysql-4.0.27-r1:0::gentoo':
  ... When adding post dependencies as post dependencies unless under a suggested label:
  ... When adding PackageDepSpec '>=dev-perl/DBD-mysql-2.9004':
  ... When adding package 'dev-perl/DBD-mysql-4.00.5:0::gentoo':
  ... When adding build dependencies as pre dependencies:
  ... When adding PackageDepSpec 'virtual/mysql':
  ... When adding package 'virtual/mysql-5.0:0::gentoo':
  ... When adding run dependencies as pre dependencies:
  ... When using new group to resolve dependencies:
  ... When adding PackageDepSpec '=dev-db/mysql-5.0*':
  ... When adding package 'dev-db/mysql-5.0.60-r1:0::gentoo':
  ... When adding post dependencies as post dependencies with cycle breaking unless under a suggested label:
  ... When adding PackageDepSpec '>=dev-perl/DBD-mysql-2.9004':
  ... Dropping circular dependency on 'dev-perl/DBD-mysql-4.00.5:0::gentoo'


These packages will be installed:

* sys-apps/ed [N 0.9]
    Reasons: *dev-db/mysql-4.0.27-r1:0::gentoo, *dev-db/mysql-5.0.60-r1:0::gentoo
    "Your basic line editor"
    66.35 kBytes to download
* dev-db/mysql-init-scripts [N 1.2]
    Reasons: *dev-db/mysql-4.0.27-r1:0::gentoo, *dev-db/mysql-5.0.60-r1:0::gentoo
    "Gentoo MySQL init scripts."
* dev-db/mysql [N 4.0.27-r1] <target>
    "A fast, multi-threaded, multi-user SQL database server."
    berkdb -big-tables -debug -embedded -minimal perl -raid (-selinux) ssl -static
    10.68 MBytes to download
* perl-core/Storable [N 2.16]
    Reasons: *virtual/perl-Storable-2.16:0::gentoo
    "The Perl Storable Module"
    169.51 kBytes to download
* virtual/perl-Storable [N 2.16]
    Reasons: *dev-perl/PlRPC-0.2020-r1:0::gentoo
    "Virtual for Storable"
* dev-perl/Net-Daemon [N 0.43]
    Reasons: *dev-perl/PlRPC-0.2020-r1:0::gentoo
    "Abstract base class for portable servers"
    27.88 kBytes to download
* dev-perl/PlRPC [N 0.2020-r1]
    Reasons: *dev-perl/DBI-1.601:0::gentoo
    "The Perl RPC Module"
    17.80 kBytes to download
* perl-core/Sys-Syslog [N 0.18]
    Reasons: *virtual/perl-Sys-Syslog-0.18:0::gentoo
    "Provides same functionality as BSD syslog"
    50.85 kBytes to download
* virtual/perl-Sys-Syslog [N 0.18]
    Reasons: *dev-perl/DBI-1.601:0::gentoo
    "Virtual for Sys-Syslog"
* dev-perl/DBI [N 1.601]
    Reasons: *dev-perl/DBD-mysql-4.00.5:0::gentoo
    "The Perl DBI Module"
    483.52 kBytes to download
* dev-db/mysql [N 5.0.60-r1]
    Reasons: *virtual/mysql-5.0:0::gentoo
    "A fast, multi-threaded, multi-user SQL database server."
    berkdb -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal perl (-selinux) ssl -static
    26.73 MBytes to download
* virtual/mysql [N 5.0]
    Reasons: *dev-perl/DBD-mysql-4.00.5:0::gentoo
    "Virtual for MySQL client or database"
* dev-perl/DBD-mysql [N 4.00.5]
    Reasons: *dev-db/mysql-4.0.27-r1:0::gentoo, *dev-db/mysql-5.0.60-r1:0::gentoo
    "The Perl DBD:mysql Module"
    119.65 kBytes to download

Total: 13 packages (13 new), 38.32 MBytes to download


Which means that, since mysql isn't slotted, I end up with mysql 5.0 eventough I explicitly asked for 4.0.

This is a bug, right?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 23, 24, 25, 26  Next
Page 24 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum