Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PALUDIS] Support thread (current v. 0.26.*) - Part 4
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 24, 25, 26  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Thu Aug 07, 2008 9:10 pm    Post subject: Reply with quote

Mask virtual/mysql-5.0 and higher to find out which package is depending on it. It seems pretty obvious that mysql-4 depends on something that depends on mysql-5.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Aug 08, 2008 8:36 am    Post subject: Reply with quote

Similar problems with postgresql.

EDIT: I take it back. dev-db/postgresql-base was guilty here.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
12345moon12345
n00b
n00b


Joined: 24 Dec 2006
Posts: 27

PostPosted: Sun Aug 10, 2008 4:11 pm    Post subject: mixing gcc-versions from bashrc?? Reply with quote

Hi, i'd like to mix different gcc-versions ( because virtualbox needs doesn't compile with gcc 4.3 and the rest of my system does)
Is this a good solution?

#/etc/paludis/bashrc


# bashrc
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

case "${PN}" in
boost|boost-build)
LDFLAGS="--verbose"
;;
*)
LDFLAGS="-Wl,-O1 -Wl,--as-needed "
;;
esac

case "${PN}" in
virtualbox)
gcc-config x86_64-pc-linux-gnu-4.2.4
;;
*)
gcc-config x86_64-pc-linux-gnu-4.3.1
;;
esac
env-update
source /etc/profile


the logic seems right but when I try tu run paludis -i virtualbox it gives weird errors

any thoughts??
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Sun Aug 10, 2008 4:20 pm    Post subject: Re: mixing gcc-versions from bashrc?? Reply with quote

12345moon12345 wrote:
Hi, i'd like to mix different gcc-versions ( because virtualbox needs doesn't compile with gcc 4.3 and the rest of my system does)
Is this a good solution?

#/etc/paludis/bashrc


# bashrc
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"

case "${PN}" in
boost|boost-build)
LDFLAGS="--verbose"
;;
*)
LDFLAGS="-Wl,-O1 -Wl,--as-needed "
;;
esac

case "${PN}" in
virtualbox)
gcc-config x86_64-pc-linux-gnu-4.2.4
;;
*)
gcc-config x86_64-pc-linux-gnu-4.3.1
;;
esac
env-update
source /etc/profile


the logic seems right but when I try tu run paludis -i virtualbox it gives weird errors

any thoughts??
It might be best if you read the hook documentation on Paludis and wrote a pre hook for the compile stage and a post hook for the install stage. The pre_compile hook would detect package virtualbox and run gcc-config and set a previous version of gcc, then the post_install hook would detect package virtualbox and run gcc-config and set the new version of gcc. I think GCC needs special symlinks.

If you get these hooks to work, please share them with us. ;)

Cheers
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Sun Aug 10, 2008 5:36 pm    Post subject: Reply with quote

The hook would also need to run gcc-config again to set the gcc profile back to the normal one, as running gcc-config sets it globally.
Back to top
View user's profile Send private message
jmanig
n00b
n00b


Joined: 20 Jun 2008
Posts: 4
Location: Montreal, QC

PostPosted: Mon Aug 11, 2008 7:41 pm    Post subject: Reply with quote

slycordinator wrote:
Mask virtual/mysql-5.0 and higher to find out which package is depending on it. It seems pretty obvious that mysql-4 depends on something that depends on mysql-5.


From what I understand...

mysql4 has a PDEPEND on perl/DBD-mysql
DBD-mysql depends on virtual/mysql
for some reason, DBD-mysql insists on pulling in the lastest version of virtual/mysql (5.0), which pulls in mysql 5.

Wait... does that mean that I should install virtual/mysql and not dev-db/mysql?
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Mon Aug 11, 2008 8:16 pm    Post subject: Reply with quote

jmanig wrote:
BD-mysql depends on virtual/mysql
for some reason, DBD-mysql insists on pulling in the lastest version of virtual/mysql (5.0), which pulls in mysql 5.


In short: No

If you look at the virtual/mysql-5.0 ebuild you'll notice that it is marked stable. So if I do "emerge virtual/mysql" I will get virtual/mysql-5.0 installed. Since dev-perl/DBD-mysql depends on virtual/mysql (note that it does not include a version number on that dependency) portage/paludis will look for the most recent version which is marked stable.

And yes if you want mysql-4.0 you could do
Code:
paludis -i =virtual/mysql-4.0


And all this dependency mess will be dealt with.

Though I think it would try to upgrade virtual/mysql later (to the current stable version).
Back to top
View user's profile Send private message
slycordinator
Advocate
Advocate


Joined: 31 Jan 2004
Posts: 3060
Location: Korea

PostPosted: Tue Aug 12, 2008 4:04 pm    Post subject: Reply with quote

I can't get mythtv-themes-extra-0.21_p17416 to build with paludis (0.28.2) but it builds with portage (2.1.4.4).

Code:
>>> Running ebuild phase killold as root:root...
>>> Starting builtin_killold
>>> Done builtin_killold
>>> Completed ebuild phase killold
>>> Running ebuild phases init saveenv as root:root...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup
>>> Done pkg_setup
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv setup saveenv
>>> Running ebuild phases loadenv unpack compile saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_unpack
 * subversion update start -->
 *      repository: http://svn.mythtv.org/svn/branches/release-0-21-fixes/themes@17416
At revision 17416.
 *    working copy: /data/distfiles/svn-src/mythtv-themes-extra/themes

>>> Done src_unpack
>>> Starting src_compile
./configure: line 39: qmake: command not found
Back to top
View user's profile Send private message
CosminG
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 166

PostPosted: Thu Aug 28, 2008 10:03 am    Post subject: Reply with quote

how do I install screenlets or/and fusion-icon?
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Aug 28, 2008 2:18 pm    Post subject: Reply with quote

I don't understand your question.

Are you getting an error related to Paludis?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
CosminG
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 166

PostPosted: Thu Aug 28, 2008 6:14 pm    Post subject: Reply with quote

I do not know how to handle ebuilds that are not in the portage

http://forum.compiz-fusion.org/showpost.php?p=48380&postcount=27 - this is for emerge, what is diferent for paludis?
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Thu Aug 28, 2008 6:30 pm    Post subject: Reply with quote

CosminG wrote:
I do not know how to handle ebuilds that are not in the portage.
Start with short reading and then cook yourself something like:
/etc/paludis/repositories/desktop-effects.conf wrote:
location = ${ROOT}/usr/portage/local/desktop-effects
sync = git://git.overlays.gentoo.org/proj/desktop-effects.git
master_repository = gentoo
format = ebuild
names_cache = /var/cache/paludis/names
write_cache = /var/cache/paludis/metadata
and run paludis -s x-desktop-effects.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Aug 28, 2008 8:41 pm    Post subject: Reply with quote

or you can install paludis with the ruby use flag and use playman.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Thu Aug 28, 2008 9:03 pm    Post subject: Reply with quote

It's long time ago I remember playman worked for me. Since then I'm getting
playman wrote:
/usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so: /usr/lib/libpaludisruby.so.28: undefined symbol: _ZN7paludis18FakeRepositoryBase12add_categoryERKNS_9ValidatedISsNS_25CategoryNamePartValidatorELb1ENS_26DefaultValidatedComparatorISsEEEE - /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so (LoadError)
from /usr/bin/playman:21
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Aug 28, 2008 9:22 pm    Post subject: Reply with quote

That usually means your CFLAGS or LDFLAGS are excessive.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
CosminG
Apprentice
Apprentice


Joined: 19 Jan 2005
Posts: 166

PostPosted: Fri Aug 29, 2008 10:15 am    Post subject: Reply with quote

Thank you Mr. Tao, I had to also install git and it worked.
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Fri Aug 29, 2008 11:46 pm    Post subject: Reply with quote

Mr. Tao wrote:
It's long time ago I remember playman worked for me. Since then I'm getting
playman wrote:
/usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so: /usr/lib/libpaludisruby.so.28: undefined symbol: _ZN7paludis18FakeRepositoryBase12add_categoryERKNS_9ValidatedISsNS_25CategoryNamePartValidatorELb1ENS_26DefaultValidatedComparatorISsEEEE - /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/Paludis.so (LoadError)
from /usr/bin/playman:21


Playman works here (paludis 0.28.2)
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Wed Sep 03, 2008 5:06 pm    Post subject: Reply with quote

Paludis refuses to install from overlays:
Code:
paludis -ip dolphin
Building target list...
Building dependency list...
Query error:
  * In program paludis (--dl-upgrade as-needed --continue-on-failure if-satisfied --log-level silent --resume-command-template /var/paludis/resume/resume --with-unused-dependencies --with-dependencies) -ip dolphin:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'kde-base/dolphin':
  * All versions of 'kde-base/dolphin' are masked. Candidates are:
    * kde-base/dolphin-4.0.4:kde-4::gentoo: Masked by repository (/var/paludis/repositories/gentoo/profiles/package.mask: Ingmar Vanhassel <ingmar@gentoo.org> (16 Jan 2008) Mask KDE 4.0.x for testing. This release of KDE 4 will not be unmasked. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first. KDE 4 guide: http://www.gentoo.org/proj/en/desktop/kde/kde4.xml)
    * kde-base/dolphin-4.0.5:kde-4::gentoo: Masked by repository (/var/paludis/repositories/gentoo/profiles/package.mask: Ingmar Vanhassel <ingmar@gentoo.org> (16 Jan 2008) Mask KDE 4.0.x for testing. This release of KDE 4 will not be unmasked. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first. KDE 4 guide: http://www.gentoo.org/proj/en/desktop/kde/kde4.xml)

 * No unread news items found

Actually, I have the kdesvn-portage overlay enabled. "paludis -s kde4-overlay" works.
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 848
Location: PL

PostPosted: Wed Sep 03, 2008 8:49 pm    Post subject: Reply with quote

a.b. wrote:
Paludis refuses to install from overlays:
(....)
* All versions of 'kde-base/dolphin' are masked. Candidates are:
* kde-base/dolphin-4.0.4:kde-4::gentoo: Masked by repository (/var/paludis/repositories/gentoo/profiles/package.mask: Ingmar Vanhassel <ingmar@gentoo.org> (16 Jan 2008) Mask KDE 4.0.x for testing. This release of KDE 4 will not be unmasked. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first. KDE 4 guide: http://www.gentoo.org/proj/en/desktop/kde/kde4.xml)
* kde-base/dolphin-4.0.5:kde-4::gentoo: Masked by repository (/var/paludis/repositories/gentoo/profiles/package.mask: Ingmar Vanhassel <ingmar@gentoo.org> (16 Jan 2008) Mask KDE 4.0.x for testing. This release of KDE 4 will not be unmasked. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first. KDE 4 guide: http://www.gentoo.org/proj/en/desktop/kde/kde4.xml)

* No unread news items found
[/code]
Actually, I have the kdesvn-portage overlay enabled. "paludis -s kde4-overlay" works.


syncing the overlay and unmasking ebuilds it contains are two different things.
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Wed Sep 03, 2008 9:04 pm    Post subject: Reply with quote

The ebuilds paludis talks about are the ones in portage. The ones in the overlay (KDE 4.1) aren't even mentioned.

EDIT: Found & fixed the problem. I still had debug output in my bashrc which somehow broke it.
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Thu Sep 04, 2008 6:18 pm    Post subject: Reply with quote

Because this thread is getting biig and new paludis 0.30.0 is out I started a new thread here: [PALUDIS] Support thread (current v. 0.30.*) - Part 5
_________________
Nature does not hurry, yet everything is accomplished.
Lao Tzu
Back to top
View user's profile Send private message
Harrakan
n00b
n00b


Joined: 01 Aug 2005
Posts: 6

PostPosted: Mon Mar 30, 2009 6:18 pm    Post subject: paludis and emerge broken Reply with quote

Hi folks

I had a power out while merging packages (presumably while 'sandbox').
At first the libstdc++.so.6 couldnt be found, which could be solved by gcc-config.

But now I have no clue how to proceed. The system works at the moment, but I can't install any packages.

When using paludis (my default) I get something like:

#paludis -pi sandbox
Building target list...
Building dependency list...
Unhandled exception:
* In program paludis -pi sandbox:
* When performing install action from command line:
* When executing install task:
* When building dependency list:
* When adding PackageDepSpec 'sys-apps/sandbox':
* When finding SLOT for 'sys-apps/sandbox-1.6::installed':
* When validating slot name '':
* Name '' is not a valid slot name (paludis::SlotNameError)

when trying emerg (quite outdated config):

# emerge -v sandbox
!!! Invalid db entry: /var/db/pkg/server-pim/akonadi-server-scm

These are the packages that would be merged, in order:

Calculating dependencies !!! Invalid db entry: /var/db/pkg/server-pim/akonadi-server-scm
... done!
[ebuild NS ] sys-apps/sandbox-1.2.18.1-r2 [1.6] 0 kB

Total: 1 package (1 in new slot), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/sandbox-1.2.18.1-r2
* sandbox-1.2.18.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
[Errno 8] Exec format error:
/usr/bin/sandbox "/usr/lib/portage/bin/ebuild.sh" unpack

>>> Failed to emerge sys-apps/sandbox-1.2.18.1-r2, Log file:

>>> '/var/tmp/portage/sys-apps/sandbox-1.2.18.1-r2/temp/build.log'
!!! Invalid db entry: /var/db/pkg/server-pim/akonadi-server-scm


At the moment, I have no clue how to proceed.

Hoping for help
Harrakan
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43546
Location: 56N 3W

PostPosted: Mon Mar 30, 2009 6:43 pm    Post subject: Reply with quote

Harrakan,

It looks like sandbox or the package database is corrupt. Moved here so Plaudis users will see your post
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
thewtex
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2007
Posts: 93

PostPosted: Mon Mar 30, 2009 7:47 pm    Post subject: Reply with quote

@Harrakan

Have you tried syncing again, and maybe
paludis --regenerate-installed-cache
paludis --regenerate-installable-cache
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Mar 30, 2009 9:17 pm    Post subject: Reply with quote

The invalid DB entries can be fixed by deleting the directory and re-installing the package, backups of /var/db/pkg are a good idea..

The sandbox error is Exec format error is possible from a bad portage install.

I would check to see if you have bad memory or hard drive failure going on. Either of these can cause these errors.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 24, 25, 26  Next
Page 25 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum